source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 9756

Revision 9756, 27.2 KB checked in by tomop, 9 years ago (diff)

libpq-9.4.5-1

Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 9.4
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Group: System Environment/Libraries
18Version: %{pgver}.5
19Release: 1%{?_dist_release}
20License: BSD
21Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
22Source3: postgresql.init
23Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
24Source6: README.rpm-dist
25Source15: postgresql-bashprofile
26Patch2: postgresql-8.3.3-nls.patch
27Patch3: postgresql-7.4-ecpg-patch
28Buildrequires: perl build-essential
29Buildrequires: libedit-devel
30Buildrequires: zlib-devel >= 1.0.4
31BuildRequires: bison, flex, pam-devel
32%if %ssl
33Buildrequires: openssl-devel
34%endif
35%if %kerberos
36Buildrequires: krb5-devel
37%endif
38%if %nls
39Buildrequires: gettext >= 0.10.35
40%endif
41
42%if %pam
43Buildrequires: pam-devel
44%endif
45
46Url: http://www.postgresql.org/
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53The %{name} package provides the essential shared libraries for any
54PostgreSQL client program or interface. You will need to install this package
55to use any other PostgreSQL package or any clients that need to connect to a
56PostgreSQL server.
57
58%description -l ja
59%{name} パッケージは、すべての PostgreSQL クライアントプログラ
60ムやインターフェースのための中核的な共有ライブラリを提供します。
61PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
62ントを使う場合には、このパッケージをインストールする必要があります。
63
64%package -n libpq%{pq_soname}
65Summary: The shared libraries required for any PostgreSQL clients.
66Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
67Group: System Environment/Libraries
68Requires(post): /sbin/ldconfig
69Requires(postun): /sbin/ldconfig
70Obsoletes: postgresql7-libs
71Obsoletes: postgresql8-libs
72Obsoletes: postgresql-libs < 9.3.0
73Conflicts: postgresql-libs >= 9.3.0
74
75%description -n libpq%{pq_soname}
76The %{name} package provides the essential shared libraries for any
77PostgreSQL client program or interface. You will need to install this package
78to use any other PostgreSQL package or any clients that need to connect to a
79PostgreSQL server.
80
81%description -n libpq%{pq_soname} -l ja
82%{name} パッケージは、すべての PostgreSQL クライアントプログラ
83ムやインターフェースのための中核的な共有ライブラリを提供します。
84PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
85ントを使う場合には、このパッケージをインストールする必要があります。
86
87%package devel
88Summary: PostgreSQL development header files and libraries.
89Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
90Group: Development/Libraries
91Requires: libpq%{pq_soname} = %{version}
92Obsoletes: postgresql7-devel
93Obsoletes: postgresql8-devel
94Obsoletes: postgresql-devel < 9.3.0
95
96%description devel
97The %{name}-devel package contains the header files and libraries
98needed to compile C or C++ applications which will directly interact
99with a PostgreSQL database management server and the ecpg Embedded C
100Postgres preprocessor. You need to install this package if you want to
101develop applications which will interact with a PostgreSQL server.
102
103%description -l ja devel
104%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
105するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
106ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
107が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
108したい場合にはこのパッケージをインストールしてください。
109
110
111%prep
112%setup -q -n postgresql-%{version}
113
114
115%build
116CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
117CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
118
119# Strip out -ffast-math from CFLAGS....
120
121CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
122
123./configure \
124        --prefix=%{_prefix} \
125        --libdir=%{_libdir} \
126        --disable-rpath \
127%if %beta
128        --enable-debug \
129        --enable-cassert \
130%endif
131%if %ssl
132        --with-openssl \
133%endif
134%if %pam
135        --with-pam \
136%endif
137%if %kerberos
138        --with-krb5=/usr/kerberos \
139%endif
140%if %nls
141        --enable-nls \
142%endif
143        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
144        --mandir=%{_mandir} \
145        --with-docdir=%{_docdir} \
146        --includedir=%{_includedir}/pgsql \
147        --datadir=%{_datadir}/pgsql
148
149make %{?_smp_mflags} -C ./src/interfaces all
150make %{?_smp_mflags} -C ./src/bin/pg_config all
151make %{?_smp_mflags} -C ./src/backend utils/errcodes.h
152make %{?_smp_mflags} -C ./src/backend utils/fmgroids.h
153
154
155%install
156rm -rf $RPM_BUILD_ROOT
157
158make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
159make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
160cp -f ./src/backend/utils/fmgroids.h ./src/include/utils/
161make DESTDIR=$RPM_BUILD_ROOT -C ./src/include install
162
163# copy over Makefile.global to the include dir....
164install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
165install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
166
167# install missing header
168mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
169install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
170install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
171install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
172install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
173install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
174install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
175install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
176
177# Fix some more documentation
178##gzip doc/internals.ps
179cp %{SOURCE6} README.rpm-dist
180##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
181##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
182
183mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
184install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
185
186
187%find_lang libpq5-%{pgver}
188%find_lang ecpg-%{pgver}
189%find_lang ecpglib%{ecpg_soname}-%{pgver}
190#%find_lang pg_config-%{pgver}
191
192cat libpq5-%{pgver}.lang > libpq.lst
193cat ecpg-%{pgver}.lang >> libpq.lst
194cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
195#cat pg_config-%{pgver}.lang > devel.lst
196
197rm -rf %{buildroot}%{_libdir}/lib*.a
198rm -rf %{buildroot}%{_datadir}/pgsql
199find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
200
201rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
202find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
203
204%post
205/sbin/ldconfig
206
207%postun
208/sbin/ldconfig
209
210
211%clean
212rm -rf $RPM_BUILD_ROOT
213
214
215%files -n libpq%{pq_soname} -f libpq.lst
216%defattr(-,root,root)
217%doc COPYRIGHT HISTORY INSTALL README*
218%{_libdir}/libecpg.so.*
219%{_libdir}/libecpg_compat.so.*
220%{_libdir}/libpgtypes.so.*
221%{_libdir}/libpq.so.*
222
223%files devel -f devel.lst
224%defattr(-,root,root)
225%{_bindir}/ecpg
226%{_bindir}/pg_config
227%{_libdir}/libecpg.so
228%{_libdir}/libecpg_compat.so
229%{_libdir}/libpgtypes.so
230%{_libdir}/libpq.so
231%{_libdir}/pkgconfig/*
232%{_datadir}/locale/*/LC_MESSAGES/*.mo
233%{_mandir}/man1/ecpg.*
234#%{_mandir}/man1/pg_config.*
235
236
237%changelog
238* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.5-1
239- new upstream release.
240
241* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.4-1
242- new upstream release.
243
244* Fri Jun 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.3-1
245- new upstream release.
246
247* Thu Jul 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-4
248- added all headers for a strange client.
249
250* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
251- add pgconfig
252- add pg_config*.h and libpq/libpq-fs.h
253
254* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
255- add postgres_ext.h and pg_config_ext.h
256
257* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
258- new upstream release
259
260* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
261- made to build client libraries only.
262
263* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
264- new upstream release
265
266* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
267- new upstream release
268- add Vendor and Distribution tags
269
270* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
271- build with Tcl/Tk 8.5.7-1
272- fix init script (Source3): fix su(1) paramaters.
273
274* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
275- new upstream release
276- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
277- remove *_and_*.so from -contrib (included in -server)
278
279* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
280- updated postgresql to 9.0.4
281
282* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
283- updated postgresql to 9.0.3
284- separated postgresql-jdbc package
285
286* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
287- updated postgresql to 8.4.7 (contains a variety of fixes)
288
289* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
290- updated postgresql to 8.4.6
291- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
292- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
293- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
294
295* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
296- rebuilt with openssl-1.0.0c
297
298* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
299- updated postgresql to 8.4.5
300
301* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
302- updated postgresql to 8.4.4
303
304* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
305- updated postgresql to 8.4.3
306- s/BuildPrereq/Buildrequires/
307
308* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
309- updated postgresql to 8.4.2
310- rebuilt with new environment
311
312* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
313- updated postgresql to 8.4.1
314
315* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
316- moved dict_snowball.so from conrib to server
317
318* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
319- updated postgresql to 8.4.0
320- updated jdbc3,4 to 701
321- dropt postgresql-8.3.3-nls.patch (fixed)
322- dropt postgresql-7.4-ecpg-patch (no effect)
323
324* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
325- changed libs Group to System Environment/Libraries
326
327* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
328- updated postgresql to 8.3.7
329
330* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
331- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
332
333* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
334- new upstream release (postgresql to 8.3.5, jdbc to 604)
335
336* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
337- applied new versioning policy, and spec in utf-8
338- updated postgresql to 8.3.3
339- updated jdbcver to 603
340- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
341- added a script to replace PGVERSION in postgresql.init
342
343* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
344- rebuild with tcl/tk-8.4.18
345
346* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
347- updated postgresql to 8.2.6
348- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
349
350* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
351- updated PGVERSION to 8.2 in postgresql.init (sorry;)
352
353* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
354- rebuild with tcl/tk-8.4.16
355
356* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
357- updated postgresql to 8.2.5
358- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
359- updated nls-patch to 8-2-0
360- dropt postgresql-8.1.4-Pg.patch.gz
361
362* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
363- for VineSeed
364- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
365- JDBC driver updated to 410
366
367* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
368- rebuilt for VineSeed
369- fixed install script
370
371* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
372- upstream release
373- fix missing %defattr in %files server
374
375* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
376- fix version number in postgresql.init
377
378* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
379- upstream release
380- drop rpm-pgsql-8.0.0.patch
381- add Requires: perl-DBD-Pg for contrib
382- add postgresql-8.1.4-Pg.patch.gz
383- update nls patches
384- new JDBC driver
385
386* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
387- added build options --without perl, --without python
388- rebuilt for x86_64 architecture support
389
390* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
391- drop Provides: on postgresql-libs
392- drop Requires: libpq.so on postgresql-server
393
394* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
395- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
396
397* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
398- upstream release
399- update nls patches
400
401* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
402- upstream release
403- update nls patches
404
405* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
406- rebuilded with python-2.4.1-0vl1
407
408* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
409- Dropped PyGreSQL-3.4.tgz.
410- Dropped PyGreSQL-3.4-setup-2.patch.
411- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
412- Dropped pyver and pynextver macros.
413- Changed macro name "python" to "plpython" like plperl.
414- Added "Obsoletes: postgresql-python"
415
416* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
417- Major version up
418- Obsoletes: postgresql7
419- update nls patch(es)
420- modify %postun not to delete postgres account on upgrade
421
422* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
423- upstream release (release as a new package)
424- Conflicts: postgresql
425- update nls patch(es)
426- (this package revision was rejected by Vine Project)
427
428* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
429- upstream release
430- new JDBC driver
431- add BuildRequires: bison, flex, pam-devel
432- drop postgresql-7.4.5-tempfile.patch (repaired)
433
434* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
435- Added a security fix patch postgresql-7.4.5-tempfile.patch
436  from Gentoo Linux (CAN-2004-0977).
437- Changed Patch4:
438  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
439  It is possible to compile this package without pre-installed postgresql.
440- Removed Patch5 because Patch4 was changed.
441
442* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
443- upstream release
444
445* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
446- upstream release
447- new jdbc driver
448
449* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
450- rebuild with python-2.3.3-0vl1
451
452* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
453- changed mode to 644 at Makefile.global, Makefile.shlib
454
455* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
456- updated python install section
457
458* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
459- added PyGreSQL-3.4.tgz and set python flag
460- added PyGreSQL-3.4-setup.patch
461- added PyGreSQL-3.4-pgmodule.patch
462- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
463
464* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
465- rebuild with new openssl
466
467* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
468- upstream release
469- change all of %{?foo:%define foo 0} -like descriptions to simple
470  %define format for latest rpm to build.
471
472* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
473- rebuild on latest tcl package environment.
474
475* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
476- fixed lacking files at server's %files
477
478* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
479- include JDBC driver for 7.4
480- fix typo in postgresql-7.4-psql-patch
481
482* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
483- upstream release
484- change '--includedir=' option to avoid conflicting with unixODBC
485- add postgresql-7.4-ecpg-patch
486
487* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
488- upstream release
489
490* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
491- drop previous version of libpq's trash
492
493* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
494- upstream release with new nls patch
495- fix postgresql-bashprofile (value of PGDATA)
496- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
497
498* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
499- rebuild with tcltk8.4 and readline-4.3
500
501* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
502- upstream release
503
504* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
505- upstream release
506- remove garbage changelog
507
508* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
509- upstream release based on 7.3-2PGDG
510- add nls patch
511
512* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
513- 7.3-2PGDG
514- Fix typo in initscript.  Argh!!
515
516* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
517- 7.3-0.5PGDG
518- Jerk out all perl client stuff and kludgage
519- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
520- Eliminate locale and multibyte explicit enables -- they are both defaults now
521- Eliminate pgaccess code; it's not a part of the main tarball anymore
522- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
523- Eliminated separate tk client package -- rolled the tk client into the tcl client.
524- Moved pltcl into the pl subpackage.
525- Added plpython to the pl subpackage.
526- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
527
528* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
529- 7.3-0.1PGDG (not released)
530- Integrate 7.3 jar's courtesy Joe Conway
531- Integrate multi-postmaster initscript courtesy Karl DeBisschop
532- Some renames and restructures.
533- Stripped out the last dregs of the postgresql-dump migration script.
534- Conflicts with less than 7.3.
535
536- (See below for old changelogs from VineSeed)
537
538* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
539- updated to 7.2.3.
540
541* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
542- absorbed previous patch8 into original nlspatch
543- fixed configure options (--enable-nls and --enable-locale to be antinomy)
544
545* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
546- add patch8 (ja.po for psql was invalid)
547
548* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
549- updated to 7.2.2.
550- improved nlspatch to enable japanese SQL help in psql.
551
552* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
553- fixed garbage chars in description(ja).
554
555* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
556- imported & replaced changelog (following VineSeed's).
557  add some stuff to '%%files'.
558
559* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
560- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
561  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
562
563* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
564- replace nls patch.
565- add *.mo to '%%files'.
566
567* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
568- fix initscript
569
570* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
571- add /usr/bin/pg_id to the package (fix)
572
573* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
574- updated 7.2
575- added nls.patch
576- fixed spec file
577- added New JDBC
578-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
579
580* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
581- updated 7.1.3
582
583* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
584- 7.1.2-7vl3
585- merge 7.1.2-7vl2 and 7.1.2-7
586
587* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
588- 7.1.2-7vl2
589- fixed spec typo (%%{_includesir} -> %%{_includedir})
590
591* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
592- updated 7.1.2 (used postgresql-7.1.2-7)
593- used psqlj patch for 7.1.2
594- used jumbo-20010801.patch.gz
595
596* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
597- Add patches from 7.1-stable branch. This should fix #50799 and #50797
598- Enable kerberos authentication (#50644)
599- handle stop with stale pid file (#50499)
600- make the test subpackage (not built by default) own /usr/lib/pgsql/test
601
602* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
603- Make the -devel subpackage depend on -libs, not the main package
604
605* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
606- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
607
608* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
609- add changes for s390x
610
611* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
612- Many path fixes for contrib packages
613- Newer intarray
614- Don't use nested ifs for tkpkg/pgaccess
615- Turn off test package for Red Hat Linux - it makes most sense just to use
616  this during development
617- One "pgacess" -> "pgaccess"
618
619* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
620- -4PGDG
621- patchset update for pg_regress.sh
622- can the dot in the release -- confused too many people and some programs.
623- -3.PGDG
624- updated README.rpm-dist
625- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
626  was still being used where /usr/lib/pgsql was intended.
627- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
628
629* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
630- sync
631- Run chkconfig --add on server install
632- Move the prereqs on useradd on chkconfig to the server package
633- don't disable the %%clean section
634
635* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
636- Sync up with Trond Eivind's set.
637
638* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
639- Don't create postgres' .bashrc from the server post script: include it instead
640- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
641- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
642  libs
643- Source the i18n data from the .bashrc instead of in the initscript
644
645* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
646- Handle i18n for database startup - backend needs to have the same locale everytime,
647  but this certainly can't be hardcoded to C either
648- Fix stop, restart in initscript (#42217)
649- Make database init _much_ less verbose
650- other minor fixes to the initscript
651
652* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
653- 7.1.2
654
655* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
656- 7.1.2-0.1.1.PGDG PRERELEASE
657- Changed versioning and release numbering a little for better flexibility,
658-- particularly for distribution packagers.
659- Release numbering comment at top of spec, where it's more useful.
660- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
661  changlog, and the last 6.5.3's specfile for the changelog prior to
662  7.0.
663
664* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
665- 7.1.1-4.PGDG
666- _really_ got Python version agnosticism working.
667
668* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
669- 7.1.1-3.PGDG Release
670- Python version agnosticism.....
671
672* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
673- Use openssl
674- Make it obsolete subpackages if they aren't built
675
676* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
677- 7.1.1-2.PGDG Release.
678- Appended .PGDG to release string to differentiate our RPM set from the others.
679- /bin/sh fix in initscript
680- README.rpm-dist updates.
681
682* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
683- Rebuild with new readline
684
685* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
686- Initial 7.1.1
687
688* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
689- Specify shell when running commands through su in the initscript, to avoid problems
690  when people switch the postgres user to use tcsh
691
692* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
693- JDBC driver for Postgresql 7.1
694
695* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
696- slightly different versioning scheming, will go back to the official
697  later when I'm sure the package is ready to use
698
699* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
700- 7.1 RELEASE
701- 7.1-1 RPM RELEASE
702- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
703- Back to old versioning scheme, kept teg's other fixes.
704- README.rpm-dist updated.
705- PGVERSION updated all-around (hopefully!)
706- Couple of fixes from Peter E.
707- Rearrange dependencies -- only the -libs subpackage is required for most stuff
708- Removed broken and confusing logrotate script.
709
710* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
711- chown considered harmful - removed
712- fix dangling symlimks (pg_crc.c)
713- libpq.so changes for maximum compatiblity
714- different versioning scheme, to avoid trouble later
715- remove temporary perl file from the file list
716- fix spelling error in tcl description
717- mark odbcinst.ini as a config file
718- use %%defattr on packages which didn't have it
719
720* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
721- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
722- Packaging reorg: added contrib and docs subpackages.
723- Removed sgml source docs from main package --> docs subpackage.
724- Removed contrib tree from main package --> contrib subpackage.
725- Contrib tree is now prebuilt -- HOWEVER, very little install work is
726  currently done with this.
727
728* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
729- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
730
731* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
732- RC2
733- eliminate versioning information for ancilliary files in prep for CVS.
734- Fix docs mixup.
735
736* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
737- RC1 quickie.
738
739* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
740- Beta 6 initial build.
741- Use make install-all-headers instead of cpio hack for devel headers.
742- Split out the libs into the libs subpackage.
743- Updated initscript to use pg_ctl to stop
744- Updated initscript to initdb and start postmaster with LC_ALL=C to
745  prevent index corruption.
746
747
748* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
749- Beta4
750- Return to 'pgsql' directories instead of 'postgresql'
751- Better perl patches.
752
753* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
754- Edit patches to get rid of some cruft.
755- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
756- Moved pg_id to server
757- added Makefile.global and pg_config to devel
758- Corrected /usr/include/pgsql to /usr/include/postgresql
759- Fixed some configure options.  Will be trying the configure macro next release
760- Since it is terminally ill in this version pg_upgrade is _gone_.
761- Thanks to Peter E for a good review.
762
763* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
764- Running regression. 1 on the release-o-meter.
765- Minor patches to get regression running right. 
766- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
767
768* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
769- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
770- The 7.1 build is different from the 7.0 build -- see the configure line.
771- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
772- by request, conditional packages are now supported. See the top of the spec.
773- Fixed the server postinstall problems.
774
775* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
776- First 7.1 beta test-build
777
Note: See TracBrowser for help on using the repository browser.