source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 10006

Revision 10006, 27.3 KB checked in by tomop, 8 years ago (diff)

libpq-9.5.0-1, postgresql-9.5.0-1

Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 9.5
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Group: System Environment/Libraries
18Version: %{pgver}.0
19Release: 1%{?_dist_release}
20License: BSD
21Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
22Source3: postgresql.init
23Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
24Source6: README.rpm-dist
25Source15: postgresql-bashprofile
26Patch2: postgresql-8.3.3-nls.patch
27Patch3: postgresql-7.4-ecpg-patch
28Buildrequires: perl build-essential
29Buildrequires: libedit-devel
30Buildrequires: zlib-devel >= 1.0.4
31BuildRequires: bison, flex, pam-devel
32%if %ssl
33Buildrequires: openssl-devel
34%endif
35%if %kerberos
36Buildrequires: krb5-devel
37%endif
38%if %nls
39Buildrequires: gettext >= 0.10.35
40%endif
41
42%if %pam
43Buildrequires: pam-devel
44%endif
45
46Url: http://www.postgresql.org/
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53The %{name} package provides the essential shared libraries for any
54PostgreSQL client program or interface. You will need to install this package
55to use any other PostgreSQL package or any clients that need to connect to a
56PostgreSQL server.
57
58%description -l ja
59%{name} パッケージは、すべての PostgreSQL クライアントプログラ
60ムやインターフェースのための中核的な共有ライブラリを提供します。
61PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
62ントを使う場合には、このパッケージをインストールする必要があります。
63
64%package -n libpq%{pq_soname}
65Summary: The shared libraries required for any PostgreSQL clients.
66Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
67Group: System Environment/Libraries
68Requires(post): /sbin/ldconfig
69Requires(postun): /sbin/ldconfig
70Obsoletes: postgresql7-libs
71Obsoletes: postgresql8-libs
72Obsoletes: postgresql-libs < 9.3.0
73Conflicts: postgresql-libs >= 9.3.0
74
75%description -n libpq%{pq_soname}
76The %{name} package provides the essential shared libraries for any
77PostgreSQL client program or interface. You will need to install this package
78to use any other PostgreSQL package or any clients that need to connect to a
79PostgreSQL server.
80
81%description -n libpq%{pq_soname} -l ja
82%{name} パッケージは、すべての PostgreSQL クライアントプログラ
83ムやインターフェースのための中核的な共有ライブラリを提供します。
84PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
85ントを使う場合には、このパッケージをインストールする必要があります。
86
87%package devel
88Summary: PostgreSQL development header files and libraries.
89Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
90Group: Development/Libraries
91Requires: libpq%{pq_soname} = %{version}
92Obsoletes: postgresql7-devel
93Obsoletes: postgresql8-devel
94Obsoletes: postgresql-devel < 9.3.0
95
96%description devel
97The %{name}-devel package contains the header files and libraries
98needed to compile C or C++ applications which will directly interact
99with a PostgreSQL database management server and the ecpg Embedded C
100Postgres preprocessor. You need to install this package if you want to
101develop applications which will interact with a PostgreSQL server.
102
103%description -l ja devel
104%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
105するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
106ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
107が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
108したい場合にはこのパッケージをインストールしてください。
109
110
111%prep
112%setup -q -n postgresql-%{version}
113
114
115%build
116CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
117CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
118
119# Strip out -ffast-math from CFLAGS....
120
121CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
122
123./configure \
124        --prefix=%{_prefix} \
125        --libdir=%{_libdir} \
126        --disable-rpath \
127%if %beta
128        --enable-debug \
129        --enable-cassert \
130%endif
131%if %ssl
132        --with-openssl \
133%endif
134%if %pam
135        --with-pam \
136%endif
137%if %kerberos
138        --with-krb5=/usr/kerberos \
139%endif
140%if %nls
141        --enable-nls \
142%endif
143        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
144        --mandir=%{_mandir} \
145        --with-docdir=%{_docdir} \
146        --includedir=%{_includedir}/pgsql \
147        --datadir=%{_datadir}/pgsql
148
149make %{?_smp_mflags} -C ./src/interfaces all
150make %{?_smp_mflags} -C ./src/bin/pg_config all
151make %{?_smp_mflags} -C ./src/backend utils/errcodes.h
152make %{?_smp_mflags} -C ./src/backend utils/fmgroids.h
153
154
155%install
156rm -rf $RPM_BUILD_ROOT
157
158make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
159make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
160cp -f ./src/backend/utils/fmgroids.h ./src/include/utils/
161make DESTDIR=$RPM_BUILD_ROOT -C ./src/include install
162
163# copy over Makefile.global to the include dir....
164install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
165install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
166
167# install missing header
168mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
169install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
170install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
171install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
172install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
173install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
174install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
175install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
176
177# Fix some more documentation
178##gzip doc/internals.ps
179cp %{SOURCE6} README.rpm-dist
180##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
181##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
182
183mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
184install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
185
186
187%find_lang libpq5-%{pgver}
188%find_lang ecpg-%{pgver}
189%find_lang ecpglib%{ecpg_soname}-%{pgver}
190#%find_lang pg_config-%{pgver}
191
192cat libpq5-%{pgver}.lang > libpq.lst
193cat ecpg-%{pgver}.lang >> libpq.lst
194cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
195#cat pg_config-%{pgver}.lang > devel.lst
196
197rm -rf %{buildroot}%{_libdir}/lib*.a
198rm -rf %{buildroot}%{_datadir}/pgsql
199find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
200
201rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
202find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
203
204%post
205/sbin/ldconfig
206
207%postun
208/sbin/ldconfig
209
210
211%clean
212rm -rf $RPM_BUILD_ROOT
213
214
215%files -n libpq%{pq_soname} -f libpq.lst
216%defattr(-,root,root)
217%doc COPYRIGHT HISTORY INSTALL README*
218%{_libdir}/libecpg.so.*
219%{_libdir}/libecpg_compat.so.*
220%{_libdir}/libpgtypes.so.*
221%{_libdir}/libpq.so.*
222
223%files devel -f devel.lst
224%defattr(-,root,root)
225%{_bindir}/ecpg
226%{_bindir}/pg_config
227%{_libdir}/libecpg.so
228%{_libdir}/libecpg_compat.so
229%{_libdir}/libpgtypes.so
230%{_libdir}/libpq.so
231%{_libdir}/pkgconfig/*
232%{_datadir}/locale/*/LC_MESSAGES/*.mo
233%{_mandir}/man1/ecpg.*
234#%{_mandir}/man1/pg_config.*
235
236
237%changelog
238* Sat Jan  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.0-1
239- new upstream release.
240
241* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.5-1
242- new upstream release.
243
244* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.4-1
245- new upstream release.
246
247* Fri Jun 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.3-1
248- new upstream release.
249
250* Thu Jul 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-4
251- added all headers for a strange client.
252
253* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
254- add pgconfig
255- add pg_config*.h and libpq/libpq-fs.h
256
257* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
258- add postgres_ext.h and pg_config_ext.h
259
260* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
261- new upstream release
262
263* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
264- made to build client libraries only.
265
266* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
267- new upstream release
268
269* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
270- new upstream release
271- add Vendor and Distribution tags
272
273* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
274- build with Tcl/Tk 8.5.7-1
275- fix init script (Source3): fix su(1) paramaters.
276
277* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
278- new upstream release
279- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
280- remove *_and_*.so from -contrib (included in -server)
281
282* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
283- updated postgresql to 9.0.4
284
285* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
286- updated postgresql to 9.0.3
287- separated postgresql-jdbc package
288
289* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
290- updated postgresql to 8.4.7 (contains a variety of fixes)
291
292* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
293- updated postgresql to 8.4.6
294- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
295- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
296- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
297
298* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
299- rebuilt with openssl-1.0.0c
300
301* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
302- updated postgresql to 8.4.5
303
304* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
305- updated postgresql to 8.4.4
306
307* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
308- updated postgresql to 8.4.3
309- s/BuildPrereq/Buildrequires/
310
311* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
312- updated postgresql to 8.4.2
313- rebuilt with new environment
314
315* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
316- updated postgresql to 8.4.1
317
318* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
319- moved dict_snowball.so from conrib to server
320
321* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
322- updated postgresql to 8.4.0
323- updated jdbc3,4 to 701
324- dropt postgresql-8.3.3-nls.patch (fixed)
325- dropt postgresql-7.4-ecpg-patch (no effect)
326
327* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
328- changed libs Group to System Environment/Libraries
329
330* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
331- updated postgresql to 8.3.7
332
333* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
334- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
335
336* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
337- new upstream release (postgresql to 8.3.5, jdbc to 604)
338
339* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
340- applied new versioning policy, and spec in utf-8
341- updated postgresql to 8.3.3
342- updated jdbcver to 603
343- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
344- added a script to replace PGVERSION in postgresql.init
345
346* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
347- rebuild with tcl/tk-8.4.18
348
349* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
350- updated postgresql to 8.2.6
351- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
352
353* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
354- updated PGVERSION to 8.2 in postgresql.init (sorry;)
355
356* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
357- rebuild with tcl/tk-8.4.16
358
359* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
360- updated postgresql to 8.2.5
361- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
362- updated nls-patch to 8-2-0
363- dropt postgresql-8.1.4-Pg.patch.gz
364
365* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
366- for VineSeed
367- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
368- JDBC driver updated to 410
369
370* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
371- rebuilt for VineSeed
372- fixed install script
373
374* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
375- upstream release
376- fix missing %defattr in %files server
377
378* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
379- fix version number in postgresql.init
380
381* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
382- upstream release
383- drop rpm-pgsql-8.0.0.patch
384- add Requires: perl-DBD-Pg for contrib
385- add postgresql-8.1.4-Pg.patch.gz
386- update nls patches
387- new JDBC driver
388
389* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
390- added build options --without perl, --without python
391- rebuilt for x86_64 architecture support
392
393* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
394- drop Provides: on postgresql-libs
395- drop Requires: libpq.so on postgresql-server
396
397* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
398- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
399
400* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
401- upstream release
402- update nls patches
403
404* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
405- upstream release
406- update nls patches
407
408* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
409- rebuilded with python-2.4.1-0vl1
410
411* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
412- Dropped PyGreSQL-3.4.tgz.
413- Dropped PyGreSQL-3.4-setup-2.patch.
414- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
415- Dropped pyver and pynextver macros.
416- Changed macro name "python" to "plpython" like plperl.
417- Added "Obsoletes: postgresql-python"
418
419* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
420- Major version up
421- Obsoletes: postgresql7
422- update nls patch(es)
423- modify %postun not to delete postgres account on upgrade
424
425* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
426- upstream release (release as a new package)
427- Conflicts: postgresql
428- update nls patch(es)
429- (this package revision was rejected by Vine Project)
430
431* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
432- upstream release
433- new JDBC driver
434- add BuildRequires: bison, flex, pam-devel
435- drop postgresql-7.4.5-tempfile.patch (repaired)
436
437* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
438- Added a security fix patch postgresql-7.4.5-tempfile.patch
439  from Gentoo Linux (CAN-2004-0977).
440- Changed Patch4:
441  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
442  It is possible to compile this package without pre-installed postgresql.
443- Removed Patch5 because Patch4 was changed.
444
445* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
446- upstream release
447
448* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
449- upstream release
450- new jdbc driver
451
452* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
453- rebuild with python-2.3.3-0vl1
454
455* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
456- changed mode to 644 at Makefile.global, Makefile.shlib
457
458* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
459- updated python install section
460
461* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
462- added PyGreSQL-3.4.tgz and set python flag
463- added PyGreSQL-3.4-setup.patch
464- added PyGreSQL-3.4-pgmodule.patch
465- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
466
467* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
468- rebuild with new openssl
469
470* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
471- upstream release
472- change all of %{?foo:%define foo 0} -like descriptions to simple
473  %define format for latest rpm to build.
474
475* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
476- rebuild on latest tcl package environment.
477
478* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
479- fixed lacking files at server's %files
480
481* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
482- include JDBC driver for 7.4
483- fix typo in postgresql-7.4-psql-patch
484
485* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
486- upstream release
487- change '--includedir=' option to avoid conflicting with unixODBC
488- add postgresql-7.4-ecpg-patch
489
490* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
491- upstream release
492
493* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
494- drop previous version of libpq's trash
495
496* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
497- upstream release with new nls patch
498- fix postgresql-bashprofile (value of PGDATA)
499- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
500
501* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
502- rebuild with tcltk8.4 and readline-4.3
503
504* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
505- upstream release
506
507* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
508- upstream release
509- remove garbage changelog
510
511* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
512- upstream release based on 7.3-2PGDG
513- add nls patch
514
515* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
516- 7.3-2PGDG
517- Fix typo in initscript.  Argh!!
518
519* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
520- 7.3-0.5PGDG
521- Jerk out all perl client stuff and kludgage
522- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
523- Eliminate locale and multibyte explicit enables -- they are both defaults now
524- Eliminate pgaccess code; it's not a part of the main tarball anymore
525- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
526- Eliminated separate tk client package -- rolled the tk client into the tcl client.
527- Moved pltcl into the pl subpackage.
528- Added plpython to the pl subpackage.
529- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
530
531* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
532- 7.3-0.1PGDG (not released)
533- Integrate 7.3 jar's courtesy Joe Conway
534- Integrate multi-postmaster initscript courtesy Karl DeBisschop
535- Some renames and restructures.
536- Stripped out the last dregs of the postgresql-dump migration script.
537- Conflicts with less than 7.3.
538
539- (See below for old changelogs from VineSeed)
540
541* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
542- updated to 7.2.3.
543
544* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
545- absorbed previous patch8 into original nlspatch
546- fixed configure options (--enable-nls and --enable-locale to be antinomy)
547
548* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
549- add patch8 (ja.po for psql was invalid)
550
551* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
552- updated to 7.2.2.
553- improved nlspatch to enable japanese SQL help in psql.
554
555* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
556- fixed garbage chars in description(ja).
557
558* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
559- imported & replaced changelog (following VineSeed's).
560  add some stuff to '%%files'.
561
562* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
563- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
564  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
565
566* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
567- replace nls patch.
568- add *.mo to '%%files'.
569
570* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
571- fix initscript
572
573* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
574- add /usr/bin/pg_id to the package (fix)
575
576* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
577- updated 7.2
578- added nls.patch
579- fixed spec file
580- added New JDBC
581-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
582
583* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
584- updated 7.1.3
585
586* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
587- 7.1.2-7vl3
588- merge 7.1.2-7vl2 and 7.1.2-7
589
590* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
591- 7.1.2-7vl2
592- fixed spec typo (%%{_includesir} -> %%{_includedir})
593
594* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
595- updated 7.1.2 (used postgresql-7.1.2-7)
596- used psqlj patch for 7.1.2
597- used jumbo-20010801.patch.gz
598
599* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
600- Add patches from 7.1-stable branch. This should fix #50799 and #50797
601- Enable kerberos authentication (#50644)
602- handle stop with stale pid file (#50499)
603- make the test subpackage (not built by default) own /usr/lib/pgsql/test
604
605* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
606- Make the -devel subpackage depend on -libs, not the main package
607
608* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
609- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
610
611* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
612- add changes for s390x
613
614* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
615- Many path fixes for contrib packages
616- Newer intarray
617- Don't use nested ifs for tkpkg/pgaccess
618- Turn off test package for Red Hat Linux - it makes most sense just to use
619  this during development
620- One "pgacess" -> "pgaccess"
621
622* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
623- -4PGDG
624- patchset update for pg_regress.sh
625- can the dot in the release -- confused too many people and some programs.
626- -3.PGDG
627- updated README.rpm-dist
628- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
629  was still being used where /usr/lib/pgsql was intended.
630- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
631
632* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
633- sync
634- Run chkconfig --add on server install
635- Move the prereqs on useradd on chkconfig to the server package
636- don't disable the %%clean section
637
638* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
639- Sync up with Trond Eivind's set.
640
641* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
642- Don't create postgres' .bashrc from the server post script: include it instead
643- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
644- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
645  libs
646- Source the i18n data from the .bashrc instead of in the initscript
647
648* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
649- Handle i18n for database startup - backend needs to have the same locale everytime,
650  but this certainly can't be hardcoded to C either
651- Fix stop, restart in initscript (#42217)
652- Make database init _much_ less verbose
653- other minor fixes to the initscript
654
655* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
656- 7.1.2
657
658* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
659- 7.1.2-0.1.1.PGDG PRERELEASE
660- Changed versioning and release numbering a little for better flexibility,
661-- particularly for distribution packagers.
662- Release numbering comment at top of spec, where it's more useful.
663- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
664  changlog, and the last 6.5.3's specfile for the changelog prior to
665  7.0.
666
667* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
668- 7.1.1-4.PGDG
669- _really_ got Python version agnosticism working.
670
671* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
672- 7.1.1-3.PGDG Release
673- Python version agnosticism.....
674
675* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
676- Use openssl
677- Make it obsolete subpackages if they aren't built
678
679* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
680- 7.1.1-2.PGDG Release.
681- Appended .PGDG to release string to differentiate our RPM set from the others.
682- /bin/sh fix in initscript
683- README.rpm-dist updates.
684
685* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
686- Rebuild with new readline
687
688* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
689- Initial 7.1.1
690
691* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
692- Specify shell when running commands through su in the initscript, to avoid problems
693  when people switch the postgres user to use tcsh
694
695* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
696- JDBC driver for Postgresql 7.1
697
698* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
699- slightly different versioning scheming, will go back to the official
700  later when I'm sure the package is ready to use
701
702* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
703- 7.1 RELEASE
704- 7.1-1 RPM RELEASE
705- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
706- Back to old versioning scheme, kept teg's other fixes.
707- README.rpm-dist updated.
708- PGVERSION updated all-around (hopefully!)
709- Couple of fixes from Peter E.
710- Rearrange dependencies -- only the -libs subpackage is required for most stuff
711- Removed broken and confusing logrotate script.
712
713* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
714- chown considered harmful - removed
715- fix dangling symlimks (pg_crc.c)
716- libpq.so changes for maximum compatiblity
717- different versioning scheme, to avoid trouble later
718- remove temporary perl file from the file list
719- fix spelling error in tcl description
720- mark odbcinst.ini as a config file
721- use %%defattr on packages which didn't have it
722
723* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
724- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
725- Packaging reorg: added contrib and docs subpackages.
726- Removed sgml source docs from main package --> docs subpackage.
727- Removed contrib tree from main package --> contrib subpackage.
728- Contrib tree is now prebuilt -- HOWEVER, very little install work is
729  currently done with this.
730
731* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
732- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
733
734* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
735- RC2
736- eliminate versioning information for ancilliary files in prep for CVS.
737- Fix docs mixup.
738
739* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
740- RC1 quickie.
741
742* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
743- Beta 6 initial build.
744- Use make install-all-headers instead of cpio hack for devel headers.
745- Split out the libs into the libs subpackage.
746- Updated initscript to use pg_ctl to stop
747- Updated initscript to initdb and start postmaster with LC_ALL=C to
748  prevent index corruption.
749
750
751* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
752- Beta4
753- Return to 'pgsql' directories instead of 'postgresql'
754- Better perl patches.
755
756* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
757- Edit patches to get rid of some cruft.
758- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
759- Moved pg_id to server
760- added Makefile.global and pg_config to devel
761- Corrected /usr/include/pgsql to /usr/include/postgresql
762- Fixed some configure options.  Will be trying the configure macro next release
763- Since it is terminally ill in this version pg_upgrade is _gone_.
764- Thanks to Peter E for a good review.
765
766* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
767- Running regression. 1 on the release-o-meter.
768- Minor patches to get regression running right. 
769- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
770
771* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
772- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
773- The 7.1 build is different from the 7.0 build -- see the configure line.
774- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
775- by request, conditional packages are now supported. See the top of the spec.
776- Fixed the server postinstall problems.
777
778* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
779- First 7.1 beta test-build
780
Note: See TracBrowser for help on using the repository browser.