source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 12502

Revision 12502, 28.0 KB checked in by tomop, 3 years ago (diff)

updated 8 packages

firefox-78.3.1-1

libpq-13.0-1

nodejs-12.18.4-1

openssh-8.4p1-1

php74-7.4.11-1

postgresql-13.0-1

rspamd-2.6-1

thunderbird-68.12.1-1

Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 13
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Version: %{pgver}.0
18Release: 1%{?_dist_release}
19Group: system
20Vendor: Project Vine
21Distribution: Vine Linux
22
23License: BSD
24URL: https://www.postgresql.org/
25Source0: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
26Source5: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
27Source6: README.rpm-dist
28Patch2: postgresql-8.3.3-nls.patch
29Patch3: postgresql-7.4-ecpg-patch
30
31Buildroot: %{_tmppath}/%{name}-%{version}-root
32
33Buildrequires: perl build-essential
34Buildrequires: libedit-devel
35Buildrequires: zlib-devel >= 1.0.4
36BuildRequires: bison, flex, pam-devel
37%if %ssl
38Buildrequires: openssl-devel
39%endif
40%if %kerberos
41Buildrequires: krb5-devel
42%endif
43%if %nls
44Buildrequires: gettext >= 0.10.35
45%endif
46
47%if %pam
48Buildrequires: pam-devel
49%endif
50
51%description
52The %{name} package provides the essential shared libraries for any
53PostgreSQL client program or interface. You will need to install this package
54to use any other PostgreSQL package or any clients that need to connect to a
55PostgreSQL server.
56
57%description -l ja
58%{name} パッケージは、すべての PostgreSQL クライアントプログラ
59ムやインターフェースのための中核的な共有ライブラリを提供します。
60PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
61ントを使う場合には、このパッケージをインストールする必要があります。
62
63
64%package -n libpq%{pq_soname}
65Summary: The shared libraries required for any PostgreSQL clients.
66Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
67Group: system
68Requires(post): /sbin/ldconfig
69Requires(postun): /sbin/ldconfig
70Obsoletes: postgresql7-libs
71Obsoletes: postgresql8-libs
72Obsoletes: postgresql-libs < 9.3.0
73Conflicts: postgresql-libs >= 9.3.0
74
75%description -n libpq%{pq_soname}
76The %{name} package provides the essential shared libraries for any
77PostgreSQL client program or interface. You will need to install this package
78to use any other PostgreSQL package or any clients that need to connect to a
79PostgreSQL server.
80
81%description -n libpq%{pq_soname} -l ja
82%{name} パッケージは、すべての PostgreSQL クライアントプログラ
83ムやインターフェースのための中核的な共有ライブラリを提供します。
84PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
85ントを使う場合には、このパッケージをインストールする必要があります。
86
87
88%package devel
89Summary: PostgreSQL development header files and libraries.
90Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
91Group: programming
92Requires: libpq%{pq_soname} = %{version}
93Obsoletes: postgresql7-devel
94Obsoletes: postgresql8-devel
95Obsoletes: postgresql-devel < 9.3.0
96
97%description devel
98The %{name}-devel package contains the header files and libraries
99needed to compile C or C++ applications which will directly interact
100with a PostgreSQL database management server and the ecpg Embedded C
101Postgres preprocessor. You need to install this package if you want to
102develop applications which will interact with a PostgreSQL server.
103
104%description -l ja devel
105%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
106するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
107ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
108が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
109したい場合にはこのパッケージをインストールしてください。
110
111
112%debug_package
113
114
115%prep
116%setup -q -n postgresql-%{version}
117
118
119%build
120CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
121CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
122
123# Strip out -ffast-math from CFLAGS....
124
125CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
126
127./configure \
128        --prefix=%{_prefix} \
129        --libdir=%{_libdir} \
130        --disable-rpath \
131%if %beta
132        --enable-debug \
133        --enable-cassert \
134%endif
135%if %ssl
136        --with-openssl \
137%endif
138%if %pam
139        --with-pam \
140%endif
141%if %kerberos
142        --with-krb5=/usr/kerberos \
143%endif
144%if %nls
145        --enable-nls \
146%endif
147        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
148        --mandir=%{_mandir} \
149        --with-docdir=%{_docdir} \
150        --includedir=%{_includedir}/pgsql \
151        --datadir=%{_datadir}/pgsql
152
153# workaround for bug with parallel build
154make %{?_smp_mflags} -C ./src/interfaces all ||:
155make %{?_smp_mflags} -C ./src/interfaces all
156make %{?_smp_mflags} -C ./src/bin/pg_config all
157make %{?_smp_mflags} -C ./src/backend utils/errcodes.h
158make %{?_smp_mflags} -C ./src/backend utils/fmgroids.h
159
160
161%install
162rm -rf $RPM_BUILD_ROOT
163
164make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
165make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
166make DESTDIR=$RPM_BUILD_ROOT -C ./src/include install
167
168# copy over Makefile.global to the include dir....
169install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
170install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
171
172# install missing header
173mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
174install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
175install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
176install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
177install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
178install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
179install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
180install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
181
182# Fix some more documentation
183##gzip doc/internals.ps
184cp %{SOURCE6} README.rpm-dist
185##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
186##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
187
188mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
189install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
190
191%find_lang libpq5-%{pgver}
192%find_lang ecpg-%{pgver}
193%find_lang ecpglib%{ecpg_soname}-%{pgver}
194#%find_lang pg_config-%{pgver}
195
196cat libpq5-%{pgver}.lang > libpq.lst
197cat ecpg-%{pgver}.lang >> libpq.lst
198cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
199#cat pg_config-%{pgver}.lang > devel.lst
200
201rm -rf %{buildroot}%{_libdir}/lib*.a
202rm -rf %{buildroot}%{_datadir}/pgsql
203find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
204
205rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
206find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
207
208
209%clean
210rm -rf $RPM_BUILD_ROOT
211
212
213%post -n libpq%{pq_soname} -p /sbin/ldconfig
214%postun -n libpq%{pq_soname} -p /sbin/ldconfig
215
216
217%files -n libpq%{pq_soname} -f libpq.lst
218%defattr(-,root,root)
219%license COPYRIGHT
220%doc HISTORY INSTALL README*
221%{_libdir}/libecpg.so.*
222%{_libdir}/libecpg_compat.so.*
223%{_libdir}/libpgtypes.so.*
224%{_libdir}/libpq.so.*
225
226%files devel -f devel.lst
227%defattr(-,root,root)
228%{_bindir}/ecpg
229%{_bindir}/pg_config
230%{_libdir}/libecpg.so
231%{_libdir}/libecpg_compat.so
232%{_libdir}/libpgtypes.so
233%{_libdir}/libpq.so
234%{_libdir}/pkgconfig/*
235%dir %{_includedir}/pgsql
236%{_datadir}/locale/*/LC_MESSAGES/*.mo
237%{_mandir}/man1/ecpg.*
238#%{_mandir}/man1/pg_config.*
239
240
241%changelog
242* Mon Oct 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0-1
243- new upstream release.
244
245* Fri Feb 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.2-1
246- new upstream release.
247
248* Sat Oct 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0-1
249- new upstream release.
250
251* Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.5-1
252- new upstream release.
253
254* Fri Mar 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.3-1
255- new upstream release.
256
257* Fri Apr  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.2-1
258- new upstream release.
259
260* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.1-1
261- new upstream release.
262
263* Sat Jan  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.0-1
264- new upstream release.
265
266* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.5-1
267- new upstream release.
268
269* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.4-1
270- new upstream release.
271
272* Fri Jun 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.3-1
273- new upstream release.
274
275* Thu Jul 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-4
276- added all headers for a strange client.
277
278* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
279- add pgconfig
280- add pg_config*.h and libpq/libpq-fs.h
281
282* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
283- add postgres_ext.h and pg_config_ext.h
284
285* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
286- new upstream release
287
288* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
289- made to build client libraries only.
290
291* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
292- new upstream release
293
294* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
295- new upstream release
296- add Vendor and Distribution tags
297
298* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
299- build with Tcl/Tk 8.5.7-1
300- fix init script (Source3): fix su(1) paramaters.
301
302* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
303- new upstream release
304- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
305- remove *_and_*.so from -contrib (included in -server)
306
307* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
308- updated postgresql to 9.0.4
309
310* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
311- updated postgresql to 9.0.3
312- separated postgresql-jdbc package
313
314* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
315- updated postgresql to 8.4.7 (contains a variety of fixes)
316
317* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
318- updated postgresql to 8.4.6
319- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
320- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
321- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
322
323* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
324- rebuilt with openssl-1.0.0c
325
326* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
327- updated postgresql to 8.4.5
328
329* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
330- updated postgresql to 8.4.4
331
332* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
333- updated postgresql to 8.4.3
334- s/BuildPrereq/Buildrequires/
335
336* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
337- updated postgresql to 8.4.2
338- rebuilt with new environment
339
340* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
341- updated postgresql to 8.4.1
342
343* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
344- moved dict_snowball.so from conrib to server
345
346* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
347- updated postgresql to 8.4.0
348- updated jdbc3,4 to 701
349- dropt postgresql-8.3.3-nls.patch (fixed)
350- dropt postgresql-7.4-ecpg-patch (no effect)
351
352* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
353- changed libs Group to System Environment/Libraries
354
355* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
356- updated postgresql to 8.3.7
357
358* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
359- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
360
361* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
362- new upstream release (postgresql to 8.3.5, jdbc to 604)
363
364* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
365- applied new versioning policy, and spec in utf-8
366- updated postgresql to 8.3.3
367- updated jdbcver to 603
368- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
369- added a script to replace PGVERSION in postgresql.init
370
371* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
372- rebuild with tcl/tk-8.4.18
373
374* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
375- updated postgresql to 8.2.6
376- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
377
378* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
379- updated PGVERSION to 8.2 in postgresql.init (sorry;)
380
381* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
382- rebuild with tcl/tk-8.4.16
383
384* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
385- updated postgresql to 8.2.5
386- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
387- updated nls-patch to 8-2-0
388- dropt postgresql-8.1.4-Pg.patch.gz
389
390* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
391- for VineSeed
392- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
393- JDBC driver updated to 410
394
395* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
396- rebuilt for VineSeed
397- fixed install script
398
399* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
400- upstream release
401- fix missing %defattr in %files server
402
403* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
404- fix version number in postgresql.init
405
406* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
407- upstream release
408- drop rpm-pgsql-8.0.0.patch
409- add Requires: perl-DBD-Pg for contrib
410- add postgresql-8.1.4-Pg.patch.gz
411- update nls patches
412- new JDBC driver
413
414* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
415- added build options --without perl, --without python
416- rebuilt for x86_64 architecture support
417
418* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
419- drop Provides: on postgresql-libs
420- drop Requires: libpq.so on postgresql-server
421
422* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
423- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
424
425* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
426- upstream release
427- update nls patches
428
429* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
430- upstream release
431- update nls patches
432
433* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
434- rebuilded with python-2.4.1-0vl1
435
436* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
437- Dropped PyGreSQL-3.4.tgz.
438- Dropped PyGreSQL-3.4-setup-2.patch.
439- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
440- Dropped pyver and pynextver macros.
441- Changed macro name "python" to "plpython" like plperl.
442- Added "Obsoletes: postgresql-python"
443
444* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
445- Major version up
446- Obsoletes: postgresql7
447- update nls patch(es)
448- modify %postun not to delete postgres account on upgrade
449
450* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
451- upstream release (release as a new package)
452- Conflicts: postgresql
453- update nls patch(es)
454- (this package revision was rejected by Vine Project)
455
456* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
457- upstream release
458- new JDBC driver
459- add BuildRequires: bison, flex, pam-devel
460- drop postgresql-7.4.5-tempfile.patch (repaired)
461
462* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
463- Added a security fix patch postgresql-7.4.5-tempfile.patch
464  from Gentoo Linux (CAN-2004-0977).
465- Changed Patch4:
466  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
467  It is possible to compile this package without pre-installed postgresql.
468- Removed Patch5 because Patch4 was changed.
469
470* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
471- upstream release
472
473* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
474- upstream release
475- new jdbc driver
476
477* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
478- rebuild with python-2.3.3-0vl1
479
480* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
481- changed mode to 644 at Makefile.global, Makefile.shlib
482
483* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
484- updated python install section
485
486* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
487- added PyGreSQL-3.4.tgz and set python flag
488- added PyGreSQL-3.4-setup.patch
489- added PyGreSQL-3.4-pgmodule.patch
490- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
491
492* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
493- rebuild with new openssl
494
495* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
496- upstream release
497- change all of %{?foo:%define foo 0} -like descriptions to simple
498  %define format for latest rpm to build.
499
500* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
501- rebuild on latest tcl package environment.
502
503* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
504- fixed lacking files at server's %files
505
506* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
507- include JDBC driver for 7.4
508- fix typo in postgresql-7.4-psql-patch
509
510* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
511- upstream release
512- change '--includedir=' option to avoid conflicting with unixODBC
513- add postgresql-7.4-ecpg-patch
514
515* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
516- upstream release
517
518* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
519- drop previous version of libpq's trash
520
521* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
522- upstream release with new nls patch
523- fix postgresql-bashprofile (value of PGDATA)
524- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
525
526* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
527- rebuild with tcltk8.4 and readline-4.3
528
529* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
530- upstream release
531
532* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
533- upstream release
534- remove garbage changelog
535
536* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
537- upstream release based on 7.3-2PGDG
538- add nls patch
539
540* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
541- 7.3-2PGDG
542- Fix typo in initscript.  Argh!!
543
544* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
545- 7.3-0.5PGDG
546- Jerk out all perl client stuff and kludgage
547- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
548- Eliminate locale and multibyte explicit enables -- they are both defaults now
549- Eliminate pgaccess code; it's not a part of the main tarball anymore
550- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
551- Eliminated separate tk client package -- rolled the tk client into the tcl client.
552- Moved pltcl into the pl subpackage.
553- Added plpython to the pl subpackage.
554- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
555
556* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
557- 7.3-0.1PGDG (not released)
558- Integrate 7.3 jar's courtesy Joe Conway
559- Integrate multi-postmaster initscript courtesy Karl DeBisschop
560- Some renames and restructures.
561- Stripped out the last dregs of the postgresql-dump migration script.
562- Conflicts with less than 7.3.
563
564- (See below for old changelogs from VineSeed)
565
566* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
567- updated to 7.2.3.
568
569* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
570- absorbed previous patch8 into original nlspatch
571- fixed configure options (--enable-nls and --enable-locale to be antinomy)
572
573* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
574- add patch8 (ja.po for psql was invalid)
575
576* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
577- updated to 7.2.2.
578- improved nlspatch to enable japanese SQL help in psql.
579
580* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
581- fixed garbage chars in description(ja).
582
583* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
584- imported & replaced changelog (following VineSeed's).
585  add some stuff to '%%files'.
586
587* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
588- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
589  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
590
591* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
592- replace nls patch.
593- add *.mo to '%%files'.
594
595* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
596- fix initscript
597
598* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
599- add /usr/bin/pg_id to the package (fix)
600
601* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
602- updated 7.2
603- added nls.patch
604- fixed spec file
605- added New JDBC
606-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
607
608* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
609- updated 7.1.3
610
611* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
612- 7.1.2-7vl3
613- merge 7.1.2-7vl2 and 7.1.2-7
614
615* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
616- 7.1.2-7vl2
617- fixed spec typo (%%{_includesir} -> %%{_includedir})
618
619* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
620- updated 7.1.2 (used postgresql-7.1.2-7)
621- used psqlj patch for 7.1.2
622- used jumbo-20010801.patch.gz
623
624* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
625- Add patches from 7.1-stable branch. This should fix #50799 and #50797
626- Enable kerberos authentication (#50644)
627- handle stop with stale pid file (#50499)
628- make the test subpackage (not built by default) own /usr/lib/pgsql/test
629
630* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
631- Make the -devel subpackage depend on -libs, not the main package
632
633* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
634- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
635
636* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
637- add changes for s390x
638
639* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
640- Many path fixes for contrib packages
641- Newer intarray
642- Don't use nested ifs for tkpkg/pgaccess
643- Turn off test package for Red Hat Linux - it makes most sense just to use
644  this during development
645- One "pgacess" -> "pgaccess"
646
647* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
648- -4PGDG
649- patchset update for pg_regress.sh
650- can the dot in the release -- confused too many people and some programs.
651- -3.PGDG
652- updated README.rpm-dist
653- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
654  was still being used where /usr/lib/pgsql was intended.
655- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
656
657* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
658- sync
659- Run chkconfig --add on server install
660- Move the prereqs on useradd on chkconfig to the server package
661- don't disable the %%clean section
662
663* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
664- Sync up with Trond Eivind's set.
665
666* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
667- Don't create postgres' .bashrc from the server post script: include it instead
668- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
669- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
670  libs
671- Source the i18n data from the .bashrc instead of in the initscript
672
673* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
674- Handle i18n for database startup - backend needs to have the same locale everytime,
675  but this certainly can't be hardcoded to C either
676- Fix stop, restart in initscript (#42217)
677- Make database init _much_ less verbose
678- other minor fixes to the initscript
679
680* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
681- 7.1.2
682
683* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
684- 7.1.2-0.1.1.PGDG PRERELEASE
685- Changed versioning and release numbering a little for better flexibility,
686-- particularly for distribution packagers.
687- Release numbering comment at top of spec, where it's more useful.
688- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
689  changlog, and the last 6.5.3's specfile for the changelog prior to
690  7.0.
691
692* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
693- 7.1.1-4.PGDG
694- _really_ got Python version agnosticism working.
695
696* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
697- 7.1.1-3.PGDG Release
698- Python version agnosticism.....
699
700* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
701- Use openssl
702- Make it obsolete subpackages if they aren't built
703
704* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
705- 7.1.1-2.PGDG Release.
706- Appended .PGDG to release string to differentiate our RPM set from the others.
707- /bin/sh fix in initscript
708- README.rpm-dist updates.
709
710* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
711- Rebuild with new readline
712
713* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
714- Initial 7.1.1
715
716* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
717- Specify shell when running commands through su in the initscript, to avoid problems
718  when people switch the postgres user to use tcsh
719
720* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
721- JDBC driver for Postgresql 7.1
722
723* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
724- slightly different versioning scheming, will go back to the official
725  later when I'm sure the package is ready to use
726
727* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
728- 7.1 RELEASE
729- 7.1-1 RPM RELEASE
730- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
731- Back to old versioning scheme, kept teg's other fixes.
732- README.rpm-dist updated.
733- PGVERSION updated all-around (hopefully!)
734- Couple of fixes from Peter E.
735- Rearrange dependencies -- only the -libs subpackage is required for most stuff
736- Removed broken and confusing logrotate script.
737
738* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
739- chown considered harmful - removed
740- fix dangling symlimks (pg_crc.c)
741- libpq.so changes for maximum compatiblity
742- different versioning scheme, to avoid trouble later
743- remove temporary perl file from the file list
744- fix spelling error in tcl description
745- mark odbcinst.ini as a config file
746- use %%defattr on packages which didn't have it
747
748* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
749- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
750- Packaging reorg: added contrib and docs subpackages.
751- Removed sgml source docs from main package --> docs subpackage.
752- Removed contrib tree from main package --> contrib subpackage.
753- Contrib tree is now prebuilt -- HOWEVER, very little install work is
754  currently done with this.
755
756* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
757- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
758
759* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
760- RC2
761- eliminate versioning information for ancilliary files in prep for CVS.
762- Fix docs mixup.
763
764* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
765- RC1 quickie.
766
767* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
768- Beta 6 initial build.
769- Use make install-all-headers instead of cpio hack for devel headers.
770- Split out the libs into the libs subpackage.
771- Updated initscript to use pg_ctl to stop
772- Updated initscript to initdb and start postmaster with LC_ALL=C to
773  prevent index corruption.
774
775
776* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
777- Beta4
778- Return to 'pgsql' directories instead of 'postgresql'
779- Better perl patches.
780
781* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
782- Edit patches to get rid of some cruft.
783- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
784- Moved pg_id to server
785- added Makefile.global and pg_config to devel
786- Corrected /usr/include/pgsql to /usr/include/postgresql
787- Fixed some configure options.  Will be trying the configure macro next release
788- Since it is terminally ill in this version pg_upgrade is _gone_.
789- Thanks to Peter E for a good review.
790
791* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
792- Running regression. 1 on the release-o-meter.
793- Minor patches to get regression running right. 
794- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
795
796* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
797- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
798- The 7.1 build is different from the 7.0 build -- see the configure line.
799- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
800- by request, conditional packages are now supported. See the top of the spec.
801- Fixed the server postinstall problems.
802
803* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
804- First 7.1 beta test-build
805
Note: See TracBrowser for help on using the repository browser.