source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 11872

Revision 11872, 27.7 KB checked in by tomop, 6 years ago (diff)

libpq-10.5-1

Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 10
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Group: System Environment/Libraries
18Version: %{pgver}.5
19Release: 1%{?_dist_release}
20License: BSD
21Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
22Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
23Source6: README.rpm-dist
24Patch2: postgresql-8.3.3-nls.patch
25Patch3: postgresql-7.4-ecpg-patch
26Buildrequires: perl build-essential
27Buildrequires: libedit-devel
28Buildrequires: zlib-devel >= 1.0.4
29BuildRequires: bison, flex, pam-devel
30%if %ssl
31Buildrequires: openssl-devel
32%endif
33%if %kerberos
34Buildrequires: krb5-devel
35%endif
36%if %nls
37Buildrequires: gettext >= 0.10.35
38%endif
39
40%if %pam
41Buildrequires: pam-devel
42%endif
43
44Url: http://www.postgresql.org/
45Buildroot: %{_tmppath}/%{name}-%{version}-root
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51The %{name} package provides the essential shared libraries for any
52PostgreSQL client program or interface. You will need to install this package
53to use any other PostgreSQL package or any clients that need to connect to a
54PostgreSQL server.
55
56%description -l ja
57%{name} パッケージは、すべての PostgreSQL クライアントプログラ
58ムやインターフェースのための中核的な共有ライブラリを提供します。
59PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
60ントを使う場合には、このパッケージをインストールする必要があります。
61
62%package -n libpq%{pq_soname}
63Summary: The shared libraries required for any PostgreSQL clients.
64Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
65Group: System Environment/Libraries
66Requires(post): /sbin/ldconfig
67Requires(postun): /sbin/ldconfig
68Obsoletes: postgresql7-libs
69Obsoletes: postgresql8-libs
70Obsoletes: postgresql-libs < 9.3.0
71Conflicts: postgresql-libs >= 9.3.0
72
73%description -n libpq%{pq_soname}
74The %{name} package provides the essential shared libraries for any
75PostgreSQL client program or interface. You will need to install this package
76to use any other PostgreSQL package or any clients that need to connect to a
77PostgreSQL server.
78
79%description -n libpq%{pq_soname} -l ja
80%{name} パッケージは、すべての PostgreSQL クライアントプログラ
81ムやインターフェースのための中核的な共有ライブラリを提供します。
82PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
83ントを使う場合には、このパッケージをインストールする必要があります。
84
85%package devel
86Summary: PostgreSQL development header files and libraries.
87Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
88Group: Development/Libraries
89Requires: libpq%{pq_soname} = %{version}
90Obsoletes: postgresql7-devel
91Obsoletes: postgresql8-devel
92Obsoletes: postgresql-devel < 9.3.0
93
94%description devel
95The %{name}-devel package contains the header files and libraries
96needed to compile C or C++ applications which will directly interact
97with a PostgreSQL database management server and the ecpg Embedded C
98Postgres preprocessor. You need to install this package if you want to
99develop applications which will interact with a PostgreSQL server.
100
101%description -l ja devel
102%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
103するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
104ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
105が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
106したい場合にはこのパッケージをインストールしてください。
107
108
109%prep
110%setup -q -n postgresql-%{version}
111
112
113%build
114CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
115CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
116
117# Strip out -ffast-math from CFLAGS....
118
119CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
120
121./configure \
122        --prefix=%{_prefix} \
123        --libdir=%{_libdir} \
124        --disable-rpath \
125%if %beta
126        --enable-debug \
127        --enable-cassert \
128%endif
129%if %ssl
130        --with-openssl \
131%endif
132%if %pam
133        --with-pam \
134%endif
135%if %kerberos
136        --with-krb5=/usr/kerberos \
137%endif
138%if %nls
139        --enable-nls \
140%endif
141        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
142        --mandir=%{_mandir} \
143        --with-docdir=%{_docdir} \
144        --includedir=%{_includedir}/pgsql \
145        --datadir=%{_datadir}/pgsql
146
147make %{?_smp_mflags} -C ./src/interfaces all
148make %{?_smp_mflags} -C ./src/bin/pg_config all
149make %{?_smp_mflags} -C ./src/backend utils/errcodes.h
150make %{?_smp_mflags} -C ./src/backend utils/fmgroids.h
151
152
153%install
154rm -rf $RPM_BUILD_ROOT
155
156make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
157make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
158cp -f ./src/backend/utils/fmgroids.h ./src/include/utils/
159cp -f ./src/backend/utils/fmgrprotos.h ./src/include/utils/
160make DESTDIR=$RPM_BUILD_ROOT -C ./src/include install
161
162# copy over Makefile.global to the include dir....
163install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
164install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
165
166# install missing header
167mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
168install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
169install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
170install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
171install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
172install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
173install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
174install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
175
176# Fix some more documentation
177##gzip doc/internals.ps
178cp %{SOURCE6} README.rpm-dist
179##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
180##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
181
182mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
183install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
184
185
186%find_lang libpq5-%{pgver}
187%find_lang ecpg-%{pgver}
188%find_lang ecpglib%{ecpg_soname}-%{pgver}
189#%find_lang pg_config-%{pgver}
190
191cat libpq5-%{pgver}.lang > libpq.lst
192cat ecpg-%{pgver}.lang >> libpq.lst
193cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
194#cat pg_config-%{pgver}.lang > devel.lst
195
196rm -rf %{buildroot}%{_libdir}/lib*.a
197rm -rf %{buildroot}%{_datadir}/pgsql
198find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
199
200rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
201find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
202
203%post
204/sbin/ldconfig
205
206%postun
207/sbin/ldconfig
208
209
210%clean
211rm -rf $RPM_BUILD_ROOT
212
213
214%files -n libpq%{pq_soname} -f libpq.lst
215%defattr(-,root,root)
216%doc COPYRIGHT HISTORY INSTALL README*
217%{_libdir}/libecpg.so.*
218%{_libdir}/libecpg_compat.so.*
219%{_libdir}/libpgtypes.so.*
220%{_libdir}/libpq.so.*
221
222%files devel -f devel.lst
223%defattr(-,root,root)
224%{_bindir}/ecpg
225%{_bindir}/pg_config
226%{_libdir}/libecpg.so
227%{_libdir}/libecpg_compat.so
228%{_libdir}/libpgtypes.so
229%{_libdir}/libpq.so
230%{_libdir}/pkgconfig/*
231%{_datadir}/locale/*/LC_MESSAGES/*.mo
232%{_mandir}/man1/ecpg.*
233#%{_mandir}/man1/pg_config.*
234
235
236%changelog
237* Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.5-1
238- new upstream release.
239
240* Fri Mar 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.3-1
241- new upstream release.
242
243* Fri Apr  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.2-1
244- new upstream release.
245
246* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.1-1
247- new upstream release.
248
249* Sat Jan  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.0-1
250- new upstream release.
251
252* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.5-1
253- new upstream release.
254
255* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.4-1
256- new upstream release.
257
258* Fri Jun 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.3-1
259- new upstream release.
260
261* Thu Jul 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-4
262- added all headers for a strange client.
263
264* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
265- add pgconfig
266- add pg_config*.h and libpq/libpq-fs.h
267
268* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
269- add postgres_ext.h and pg_config_ext.h
270
271* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
272- new upstream release
273
274* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
275- made to build client libraries only.
276
277* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
278- new upstream release
279
280* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
281- new upstream release
282- add Vendor and Distribution tags
283
284* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
285- build with Tcl/Tk 8.5.7-1
286- fix init script (Source3): fix su(1) paramaters.
287
288* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
289- new upstream release
290- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
291- remove *_and_*.so from -contrib (included in -server)
292
293* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
294- updated postgresql to 9.0.4
295
296* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
297- updated postgresql to 9.0.3
298- separated postgresql-jdbc package
299
300* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
301- updated postgresql to 8.4.7 (contains a variety of fixes)
302
303* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
304- updated postgresql to 8.4.6
305- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
306- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
307- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
308
309* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
310- rebuilt with openssl-1.0.0c
311
312* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
313- updated postgresql to 8.4.5
314
315* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
316- updated postgresql to 8.4.4
317
318* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
319- updated postgresql to 8.4.3
320- s/BuildPrereq/Buildrequires/
321
322* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
323- updated postgresql to 8.4.2
324- rebuilt with new environment
325
326* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
327- updated postgresql to 8.4.1
328
329* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
330- moved dict_snowball.so from conrib to server
331
332* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
333- updated postgresql to 8.4.0
334- updated jdbc3,4 to 701
335- dropt postgresql-8.3.3-nls.patch (fixed)
336- dropt postgresql-7.4-ecpg-patch (no effect)
337
338* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
339- changed libs Group to System Environment/Libraries
340
341* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
342- updated postgresql to 8.3.7
343
344* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
345- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
346
347* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
348- new upstream release (postgresql to 8.3.5, jdbc to 604)
349
350* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
351- applied new versioning policy, and spec in utf-8
352- updated postgresql to 8.3.3
353- updated jdbcver to 603
354- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
355- added a script to replace PGVERSION in postgresql.init
356
357* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
358- rebuild with tcl/tk-8.4.18
359
360* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
361- updated postgresql to 8.2.6
362- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
363
364* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
365- updated PGVERSION to 8.2 in postgresql.init (sorry;)
366
367* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
368- rebuild with tcl/tk-8.4.16
369
370* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
371- updated postgresql to 8.2.5
372- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
373- updated nls-patch to 8-2-0
374- dropt postgresql-8.1.4-Pg.patch.gz
375
376* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
377- for VineSeed
378- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
379- JDBC driver updated to 410
380
381* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
382- rebuilt for VineSeed
383- fixed install script
384
385* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
386- upstream release
387- fix missing %defattr in %files server
388
389* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
390- fix version number in postgresql.init
391
392* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
393- upstream release
394- drop rpm-pgsql-8.0.0.patch
395- add Requires: perl-DBD-Pg for contrib
396- add postgresql-8.1.4-Pg.patch.gz
397- update nls patches
398- new JDBC driver
399
400* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
401- added build options --without perl, --without python
402- rebuilt for x86_64 architecture support
403
404* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
405- drop Provides: on postgresql-libs
406- drop Requires: libpq.so on postgresql-server
407
408* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
409- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
410
411* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
412- upstream release
413- update nls patches
414
415* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
416- upstream release
417- update nls patches
418
419* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
420- rebuilded with python-2.4.1-0vl1
421
422* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
423- Dropped PyGreSQL-3.4.tgz.
424- Dropped PyGreSQL-3.4-setup-2.patch.
425- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
426- Dropped pyver and pynextver macros.
427- Changed macro name "python" to "plpython" like plperl.
428- Added "Obsoletes: postgresql-python"
429
430* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
431- Major version up
432- Obsoletes: postgresql7
433- update nls patch(es)
434- modify %postun not to delete postgres account on upgrade
435
436* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
437- upstream release (release as a new package)
438- Conflicts: postgresql
439- update nls patch(es)
440- (this package revision was rejected by Vine Project)
441
442* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
443- upstream release
444- new JDBC driver
445- add BuildRequires: bison, flex, pam-devel
446- drop postgresql-7.4.5-tempfile.patch (repaired)
447
448* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
449- Added a security fix patch postgresql-7.4.5-tempfile.patch
450  from Gentoo Linux (CAN-2004-0977).
451- Changed Patch4:
452  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
453  It is possible to compile this package without pre-installed postgresql.
454- Removed Patch5 because Patch4 was changed.
455
456* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
457- upstream release
458
459* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
460- upstream release
461- new jdbc driver
462
463* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
464- rebuild with python-2.3.3-0vl1
465
466* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
467- changed mode to 644 at Makefile.global, Makefile.shlib
468
469* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
470- updated python install section
471
472* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
473- added PyGreSQL-3.4.tgz and set python flag
474- added PyGreSQL-3.4-setup.patch
475- added PyGreSQL-3.4-pgmodule.patch
476- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
477
478* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
479- rebuild with new openssl
480
481* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
482- upstream release
483- change all of %{?foo:%define foo 0} -like descriptions to simple
484  %define format for latest rpm to build.
485
486* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
487- rebuild on latest tcl package environment.
488
489* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
490- fixed lacking files at server's %files
491
492* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
493- include JDBC driver for 7.4
494- fix typo in postgresql-7.4-psql-patch
495
496* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
497- upstream release
498- change '--includedir=' option to avoid conflicting with unixODBC
499- add postgresql-7.4-ecpg-patch
500
501* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
502- upstream release
503
504* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
505- drop previous version of libpq's trash
506
507* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
508- upstream release with new nls patch
509- fix postgresql-bashprofile (value of PGDATA)
510- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
511
512* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
513- rebuild with tcltk8.4 and readline-4.3
514
515* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
516- upstream release
517
518* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
519- upstream release
520- remove garbage changelog
521
522* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
523- upstream release based on 7.3-2PGDG
524- add nls patch
525
526* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
527- 7.3-2PGDG
528- Fix typo in initscript.  Argh!!
529
530* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
531- 7.3-0.5PGDG
532- Jerk out all perl client stuff and kludgage
533- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
534- Eliminate locale and multibyte explicit enables -- they are both defaults now
535- Eliminate pgaccess code; it's not a part of the main tarball anymore
536- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
537- Eliminated separate tk client package -- rolled the tk client into the tcl client.
538- Moved pltcl into the pl subpackage.
539- Added plpython to the pl subpackage.
540- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
541
542* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
543- 7.3-0.1PGDG (not released)
544- Integrate 7.3 jar's courtesy Joe Conway
545- Integrate multi-postmaster initscript courtesy Karl DeBisschop
546- Some renames and restructures.
547- Stripped out the last dregs of the postgresql-dump migration script.
548- Conflicts with less than 7.3.
549
550- (See below for old changelogs from VineSeed)
551
552* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
553- updated to 7.2.3.
554
555* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
556- absorbed previous patch8 into original nlspatch
557- fixed configure options (--enable-nls and --enable-locale to be antinomy)
558
559* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
560- add patch8 (ja.po for psql was invalid)
561
562* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
563- updated to 7.2.2.
564- improved nlspatch to enable japanese SQL help in psql.
565
566* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
567- fixed garbage chars in description(ja).
568
569* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
570- imported & replaced changelog (following VineSeed's).
571  add some stuff to '%%files'.
572
573* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
574- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
575  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
576
577* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
578- replace nls patch.
579- add *.mo to '%%files'.
580
581* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
582- fix initscript
583
584* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
585- add /usr/bin/pg_id to the package (fix)
586
587* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
588- updated 7.2
589- added nls.patch
590- fixed spec file
591- added New JDBC
592-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
593
594* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
595- updated 7.1.3
596
597* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
598- 7.1.2-7vl3
599- merge 7.1.2-7vl2 and 7.1.2-7
600
601* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
602- 7.1.2-7vl2
603- fixed spec typo (%%{_includesir} -> %%{_includedir})
604
605* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
606- updated 7.1.2 (used postgresql-7.1.2-7)
607- used psqlj patch for 7.1.2
608- used jumbo-20010801.patch.gz
609
610* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
611- Add patches from 7.1-stable branch. This should fix #50799 and #50797
612- Enable kerberos authentication (#50644)
613- handle stop with stale pid file (#50499)
614- make the test subpackage (not built by default) own /usr/lib/pgsql/test
615
616* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
617- Make the -devel subpackage depend on -libs, not the main package
618
619* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
620- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
621
622* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
623- add changes for s390x
624
625* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
626- Many path fixes for contrib packages
627- Newer intarray
628- Don't use nested ifs for tkpkg/pgaccess
629- Turn off test package for Red Hat Linux - it makes most sense just to use
630  this during development
631- One "pgacess" -> "pgaccess"
632
633* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
634- -4PGDG
635- patchset update for pg_regress.sh
636- can the dot in the release -- confused too many people and some programs.
637- -3.PGDG
638- updated README.rpm-dist
639- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
640  was still being used where /usr/lib/pgsql was intended.
641- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
642
643* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
644- sync
645- Run chkconfig --add on server install
646- Move the prereqs on useradd on chkconfig to the server package
647- don't disable the %%clean section
648
649* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
650- Sync up with Trond Eivind's set.
651
652* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
653- Don't create postgres' .bashrc from the server post script: include it instead
654- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
655- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
656  libs
657- Source the i18n data from the .bashrc instead of in the initscript
658
659* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
660- Handle i18n for database startup - backend needs to have the same locale everytime,
661  but this certainly can't be hardcoded to C either
662- Fix stop, restart in initscript (#42217)
663- Make database init _much_ less verbose
664- other minor fixes to the initscript
665
666* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
667- 7.1.2
668
669* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
670- 7.1.2-0.1.1.PGDG PRERELEASE
671- Changed versioning and release numbering a little for better flexibility,
672-- particularly for distribution packagers.
673- Release numbering comment at top of spec, where it's more useful.
674- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
675  changlog, and the last 6.5.3's specfile for the changelog prior to
676  7.0.
677
678* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
679- 7.1.1-4.PGDG
680- _really_ got Python version agnosticism working.
681
682* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
683- 7.1.1-3.PGDG Release
684- Python version agnosticism.....
685
686* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
687- Use openssl
688- Make it obsolete subpackages if they aren't built
689
690* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
691- 7.1.1-2.PGDG Release.
692- Appended .PGDG to release string to differentiate our RPM set from the others.
693- /bin/sh fix in initscript
694- README.rpm-dist updates.
695
696* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
697- Rebuild with new readline
698
699* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
700- Initial 7.1.1
701
702* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
703- Specify shell when running commands through su in the initscript, to avoid problems
704  when people switch the postgres user to use tcsh
705
706* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
707- JDBC driver for Postgresql 7.1
708
709* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
710- slightly different versioning scheming, will go back to the official
711  later when I'm sure the package is ready to use
712
713* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
714- 7.1 RELEASE
715- 7.1-1 RPM RELEASE
716- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
717- Back to old versioning scheme, kept teg's other fixes.
718- README.rpm-dist updated.
719- PGVERSION updated all-around (hopefully!)
720- Couple of fixes from Peter E.
721- Rearrange dependencies -- only the -libs subpackage is required for most stuff
722- Removed broken and confusing logrotate script.
723
724* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
725- chown considered harmful - removed
726- fix dangling symlimks (pg_crc.c)
727- libpq.so changes for maximum compatiblity
728- different versioning scheme, to avoid trouble later
729- remove temporary perl file from the file list
730- fix spelling error in tcl description
731- mark odbcinst.ini as a config file
732- use %%defattr on packages which didn't have it
733
734* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
735- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
736- Packaging reorg: added contrib and docs subpackages.
737- Removed sgml source docs from main package --> docs subpackage.
738- Removed contrib tree from main package --> contrib subpackage.
739- Contrib tree is now prebuilt -- HOWEVER, very little install work is
740  currently done with this.
741
742* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
743- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
744
745* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
746- RC2
747- eliminate versioning information for ancilliary files in prep for CVS.
748- Fix docs mixup.
749
750* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
751- RC1 quickie.
752
753* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
754- Beta 6 initial build.
755- Use make install-all-headers instead of cpio hack for devel headers.
756- Split out the libs into the libs subpackage.
757- Updated initscript to use pg_ctl to stop
758- Updated initscript to initdb and start postmaster with LC_ALL=C to
759  prevent index corruption.
760
761
762* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
763- Beta4
764- Return to 'pgsql' directories instead of 'postgresql'
765- Better perl patches.
766
767* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
768- Edit patches to get rid of some cruft.
769- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
770- Moved pg_id to server
771- added Makefile.global and pg_config to devel
772- Corrected /usr/include/pgsql to /usr/include/postgresql
773- Fixed some configure options.  Will be trying the configure macro next release
774- Since it is terminally ill in this version pg_upgrade is _gone_.
775- Thanks to Peter E for a good review.
776
777* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
778- Running regression. 1 on the release-o-meter.
779- Minor patches to get regression running right. 
780- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
781
782* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
783- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
784- The 7.1 build is different from the 7.0 build -- see the configure line.
785- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
786- by request, conditional packages are now supported. See the top of the spec.
787- Fixed the server postinstall problems.
788
789* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
790- First 7.1 beta test-build
791
Note: See TracBrowser for help on using the repository browser.