source: projects/specs/trunk/lib/libp/libpq/libpq-vl.spec @ 11566

Revision 11566, 27.7 KB checked in by tomop, 6 years ago (diff)

libpq-10.3-1

Line 
1#%define rel 0
2%define beta 0
3%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
4
5%define ssl 1
6%define kerberos 0
7%define nls 1
8%define pam 1
9
10%define pgver 10
11%define pq_soname 5
12%define ecpg_soname 6
13
14Summary: The shared libraries required for any PostgreSQL clients.
15Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
16Name: libpq
17Group: System Environment/Libraries
18Version: %{pgver}.3
19Release: 1%{?_dist_release}
20License: BSD
21Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
22Source3: postgresql.init
23Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
24Source6: README.rpm-dist
25Source15: postgresql-bashprofile
26Patch2: postgresql-8.3.3-nls.patch
27Patch3: postgresql-7.4-ecpg-patch
28Buildrequires: perl build-essential
29Buildrequires: libedit-devel
30Buildrequires: zlib-devel >= 1.0.4
31BuildRequires: bison, flex, pam-devel
32%if %ssl
33Buildrequires: openssl-devel
34%endif
35%if %kerberos
36Buildrequires: krb5-devel
37%endif
38%if %nls
39Buildrequires: gettext >= 0.10.35
40%endif
41
42%if %pam
43Buildrequires: pam-devel
44%endif
45
46Url: http://www.postgresql.org/
47Buildroot: %{_tmppath}/%{name}-%{version}-root
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53The %{name} package provides the essential shared libraries for any
54PostgreSQL client program or interface. You will need to install this package
55to use any other PostgreSQL package or any clients that need to connect to a
56PostgreSQL server.
57
58%description -l ja
59%{name} パッケージは、すべての PostgreSQL クライアントプログラ
60ムやインターフェースのための中核的な共有ライブラリを提供します。
61PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
62ントを使う場合には、このパッケージをインストールする必要があります。
63
64%package -n libpq%{pq_soname}
65Summary: The shared libraries required for any PostgreSQL clients.
66Summary(ja): PostgreSQL クライアントに必要な共有ライブラリ
67Group: System Environment/Libraries
68Requires(post): /sbin/ldconfig
69Requires(postun): /sbin/ldconfig
70Obsoletes: postgresql7-libs
71Obsoletes: postgresql8-libs
72Obsoletes: postgresql-libs < 9.3.0
73Conflicts: postgresql-libs >= 9.3.0
74
75%description -n libpq%{pq_soname}
76The %{name} package provides the essential shared libraries for any
77PostgreSQL client program or interface. You will need to install this package
78to use any other PostgreSQL package or any clients that need to connect to a
79PostgreSQL server.
80
81%description -n libpq%{pq_soname} -l ja
82%{name} パッケージは、すべての PostgreSQL クライアントプログラ
83ムやインターフェースのための中核的な共有ライブラリを提供します。
84PostgreSQL サーバに接続する必要のある、PostgreSQL パッケージやクライア
85ントを使う場合には、このパッケージをインストールする必要があります。
86
87%package devel
88Summary: PostgreSQL development header files and libraries.
89Summary(ja): PostgreSQL の開発用ヘッダファイルとライブラリ群
90Group: Development/Libraries
91Requires: libpq%{pq_soname} = %{version}
92Obsoletes: postgresql7-devel
93Obsoletes: postgresql8-devel
94Obsoletes: postgresql-devel < 9.3.0
95
96%description devel
97The %{name}-devel package contains the header files and libraries
98needed to compile C or C++ applications which will directly interact
99with a PostgreSQL database management server and the ecpg Embedded C
100Postgres preprocessor. You need to install this package if you want to
101develop applications which will interact with a PostgreSQL server.
102
103%description -l ja devel
104%{name}-devel パッケージには、PostgreSQL データベースと直接に会話
105するための C / C++ アプリケーションをコンパイルするのに必要なヘッダフ
106ァイルとライブラリ、および C 言語埋め込み型の PostgreSQL プリプロセサ
107が含まれています。PostgreSQL サーバと会話するアプリケーションを開発
108したい場合にはこのパッケージをインストールしてください。
109
110
111%prep
112%setup -q -n postgresql-%{version}
113
114
115%build
116CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS
117CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
118
119# Strip out -ffast-math from CFLAGS....
120
121CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
122
123./configure \
124        --prefix=%{_prefix} \
125        --libdir=%{_libdir} \
126        --disable-rpath \
127%if %beta
128        --enable-debug \
129        --enable-cassert \
130%endif
131%if %ssl
132        --with-openssl \
133%endif
134%if %pam
135        --with-pam \
136%endif
137%if %kerberos
138        --with-krb5=/usr/kerberos \
139%endif
140%if %nls
141        --enable-nls \
142%endif
143        --sysconfdir=%{_sysconfdir}/sysconfig/pgsql \
144        --mandir=%{_mandir} \
145        --with-docdir=%{_docdir} \
146        --includedir=%{_includedir}/pgsql \
147        --datadir=%{_datadir}/pgsql
148
149make %{?_smp_mflags} -C ./src/interfaces all
150make %{?_smp_mflags} -C ./src/bin/pg_config all
151make %{?_smp_mflags} -C ./src/backend utils/errcodes.h
152make %{?_smp_mflags} -C ./src/backend utils/fmgroids.h
153
154
155%install
156rm -rf $RPM_BUILD_ROOT
157
158make DESTDIR=$RPM_BUILD_ROOT -C ./src/interfaces install
159make DESTDIR=$RPM_BUILD_ROOT -C ./src/bin/pg_config install
160cp -f ./src/backend/utils/fmgroids.h ./src/include/utils/
161cp -f ./src/backend/utils/fmgrprotos.h ./src/include/utils/
162make DESTDIR=$RPM_BUILD_ROOT -C ./src/include install
163
164# copy over Makefile.global to the include dir....
165install -m644 src/Makefile.global $RPM_BUILD_ROOT%{_includedir}/pgsql
166install -m644 src/Makefile.shlib $RPM_BUILD_ROOT%{_includedir}/pgsql
167
168# install missing header
169mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
170install -m644 src/include/libpq/libpq-fs.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
171install -m644 src/include/libpq/pqcomm.h $RPM_BUILD_ROOT%{_includedir}/pgsql/libpq
172install -m644 src/include/postgres_ext.h $RPM_BUILD_ROOT%{_includedir}/pgsql
173install -m644 src/include/pg_config*.h $RPM_BUILD_ROOT%{_includedir}/pgsql
174install -m644 src/include/c.h $RPM_BUILD_ROOT%{_includedir}/pgsql
175install -m644 src/include/port.h $RPM_BUILD_ROOT%{_includedir}/pgsql
176install -m644 src/include/postgres_fe.h $RPM_BUILD_ROOT%{_includedir}/pgsql
177
178# Fix some more documentation
179##gzip doc/internals.ps
180cp %{SOURCE6} README.rpm-dist
181##cp -pr $RPM_BUILD_ROOT%{_docdir}/postgresql/html doc
182##rm -rf $RPM_BUILD_ROOT%{_docdir}/postgresql/html
183
184mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
185install -m 644 ./doc/src/sgml/man1/* $RPM_BUILD_ROOT/%{_mandir}/man1
186
187
188%find_lang libpq5-%{pgver}
189%find_lang ecpg-%{pgver}
190%find_lang ecpglib%{ecpg_soname}-%{pgver}
191#%find_lang pg_config-%{pgver}
192
193cat libpq5-%{pgver}.lang > libpq.lst
194cat ecpg-%{pgver}.lang >> libpq.lst
195cat ecpglib%{ecpg_soname}-%{pgver}.lang >> libpq.lst
196#cat pg_config-%{pgver}.lang > devel.lst
197
198rm -rf %{buildroot}%{_libdir}/lib*.a
199rm -rf %{buildroot}%{_datadir}/pgsql
200find %{buildroot}%{_mandir}/man1 -type f | grep -v ecpg.1 | xargs rm -f
201
202rm -f %{buildroot}%{_includedir}/pgsql/Makefile*
203find %{buildroot}%{_includedir}/pgsql -type f | perl -pi  -e 's|^%{buildroot}||g'> devel.lst
204
205%post
206/sbin/ldconfig
207
208%postun
209/sbin/ldconfig
210
211
212%clean
213rm -rf $RPM_BUILD_ROOT
214
215
216%files -n libpq%{pq_soname} -f libpq.lst
217%defattr(-,root,root)
218%doc COPYRIGHT HISTORY INSTALL README*
219%{_libdir}/libecpg.so.*
220%{_libdir}/libecpg_compat.so.*
221%{_libdir}/libpgtypes.so.*
222%{_libdir}/libpq.so.*
223
224%files devel -f devel.lst
225%defattr(-,root,root)
226%{_bindir}/ecpg
227%{_bindir}/pg_config
228%{_libdir}/libecpg.so
229%{_libdir}/libecpg_compat.so
230%{_libdir}/libpgtypes.so
231%{_libdir}/libpq.so
232%{_libdir}/pkgconfig/*
233%{_datadir}/locale/*/LC_MESSAGES/*.mo
234%{_mandir}/man1/ecpg.*
235#%{_mandir}/man1/pg_config.*
236
237
238%changelog
239* Fri Mar 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.3-1
240- new upstream release.
241
242* Fri Apr  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.2-1
243- new upstream release.
244
245* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.1-1
246- new upstream release.
247
248* Sat Jan  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5.0-1
249- new upstream release.
250
251* Fri Oct  9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.5-1
252- new upstream release.
253
254* Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.4-1
255- new upstream release.
256
257* Fri Jun 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4.3-1
258- new upstream release.
259
260* Thu Jul 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-4
261- added all headers for a strange client.
262
263* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-3
264- add pgconfig
265- add pg_config*.h and libpq/libpq-fs.h
266
267* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 9.3.4-2
268- add postgres_ext.h and pg_config_ext.h
269
270* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.4-1
271- new upstream release
272
273* Sat Nov 30 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.3.1-1
274- made to build client libraries only.
275
276* Thu Feb 21 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.12-1
277- new upstream release
278
279* Thu Feb  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.11-1
280- new upstream release
281- add Vendor and Distribution tags
282
283* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 9.0.7-2vl7
284- build with Tcl/Tk 8.5.7-1
285- fix init script (Source3): fix su(1) paramaters.
286
287* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.0.7-1
288- new upstream release
289- move euc2004_sjis2004.so from -contrib to -server (BTS:1266)
290- remove *_and_*.so from -contrib (included in -server)
291
292* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.4-1
293- updated postgresql to 9.0.4
294
295* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 9.0.3-1
296- updated postgresql to 9.0.3
297- separated postgresql-jdbc package
298
299* Thu Feb 03 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.7-1
300- updated postgresql to 8.4.7 (contains a variety of fixes)
301
302* Sat Jan 29 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.6-1
303- updated postgresql to 8.4.6
304- updated JDBC2 driver to postgresql-8.3-606.{jdbc2,jdbc2ee}.jar
305- updated JDBC3 driver to postgresql-8.4-702.jdbc3.jar
306- updated JDBC4 driver to postgresql-8.4-702.jdbc4.jar
307
308* Thu Jan 13 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.5-2
309- rebuilt with openssl-1.0.0c
310
311* Thu Oct 07 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.5-1
312- updated postgresql to 8.4.5
313
314* Sun May 16 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.4-1
315- updated postgresql to 8.4.4
316
317* Thu Apr 15 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
318- updated postgresql to 8.4.3
319- s/BuildPrereq/Buildrequires/
320
321* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1
322- updated postgresql to 8.4.2
323- rebuilt with new environment
324
325* Thu Sep 10 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.1-1
326- updated postgresql to 8.4.1
327
328* Fri Aug 21 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-2
329- moved dict_snowball.so from conrib to server
330
331* Tue Jul 07 2009 Shu KONNO <owa@bg.wakwak.com> 8.4.0-1
332- updated postgresql to 8.4.0
333- updated jdbc3,4 to 701
334- dropt postgresql-8.3.3-nls.patch (fixed)
335- dropt postgresql-7.4-ecpg-patch (no effect)
336
337* Sat Apr 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.3.7-2
338- changed libs Group to System Environment/Libraries
339
340* Sun Apr 12 2009 Shu KONNO <owa@bg.wakwak.com> 8.3.7-1
341- updated postgresql to 8.3.7
342
343* Sun Jan 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-2
344- remove "-E EUC_JP --no-locale" option from initdb in postgresql.init
345
346* Thu Jan 22 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.3.5-1
347- new upstream release (postgresql to 8.3.5, jdbc to 604)
348
349* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 8.3.3-1vl5
350- applied new versioning policy, and spec in utf-8
351- updated postgresql to 8.3.3
352- updated jdbcver to 603
353- added postgresql-8.3.3-nls.patch instead of postgresql-8.2.0-nls.patch.gz
354- added a script to replace PGVERSION in postgresql.init
355
356* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl2
357- rebuild with tcl/tk-8.4.18
358
359* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 8.2.6-0vl1
360- updated postgresql to 8.2.6
361- included security fixes: CVE-{2007-6600, 2007-4772, 2007-6067, 2007-4769, 2007-6601}
362
363* Tue Oct 16 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl3
364- updated PGVERSION to 8.2 in postgresql.init (sorry;)
365
366* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl2
367- rebuild with tcl/tk-8.4.16
368
369* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 8.2.5-0vl1
370- updated postgresql to 8.2.5
371- updated jdbc driver to 8.2-506, and added 8.2-506.jdbc4.jar
372- updated nls-patch to 8-2-0
373- dropt postgresql-8.1.4-Pg.patch.gz
374
375* Wed Sep 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 8.1.10-0vl1
376- for VineSeed
377- updated to 8.1.10 (8.1.9 and up has fixes for CVE-2007-2138)
378- JDBC driver updated to 410
379
380* Sun Jul  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.1.5-0vl1
381- rebuilt for VineSeed
382- fixed install script
383
384* Thu Nov 23 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.5-0vl0
385- upstream release
386- fix missing %defattr in %files server
387
388* Fri Sep 15 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl2
389- fix version number in postgresql.init
390
391* Tue Sep 12 2006 HOTTA Michihide <hotta@net-newbie.com> 8.1.4-0vl1
392- upstream release
393- drop rpm-pgsql-8.0.0.patch
394- add Requires: perl-DBD-Pg for contrib
395- add postgresql-8.1.4-Pg.patch.gz
396- update nls patches
397- new JDBC driver
398
399* Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 8.0.3-0vl4
400- added build options --without perl, --without python
401- rebuilt for x86_64 architecture support
402
403* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl3
404- drop Provides: on postgresql-libs
405- drop Requires: libpq.so on postgresql-server
406
407* Tue May 31 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl2
408- change SONAME -- Provides: libpq.so.4 libpq.so.4.0 libpq.so
409
410* Thu May 26 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.3-0vl1
411- upstream release
412- update nls patches
413
414* Fri Apr 22 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.2-0vl1
415- upstream release
416- update nls patches
417
418* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl3
419- rebuilded with python-2.4.1-0vl1
420
421* Sat Mar 26 2005 Shu KONNO <owa@bg.wakwak.com> 8.0.1-0vl2
422- Dropped PyGreSQL-3.4.tgz.
423- Dropped PyGreSQL-3.4-setup-2.patch.
424- Dropped plpython.so in postgresql-server, because it's exist in postgresql-pl.
425- Dropped pyver and pynextver macros.
426- Changed macro name "python" to "plpython" like plperl.
427- Added "Obsoletes: postgresql-python"
428
429* Fri Feb 18 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.1-0vl1
430- Major version up
431- Obsoletes: postgresql7
432- update nls patch(es)
433- modify %postun not to delete postgres account on upgrade
434
435* Thu Jan 27 2005 HOTTA Michihide <hotta@net-newbie.com> 8.0.0-0vl1
436- upstream release (release as a new package)
437- Conflicts: postgresql
438- update nls patch(es)
439- (this package revision was rejected by Vine Project)
440
441* Sat Dec 04 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.6-0vl2
442- upstream release
443- new JDBC driver
444- add BuildRequires: bison, flex, pam-devel
445- drop postgresql-7.4.5-tempfile.patch (repaired)
446
447* Thu Nov 18 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 7.4.5-0vl2
448- Added a security fix patch postgresql-7.4.5-tempfile.patch
449  from Gentoo Linux (CAN-2004-0977).
450- Changed Patch4:
451  from PyGreSQL-3.4-setup-2.patch into PyGreSQL-3.4-setup-2.patch
452  It is possible to compile this package without pre-installed postgresql.
453- Removed Patch5 because Patch4 was changed.
454
455* Tue Aug 24 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.5-0vl1
456- upstream release
457
458* Mon Jun 21 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.3-0vl1
459- upstream release
460- new jdbc driver
461
462* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl3
463- rebuild with python-2.3.3-0vl1
464
465* Tue Apr 13 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.3
466- changed mode to 644 at Makefile.global, Makefile.shlib
467
468* Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.2
469- updated python install section
470
471* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 7.4.2-0vl2.1
472- added PyGreSQL-3.4.tgz and set python flag
473- added PyGreSQL-3.4-setup.patch
474- added PyGreSQL-3.4-pgmodule.patch
475- rebuilded with python-2.3.3-0vl0.3 (for TestPkg)
476
477* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.4.2-0vl2
478- rebuild with new openssl
479
480* Wed Mar 17 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.2-0vl1
481- upstream release
482- change all of %{?foo:%define foo 0} -like descriptions to simple
483  %define format for latest rpm to build.
484
485* Sat Feb 14 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl3
486- rebuild on latest tcl package environment.
487
488* Wed Feb 11 2004 HOTTA Michihide <hotta@net-newbie.com> 7.4.1-0vl2
489- fixed lacking files at server's %files
490
491* Fri Dec 05 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl2
492- include JDBC driver for 7.4
493- fix typo in postgresql-7.4-psql-patch
494
495* Thu Nov 20 2003 HOTTA Michihide <hotta@net-newbie.com> 7.4-0vl1
496- upstream release
497- change '--includedir=' option to avoid conflicting with unixODBC
498- add postgresql-7.4-ecpg-patch
499
500* Wed Sep 10 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.4-0vl1
501- upstream release
502
503* Wed Jul 23 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl2
504- drop previous version of libpq's trash
505
506* Wed May 28 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.3-0vl1
507- upstream release with new nls patch
508- fix postgresql-bashprofile (value of PGDATA)
509- fix postgresql-init for Japanese-specific use (-E EUC_JP --no-locale)
510
511* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 7.3.2-0vl2
512- rebuild with tcltk8.4 and readline-4.3
513
514* Fri Mar 07 2003 HOTTA Michihide <hotta@net-newbie.com> 7.3.2-0vl1
515- upstream release
516
517* Wed Dec 25 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3.1-0vl1
518- upstream release
519- remove garbage changelog
520
521* Mon Dec 23 2002 HOTTA Michihide <hotta@net-newbie.com> 7.3-0vl1
522- upstream release based on 7.3-2PGDG
523- add nls patch
524
525* Thu Dec 05 2002 Lamar Owen <lamar.owen@ramifordistat.net>
526- 7.3-2PGDG
527- Fix typo in initscript.  Argh!!
528
529* Wed Dec 04 2002 Lamar Owen <lamar.owen@ramifordistat.net>
530- 7.3-0.5PGDG
531- Jerk out all perl client stuff and kludgage
532- Rename plperl subpackage to a pl subpackage containing all but PL/Pgsql PL's
533- Eliminate locale and multibyte explicit enables -- they are both defaults now
534- Eliminate pgaccess code; it's not a part of the main tarball anymore
535- Eliminate ODBC stuff -- it's also separate now.  Use unixODBC instead.
536- Eliminated separate tk client package -- rolled the tk client into the tcl client.
537- Moved pltcl into the pl subpackage.
538- Added plpython to the pl subpackage.
539- /etc/sysconfig/pgsql is sysconfdir for multiple postmaster startup.
540
541* Mon Dec 02 2002 Lamar Owen <lamar.owen@ramifordistat.net>
542- 7.3-0.1PGDG (not released)
543- Integrate 7.3 jar's courtesy Joe Conway
544- Integrate multi-postmaster initscript courtesy Karl DeBisschop
545- Some renames and restructures.
546- Stripped out the last dregs of the postgresql-dump migration script.
547- Conflicts with less than 7.3.
548
549- (See below for old changelogs from VineSeed)
550
551* Fri Oct 04 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.3-0vl1
552- updated to 7.2.3.
553
554* Tue Sep 10 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl3
555- absorbed previous patch8 into original nlspatch
556- fixed configure options (--enable-nls and --enable-locale to be antinomy)
557
558* Fri Aug 30 2002 Shoji Matsumoto <shom@vinelinux.org> 7.2.2-0vl2
559- add patch8 (ja.po for psql was invalid)
560
561* Thu Aug 29 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.2-0vl1
562- updated to 7.2.2.
563- improved nlspatch to enable japanese SQL help in psql.
564
565* Sat Jul 06 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl3
566- fixed garbage chars in description(ja).
567
568* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl2
569- imported & replaced changelog (following VineSeed's).
570  add some stuff to '%%files'.
571
572* Wed Jul 03 2002 HOTTA Michihide <hotta@net-newbie.com> 7.2.1-5vl1
573- Modified for Vine Linux 2.5. Originaly from RHL 7.2.1-5, adding
574  nls patch, pg_dump patch, date_part patch by Jun Kuwamura
575
576* Thu May 23 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
577- replace nls patch.
578- add *.mo to '%%files'.
579
580* Mon Mar 04 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
581- fix initscript
582
583* Sun Mar 03 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
584- add /usr/bin/pg_id to the package (fix)
585
586* Fri Mar 01 2002 Satoshi MACHINO <machino@vinelinux.org> 7.2-0vl1
587- updated 7.2
588- added nls.patch
589- fixed spec file
590- added New JDBC
591-- pgjdbc1.jar(for JDK1.1.x), pgjdbc2(for Java2)
592
593* Sat Sep 22 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.3-4vl1
594- updated 7.1.3
595
596* Tue Aug 21 2001 Hisao SHIBUYA <shibuya@alpha.or.jp>
597- 7.1.2-7vl3
598- merge 7.1.2-7vl2 and 7.1.2-7
599
600* Sun Aug 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
601- 7.1.2-7vl2
602- fixed spec typo (%%{_includesir} -> %%{_includedir})
603
604* Tue Aug 14 2001 Satoshi MACHINO <machino@vinelinux.org> 7.1.2-7vl1
605- updated 7.1.2 (used postgresql-7.1.2-7)
606- used psqlj patch for 7.1.2
607- used jumbo-20010801.patch.gz
608
609* Mon Aug  6 2001 Trond Eivind Glomsr <teg@redhat.com> 7.1.2-7
610- Add patches from 7.1-stable branch. This should fix #50799 and #50797
611- Enable kerberos authentication (#50644)
612- handle stop with stale pid file (#50499)
613- make the test subpackage (not built by default) own /usr/lib/pgsql/test
614
615* Mon Jul  9 2001 Trond Eivind Glomsr <teg@redhat.com>
616- Make the -devel subpackage depend on -libs, not the main package
617
618* Tue Jun 19 2001 Trond Eivind Glomsr <teg@redhat.com>
619- Make sure the python subpackage depends on mx - otherwise, you'd get an error when importing
620
621* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
622- add changes for s390x
623
624* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
625- Many path fixes for contrib packages
626- Newer intarray
627- Don't use nested ifs for tkpkg/pgaccess
628- Turn off test package for Red Hat Linux - it makes most sense just to use
629  this during development
630- One "pgacess" -> "pgaccess"
631
632* Wed Jun 13 2001 Lamar Owen <lamar.owen@wgcr.org> <lamar@postgresql.org>
633- -4PGDG
634- patchset update for pg_regress.sh
635- can the dot in the release -- confused too many people and some programs.
636- -3.PGDG
637- updated README.rpm-dist
638- updated patch to 7.1.2, fixing some places where /usr/share/pgsql
639  was still being used where /usr/lib/pgsql was intended.
640- PGLIB now set to /usr/lib/pgsql -- initdb doesn't use it to find the bki's.
641
642* Tue Jun 12 2001 Trond Eivind Glomsr <teg@redhat.com>
643- sync
644- Run chkconfig --add on server install
645- Move the prereqs on useradd on chkconfig to the server package
646- don't disable the %%clean section
647
648* Sat Jun 09 2001 Lamar Owen <lamar.owen@wgcr.org>
649- Sync up with Trond Eivind's set.
650
651* Thu Jun  7 2001 Trond Eivind Glomsr <teg@redhat.com>
652- Don't create postgres' .bashrc from the server post script: include it instead
653- Move the test packages from /usr/share/pgsql to /usr/lib/pgsql
654- Move the symlinks libpq.so, libecpg.so, libpq++.so and libpgeasy.so to the devel subpackage from
655  libs
656- Source the i18n data from the .bashrc instead of in the initscript
657
658* Mon May 28 2001 Trond Eivind Glomsr <teg@redhat.com>
659- Handle i18n for database startup - backend needs to have the same locale everytime,
660  but this certainly can't be hardcoded to C either
661- Fix stop, restart in initscript (#42217)
662- Make database init _much_ less verbose
663- other minor fixes to the initscript
664
665* Fri May 25 2001 Trond Eivind Glomsr <teg@redhat.com>
666- 7.1.2
667
668* Thu May 24 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
669- 7.1.2-0.1.1.PGDG PRERELEASE
670- Changed versioning and release numbering a little for better flexibility,
671-- particularly for distribution packagers.
672- Release numbering comment at top of spec, where it's more useful.
673- Trimmed changelog to 7.1.x. See the last 7.0.3's specfile for the 7.0
674  changlog, and the last 6.5.3's specfile for the changelog prior to
675  7.0.
676
677* Sun May 20 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
678- 7.1.1-4.PGDG
679- _really_ got Python version agnosticism working.
680
681* Sat May 19 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
682- 7.1.1-3.PGDG Release
683- Python version agnosticism.....
684
685* Tue May 15 2001 Trond Eivind Glomsr <teg@redhat.com>
686- Use openssl
687- Make it obsolete subpackages if they aren't built
688
689* Mon May 14 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
690- 7.1.1-2.PGDG Release.
691- Appended .PGDG to release string to differentiate our RPM set from the others.
692- /bin/sh fix in initscript
693- README.rpm-dist updates.
694
695* Mon May 14 2001 Bernhard Rosenkraenzer <bero@redhat.com> 7.1.1-0.7
696- Rebuild with new readline
697
698* Thu May 10 2001 Trond Eivind Glomsr <teg@redhat.com>
699- Initial 7.1.1
700
701* Mon May  7 2001 Trond Eivind Glomsr <teg@redhat.com>
702- Specify shell when running commands through su in the initscript, to avoid problems
703  when people switch the postgres user to use tcsh
704
705* Thu Apr 19 2001 Trond Eivind Glomsr <teg@redhat.com>
706- JDBC driver for Postgresql 7.1
707
708* Sun Apr 15 2001 Trond Eivind Glomsr <teg@redhat.com>
709- slightly different versioning scheming, will go back to the official
710  later when I'm sure the package is ready to use
711
712* Fri Apr 13 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
713- 7.1 RELEASE
714- 7.1-1 RPM RELEASE
715- Change to COPTS -- strip out -ffastmath -- Considered Harmful.
716- Back to old versioning scheme, kept teg's other fixes.
717- README.rpm-dist updated.
718- PGVERSION updated all-around (hopefully!)
719- Couple of fixes from Peter E.
720- Rearrange dependencies -- only the -libs subpackage is required for most stuff
721- Removed broken and confusing logrotate script.
722
723* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
724- chown considered harmful - removed
725- fix dangling symlimks (pg_crc.c)
726- libpq.so changes for maximum compatiblity
727- different versioning scheme, to avoid trouble later
728- remove temporary perl file from the file list
729- fix spelling error in tcl description
730- mark odbcinst.ini as a config file
731- use %%defattr on packages which didn't have it
732
733* Sat Apr 07 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
734- Integrated the PL/Perl stuff from Karl DeBisschop --conditional.
735- Packaging reorg: added contrib and docs subpackages.
736- Removed sgml source docs from main package --> docs subpackage.
737- Removed contrib tree from main package --> contrib subpackage.
738- Contrib tree is now prebuilt -- HOWEVER, very little install work is
739  currently done with this.
740
741* Fri Apr 06 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
742- Quickie RC3.  There will be a 7.1RC3-2 shortly with other stuff.
743
744* Tue Apr 03 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
745- RC2
746- eliminate versioning information for ancilliary files in prep for CVS.
747- Fix docs mixup.
748
749* Tue Mar 27 2001 Lamar Owen <lamar@postgresql.org> <lamar.owen@wgcr.org>
750- RC1 quickie.
751
752* Tue Mar 20 2001 Lamar Owen <lamar@postgresql.org>
753- Beta 6 initial build.
754- Use make install-all-headers instead of cpio hack for devel headers.
755- Split out the libs into the libs subpackage.
756- Updated initscript to use pg_ctl to stop
757- Updated initscript to initdb and start postmaster with LC_ALL=C to
758  prevent index corruption.
759
760
761* Sun Jan 28 2001 Lamar Owen <lamar@postgresql.org>
762- Beta4
763- Return to 'pgsql' directories instead of 'postgresql'
764- Better perl patches.
765
766* Mon Jan 15 2001 Lamar Owen <lamar@postgresql.org>
767- Edit patches to get rid of some cruft.
768- Eliminate some more pre-7.1 specfile baggage that is no longer necessary.
769- Moved pg_id to server
770- added Makefile.global and pg_config to devel
771- Corrected /usr/include/pgsql to /usr/include/postgresql
772- Fixed some configure options.  Will be trying the configure macro next release
773- Since it is terminally ill in this version pg_upgrade is _gone_.
774- Thanks to Peter E for a good review.
775
776* Sun Jan 14 2001 Lamar Owen <lamar@postgresql.org>
777- Running regression. 1 on the release-o-meter.
778- Minor patches to get regression running right. 
779- Initscript tweaking -- the old test for a database structure fails with 7.1's new structure.
780
781* Sat Jan 13 2001 Lamar Owen <lamar@postgresql.org>
782- Perl 5 needs to be built with PREFIX set on the Makefile, not GNUmakefile....
783- The 7.1 build is different from the 7.0 build -- see the configure line.
784- NOTE: many files that used to be in /usr/share/postgresql are now in /usr/share/postgresql!
785- by request, conditional packages are now supported. See the top of the spec.
786- Fixed the server postinstall problems.
787
788* Mon Jan 08 2001 Lamar Owen <lamar@postgresql.org>
789- First 7.1 beta test-build
790
Note: See TracBrowser for help on using the repository browser.