source: projects/specs/trunk/lib/libl/libldb/libldb-vl.spec @ 11159

Revision 11159, 9.4 KB checked in by tomop, 7 years ago (diff)

libldb-1.1.31-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4%define talloc_version 2.1.9
5%define tdb_version 1.3.14
6%define tevent_version 0.9.32
7
8Name: libldb
9Summary: A schema-less, ldap like, API and database
10Version: 1.1.31
11Release: 1%{?_dist_release}
12
13Group: System Environment/Libraries
14License: LGPLv3+
15URL: http://ldb.samba.org/
16
17Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
18# Patches
19Patch1001: FED01-fix-tevent-check.patch
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: libtalloc-devel >= %{talloc_version}
23BuildRequires: libtdb-devel >= %{tdb_version}
24BuildRequires: libtevent-devel >= %{tevent_version}
25BuildRequires: popt-devel
26BuildRequires: autoconf
27BuildRequires: libxslt
28BuildRequires: docbook-style-xsl
29BuildRequires: python-devel
30BuildRequires: python-tdb
31BuildRequires: pytalloc-devel
32BuildRequires: python-tevent
33BuildRequires: doxygen
34Requires: libtalloc >= %{talloc_version}
35Requires: libtdb >= %{tdb_version}
36Requires: libtevent >= %{tevent_version}
37
38Provides: bundled(libreplace)
39Provides: bundled(libtdb_compat)
40Provides: bundled(libccan)
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: tomop
45
46%description
47An extensible library that implements an LDAP like API to access remote LDAP
48servers, or use local tdb databases.
49
50%package -n ldb-tools
51Group: Applications/System
52Summary: Tools to manage LDB files
53Requires: libldb = %{version}-%{release}
54
55%description -n ldb-tools
56Tools to manage LDB files
57
58%package devel
59Group: Development/Libraries
60Summary: Developer tools for the LDB library
61Requires: libldb = %{version}-%{release}
62Requires: libtdb-devel >= %{tdb_version}
63Requires: libtalloc-devel >= %{talloc_version}
64Requires: libtevent-devel >= %{tevent_version}
65Requires: pkgconfig
66
67%description devel
68Header files needed to develop programs that link against the LDB library.
69
70%package -n pyldb
71Group: System Environment/Libraries
72Summary: Python bindings for the LDB library
73Requires: libldb = %{version}-%{release}
74Requires: python-tdb >= %{tdb_version}
75
76%description -n pyldb
77Python bindings for the LDB library
78
79%package -n pyldb-devel
80Group: Development/Libraries
81Summary: Development files for the Python bindings for the LDB library
82Requires: pyldb = %{version}-%{release}
83
84%description -n pyldb-devel
85Development files for the Python bindings for the LDB library
86
87%if %build_compat32
88
89%package -n compat32-%{name}
90Summary: A schema-less, ldap like, API and database
91Group: System Environment/Libraries
92
93%description -n compat32-%{name}
94An extensible library that implements an LDAP like API to access remote LDAP
95servers, or use local tdb databases.
96
97%endif
98
99%prep
100%setup -q -n ldb-%{version}
101
102%patch1001 -p1
103
104%build
105
106# tdb_compat and ccan have no upstream releases to link against yet and their
107# API is in flux. It is unsafe to make them public and shared at this time.
108%configure --disable-rpath \
109           --disable-rpath-install \
110           --bundled-libraries=cmocka \
111           --builtin-libraries=tdb_compat,ccan,replace \
112           --with-modulesdir=%{_libdir}/ldb/modules \
113           --with-privatelibdir=%{_libdir}/ldb
114
115make V=1 %{?_smp_mflags}
116doxygen Doxyfile
117
118%install
119make install DESTDIR=%{buildroot}
120
121rm -f %{buildroot}%{_libdir}/libldb.a
122
123# Remove _tevent.so (it's managed by python-tevent)
124#rm -f %{buildroot}/%{python_sitearch}/_tevent.so
125
126# Shared libraries need to be marked executable for
127# rpmbuild to strip them and include them in debuginfo
128find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
129
130# Install API docs
131cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
132
133# drop garbages
134rm -f %{buildroot}%{_mandir}/man3/_home_vbuilder_rpm_BUILD_ldb-*_include_.3*
135rm -f %{buildroot}%{_mandir}/man3/ldif_read_file_state.3*
136
137%clean
138rm -rf %{buildroot}
139
140%post
141/sbin/ldconfig
142
143%postun
144/sbin/ldconfig
145
146%post -n pyldb
147/sbin/ldconfig
148
149%postun -n pyldb
150/sbin/ldconfig
151
152%if %build_compat32
153
154%post -n compat32-%{name}
155/sbin/ldconfig
156
157%postun -n compat32-%{name}
158/sbin/ldconfig
159
160%endif
161
162%files
163%defattr(-,root,root,-)
164%dir %{_libdir}/ldb
165%{_libdir}/libldb.so.*
166%dir %{_libdir}/ldb/modules
167%dir %{_libdir}/ldb/modules/ldb
168%{_libdir}/ldb/libldb-cmdline.so
169%{_libdir}/ldb/libcmocka-ldb.so
170%{_libdir}/ldb/modules/ldb/*.so
171
172%files -n ldb-tools
173%defattr(-,root,root,-)
174%{_bindir}/ldbadd
175%{_bindir}/ldbdel
176%{_bindir}/ldbedit
177%{_bindir}/ldbmodify
178%{_bindir}/ldbrename
179%{_bindir}/ldbsearch
180%{_mandir}/man1/ldbadd.1.*
181%{_mandir}/man1/ldbdel.1.*
182%{_mandir}/man1/ldbedit.1.*
183%{_mandir}/man1/ldbmodify.1.*
184%{_mandir}/man1/ldbrename.1.*
185%{_mandir}/man1/ldbsearch.1.*
186
187%files devel
188%defattr(-,root,root,-)
189%{_includedir}/ldb_module.h
190%{_includedir}/ldb_handlers.h
191%{_includedir}/ldb_errors.h
192%{_includedir}/ldb_version.h
193%{_includedir}/ldb.h
194%{_libdir}/libldb.so
195
196%{_libdir}/pkgconfig/ldb.pc
197%{_mandir}/man3/ldb*.gz
198
199%files -n pyldb
200%defattr(-,root,root,-)
201%{python_sitearch}/ldb.so
202%{python_sitearch}/_ldb_text.*
203%{_libdir}/libpyldb-util.so.1*
204
205%files -n pyldb-devel
206%defattr(-,root,root,-)
207%{_includedir}/pyldb.h
208%{_libdir}/libpyldb-util.so
209%{_libdir}/pkgconfig/pyldb-util.pc
210%{_mandir}/man*/Py*.gz
211
212%if %build_compat32
213
214%files -n compat32-%{name}
215%defattr(-,root,root,-)
216%dir %{_libdir}/ldb
217%{_libdir}/libldb.so.*
218%dir %{_libdir}/ldb/modules
219%dir %{_libdir}/ldb/modules/ldb
220%{_libdir}/ldb/libldb-cmdline.so
221%{_libdir}/ldb/libcmocka-ldb.so
222%{_libdir}/ldb/modules/ldb/*.so
223
224%endif
225
226
227%changelog
228* Sat Jul 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.31-1
229- new upstream release.
230
231* Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.29-1
232- new upstream release.
233
234* Wed Feb 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.26-1
235- new upstream release.
236
237* Fri Dec 18 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.25-1
238- new upstream release.
239
240* Thu Dec 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.24-1
241- new upstream release.
242
243* Wed Dec  2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.23-1
244- new upstream release.
245
246* Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.21-1
247- new upstream release.
248
249* Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-2
250- added compat32 package.
251
252* Fri Mar  6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-1
253- new upstream release.
254
255* Mon Jan 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.19-1
256- new upstream release.
257
258* Wed Dec  3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.18-1
259- new upstream release.
260
261* Fri Oct  3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.17-2
262- moved libldb and pyldb to System Environment/Libraries Group
263- moved ldb-tool to Applications/System Group
264
265* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.17-1
266- new upstream release.
267
268* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-2
269- rebuilt with current environment.
270
271* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
272- new upstream release.
273
274* Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
275- new upstream release.
276
277* Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
278- moved libldb-cmdline.so to main package.
279
280* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
281- fixed dependency.
282
283* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
284- new upstream release.
285- initial build for Vine Linux.
286
287* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
288- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
289
290* Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
291- New upstream release
292- Add ldb_module_error() routine
293- Fedora: work around unreliable configure check for pytevent
294- Drop patch to ignore --disable-silent-rules (included in tarball)
295
296* Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
297- Add patch to ignore --disable-silent-rules
298
299* Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
300- Add explicit mention of the bundled libreplace
301- https://fedorahosted.org/fpc/ticket/120
302- Add explicit mention of bundled libtdb_compat and libccan
303- https://fedorahosted.org/fpc/ticket/119
304
305* Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
306- Build and install API documentation
307- Build tdb_compat and ccan statically. They have no upstream releases to
308  link against yet and their API is in flux. It is unsafe to make them
309  public and shared at this time.
310
311* Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
312- New upstream release
313- Required for building newer samba4 packages
314
315* Tue Aug  2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
316- Update to 1.1.0
317  (dependency for samba4 alpha16 snapshot)
318
319* Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
320- Update to 1.0.2
321  (dependency for samba4 alpha15 snapshot)
322
323* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
324- Disable rpath
325
326* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
327- New upstream release 1.0.0
328- SOname bump to account for module loading changes
329- Rename libldb-tools to ldb-tools to make upgrades easier
330
331* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
332- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
333
334* Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
335- Fixes from package review
336- Change Requires: on tools subpackage to be the exact version/release
337- Remove unnecessary BuildRoot directive
338
339* Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
340- Update to 0.9.22 (first independent release of libldb upstream)
341
Note: See TracBrowser for help on using the repository browser.