source: projects/specs/trunk/lib/libl/libldb/libldb-vl.spec @ 11585

Revision 11585, 11.2 KB checked in by tomop, 6 years ago (diff)

libldb-1.3.2-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4%define talloc_version 2.1.11
5%define tdb_version 1.3.15
6%define tevent_version 0.9.36
7
8Name: libldb
9Summary: A schema-less, ldap like, API and database
10Version: 1.3.2
11Release: 1%{?_dist_release}
12
13Group: System Environment/Libraries
14License: LGPLv3+
15URL: http://ldb.samba.org/
16
17Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
18# Patches
19Patch0001: 0001-ldb-Fix-memory-leak-on-module-context.patch
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: libtalloc-devel >= %{talloc_version}
23BuildRequires: libtdb-devel >= %{tdb_version}
24BuildRequires: libtevent-devel >= %{tevent_version}
25BuildRequires: popt-devel
26BuildRequires: autoconf
27BuildRequires: libxslt
28BuildRequires: docbook-style-xsl
29BuildRequires: python-devel
30BuildRequires: python-rpm-macros
31BuildRequires: python-tdb
32BuildRequires: python-talloc-devel
33BuildRequires: python-tevent
34BuildRequires: python3-devel
35BuildRequires: python3-rpm-macros
36BuildRequires: python3-tdb
37BuildRequires: python3-talloc-devel
38BuildRequires: python3-tevent
39BuildRequires: doxygen
40Requires: libtalloc >= %{talloc_version}
41Requires: libtdb >= %{tdb_version}
42Requires: libtevent >= %{tevent_version}
43
44Provides: bundled(libreplace)
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: tomop
49
50%description
51An extensible library that implements an LDAP like API to access remote LDAP
52servers, or use local tdb databases.
53
54%package -n ldb-tools
55Group: Applications/System
56Summary: Tools to manage LDB files
57Requires: libldb = %{version}-%{release}
58
59%description -n ldb-tools
60Tools to manage LDB files
61
62%package devel
63Group: Development/Libraries
64Summary: Developer tools for the LDB library
65Requires: libldb = %{version}-%{release}
66Requires: libtdb-devel >= %{tdb_version}
67Requires: libtalloc-devel >= %{talloc_version}
68Requires: libtevent-devel >= %{tevent_version}
69Requires: pkgconfig
70
71%description devel
72Header files needed to develop programs that link against the LDB library.
73
74%package -n python-ldb
75Group: System Environment/Libraries
76Summary: Python bindings for the LDB library
77Requires: libldb = %{version}-%{release}
78Requires: python-tdb >= %{tdb_version}
79Provides: pyldb = %{version}-%{release}
80Obsoletes: pyldb < 1.1.31-2
81
82%description -n python-ldb
83Python bindings for the LDB library
84
85%package -n python-ldb-devel
86Group: Development/Libraries
87Summary: Development files for the Python bindings for the LDB library
88Requires: python-ldb = %{version}-%{release}
89Requires: python-ldb-devel-common = %{version}-%{release}
90Provides: pyldb-devel = %{version}-%{release}
91Obsoletes: pyldb-devel <= 1.1.31-2
92
93%description -n python-ldb-devel
94Development files for the Python bindings for the LDB library
95
96%package -n python-ldb-devel-common
97Summary: Common development files for the Python bindings for the LDB library
98
99%description -n python-ldb-devel-common
100Development files for the Python bindings for the LDB library.
101This package includes files that aren't specific to a Python version.
102
103%package -n python3-ldb
104Group: System Environment/Libraries
105Summary: Python3 bindings for the LDB library
106Requires: libldb = %{version}-%{release}
107Requires: python3-tdb >= %{tdb_version}
108
109%description -n python3-ldb
110Python3 bindings for the LDB library
111
112%package -n python3-ldb-devel
113Group: Development/Libraries
114Summary: Development files for the Python3 bindings for the LDB library
115Requires: python3-ldb = %{version}-%{release}
116Requires: python-ldb-devel-common = %{version}-%{release}
117
118%description -n python3-ldb-devel
119Development files for the Python3 bindings for the LDB library
120
121%if %{build_compat32}
122
123%package -n compat32-%{name}
124Summary: A schema-less, ldap like, API and database
125Group: System Environment/Libraries
126
127%description -n compat32-%{name}
128An extensible library that implements an LDAP like API to access remote LDAP
129servers, or use local tdb databases.
130
131%endif
132
133%prep
134%setup -q -n ldb-%{version}
135%patch1 -p3
136
137%build
138
139# tdb_compat and ccan have no upstream releases to link against yet and their
140# API is in flux. It is unsafe to make them public and shared at this time.
141%configure \
142        --disable-rpath \
143        --disable-rpath-install \
144        --bundled-libraries=cmocka \
145        --builtin-libraries=replace \
146        --with-modulesdir=%{_libdir}/ldb/modules \
147        --with-privatelibdir=%{_libdir}/ldb \
148        --extra-python=%{__python3}
149
150make V=1 %{?_smp_mflags}
151doxygen Doxyfile
152
153%install
154make install DESTDIR=%{buildroot}
155
156rm -f %{buildroot}%{_libdir}/libldb.a
157
158# Shared libraries need to be marked executable for
159# rpmbuild to strip them and include them in debuginfo
160find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
161
162# Install API docs
163cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
164
165# LDB 1.1.8+ bug: remove manpage named after full
166# file path
167rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
168
169%clean
170rm -rf %{buildroot}
171
172%post
173/sbin/ldconfig
174
175%postun
176/sbin/ldconfig
177
178%post -n python-ldb
179/sbin/ldconfig
180
181%postun -n python-ldb
182/sbin/ldconfig
183
184%post -n python3-ldb
185/sbin/ldconfig
186
187%postun -n python3-ldb
188/sbin/ldconfig
189
190%if %{build_compat32}
191
192%post -n compat32-%{name}
193/sbin/ldconfig
194
195%postun -n compat32-%{name}
196/sbin/ldconfig
197
198%endif
199
200%files
201%defattr(-,root,root,-)
202%dir %{_libdir}/ldb
203%{_libdir}/ldb/libcmocka-ldb.so
204%{_libdir}/libldb.so.*
205%dir %{_libdir}/ldb/modules
206%dir %{_libdir}/ldb/modules/ldb
207%{_libdir}/ldb/modules/ldb/*.so
208
209%files -n ldb-tools
210%defattr(-,root,root,-)
211%{_bindir}/ldbadd
212%{_bindir}/ldbdel
213%{_bindir}/ldbedit
214%{_bindir}/ldbmodify
215%{_bindir}/ldbrename
216%{_bindir}/ldbsearch
217%{_libdir}/ldb/libldb-cmdline.so
218%{_mandir}/man1/ldbadd.1.*
219%{_mandir}/man1/ldbdel.1.*
220%{_mandir}/man1/ldbedit.1.*
221%{_mandir}/man1/ldbmodify.1.*
222%{_mandir}/man1/ldbrename.1.*
223%{_mandir}/man1/ldbsearch.1.*
224
225%files devel
226%defattr(-,root,root,-)
227%{_includedir}/ldb_module.h
228%{_includedir}/ldb_handlers.h
229%{_includedir}/ldb_errors.h
230%{_includedir}/ldb_version.h
231%{_includedir}/ldb.h
232%{_libdir}/libldb.so
233
234%{_libdir}/pkgconfig/ldb.pc
235%{_mandir}/man3/ldb*.gz
236%{_mandir}/man3/ldif*.gz
237
238%files -n python-ldb
239%defattr(-,root,root,-)
240%{python_sitearch}/ldb.so
241%{python_sitearch}/_ldb_text.*
242%{_libdir}/libpyldb-util.so.1*
243
244%files -n python-ldb-devel
245%defattr(-,root,root,-)
246%{_libdir}/libpyldb-util.so
247%{_libdir}/pkgconfig/pyldb-util.pc
248
249%files -n python-ldb-devel-common
250%{_includedir}/pyldb.h
251%{_mandir}/man*/Py*.gz
252
253%files -n python3-ldb
254%{python3_sitearch}/ldb.cpython-*.so
255%{_libdir}/libpyldb-util.cpython-*.so.1*
256%{python3_sitearch}/_ldb_text.py
257
258%files -n python3-ldb-devel
259%{_libdir}/libpyldb-util.cpython-*.so
260%{_libdir}/pkgconfig/pyldb-util.cpython-*.pc
261
262%if %{build_compat32}
263
264%files -n compat32-%{name}
265%defattr(-,root,root,-)
266%dir %{_libdir}/ldb
267%{_libdir}/libldb.so.*
268%dir %{_libdir}/ldb/modules
269%dir %{_libdir}/ldb/modules/ldb
270%{_libdir}/ldb/libldb-cmdline.so
271%{_libdir}/ldb/libcmocka-ldb.so
272%{_libdir}/ldb/modules/ldb/*.so
273
274%endif
275
276
277%changelog
278* Thu Mar 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-1
279- new upstream release.
280
281* Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
282- new upstream release.
283- dropped Patch1001.
284- imported Patch1 from rawhide.
285- enabled python3 modules.
286- renamed python packages.
287
288* Sat Jul 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.31-1
289- new upstream release.
290
291* Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.29-1
292- new upstream release.
293
294* Wed Feb 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.26-1
295- new upstream release.
296
297* Fri Dec 18 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.25-1
298- new upstream release.
299
300* Thu Dec 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.24-1
301- new upstream release.
302
303* Wed Dec  2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.23-1
304- new upstream release.
305
306* Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.21-1
307- new upstream release.
308
309* Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-2
310- added compat32 package.
311
312* Fri Mar  6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-1
313- new upstream release.
314
315* Mon Jan 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.19-1
316- new upstream release.
317
318* Wed Dec  3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.18-1
319- new upstream release.
320
321* Fri Oct  3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.17-2
322- moved libldb and pyldb to System Environment/Libraries Group
323- moved ldb-tool to Applications/System Group
324
325* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.17-1
326- new upstream release.
327
328* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-2
329- rebuilt with current environment.
330
331* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
332- new upstream release.
333
334* Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
335- new upstream release.
336
337* Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
338- moved libldb-cmdline.so to main package.
339
340* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
341- fixed dependency.
342
343* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
344- new upstream release.
345- initial build for Vine Linux.
346
347* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
348- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
349
350* Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
351- New upstream release
352- Add ldb_module_error() routine
353- Fedora: work around unreliable configure check for pytevent
354- Drop patch to ignore --disable-silent-rules (included in tarball)
355
356* Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
357- Add patch to ignore --disable-silent-rules
358
359* Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
360- Add explicit mention of the bundled libreplace
361- https://fedorahosted.org/fpc/ticket/120
362- Add explicit mention of bundled libtdb_compat and libccan
363- https://fedorahosted.org/fpc/ticket/119
364
365* Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
366- Build and install API documentation
367- Build tdb_compat and ccan statically. They have no upstream releases to
368  link against yet and their API is in flux. It is unsafe to make them
369  public and shared at this time.
370
371* Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
372- New upstream release
373- Required for building newer samba4 packages
374
375* Tue Aug  2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
376- Update to 1.1.0
377  (dependency for samba4 alpha16 snapshot)
378
379* Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
380- Update to 1.0.2
381  (dependency for samba4 alpha15 snapshot)
382
383* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
384- Disable rpath
385
386* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
387- New upstream release 1.0.0
388- SOname bump to account for module loading changes
389- Rename libldb-tools to ldb-tools to make upgrades easier
390
391* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
392- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
393
394* Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
395- Fixes from package review
396- Change Requires: on tools subpackage to be the exact version/release
397- Remove unnecessary BuildRoot directive
398
399* Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
400- Update to 0.9.22 (first independent release of libldb upstream)
401
Note: See TracBrowser for help on using the repository browser.