source: projects/specs/trunk/lib/libl/libldb/libldb-vl.spec @ 11959

Revision 11959, 11.3 KB checked in by tomop, 5 years ago (diff)

samba-4.9.3-1 and requirements

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4%define talloc_version 2.1.14
5%define tdb_version 1.3.16
6%define tevent_version 0.9.37
7
8Name: libldb
9Summary: A schema-less, ldap like, API and database
10Version: 1.4.3
11Release: 1%{?_dist_release}
12
13Group: System Environment/Libraries
14License: LGPLv3+
15URL: http://ldb.samba.org/
16
17Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
18# Patches
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: libtalloc-devel >= %{talloc_version}
22BuildRequires: libtdb-devel >= %{tdb_version}
23BuildRequires: libtevent-devel >= %{tevent_version}
24BuildRequires: popt-devel
25BuildRequires: autoconf
26BuildRequires: libxslt
27BuildRequires: docbook-style-xsl
28BuildRequires: python-devel
29BuildRequires: python-rpm-macros
30BuildRequires: python-tdb
31BuildRequires: python-talloc-devel
32BuildRequires: python-tevent
33BuildRequires: python3-devel
34BuildRequires: python3-rpm-macros
35BuildRequires: python3-tdb
36BuildRequires: python3-talloc-devel
37BuildRequires: python3-tevent
38BuildRequires: doxygen
39Requires: libtalloc >= %{talloc_version}
40Requires: libtdb >= %{tdb_version}
41Requires: libtevent >= %{tevent_version}
42
43Provides: bundled(libreplace)
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: tomop
48
49%description
50An extensible library that implements an LDAP like API to access remote LDAP
51servers, or use local tdb databases.
52
53%package -n ldb-tools
54Group: Applications/System
55Summary: Tools to manage LDB files
56Requires: libldb = %{version}-%{release}
57
58%description -n ldb-tools
59Tools to manage LDB files
60
61%package devel
62Group: Development/Libraries
63Summary: Developer tools for the LDB library
64Requires: libldb = %{version}-%{release}
65Requires: libtdb-devel >= %{tdb_version}
66Requires: libtalloc-devel >= %{talloc_version}
67Requires: libtevent-devel >= %{tevent_version}
68Requires: pkgconfig
69
70%description devel
71Header files needed to develop programs that link against the LDB library.
72
73%package -n python-ldb
74Group: System Environment/Libraries
75Summary: Python bindings for the LDB library
76Requires: libldb = %{version}-%{release}
77Requires: python-tdb >= %{tdb_version}
78Provides: pyldb = %{version}-%{release}
79Obsoletes: pyldb < 1.1.31-2
80
81%description -n python-ldb
82Python bindings for the LDB library
83
84%package -n python-ldb-devel
85Group: Development/Libraries
86Summary: Development files for the Python bindings for the LDB library
87Requires: python-ldb = %{version}-%{release}
88Requires: python-ldb-devel-common = %{version}-%{release}
89Provides: pyldb-devel = %{version}-%{release}
90Obsoletes: pyldb-devel <= 1.1.31-2
91
92%description -n python-ldb-devel
93Development files for the Python bindings for the LDB library
94
95%package -n python-ldb-devel-common
96Summary: Common development files for the Python bindings for the LDB library
97
98%description -n python-ldb-devel-common
99Development files for the Python bindings for the LDB library.
100This package includes files that aren't specific to a Python version.
101
102%package -n python3-ldb
103Group: System Environment/Libraries
104Summary: Python3 bindings for the LDB library
105Requires: libldb = %{version}-%{release}
106Requires: python3-tdb >= %{tdb_version}
107
108%description -n python3-ldb
109Python3 bindings for the LDB library
110
111%package -n python3-ldb-devel
112Group: Development/Libraries
113Summary: Development files for the Python3 bindings for the LDB library
114Requires: python3-ldb = %{version}-%{release}
115Requires: python-ldb-devel-common = %{version}-%{release}
116
117%description -n python3-ldb-devel
118Development files for the Python3 bindings for the LDB library
119
120%if %{build_compat32}
121
122%package -n compat32-%{name}
123Summary: A schema-less, ldap like, API and database
124Group: System Environment/Libraries
125
126%description -n compat32-%{name}
127An extensible library that implements an LDAP like API to access remote LDAP
128servers, or use local tdb databases.
129
130%endif
131
132%prep
133%setup -q -n ldb-%{version}
134
135%build
136
137# tdb_compat and ccan have no upstream releases to link against yet and their
138# API is in flux. It is unsafe to make them public and shared at this time.
139%configure \
140        --disable-rpath \
141        --disable-rpath-install \
142        --bundled-libraries=cmocka \
143        --builtin-libraries=replace \
144        --with-modulesdir=%{_libdir}/ldb/modules \
145        --with-privatelibdir=%{_libdir}/ldb \
146        --without-ldb-lmdb \
147        --extra-python=%{__python3}
148
149make V=1 %{?_smp_mflags}
150doxygen Doxyfile
151
152%install
153make install DESTDIR=%{buildroot}
154
155rm -f %{buildroot}%{_libdir}/libldb.a
156
157# Shared libraries need to be marked executable for
158# rpmbuild to strip them and include them in debuginfo
159find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
160
161# Install API docs
162cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
163
164# LDB 1.1.8+ bug: remove manpage named after full
165# file path
166rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
167
168%clean
169rm -rf %{buildroot}
170
171%post
172/sbin/ldconfig
173
174%postun
175/sbin/ldconfig
176
177%post -n python-ldb
178/sbin/ldconfig
179
180%postun -n python-ldb
181/sbin/ldconfig
182
183%post -n python3-ldb
184/sbin/ldconfig
185
186%postun -n python3-ldb
187/sbin/ldconfig
188
189%if %{build_compat32}
190
191%post -n compat32-%{name}
192/sbin/ldconfig
193
194%postun -n compat32-%{name}
195/sbin/ldconfig
196
197%endif
198
199%files
200%defattr(-,root,root,-)
201%dir %{_libdir}/ldb
202%{_libdir}/ldb/libcmocka-ldb.so
203%{_libdir}/ldb/libldb-key-value.so
204%{_libdir}/libldb.so.*
205%dir %{_libdir}/ldb/modules
206%dir %{_libdir}/ldb/modules/ldb
207%{_libdir}/ldb/modules/ldb/*.so
208
209%files -n ldb-tools
210%defattr(-,root,root,-)
211%{_bindir}/ldbadd
212%{_bindir}/ldbdel
213%{_bindir}/ldbedit
214%{_bindir}/ldbmodify
215%{_bindir}/ldbrename
216%{_bindir}/ldbsearch
217%{_libdir}/ldb/libldb-cmdline.so
218%{_mandir}/man1/ldbadd.1.*
219%{_mandir}/man1/ldbdel.1.*
220%{_mandir}/man1/ldbedit.1.*
221%{_mandir}/man1/ldbmodify.1.*
222%{_mandir}/man1/ldbrename.1.*
223%{_mandir}/man1/ldbsearch.1.*
224
225%files devel
226%defattr(-,root,root,-)
227%{_includedir}/ldb_module.h
228%{_includedir}/ldb_handlers.h
229%{_includedir}/ldb_errors.h
230%{_includedir}/ldb_version.h
231%{_includedir}/ldb.h
232%{_libdir}/libldb.so
233
234%{_libdir}/pkgconfig/ldb.pc
235%{_mandir}/man3/ldb*.gz
236%{_mandir}/man3/ldif*.gz
237
238%files -n python-ldb
239%defattr(-,root,root,-)
240%{python_sitearch}/ldb.so
241%{python_sitearch}/_ldb_text.*
242%{_libdir}/libpyldb-util.so.1*
243
244%files -n python-ldb-devel
245%defattr(-,root,root,-)
246%{_libdir}/libpyldb-util.so
247%{_libdir}/pkgconfig/pyldb-util.pc
248
249%files -n python-ldb-devel-common
250%{_includedir}/pyldb.h
251%{_mandir}/man*/Py*.gz
252
253%files -n python3-ldb
254%{python3_sitearch}/ldb.cpython-*.so
255%{_libdir}/libpyldb-util.cpython-*.so.1*
256%{python3_sitearch}/_ldb_text.py
257
258%files -n python3-ldb-devel
259%{_libdir}/libpyldb-util.cpython-*.so
260%{_libdir}/pkgconfig/pyldb-util.cpython-*.pc
261
262%if %{build_compat32}
263
264%files -n compat32-%{name}
265%defattr(-,root,root,-)
266%dir %{_libdir}/ldb
267%{_libdir}/libldb.so.*
268%dir %{_libdir}/ldb/modules
269%dir %{_libdir}/ldb/modules/ldb
270%{_libdir}/ldb/libcmocka-ldb.so
271%{_libdir}/ldb/libldb-cmdline.so
272%{_libdir}/ldb/libldb-key-value.so
273%{_libdir}/ldb/modules/ldb/*.so
274
275%endif
276
277
278%changelog
279* Fri Nov 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
280- new upstream release.
281- dropped Patch1.
282
283* Thu Mar 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-1
284- new upstream release.
285
286* Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
287- new upstream release.
288- dropped Patch1001.
289- imported Patch1 from rawhide.
290- enabled python3 modules.
291- renamed python packages.
292
293* Sat Jul 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.31-1
294- new upstream release.
295
296* Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.29-1
297- new upstream release.
298
299* Wed Feb 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.26-1
300- new upstream release.
301
302* Fri Dec 18 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.25-1
303- new upstream release.
304
305* Thu Dec 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.24-1
306- new upstream release.
307
308* Wed Dec  2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.23-1
309- new upstream release.
310
311* Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.21-1
312- new upstream release.
313
314* Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-2
315- added compat32 package.
316
317* Fri Mar  6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-1
318- new upstream release.
319
320* Mon Jan 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.19-1
321- new upstream release.
322
323* Wed Dec  3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.18-1
324- new upstream release.
325
326* Fri Oct  3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.17-2
327- moved libldb and pyldb to System Environment/Libraries Group
328- moved ldb-tool to Applications/System Group
329
330* Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.17-1
331- new upstream release.
332
333* Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-2
334- rebuilt with current environment.
335
336* Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
337- new upstream release.
338
339* Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
340- new upstream release.
341
342* Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
343- moved libldb-cmdline.so to main package.
344
345* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
346- fixed dependency.
347
348* Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
349- new upstream release.
350- initial build for Vine Linux.
351
352* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
353- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
354
355* Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
356- New upstream release
357- Add ldb_module_error() routine
358- Fedora: work around unreliable configure check for pytevent
359- Drop patch to ignore --disable-silent-rules (included in tarball)
360
361* Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
362- Add patch to ignore --disable-silent-rules
363
364* Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
365- Add explicit mention of the bundled libreplace
366- https://fedorahosted.org/fpc/ticket/120
367- Add explicit mention of bundled libtdb_compat and libccan
368- https://fedorahosted.org/fpc/ticket/119
369
370* Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
371- Build and install API documentation
372- Build tdb_compat and ccan statically. They have no upstream releases to
373  link against yet and their API is in flux. It is unsafe to make them
374  public and shared at this time.
375
376* Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
377- New upstream release
378- Required for building newer samba4 packages
379
380* Tue Aug  2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
381- Update to 1.1.0
382  (dependency for samba4 alpha16 snapshot)
383
384* Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
385- Update to 1.0.2
386  (dependency for samba4 alpha15 snapshot)
387
388* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
389- Disable rpath
390
391* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
392- New upstream release 1.0.0
393- SOname bump to account for module loading changes
394- Rename libldb-tools to ldb-tools to make upgrades easier
395
396* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
397- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
398
399* Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
400- Fixes from package review
401- Change Requires: on tools subpackage to be the exact version/release
402- Remove unnecessary BuildRoot directive
403
404* Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
405- Update to 0.9.22 (first independent release of libldb upstream)
406
Note: See TracBrowser for help on using the repository browser.