source: projects/specs/trunk/lib/libg/libgpod/libgpod-vl.spec @ 9087

Revision 9087, 6.7 KB checked in by inagaki, 10 years ago (diff)

2014-11-14 Ryoichi INAGAKI <ryo1@…>

  • eet, gmtk, libeina: updated
  • libgpod, swfdec: changed Group


Line 
1%define with_mono 1
2
3Summary: Library to access the iPod
4Summary(ja): iPod にアクセスするためのライブラリ
5Name: libgpod
6Version: 0.8.3
7Release: 3%{?_dist_release}
8Group: System Environment/Libraries
9License: LGPLv2+
10URL: http://www.gtkpod.org/libgpod.html
11
12Source: %{name}-%{version}.tar.bz2
13
14Buildroot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: docbook-style-xsl
16BuildRequires: glib2-devel
17BuildRequires: gtk2-devel
18BuildRequires: gettext
19BuildRequires: intltool
20BuildRequires: libimobiledevice-devel >= 1.1.4
21BuildRequires: libplist-devel >= 1.0
22BuildRequires: libusb1-devel
23BuildRequires: libxml2-devel
24BuildRequires: libxslt
25BuildRequires: libffi-devel
26BuildRequires: perl(XML::Parser)
27BuildRequires: pygobject-devel
28BuildRequires: python-devel
29BuildRequires: python-mutagen
30BuildRequires: sg3_utils-devel
31BuildRequires: sqlite3-devel
32BuildRequires: taglib-devel
33BuildRequires: swig
34%if %{with_mono}
35BuildRequires: mono-devel
36BuildRequires: gtk-sharp2-devel
37%endif
38
39Requires: udev
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: daisuke
44
45%description
46libgpod is a library meant to abstract access to an iPod content. It
47provides an easy to use API to retrieve the list of files and playlist
48stored on an iPod, to modify them and to save them back to the iPod.
49
50%description -l ja
51libgpod は iPod のコンテンツにアクセスするためのライブラリです。
52iPod に格納されているファイルリストやプレイリストを取得し、変更し、
53iPod に書き戻すための API が提供されています。
54
55%package devel
56Summary: Support files necessary to compile applications with libgpod.
57Summary(ja): libgpod を使うアプリケーションのコンパイルに必要なファイル.
58Group: Development/Libraries
59Requires: libgpod = %{version}-%{release}
60Requires: glib2-devel
61Requires: gtk2-devel
62
63%description devel
64Libraries, headers, and support files necessary to compile applications
65using libgpod.
66
67%description -l ja devel
68libgpod を使ったアプリケーションのコンパイルに必要なライブラリ,
69ヘッダファイルなどが含まれています.
70
71%package -n python-gpod
72Summary: Python module to access iPod content
73Summary(ja): iPod にアクセスするための Python モジュール
74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
76Requires: python-mutagen
77
78%description -n python-gpod
79A python module to access iPod content.  This module provides bindings
80to the libgpod library.
81
82
83%if %{with_mono}
84%package sharp
85Summary: C#/.NET library to access iPod content
86Summary(ja): iPod にアクセスするための C#/.NET ライブラリ
87Group: System Environment/Libraries
88Requires: %{name} = %{version}-%{release}
89
90%description sharp
91C#/.NET library to access iPod content.  Provides bindings to the libgpod
92library.
93
94%package sharp-devel
95Summary: Development files for libgpod-sharp
96Summary(ja): libgpod-sharp の開発用ファイル
97Group: Development/Libraries
98Requires: %{name}-sharp = %{version}-%{release}
99Requires: pkgconfig
100
101%description sharp-devel
102C#/.NET library to access iPod content.  Provides bindings to the libgpod
103library.
104
105This package contains the files required to develop programs that will use
106libgpod-sharp.
107%endif
108
109
110%prep
111%setup -q
112
113chmod -x bindings/python/examples/*.py
114
115%build
116%configure \
117  --without-hal \
118  --enable-udev \
119  --with-temp-mount-dir=%{_localstatedir}/run/%{name}
120make %{?_smp_mflags}
121
122%install
123if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
124
125make DESTDIR=%{buildroot} install
126
127%find_lang %{name}
128
129rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
130rm -f $RPM_BUILD_ROOT%{python_sitearch}/gpod/*.{a,la}
131
132%clean
133if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
134
135%post -p /sbin/ldconfig
136
137%postun -p /sbin/ldconfig
138
139%files -f %{name}.lang
140%defattr(-, root, root, 0755)
141%doc AUTHORS ChangeLog COPYING README
142%{_bindir}/*
143%{_libdir}/lib*.so.*
144%dir %{_localstatedir}/run/%{name}
145/lib/udev/iphone-set-info
146/lib/udev/ipod-set-info
147/lib/udev/rules.d/*.rules
148
149%files devel
150%defattr(-, root, root, 0755)
151%{_libdir}/lib*.so
152%{_libdir}/pkgconfig/*.pc
153%{_includedir}/gpod-1.0/
154%{_datadir}/gtk-doc/html/%{name}
155
156%files -n python-gpod
157%defattr(-, root, root, 0755)
158%doc COPYING bindings/python/README bindings/python/examples
159%{python_sitearch}/gpod
160
161%if %{with_mono}
162%files sharp
163%defattr(-, root, root, 0755)
164%{_libdir}/%{name}/%{name}-sharp*
165
166%files sharp-devel
167%defattr(-, root, root, 0755)
168%{_libdir}/pkgconfig/%{name}-sharp.pc
169%endif
170
171
172%changelog
173* Wed Nov 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.3-3
174- moved sharp subpackage to System Environment/Libraries Group
175- moved sharp-devel subpackage to Development/Libraries Group
176
177* Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.8.3-2
178- rebuild with new libplist, libimobiledevice
179
180* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
181- new upstream release
182
183* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-2
184- rebuild with libimobiledevice-1.1.5
185
186* Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-1
187- update to 0.8.2
188- remove Patch0
189- add BuildRequires: mono-devel, gtk-sharp2, taglib-devel
190- create sharp and sharp-devel package
191
192* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-4
193- rebuild with libimobiledevice-1.1.4
194
195* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-3
196- rebuild with python-2.7.2
197
198* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
199- rebuild with libimobiledevice-1.1.1
200
201* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-1
202- update to 0.8.0
203
204* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.7.93-2
205- rebuilt with rpm-4.8.1 for pkg-config
206
207* Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.93-1
208- new upstream release
209- add configure option (disable hal, enable udev, specify temp mount dir)
210- add python subpackage
211- add BR:
212
213* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
214- new upstream release
215- remove static library
216
217* Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-3vl5
218- added BuildRequires: libffi-devel
219
220* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2vl5
221- spec in utf-8
222
223* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1vl5
224- applied new versioning policy
225
226* Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 0.6.0-0vl1
227- new upstream release
228
229* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4.2-0vl2
230- for VineSeedPlus
231- new upstream release
232- built with new toolchain
233
234* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
235- new upstream release
236- build with dbus-0.62
237
238* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
239- new upstream release
240- build with dbus-0.61
241
242* Wed Dec 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
243- initial package
Note: See TracBrowser for help on using the repository browser.