source: projects/specs/trunk/lib/libg/libgpod/libgpod-vl.spec @ 8768

Revision 8768, 6.3 KB checked in by daisuke, 10 years ago (diff)

libgpod: rebuild with new libimobiledevice

Line 
1%define with_mono 1
2
3Summary: Library to access the iPod
4Summary(ja): iPod にアクセスするためのライブラリ
5Name: libgpod
6Version: 0.8.3
7Release: 2%{?_dist_release}
8Group: System Environment/Libraries
9License: LGPLv2+
10URL: http://www.gtkpod.org/libgpod.html
11
12Source: %{name}-%{version}.tar.bz2
13
14Buildroot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: docbook-style-xsl
16BuildRequires: glib2-devel
17BuildRequires: gtk2-devel
18BuildRequires: gettext
19BuildRequires: intltool
20BuildRequires: libimobiledevice-devel >= 1.1.4
21BuildRequires: libplist-devel >= 1.0
22BuildRequires: libusb1-devel
23BuildRequires: libxml2-devel
24BuildRequires: libxslt
25BuildRequires: libffi-devel
26BuildRequires: perl(XML::Parser)
27BuildRequires: pygobject-devel
28BuildRequires: python-devel
29BuildRequires: python-mutagen
30BuildRequires: sg3_utils-devel
31BuildRequires: sqlite3-devel
32BuildRequires: taglib-devel
33BuildRequires: swig
34%if %{with_mono}
35BuildRequires: mono-devel
36BuildRequires: gtk-sharp2
37%endif
38
39Requires: udev
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: daisuke
44
45%description
46libgpod is a library meant to abstract access to an iPod content. It
47provides an easy to use API to retrieve the list of files and playlist
48stored on an iPod, to modify them and to save them back to the iPod.
49
50%description -l ja
51libgpod は iPod のコンテンツにアクセスするためのライブラリです。
52iPod に格納されているファイルリストやプレイリストを取得し、変更し、
53iPod に書き戻すための API が提供されています。
54
55%package devel
56Summary: Support files necessary to compile applications with libgpod.
57Summary(ja): libgpod を使うアプリケーションのコンパイルに必要なファイル.
58Group: Development/Libraries
59Requires: libgpod = %{version}-%{release}
60Requires: glib2-devel
61Requires: gtk2-devel
62
63%description devel
64Libraries, headers, and support files necessary to compile applications
65using libgpod.
66
67%description -l ja devel
68libgpod を使ったアプリケーションのコンパイルに必要なライブラリ,
69ヘッダファイルなどが含まれています.
70
71%package -n python-gpod
72Summary: Python module to access iPod content
73Group: Development/Languages
74Requires: %{name} = %{version}-%{release}
75Requires: python-mutagen
76
77%description -n python-gpod
78A python module to access iPod content.  This module provides bindings
79to the libgpod library.
80
81
82%if %{with_mono}
83%package sharp
84Summary: C#/.NET library to access iPod content
85Group: Development/Languages
86Requires: %{name} = %{version}-%{release}
87
88%description sharp
89C#/.NET library to access iPod content.  Provides bindings to the libgpod
90library.
91
92%package sharp-devel
93Summary: Development files for libgpod-sharp
94Summary: C#/.NET library to access iPod content
95Group: Development/Languages
96Requires: %{name}-sharp = %{version}-%{release}
97Requires: pkgconfig
98
99%description sharp-devel
100C#/.NET library to access iPod content.  Provides bindings to the libgpod
101library.
102
103This package contains the files required to develop programs that will use
104libgpod-sharp.
105%endif
106
107
108%prep
109%setup -q
110
111chmod -x bindings/python/examples/*.py
112
113%build
114%configure \
115  --without-hal \
116  --enable-udev \
117  --with-temp-mount-dir=%{_localstatedir}/run/%{name}
118make %{?_smp_mflags}
119
120%install
121if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
122
123make DESTDIR=%{buildroot} install
124
125%find_lang %{name}
126
127rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
128rm -f $RPM_BUILD_ROOT%{python_sitearch}/gpod/*.{a,la}
129
130%clean
131if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
132
133%post -p /sbin/ldconfig
134
135%postun -p /sbin/ldconfig
136
137%files -f %{name}.lang
138%defattr(-, root, root, 0755)
139%doc AUTHORS ChangeLog COPYING README
140%{_bindir}/*
141%{_libdir}/lib*.so.*
142%dir %{_localstatedir}/run/%{name}
143/lib/udev/iphone-set-info
144/lib/udev/ipod-set-info
145/lib/udev/rules.d/*.rules
146
147%files devel
148%defattr(-, root, root, 0755)
149%{_libdir}/lib*.so
150%{_libdir}/pkgconfig/*.pc
151%{_includedir}/gpod-1.0/
152%{_datadir}/gtk-doc/html/%{name}
153
154%files -n python-gpod
155%defattr(-, root, root, 0755)
156%doc COPYING bindings/python/README bindings/python/examples
157%{python_sitearch}/gpod
158
159%if %{with_mono}
160%files sharp
161%defattr(-, root, root, 0755)
162%{_libdir}/%{name}/%{name}-sharp*
163
164%files sharp-devel
165%defattr(-, root, root, 0755)
166%{_libdir}/pkgconfig/%{name}-sharp.pc
167%endif
168
169
170%changelog
171* Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.8.3-2
172- rebuild with new libplist, libimobiledevice
173
174* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
175- new upstream release
176
177* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-2
178- rebuild with libimobiledevice-1.1.5
179
180* Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-1
181- update to 0.8.2
182- remove Patch0
183- add BuildRequires: mono-devel, gtk-sharp2, taglib-devel
184- create sharp and sharp-devel package
185
186* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-4
187- rebuild with libimobiledevice-1.1.4
188
189* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-3
190- rebuild with python-2.7.2
191
192* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
193- rebuild with libimobiledevice-1.1.1
194
195* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-1
196- update to 0.8.0
197
198* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.7.93-2
199- rebuilt with rpm-4.8.1 for pkg-config
200
201* Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.93-1
202- new upstream release
203- add configure option (disable hal, enable udev, specify temp mount dir)
204- add python subpackage
205- add BR:
206
207* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
208- new upstream release
209- remove static library
210
211* Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-3vl5
212- added BuildRequires: libffi-devel
213
214* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2vl5
215- spec in utf-8
216
217* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1vl5
218- applied new versioning policy
219
220* Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 0.6.0-0vl1
221- new upstream release
222
223* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4.2-0vl2
224- for VineSeedPlus
225- new upstream release
226- built with new toolchain
227
228* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
229- new upstream release
230- build with dbus-0.62
231
232* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
233- new upstream release
234- build with dbus-0.61
235
236* Wed Dec 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
237- initial package
Note: See TracBrowser for help on using the repository browser.