source: projects/specs/trunk/lib/libg/libgpod/libgpod-vl.spec @ 9421

Revision 9421, 7.1 KB checked in by inagaki, 9 years ago (diff)

2015-03-08 Ryoichi INAGAKI <ryo1@…>

  • libgpod, libwps: fixed spec


Line 
1%define with_mono 1
2
3Summary:       Library to access the iPod
4Summary(ja):   iPod にアクセスするためのライブラリ
5Name:          libgpod
6Version:       0.8.3
7Release:       4%{?_dist_release}
8Group:         System Environment/Libraries
9License:       LGPLv2+
10URL:           http://www.gtkpod.org/libgpod.html
11
12Source0:       %{name}-%{version}.tar.bz2
13
14# Vine Patch
15Patch100:      %{name}-0.8.3-python-uncomment.patch
16
17Buildroot:     %{_tmppath}/%{name}-%{version}-root
18BuildRequires: docbook-style-xsl
19BuildRequires: glib2-devel
20BuildRequires: gtk2-devel
21BuildRequires: gettext
22BuildRequires: intltool
23BuildRequires: libimobiledevice-devel >= 1.1.4
24BuildRequires: libplist-devel >= 1.0
25BuildRequires: libusb1-devel
26BuildRequires: libxml2-devel
27BuildRequires: libxslt
28BuildRequires: libffi-devel
29BuildRequires: perl(XML::Parser)
30BuildRequires: pygobject-devel
31BuildRequires: python-devel
32BuildRequires: python-mutagen
33BuildRequires: sg3_utils-devel
34BuildRequires: sqlite3-devel
35BuildRequires: taglib-devel
36BuildRequires: swig
37%if %{with_mono}
38BuildRequires: mono-devel
39BuildRequires: gtk-sharp2-devel
40%endif
41
42Requires:      udev
43
44Vendor:        Project Vine
45Distribution:  Vine Linux
46Packager:      daisuke
47
48%description
49libgpod is a library meant to abstract access to an iPod content. It
50provides an easy to use API to retrieve the list of files and playlist
51stored on an iPod, to modify them and to save them back to the iPod.
52
53%description -l ja
54libgpod は iPod のコンテンツにアクセスするためのライブラリです。
55iPod に格納されているファイルリストやプレイリストを取得し、変更し、
56iPod に書き戻すための API が提供されています。
57
58%package devel
59Summary:     Support files necessary to compile applications with libgpod.
60Summary(ja): libgpod を使うアプリケーションのコンパイルに必要なファイル.
61Group:       Development/Libraries
62Requires:    libgpod = %{version}-%{release}
63Requires:    glib2-devel
64Requires:    gtk2-devel
65
66%description devel
67Libraries, headers, and support files necessary to compile applications using libgpod.
68
69%description -l ja devel
70libgpod を使ったアプリケーションのコンパイルに必要なライブラリ,ヘッダファイルなどが含まれています.
71
72%package -n python-gpod
73Summary:     Python module to access iPod content
74Summary(ja): iPod にアクセスするための Python モジュール
75Group:       Development/Libraries
76Requires:    %{name} = %{version}-%{release}
77Requires:    python-mutagen
78
79%description -n python-gpod
80A python module to access iPod content. This module provides bindings to the libgpod library.
81
82
83%if %{with_mono}
84%package sharp
85Summary:     C#/.NET library to access iPod content
86Summary(ja): iPod にアクセスするための C#/.NET ライブラリ
87Group:       System Environment/Libraries
88Requires:    %{name} = %{version}-%{release}
89
90%description sharp
91C#/.NET library to access iPod content.  Provides bindings to the libgpod library.
92
93%package sharp-devel
94Summary:     Development files for libgpod-sharp
95Summary(ja): libgpod-sharp の開発用ファイル
96Group:       Development/Libraries
97Requires:    %{name}-sharp = %{version}-%{release}
98Requires:    pkgconfig
99
100%description sharp-devel
101C#/.NET library to access iPod content. Provides bindings to the libgpod library.
102
103This package contains the files required to develop programs that will use
104libgpod-sharp.
105%endif
106
107
108%prep
109%setup -q
110%patch100 -p1 -b .uncomment
111
112chmod -x bindings/python/examples/*.py
113
114%build
115%configure \
116    --without-hal \
117    --enable-udev \
118    --with-temp-mount-dir=%{_localstatedir}/run/%{name}
119make %{?_smp_mflags}
120
121%install
122if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
123
124make DESTDIR=%{buildroot} install
125
126%find_lang %{name}
127
128rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
129rm -f $RPM_BUILD_ROOT%{python_sitearch}/gpod/*.{a,la}
130
131%clean
132if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
133
134%post -p /sbin/ldconfig
135
136%postun -p /sbin/ldconfig
137
138%files -f %{name}.lang
139%defattr(-, root, root, 0755)
140%doc AUTHORS ChangeLog COPYING README
141%{_bindir}/*
142%{_libdir}/lib*.so.*
143%dir %{_localstatedir}/run/%{name}
144/lib/udev/iphone-set-info
145/lib/udev/ipod-set-info
146/lib/udev/rules.d/*.rules
147
148%files devel
149%defattr(-, root, root, 0755)
150%{_libdir}/lib*.so
151%{_libdir}/pkgconfig/%{name}-1.0.pc
152%{_includedir}/gpod-1.0/
153%{_datadir}/gtk-doc/html/%{name}
154
155%files -n python-gpod
156%defattr(-, root, root, 0755)
157%doc COPYING bindings/python/README bindings/python/examples
158%{python_sitearch}/gpod
159
160%if %{with_mono}
161%files sharp
162%defattr(-, root, root, 0755)
163%{_libdir}/%{name}/%{name}-sharp*
164
165%files sharp-devel
166%defattr(-, root, root, 0755)
167%{_libdir}/pkgconfig/%{name}-sharp.pc
168%endif
169
170
171%changelog
172* Sun Mar  8 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.3-4
173- added patch100 to build swig 3.0.5
174- moved %%{_libdir}/pkgconfig/libgpod-sharp.pc to sharp subpackage
175
176* Wed Nov 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.3-3
177- moved sharp subpackage to System Environment/Libraries Group
178- moved sharp-devel subpackage to Development/Libraries Group
179
180* Wed Jul 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.8.3-2
181- rebuild with new libplist, libimobiledevice
182
183* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
184- new upstream release
185
186* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-2
187- rebuild with libimobiledevice-1.1.5
188
189* Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-1
190- update to 0.8.2
191- remove Patch0
192- add BuildRequires: mono-devel, gtk-sharp2, taglib-devel
193- create sharp and sharp-devel package
194
195* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-4
196- rebuild with libimobiledevice-1.1.4
197
198* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-3
199- rebuild with python-2.7.2
200
201* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
202- rebuild with libimobiledevice-1.1.1
203
204* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-1
205- update to 0.8.0
206
207* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.7.93-2
208- rebuilt with rpm-4.8.1 for pkg-config
209
210* Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.93-1
211- new upstream release
212- add configure option (disable hal, enable udev, specify temp mount dir)
213- add python subpackage
214- add BR:
215
216* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
217- new upstream release
218- remove static library
219
220* Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-3vl5
221- added BuildRequires: libffi-devel
222
223* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2vl5
224- spec in utf-8
225
226* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1vl5
227- applied new versioning policy
228
229* Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 0.6.0-0vl1
230- new upstream release
231
232* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4.2-0vl2
233- for VineSeedPlus
234- new upstream release
235- built with new toolchain
236
237* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
238- new upstream release
239- build with dbus-0.62
240
241* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
242- new upstream release
243- build with dbus-0.61
244
245* Wed Dec 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
246- initial package
Note: See TracBrowser for help on using the repository browser.