source: projects/specs/trunk/lib/libd/libdb/libdb-vl.spec @ 9159

Revision 9159, 22.2 KB checked in by inagaki, 9 years ago (diff)

2014-12-17 Ryoichi INAGAKI <ryo1@…>

  • libdb: created compat32-*


Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define __soversion_major 5
4%define __soversion %{__soversion_major}.3
5
6%bcond_with java
7
8Summary: The Berkeley DB database library for C
9Summary(ja): C 言語用 Berkeley DB データベースライブラリ
10Name: libdb
11Version: 5.3.28
12Release: 8%{?_dist_release}
13Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
14Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
15# For mt19937db.c
16Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
17Patch0: libdb-multiarch.patch
18# db-1.85 upstream patches
19Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
20Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
21Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
22Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
23# other patches
24Patch20: db-1.85-errno.patch
25Patch22: db-4.6.21-1.85-compat.patch
26Patch24: db-4.5.20-jni-include-dir.patch
27# License clarification patch
28# http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
29Patch25: 007-mt19937db.c_license.patch
30URL: http://www.oracle.com/database/berkeley-db/
31License: BSD and LGPLv2 and Sleepycat
32Group: System Environment/Libraries
33BuildRequires: perl libtool
34BuildRequires: tcl >= 8.5.2-3
35%if %{with java}
36BuildRequires: java-devel >= 1:1.6.0
37%endif
38#BuildRequires: chrpath
39#Conflicts: filesystem < 3
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: tomop
44
45%description
46The Berkeley Database (Berkeley DB) is a programmatic toolkit that
47provides embedded database support for both traditional and
48client/server applications. The Berkeley DB includes B+tree, Extended
49Linear Hashing, Fixed and Variable-length record access methods,
50transactions, locking, logging, shared memory caching, and database
51recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
52used by many applications, including Python and Perl, so this should
53be installed on all systems.
54
55%package utils
56Summary: Command line tools for managing Berkeley DB databases
57Summary(ja): Berkeley DB データベースを管理するためのコマンドラインツール集
58Group: Applications/Databases
59Requires: %{name}%{?_isa} = %{version}-%{release}
60Obsoletes: db4-utils
61Provides: db4-utils
62
63%description utils
64The Berkeley Database (Berkeley DB) is a programmatic toolkit that
65provides embedded database support for both traditional and
66client/server applications. Berkeley DB includes B+tree, Extended
67Linear Hashing, Fixed and Variable-length record access methods,
68transactions, locking, logging, shared memory caching, and database
69recovery. DB supports C, C++, Java and Perl APIs.
70
71%package devel
72Summary: C development files for the Berkeley DB library
73Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
74Group: Development/Libraries
75Requires: %{name}%{?_isa} = %{version}-%{release}
76Obsoletes: db4-devel
77Provides: db4-devel
78
79%description devel
80The Berkeley Database (Berkeley DB) is a programmatic toolkit that
81provides embedded database support for both traditional and
82client/server applications. This package contains the header files
83and libraries for building programs which use the Berkeley DB.
84
85%package devel-doc
86Summary: C development documentation files for the Berkeley DB library
87Summary(ja): Berkeley DB ライブラリの C 言語用開発ドキュメント
88Group: Documentation
89Requires: %{name} = %{version}-%{release}
90Requires: %{name}-devel = %{version}-%{release}
91BuildArch: noarch
92
93%description devel-doc
94The Berkeley Database (Berkeley DB) is a programmatic toolkit that
95provides embedded database support for both traditional and
96client/server applications. This package contains the documentation
97for building programs which use the Berkeley DB.
98
99%package devel-static
100Summary: Berkeley DB static libraries
101Summary(ja): Berkeley DB 静的ライブラリ
102Group: Development/Libraries
103Requires: %{name}-devel%{?_isa} = %{version}-%{release}
104
105%description devel-static
106The Berkeley Database (Berkeley DB) is a programmatic toolkit that
107provides embedded database support for both traditional and
108client/server applications. This package contains static libraries
109needed for applications that require static linking of
110Berkeley DB.
111
112%package cxx
113Summary: The Berkeley DB database library for C++
114Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
115Group: System Environment/Libraries
116Requires: %{name}%{?_isa} = %{version}-%{release}
117
118%description cxx
119The Berkeley Database (Berkeley DB) is a programmatic toolkit that
120provides embedded database support for both traditional and
121client/server applications. The Berkeley DB includes B+tree, Extended
122Linear Hashing, Fixed and Variable-length record access methods,
123transactions, locking, logging, shared memory caching, and database
124recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
125used by many applications, including Python and Perl, so this should
126be installed on all systems.
127
128%package cxx-devel
129Summary: C++ development files for the Berkeley DB library
130Summary(ja): Berkeley DB ライブラリの C++ 言語用開発ファイル
131Group: Development/Libraries
132Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
133Requires: %{name}-devel%{?_isa} = %{version}-%{release}
134
135%description cxx-devel
136The Berkeley Database (Berkeley DB) is a programmatic toolkit that
137provides embedded database support for both traditional and
138client/server applications. This package contains the header files,
139libraries, and documentation for building programs which use the
140Berkeley DB in C++.
141
142%package tcl
143Summary: The Berkeley DB library for tcl
144Summary(ja): tcl 用 Berkeley DB データベースライブラリ
145Group: System Environment/Libraries
146Requires: %{name}%{?_isa} = %{version}-%{release}
147
148%description tcl
149The Berkeley Database (Berkeley DB) is a programmatic toolkit that
150provides embedded database support for both traditional and
151client/server applications. This package contains the libraries
152for building programs which use the Berkeley DB in Tcl.
153
154%package tcl-devel
155Summary: Development files for using the Berkeley DB with tcl
156Summary(ja): tcl で Berkeley DB を利用するための開発ファイル
157Group: Development/Libraries
158Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
159
160%description tcl-devel
161The Berkeley Database (Berkeley DB) is a programmatic toolkit that
162provides embedded database support for both traditional and
163client/server applications. This package contains the libraries
164for building programs which use the Berkeley DB in Tcl.
165
166%package sql
167Summary: The Berkeley DB library for SQL
168Summary(ja): SQL 用 Berkeley DB データベースライブラリ
169Group: System Environment/Libraries
170Requires: %{name}%{?_isa} = %{version}-%{release}
171
172%description sql
173The Berkeley Database (Berkeley DB) is a programmatic toolkit that
174provides embedded database support for both traditional and
175client/server applications. This package contains the libraries
176for building programs which use the Berkeley DB in SQL.
177
178%package sql-devel
179Summary: Development files for using the Berkeley DB with sql
180Summary(ja): SQL で Berkeley DB を利用するための開発ファイル
181Group: Development/Libraries
182Requires: %{name}-sql%{?_isa} = %{version}-%{release}
183
184%description sql-devel
185The Berkeley Database (Berkeley DB) is a programmatic toolkit that
186provides embedded database support for both traditional and
187client/server applications. This package contains the libraries
188for building programs which use the Berkeley DB in SQL.
189
190%if %{with java}
191%package java
192Summary: The Berkeley DB library for Java
193Summary(ja): Java 用 Berkeley DB データベースライブラリ
194Group: System Environment/Libraries
195Requires: %{name}%{?_isa} = %{version}-%{release}
196
197%description java
198The Berkeley Database (Berkeley DB) is a programmatic toolkit that
199provides embedded database support for both traditional and
200client/server applications. This package contains the libraries
201for building programs which use the Berkeley DB in Java.
202
203%package java-devel
204Summary: Development files for using the Berkeley DB with Java
205Summary(ja): Java で Berkeley DB を利用するための開発ファイル
206Group: Development/Libraries
207Requires: %{name}-java%{?_isa} = %{version}-%{release}
208
209%description java-devel
210The Berkeley Database (Berkeley DB) is a programmatic toolkit that
211provides embedded database support for both traditional and
212client/server applications. This package contains the libraries
213for building programs which use the Berkeley DB in Java.
214%endif
215
216# compat32
217%package -n compat32-%{name}
218Summary: The Berkeley DB database library for C
219Summary(ja): C 言語用 Berkeley DB データベースライブラリ
220Group: System Environment/Libraries
221Requires: libdb = %{version}-%{release}
222
223%description -n compat32-%{name}
224The Berkeley Database (Berkeley DB) is a programmatic toolkit that
225provides embedded database support for both traditional and
226client/server applications. The Berkeley DB includes B+tree, Extended
227Linear Hashing, Fixed and Variable-length record access methods,
228transactions, locking, logging, shared memory caching, and database
229recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
230used by many applications, including Python and Perl, so this should
231be installed on all systems.
232
233%package -n compat32-%{name}-cxx
234Summary: The Berkeley DB database library for C++
235Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
236Group: System Environment/Libraries
237Requires: %{name}-cxx = %{version}-%{release}
238Requires: compat32-%{name} = %{version}-%{release}
239
240%description -n compat32-%{name}-cxx
241The Berkeley Database (Berkeley DB) is a programmatic toolkit that
242provides embedded database support for both traditional and
243client/server applications. The Berkeley DB includes B+tree, Extended
244Linear Hashing, Fixed and Variable-length record access methods,
245transactions, locking, logging, shared memory caching, and database
246recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
247used by many applications, including Python and Perl, so this should
248be installed on all systems.
249
250%package -n compat32-%{name}-devel
251Summary: C development files for the Berkeley DB library
252Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
253Group: Development/Libraries
254Requires: compat32-%{name} = %{version}-%{release}
255Requires: %{name}-devel    = %{version}-%{release}
256Obsoletes: compat32-db4-devel
257Provides: compat32-db4-devel
258
259%description -n compat32-%{name}-devel
260The Berkeley Database (Berkeley DB) is a programmatic toolkit that
261provides embedded database support for both traditional and
262client/server applications. This package contains the header files,
263libraries, and documentation for building programs which use the
264Berkeley DB.
265
266
267%prep
268%setup -q -n db-%{version} -a 1
269cp %{SOURCE2} .
270
271%patch0 -p1 -b .multiarch
272pushd db.1.85/PORT/linux
273%patch10 -p0 -b .1.1
274popd
275pushd db.1.85
276%patch11 -p0 -b .1.2
277%patch12 -p0 -b .1.3
278%patch13 -p0 -b .1.4
279%patch20 -p1 -b .errno
280popd
281
282%patch22 -p1 -b .185compat
283%patch24 -p1 -b .4.5.20.jni
284%patch25 -p1 -b .licensefix
285
286cd dist
287./s_config
288cd ..
289
290%build
291CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
292CFLAGS="$CFLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
293export CFLAGS
294
295# Build the old db-185 libraries.
296make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
297
298test -d dist/dist-tls || mkdir dist/dist-tls
299# Static link db_dump185 with old db-185 libraries.
300/bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
301/bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
302
303# Update config files to understand aarch64
304#for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
305#  cp /usr/lib/rpm/config.{guess,sub} "$dir"
306#done
307
308pushd dist/dist-tls
309%define _configure ../configure
310%configure -C \
311        --enable-compat185 \
312        --enable-dump185 \
313        --enable-shared \
314        --enable-static \
315        --enable-tcl \
316        --with-tcl=%{_libdir} \
317        --enable-cxx \
318        --enable-sql \
319        --enable-test \
320        --disable-rpath \
321        --with-tcl=%{_libdir}/tcl8.5 \
322%if %{with java}
323        --enable-java
324%endif
325
326# Remove libtool predep_objects and postdep_objects wonkiness so that
327# building without -nostdlib doesn't include them twice.  Because we
328# already link with g++, weird stuff happens if you don't let the
329# compiler handle this.
330perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
331perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
332perl -pi -e 's/-shared -nostdlib/-shared/' libtool
333
334make %{?_smp_mflags}
335
336%if %{with java}
337# XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
338LDBJ=./.libs/libdb_java-%{__soversion}.la
339if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
340        sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
341fi
342%endif
343
344popd
345
346%install
347rm -rf ${RPM_BUILD_ROOT}
348mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
349mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
350
351%makeinstall STRIP=/bin/true -C dist/dist-tls
352
353# XXX Nuke non-versioned archives and symlinks
354rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
355
356chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
357
358# Move the header files to a subdirectory, in case we're deploying on a
359# system with multiple versions of DB installed.
360mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
361mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
362
363# Create symlinks to includes so that "use <db.h> and link with -ldb" works.
364for i in db.h db_cxx.h db_185.h; do
365        ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
366done
367
368%if %{with java}
369# Move java jar file to the correct place
370mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
371mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
372%endif
373
374# Eliminate installed doco
375rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
376
377# XXX Avoid Permission denied. strip when building as non-root.
378chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
379
380# remove unneeded .la files (#225675)
381rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
382
383# remove RPATHs
384#chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
385
386# unify documentation and examples, remove stuff we don't need
387rm -rf docs/csharp
388rm -rf examples/csharp
389rm -rf docs/installation
390mv examples docs
391
392%clean
393rm -rf ${RPM_BUILD_ROOT}
394
395%post -p /sbin/ldconfig
396
397%postun -p /sbin/ldconfig
398
399%post cxx -p /sbin/ldconfig
400
401%postun cxx -p /sbin/ldconfig
402
403%post sql -p /sbin/ldconfig
404
405%postun sql -p /sbin/ldconfig
406
407%post tcl -p /sbin/ldconfig
408
409%postun tcl -p /sbin/ldconfig
410
411%if %{with java}
412%post java -p /sbin/ldconfig
413
414%postun java -p /sbin/ldconfig
415
416%endif
417
418
419%if %{build_compat32}
420%post -n compat32-%{name} -p /sbin/ldconfig
421
422%postun -n compat32-%{name} -p /sbin/ldconfig
423
424%post -n compat32-%{name}-cxx -p /sbin/ldconfig
425
426%postun -n compat32-%{name}-cxx -p /sbin/ldconfig
427
428%endif
429
430%files
431%defattr(-,root,root,-)
432%doc LICENSE README lgpl-2.1.txt
433%{_libdir}/libdb-%{__soversion}.so
434%{_libdir}/libdb-%{__soversion_major}.so
435
436%files devel
437%defattr(-,root,root,-)
438%{_libdir}/libdb.so
439%dir %{_includedir}/%{name}
440%{_includedir}/%{name}/db.h
441%{_includedir}/%{name}/db_185.h
442%{_includedir}/db.h
443%{_includedir}/db_185.h
444
445%files devel-doc
446%defattr(-,root,root,-)
447%doc    docs/*
448
449%files devel-static
450%defattr(-,root,root,-)
451%{_libdir}/libdb-%{__soversion}.a
452%{_libdir}/libdb_cxx-%{__soversion}.a
453%{_libdir}/libdb_tcl-%{__soversion}.a
454%{_libdir}/libdb_sql-%{__soversion}.a
455%if %{with java}
456%{_libdir}/libdb_java-%{__soversion}.a
457%endif
458
459%files utils
460%defattr(-,root,root,-)
461%{_bindir}/db*_archive
462%{_bindir}/db*_checkpoint
463%{_bindir}/db*_deadlock
464%{_bindir}/db*_dump*
465%{_bindir}/db*_hotbackup
466%{_bindir}/db*_load
467%{_bindir}/db*_printlog
468%{_bindir}/db*_recover
469%{_bindir}/db*_replicate
470%{_bindir}/db*_stat
471%{_bindir}/db*_upgrade
472%{_bindir}/db*_verify
473%{_bindir}/db*_tuner
474
475%files cxx
476%defattr(-,root,root,-)
477%{_libdir}/libdb_cxx-%{__soversion}.so
478%{_libdir}/libdb_cxx-%{__soversion_major}.so
479
480%files cxx-devel
481%defattr(-,root,root,-)
482%{_includedir}/%{name}/db_cxx.h
483%{_includedir}/db_cxx.h
484%{_libdir}/libdb_cxx.so
485
486%files tcl
487%defattr(-,root,root,-)
488%{_libdir}/libdb_tcl-%{__soversion}.so
489%{_libdir}/libdb_tcl-%{__soversion_major}.so
490
491%files tcl-devel
492%defattr(-,root,root,-)
493%{_libdir}/libdb_tcl.so
494
495%files sql
496%defattr(-,root,root,-)
497%{_libdir}/libdb_sql-%{__soversion}.so
498%{_libdir}/libdb_sql-%{__soversion_major}.so
499
500%files sql-devel
501%defattr(-,root,root,-)
502%{_bindir}/dbsql
503%{_libdir}/libdb_sql.so
504%{_includedir}/%{name}/dbsql.h
505
506%if %{with java}
507%files java
508%defattr(-,root,root,-)
509%{_libdir}/libdb_java-%{__soversion_major}*.so
510%{_datadir}/java/*.jar
511
512%files java-devel
513%defattr(-,root,root,-)
514%{_libdir}/libdb_java.so
515%endif
516
517%if %{build_compat32}
518%files -n compat32-%{name}
519%defattr(-,root,root)
520%{_libdir}/libdb-%{__soversion}.so
521%{_libdir}/libdb-%{__soversion_major}.so
522
523%files -n compat32-%{name}-cxx
524%defattr(-,root,root)
525%{_libdir}/libdb_cxx-%{__soversion}.so
526%{_libdir}/libdb_cxx-%{__soversion_major}.so
527
528%files -n compat32-%{name}-devel
529%defattr(-,root,root)
530%{_libdir}/libdb.so
531%endif
532
533%changelog
534* Tue Dec 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-8
535- added compat32 subpackages
536
537* Sat Nov  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-7
538- updated Summary and Group
539
540* Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-6
541- added "Provides: db4-{utils,devel}".
542
543* Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
544- initial build for Vine Linux.
545
546* Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
547- Add some of the previous aarch64 bits back as the sub configure don't use the macro
548
549* Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
550- Fix configure macro usage for better aarch64 build fix
551
552* Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
553- Updated config files to allow build on aarch64 (#1022970)
554
555* Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
556- Added Sleepycat to the license list (#1013841)
557- Updated to 5.3.28 (#1013233)
558
559* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
560- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
561
562* Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
563- add copy of lgpl-2.1.txt
564
565* Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
566- Fix missing debuginfo issue for utils subpackage
567
568* Thu May  9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
569- add license clarification fix
570
571* Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
572- Added sqlite compability CFLAGS (#788496)
573
574* Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
575- Cleaning the specfile - removed gcc-java dependecy other way
576
577* Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
578- Removed dependency on obsolete gcc-java package (#927742)
579
580* Thu Mar  7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
581- add LGPLv2+ and remove Sleepycat in license tag (#886838)
582
583* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
584- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
585
586* Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
587- fix license tag
588
589* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
590- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
591
592* Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
593- Specify tag for libtool (fixes FTBFS # 838334 )
594
595* Thu Jul  5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
596- update to 5.3.21
597http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
598
599* Tue Jul  3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
600- move C++ header files to cxx-devel
601
602* Tue Jul  3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
603- fix -devel packages dependencies yet more (#832225)
604
605* Sun May  6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
606- package -devel packages correctly
607
608* Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
609- fix multiarch conflict in libdb-devel (#812901)
610- remove unneeded dos2unix BR
611
612* Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
613- update to 5.3.15
614  http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
615
616* Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
617- Resolves rhbz#794472
618- Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
619
620* Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
621- add filesystem guard
622
623* Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
624- install everything in /usr
625  https://fedoraproject.org/wiki/Features/UsrMove
626
627* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
628- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
629
630* Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
631- update to 5.2.36,
632  http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
633
634* Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
635- move development documentation to devel-doc subpackage (#705386)
636
637* Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
638- update to 5.2.28
639
640* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
641- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
642
643* Thu Feb  3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
644- update to 5.1.25
645
646* Wed Sep 29 2010 jkeating - 5.1.19-2
647- Rebuilt for gcc bug 634757
648
649* Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
650- update to 5.1.19
651- rename -devel-static to -static subpackage (#617800)
652- build java on all arches
653
654* Wed Jul  7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
655- update to 5.0.26
656- drop BR: ed
657
658* Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
659- add Requires: libdb-cxx to libdb-devel
660
661* Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
662- initial build
663
664* Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
665- remove C# documentation
666- disable/remove rpath
667- fix description
668- tighten dependencies
669- run ldconfig for cxx and sql subpackages
670
671* Fri Apr  9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
672- enable sql
673- package 5.0.21
Note: See TracBrowser for help on using the repository browser.