source: projects/specs/trunk/lib/libd/libdb/libdb-vl.spec @ 10297

Revision 10297, 22.6 KB checked in by tomop, 8 years ago (diff)

libdb-5.3.28-9

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define __soversion_major 5
4%define __soversion %{__soversion_major}.3
5
6%bcond_with java
7
8Summary: The Berkeley DB database library for C
9Summary(ja): C 言語用 Berkeley DB データベースライブラリ
10Name: libdb
11Version: 5.3.28
12Release: 9%{?_dist_release}
13Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
14Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
15# For mt19937db.c
16Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
17Patch0: libdb-multiarch.patch
18# db-1.85 upstream patches
19Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
20Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
21Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
22Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
23# other patches
24Patch20: db-1.85-errno.patch
25Patch22: db-4.6.21-1.85-compat.patch
26Patch24: db-4.5.20-jni-include-dir.patch
27# License clarification patch
28# http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
29Patch25: 007-mt19937db.c_license.patch
30#Adds missing constant to Optcodes.java and changes ClassReader.java to use it. This makes package to build with Java 8.
31Patch26: java8-fix.patch
32# memp_stat fix provided by upstream (rhbz#1211871)
33Patch27: db-5.3.21-memp_stat-upstream-fix.patch
34
35URL: http://www.oracle.com/database/berkeley-db/
36License: BSD and LGPLv2 and Sleepycat
37Group: System Environment/Libraries
38BuildRequires: perl libtool
39BuildRequires: tcl-devel >= 8.5.2-3
40%if %{with java}
41BuildRequires: java-devel >= 1:1.6.0
42%endif
43#BuildRequires: chrpath
44#Conflicts: filesystem < 3
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: tomop
49
50%description
51The Berkeley Database (Berkeley DB) is a programmatic toolkit that
52provides embedded database support for both traditional and
53client/server applications. The Berkeley DB includes B+tree, Extended
54Linear Hashing, Fixed and Variable-length record access methods,
55transactions, locking, logging, shared memory caching, and database
56recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
57used by many applications, including Python and Perl, so this should
58be installed on all systems.
59
60%package utils
61Summary: Command line tools for managing Berkeley DB databases
62Summary(ja): Berkeley DB データベースを管理するためのコマンドラインツール集
63Group: Applications/Databases
64Requires: %{name}%{?_isa} = %{version}-%{release}
65Obsoletes: db4-utils
66Provides: db4-utils
67
68%description utils
69The Berkeley Database (Berkeley DB) is a programmatic toolkit that
70provides embedded database support for both traditional and
71client/server applications. Berkeley DB includes B+tree, Extended
72Linear Hashing, Fixed and Variable-length record access methods,
73transactions, locking, logging, shared memory caching, and database
74recovery. DB supports C, C++, Java and Perl APIs.
75
76%package devel
77Summary: C development files for the Berkeley DB library
78Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
79Group: Development/Libraries
80Requires: %{name}%{?_isa} = %{version}-%{release}
81Obsoletes: db4-devel
82Provides: db4-devel
83
84%description devel
85The Berkeley Database (Berkeley DB) is a programmatic toolkit that
86provides embedded database support for both traditional and
87client/server applications. This package contains the header files
88and libraries for building programs which use the Berkeley DB.
89
90%package devel-doc
91Summary: C development documentation files for the Berkeley DB library
92Summary(ja): Berkeley DB ライブラリの C 言語用開発ドキュメント
93Group: Documentation
94Requires: %{name} = %{version}-%{release}
95Requires: %{name}-devel = %{version}-%{release}
96BuildArch: noarch
97
98%description devel-doc
99The Berkeley Database (Berkeley DB) is a programmatic toolkit that
100provides embedded database support for both traditional and
101client/server applications. This package contains the documentation
102for building programs which use the Berkeley DB.
103
104%package devel-static
105Summary: Berkeley DB static libraries
106Summary(ja): Berkeley DB 静的ライブラリ
107Group: Development/Libraries
108Requires: %{name}-devel%{?_isa} = %{version}-%{release}
109
110%description devel-static
111The Berkeley Database (Berkeley DB) is a programmatic toolkit that
112provides embedded database support for both traditional and
113client/server applications. This package contains static libraries
114needed for applications that require static linking of
115Berkeley DB.
116
117%package cxx
118Summary: The Berkeley DB database library for C++
119Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
120Group: System Environment/Libraries
121Requires: %{name}%{?_isa} = %{version}-%{release}
122
123%description cxx
124The Berkeley Database (Berkeley DB) is a programmatic toolkit that
125provides embedded database support for both traditional and
126client/server applications. The Berkeley DB includes B+tree, Extended
127Linear Hashing, Fixed and Variable-length record access methods,
128transactions, locking, logging, shared memory caching, and database
129recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
130used by many applications, including Python and Perl, so this should
131be installed on all systems.
132
133%package cxx-devel
134Summary: C++ development files for the Berkeley DB library
135Summary(ja): Berkeley DB ライブラリの C++ 言語用開発ファイル
136Group: Development/Libraries
137Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
138Requires: %{name}-devel%{?_isa} = %{version}-%{release}
139
140%description cxx-devel
141The Berkeley Database (Berkeley DB) is a programmatic toolkit that
142provides embedded database support for both traditional and
143client/server applications. This package contains the header files,
144libraries, and documentation for building programs which use the
145Berkeley DB in C++.
146
147%package tcl
148Summary: The Berkeley DB library for tcl
149Summary(ja): tcl 用 Berkeley DB データベースライブラリ
150Group: System Environment/Libraries
151Requires: %{name}%{?_isa} = %{version}-%{release}
152
153%description tcl
154The Berkeley Database (Berkeley DB) is a programmatic toolkit that
155provides embedded database support for both traditional and
156client/server applications. This package contains the libraries
157for building programs which use the Berkeley DB in Tcl.
158
159%package tcl-devel
160Summary: Development files for using the Berkeley DB with tcl
161Summary(ja): tcl で Berkeley DB を利用するための開発ファイル
162Group: Development/Libraries
163Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
164
165%description tcl-devel
166The Berkeley Database (Berkeley DB) is a programmatic toolkit that
167provides embedded database support for both traditional and
168client/server applications. This package contains the libraries
169for building programs which use the Berkeley DB in Tcl.
170
171%package sql
172Summary: The Berkeley DB library for SQL
173Summary(ja): SQL 用 Berkeley DB データベースライブラリ
174Group: System Environment/Libraries
175Requires: %{name}%{?_isa} = %{version}-%{release}
176
177%description sql
178The Berkeley Database (Berkeley DB) is a programmatic toolkit that
179provides embedded database support for both traditional and
180client/server applications. This package contains the libraries
181for building programs which use the Berkeley DB in SQL.
182
183%package sql-devel
184Summary: Development files for using the Berkeley DB with sql
185Summary(ja): SQL で Berkeley DB を利用するための開発ファイル
186Group: Development/Libraries
187Requires: %{name}-sql%{?_isa} = %{version}-%{release}
188
189%description sql-devel
190The Berkeley Database (Berkeley DB) is a programmatic toolkit that
191provides embedded database support for both traditional and
192client/server applications. This package contains the libraries
193for building programs which use the Berkeley DB in SQL.
194
195%if %{with java}
196%package java
197Summary: The Berkeley DB library for Java
198Summary(ja): Java 用 Berkeley DB データベースライブラリ
199Group: System Environment/Libraries
200Requires: %{name}%{?_isa} = %{version}-%{release}
201
202%description java
203The Berkeley Database (Berkeley DB) is a programmatic toolkit that
204provides embedded database support for both traditional and
205client/server applications. This package contains the libraries
206for building programs which use the Berkeley DB in Java.
207
208%package java-devel
209Summary: Development files for using the Berkeley DB with Java
210Summary(ja): Java で Berkeley DB を利用するための開発ファイル
211Group: Development/Libraries
212Requires: %{name}-java%{?_isa} = %{version}-%{release}
213
214%description java-devel
215The Berkeley Database (Berkeley DB) is a programmatic toolkit that
216provides embedded database support for both traditional and
217client/server applications. This package contains the libraries
218for building programs which use the Berkeley DB in Java.
219%endif
220
221# compat32
222%package -n compat32-%{name}
223Summary: The Berkeley DB database library for C
224Summary(ja): C 言語用 Berkeley DB データベースライブラリ
225Group: System Environment/Libraries
226Requires: libdb = %{version}-%{release}
227
228%description -n compat32-%{name}
229The Berkeley Database (Berkeley DB) is a programmatic toolkit that
230provides embedded database support for both traditional and
231client/server applications. The Berkeley DB includes B+tree, Extended
232Linear Hashing, Fixed and Variable-length record access methods,
233transactions, locking, logging, shared memory caching, and database
234recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
235used by many applications, including Python and Perl, so this should
236be installed on all systems.
237
238%package -n compat32-%{name}-cxx
239Summary: The Berkeley DB database library for C++
240Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
241Group: System Environment/Libraries
242Requires: %{name}-cxx = %{version}-%{release}
243Requires: compat32-%{name} = %{version}-%{release}
244
245%description -n compat32-%{name}-cxx
246The Berkeley Database (Berkeley DB) is a programmatic toolkit that
247provides embedded database support for both traditional and
248client/server applications. The Berkeley DB includes B+tree, Extended
249Linear Hashing, Fixed and Variable-length record access methods,
250transactions, locking, logging, shared memory caching, and database
251recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
252used by many applications, including Python and Perl, so this should
253be installed on all systems.
254
255%package -n compat32-%{name}-devel
256Summary: C development files for the Berkeley DB library
257Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
258Group: Development/Libraries
259Requires: compat32-%{name} = %{version}-%{release}
260Requires: %{name}-devel    = %{version}-%{release}
261Obsoletes: compat32-db4-devel
262Provides: compat32-db4-devel
263
264%description -n compat32-%{name}-devel
265The Berkeley Database (Berkeley DB) is a programmatic toolkit that
266provides embedded database support for both traditional and
267client/server applications. This package contains the header files,
268libraries, and documentation for building programs which use the
269Berkeley DB.
270
271
272%prep
273%setup -q -n db-%{version} -a 1
274cp %{SOURCE2} .
275
276%patch0 -p1 -b .multiarch
277pushd db.1.85/PORT/linux
278%patch10 -p0 -b .1.1
279popd
280pushd db.1.85
281%patch11 -p0 -b .1.2
282%patch12 -p0 -b .1.3
283%patch13 -p0 -b .1.4
284%patch20 -p1 -b .errno
285popd
286
287%patch22 -p1 -b .185compat
288%patch24 -p1 -b .4.5.20.jni
289%patch25 -p1 -b .licensefix
290#%patch26 -p1 -b .java8-fix
291%patch27 -p1 -b .memp_stat-fix
292
293cd dist
294./s_config
295cd ..
296
297%build
298CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
299CFLAGS="$CFLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
300export CFLAGS
301
302# Build the old db-185 libraries.
303make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
304
305test -d dist/dist-tls || mkdir dist/dist-tls
306# Static link db_dump185 with old db-185 libraries.
307/bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
308/bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
309
310# Update config files to understand aarch64
311#for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
312#  cp /usr/lib/rpm/config.{guess,sub} "$dir"
313#done
314
315pushd dist/dist-tls
316%define _configure ../configure
317%configure -C \
318        --enable-compat185 \
319        --enable-dump185 \
320        --enable-shared \
321        --enable-static \
322        --enable-tcl \
323        --with-tcl=%{_libdir} \
324        --enable-cxx \
325        --enable-sql \
326        --enable-test \
327        --disable-rpath \
328        --with-tcl=%{_libdir}/tcl8.5 \
329%if %{with java}
330        --enable-java
331%endif
332
333# Remove libtool predep_objects and postdep_objects wonkiness so that
334# building without -nostdlib doesn't include them twice.  Because we
335# already link with g++, weird stuff happens if you don't let the
336# compiler handle this.
337perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
338perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
339perl -pi -e 's/-shared -nostdlib/-shared/' libtool
340
341make %{?_smp_mflags}
342
343%if %{with java}
344# XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
345LDBJ=./.libs/libdb_java-%{__soversion}.la
346if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
347        sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
348fi
349%endif
350
351popd
352
353%install
354rm -rf ${RPM_BUILD_ROOT}
355mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
356mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
357
358%makeinstall STRIP=/bin/true -C dist/dist-tls
359
360# XXX Nuke non-versioned archives and symlinks
361rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
362
363chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
364
365# Move the header files to a subdirectory, in case we're deploying on a
366# system with multiple versions of DB installed.
367mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
368mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
369
370# Create symlinks to includes so that "use <db.h> and link with -ldb" works.
371for i in db.h db_cxx.h db_185.h; do
372        ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
373done
374
375%if %{with java}
376# Move java jar file to the correct place
377mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
378mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
379%endif
380
381# Eliminate installed doco
382rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
383
384# XXX Avoid Permission denied. strip when building as non-root.
385chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
386
387# remove unneeded .la files (#225675)
388rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
389
390# remove RPATHs
391#chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
392
393# unify documentation and examples, remove stuff we don't need
394rm -rf docs/csharp
395rm -rf examples/csharp
396rm -rf docs/installation
397mv examples docs
398
399%clean
400rm -rf ${RPM_BUILD_ROOT}
401
402%post -p /sbin/ldconfig
403
404%postun -p /sbin/ldconfig
405
406%post cxx -p /sbin/ldconfig
407
408%postun cxx -p /sbin/ldconfig
409
410%post sql -p /sbin/ldconfig
411
412%postun sql -p /sbin/ldconfig
413
414%post tcl -p /sbin/ldconfig
415
416%postun tcl -p /sbin/ldconfig
417
418%if %{with java}
419%post java -p /sbin/ldconfig
420
421%postun java -p /sbin/ldconfig
422
423%endif
424
425
426%if %{build_compat32}
427%post -n compat32-%{name} -p /sbin/ldconfig
428
429%postun -n compat32-%{name} -p /sbin/ldconfig
430
431%post -n compat32-%{name}-cxx -p /sbin/ldconfig
432
433%postun -n compat32-%{name}-cxx -p /sbin/ldconfig
434
435%endif
436
437%files
438%defattr(-,root,root,-)
439%doc LICENSE README lgpl-2.1.txt
440%{_libdir}/libdb-%{__soversion}.so
441%{_libdir}/libdb-%{__soversion_major}.so
442
443%files devel
444%defattr(-,root,root,-)
445%{_libdir}/libdb.so
446%dir %{_includedir}/%{name}
447%{_includedir}/%{name}/db.h
448%{_includedir}/%{name}/db_185.h
449%{_includedir}/db.h
450%{_includedir}/db_185.h
451
452%files devel-doc
453%defattr(-,root,root,-)
454%doc    docs/*
455
456%files devel-static
457%defattr(-,root,root,-)
458%{_libdir}/libdb-%{__soversion}.a
459%{_libdir}/libdb_cxx-%{__soversion}.a
460%{_libdir}/libdb_tcl-%{__soversion}.a
461%{_libdir}/libdb_sql-%{__soversion}.a
462%if %{with java}
463%{_libdir}/libdb_java-%{__soversion}.a
464%endif
465
466%files utils
467%defattr(-,root,root,-)
468%{_bindir}/db*_archive
469%{_bindir}/db*_checkpoint
470%{_bindir}/db*_deadlock
471%{_bindir}/db*_dump*
472%{_bindir}/db*_hotbackup
473%{_bindir}/db*_load
474%{_bindir}/db*_printlog
475%{_bindir}/db*_recover
476%{_bindir}/db*_replicate
477%{_bindir}/db*_stat
478%{_bindir}/db*_upgrade
479%{_bindir}/db*_verify
480%{_bindir}/db*_tuner
481
482%files cxx
483%defattr(-,root,root,-)
484%{_libdir}/libdb_cxx-%{__soversion}.so
485%{_libdir}/libdb_cxx-%{__soversion_major}.so
486
487%files cxx-devel
488%defattr(-,root,root,-)
489%{_includedir}/%{name}/db_cxx.h
490%{_includedir}/db_cxx.h
491%{_libdir}/libdb_cxx.so
492
493%files tcl
494%defattr(-,root,root,-)
495%{_libdir}/libdb_tcl-%{__soversion}.so
496%{_libdir}/libdb_tcl-%{__soversion_major}.so
497
498%files tcl-devel
499%defattr(-,root,root,-)
500%{_libdir}/libdb_tcl.so
501
502%files sql
503%defattr(-,root,root,-)
504%{_libdir}/libdb_sql-%{__soversion}.so
505%{_libdir}/libdb_sql-%{__soversion_major}.so
506
507%files sql-devel
508%defattr(-,root,root,-)
509%{_bindir}/dbsql
510%{_libdir}/libdb_sql.so
511%{_includedir}/%{name}/dbsql.h
512
513%if %{with java}
514%files java
515%defattr(-,root,root,-)
516%{_libdir}/libdb_java-%{__soversion_major}*.so
517%{_datadir}/java/*.jar
518
519%files java-devel
520%defattr(-,root,root,-)
521%{_libdir}/libdb_java.so
522%endif
523
524%if %{build_compat32}
525%files -n compat32-%{name}
526%defattr(-,root,root)
527%{_libdir}/libdb-%{__soversion}.so
528%{_libdir}/libdb-%{__soversion_major}.so
529
530%files -n compat32-%{name}-cxx
531%defattr(-,root,root)
532%{_libdir}/libdb_cxx-%{__soversion}.so
533%{_libdir}/libdb_cxx-%{__soversion_major}.so
534
535%files -n compat32-%{name}-devel
536%defattr(-,root,root)
537%{_libdir}/libdb.so
538%endif
539
540%changelog
541* Thu May 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-9
542- added Patch27.
543
544* Tue Dec 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-8
545- added compat32 subpackages
546
547* Sat Nov  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-7
548- updated Summary and Group
549
550* Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-6
551- added "Provides: db4-{utils,devel}".
552
553* Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
554- initial build for Vine Linux.
555
556* Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
557- Add some of the previous aarch64 bits back as the sub configure don't use the macro
558
559* Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
560- Fix configure macro usage for better aarch64 build fix
561
562* Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
563- Updated config files to allow build on aarch64 (#1022970)
564
565* Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
566- Added Sleepycat to the license list (#1013841)
567- Updated to 5.3.28 (#1013233)
568
569* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
570- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
571
572* Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
573- add copy of lgpl-2.1.txt
574
575* Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
576- Fix missing debuginfo issue for utils subpackage
577
578* Thu May  9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
579- add license clarification fix
580
581* Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
582- Added sqlite compability CFLAGS (#788496)
583
584* Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
585- Cleaning the specfile - removed gcc-java dependecy other way
586
587* Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
588- Removed dependency on obsolete gcc-java package (#927742)
589
590* Thu Mar  7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
591- add LGPLv2+ and remove Sleepycat in license tag (#886838)
592
593* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
594- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
595
596* Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
597- fix license tag
598
599* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
600- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
601
602* Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
603- Specify tag for libtool (fixes FTBFS # 838334 )
604
605* Thu Jul  5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
606- update to 5.3.21
607http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
608
609* Tue Jul  3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
610- move C++ header files to cxx-devel
611
612* Tue Jul  3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
613- fix -devel packages dependencies yet more (#832225)
614
615* Sun May  6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
616- package -devel packages correctly
617
618* Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
619- fix multiarch conflict in libdb-devel (#812901)
620- remove unneeded dos2unix BR
621
622* Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
623- update to 5.3.15
624  http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
625
626* Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
627- Resolves rhbz#794472
628- Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
629
630* Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
631- add filesystem guard
632
633* Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
634- install everything in /usr
635  https://fedoraproject.org/wiki/Features/UsrMove
636
637* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
638- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
639
640* Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
641- update to 5.2.36,
642  http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
643
644* Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
645- move development documentation to devel-doc subpackage (#705386)
646
647* Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
648- update to 5.2.28
649
650* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
651- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
652
653* Thu Feb  3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
654- update to 5.1.25
655
656* Wed Sep 29 2010 jkeating - 5.1.19-2
657- Rebuilt for gcc bug 634757
658
659* Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
660- update to 5.1.19
661- rename -devel-static to -static subpackage (#617800)
662- build java on all arches
663
664* Wed Jul  7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
665- update to 5.0.26
666- drop BR: ed
667
668* Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
669- add Requires: libdb-cxx to libdb-devel
670
671* Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
672- initial build
673
674* Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
675- remove C# documentation
676- disable/remove rpath
677- fix description
678- tighten dependencies
679- run ldconfig for cxx and sql subpackages
680
681* Fri Apr  9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
682- enable sql
683- package 5.0.21
Note: See TracBrowser for help on using the repository browser.