source: projects/specs/trunk/lib/libd/libdb/libdb-vl.spec @ 9047

Revision 9047, 19.2 KB checked in by inagaki, 10 years ago (diff)

2014-11-01 Ryoichi INAGAKI <ryo1@…>

  • libdb, libxshmfence: change Group


Line 
1%define __soversion_major 5
2%define __soversion %{__soversion_major}.3
3
4%bcond_with java
5
6Summary: The Berkeley DB database library for C
7Summary(ja): C 言語用 Berkeley DB データベースライブラリ
8Name: libdb
9Version: 5.3.28
10Release: 7%{?_dist_release}
11Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
12Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
13# For mt19937db.c
14Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
15Patch0: libdb-multiarch.patch
16# db-1.85 upstream patches
17Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
18Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
19Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
20Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
21# other patches
22Patch20: db-1.85-errno.patch
23Patch22: db-4.6.21-1.85-compat.patch
24Patch24: db-4.5.20-jni-include-dir.patch
25# License clarification patch
26# http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
27Patch25: 007-mt19937db.c_license.patch
28URL: http://www.oracle.com/database/berkeley-db/
29License: BSD and LGPLv2 and Sleepycat
30Group: System Environment/Libraries
31BuildRequires: perl libtool
32BuildRequires: tcl >= 8.5.2-3
33%if %{with java}
34BuildRequires: java-devel >= 1:1.6.0
35%endif
36#BuildRequires: chrpath
37#Conflicts: filesystem < 3
38
39Vendor: Project Vine
40Distribution: Vine Linux
41Packager: tomop
42
43%description
44The Berkeley Database (Berkeley DB) is a programmatic toolkit that
45provides embedded database support for both traditional and
46client/server applications. The Berkeley DB includes B+tree, Extended
47Linear Hashing, Fixed and Variable-length record access methods,
48transactions, locking, logging, shared memory caching, and database
49recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
50used by many applications, including Python and Perl, so this should
51be installed on all systems.
52
53%package utils
54Summary: Command line tools for managing Berkeley DB databases
55Summary(ja): Berkeley DB データベースを管理するためのコマンドラインツール集
56Group: Applications/Databases
57Requires: %{name}%{?_isa} = %{version}-%{release}
58Obsoletes: db4-utils
59Provides: db4-utils
60
61%description utils
62The Berkeley Database (Berkeley DB) is a programmatic toolkit that
63provides embedded database support for both traditional and
64client/server applications. Berkeley DB includes B+tree, Extended
65Linear Hashing, Fixed and Variable-length record access methods,
66transactions, locking, logging, shared memory caching, and database
67recovery. DB supports C, C++, Java and Perl APIs.
68
69%package devel
70Summary: C development files for the Berkeley DB library
71Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
72Group: Development/Libraries
73Requires: %{name}%{?_isa} = %{version}-%{release}
74Obsoletes: db4-devel
75Provides: db4-devel
76
77%description devel
78The Berkeley Database (Berkeley DB) is a programmatic toolkit that
79provides embedded database support for both traditional and
80client/server applications. This package contains the header files
81and libraries for building programs which use the Berkeley DB.
82
83%package devel-doc
84Summary: C development documentation files for the Berkeley DB library
85Summary(ja): Berkeley DB ライブラリの C 言語用開発ドキュメント
86Group: Documentation
87Requires: %{name} = %{version}-%{release}
88Requires: %{name}-devel = %{version}-%{release}
89BuildArch: noarch
90
91%description devel-doc
92The Berkeley Database (Berkeley DB) is a programmatic toolkit that
93provides embedded database support for both traditional and
94client/server applications. This package contains the documentation
95for building programs which use the Berkeley DB.
96
97%package devel-static
98Summary: Berkeley DB static libraries
99Summary(ja): Berkeley DB 静的ライブラリ
100Group: Development/Libraries
101Requires: %{name}-devel%{?_isa} = %{version}-%{release}
102
103%description devel-static
104The Berkeley Database (Berkeley DB) is a programmatic toolkit that
105provides embedded database support for both traditional and
106client/server applications. This package contains static libraries
107needed for applications that require static linking of
108Berkeley DB.
109
110%package cxx
111Summary: The Berkeley DB database library for C++
112Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
113Group: System Environment/Libraries
114Requires: %{name}%{?_isa} = %{version}-%{release}
115
116%description cxx
117The Berkeley Database (Berkeley DB) is a programmatic toolkit that
118provides embedded database support for both traditional and
119client/server applications. The Berkeley DB includes B+tree, Extended
120Linear Hashing, Fixed and Variable-length record access methods,
121transactions, locking, logging, shared memory caching, and database
122recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
123used by many applications, including Python and Perl, so this should
124be installed on all systems.
125
126%package cxx-devel
127Summary: C++ development files for the Berkeley DB library
128Summary(ja): Berkeley DB ライブラリの C++ 言語用開発ファイル
129Group: Development/Libraries
130Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
131Requires: %{name}-devel%{?_isa} = %{version}-%{release}
132
133%description cxx-devel
134The Berkeley Database (Berkeley DB) is a programmatic toolkit that
135provides embedded database support for both traditional and
136client/server applications. This package contains the header files,
137libraries, and documentation for building programs which use the
138Berkeley DB in C++.
139
140%package tcl
141Summary: The Berkeley DB library for tcl
142Summary(ja): tcl 用 Berkeley DB データベースライブラリ
143Group: System Environment/Libraries
144Requires: %{name}%{?_isa} = %{version}-%{release}
145
146%description tcl
147The Berkeley Database (Berkeley DB) is a programmatic toolkit that
148provides embedded database support for both traditional and
149client/server applications. This package contains the libraries
150for building programs which use the Berkeley DB in Tcl.
151
152%package tcl-devel
153Summary: Development files for using the Berkeley DB with tcl
154Summary(ja): tcl で Berkeley DB を利用するための開発ファイル
155Group: Development/Libraries
156Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
157
158%description tcl-devel
159The Berkeley Database (Berkeley DB) is a programmatic toolkit that
160provides embedded database support for both traditional and
161client/server applications. This package contains the libraries
162for building programs which use the Berkeley DB in Tcl.
163
164%package sql
165Summary: The Berkeley DB library for SQL
166Summary(ja): SQL 用 Berkeley DB データベースライブラリ
167Group: System Environment/Libraries
168Requires: %{name}%{?_isa} = %{version}-%{release}
169
170%description sql
171The Berkeley Database (Berkeley DB) is a programmatic toolkit that
172provides embedded database support for both traditional and
173client/server applications. This package contains the libraries
174for building programs which use the Berkeley DB in SQL.
175
176%package sql-devel
177Summary: Development files for using the Berkeley DB with sql
178Summary(ja): SQL で Berkeley DB を利用するための開発ファイル
179Group: Development/Libraries
180Requires: %{name}-sql%{?_isa} = %{version}-%{release}
181
182%description sql-devel
183The Berkeley Database (Berkeley DB) is a programmatic toolkit that
184provides embedded database support for both traditional and
185client/server applications. This package contains the libraries
186for building programs which use the Berkeley DB in SQL.
187
188%if %{with java}
189%package java
190Summary: The Berkeley DB library for Java
191Summary(ja): Java 用 Berkeley DB データベースライブラリ
192Group: System Environment/Libraries
193Requires: %{name}%{?_isa} = %{version}-%{release}
194
195%description java
196The Berkeley Database (Berkeley DB) is a programmatic toolkit that
197provides embedded database support for both traditional and
198client/server applications. This package contains the libraries
199for building programs which use the Berkeley DB in Java.
200
201%package java-devel
202Summary: Development files for using the Berkeley DB with Java
203Summary(ja): Java で Berkeley DB を利用するための開発ファイル
204Group: Development/Libraries
205Requires: %{name}-java%{?_isa} = %{version}-%{release}
206
207%description java-devel
208The Berkeley Database (Berkeley DB) is a programmatic toolkit that
209provides embedded database support for both traditional and
210client/server applications. This package contains the libraries
211for building programs which use the Berkeley DB in Java.
212%endif
213
214%prep
215%setup -q -n db-%{version} -a 1
216cp %{SOURCE2} .
217
218%patch0 -p1 -b .multiarch
219pushd db.1.85/PORT/linux
220%patch10 -p0 -b .1.1
221popd
222pushd db.1.85
223%patch11 -p0 -b .1.2
224%patch12 -p0 -b .1.3
225%patch13 -p0 -b .1.4
226%patch20 -p1 -b .errno
227popd
228
229%patch22 -p1 -b .185compat
230%patch24 -p1 -b .4.5.20.jni
231%patch25 -p1 -b .licensefix
232
233cd dist
234./s_config
235cd ..
236
237%build
238CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
239CFLAGS="$CFLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
240export CFLAGS
241
242# Build the old db-185 libraries.
243make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
244
245test -d dist/dist-tls || mkdir dist/dist-tls
246# Static link db_dump185 with old db-185 libraries.
247/bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
248/bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
249
250# Update config files to understand aarch64
251#for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
252#  cp /usr/lib/rpm/config.{guess,sub} "$dir"
253#done
254
255pushd dist/dist-tls
256%define _configure ../configure
257%configure -C \
258        --enable-compat185 \
259        --enable-dump185 \
260        --enable-shared \
261        --enable-static \
262        --enable-tcl \
263        --with-tcl=%{_libdir} \
264        --enable-cxx \
265        --enable-sql \
266        --enable-test \
267        --disable-rpath \
268        --with-tcl=%{_libdir}/tcl8.5 \
269%if %{with java}
270        --enable-java
271%endif
272
273# Remove libtool predep_objects and postdep_objects wonkiness so that
274# building without -nostdlib doesn't include them twice.  Because we
275# already link with g++, weird stuff happens if you don't let the
276# compiler handle this.
277perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
278perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
279perl -pi -e 's/-shared -nostdlib/-shared/' libtool
280
281make %{?_smp_mflags}
282
283%if %{with java}
284# XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
285LDBJ=./.libs/libdb_java-%{__soversion}.la
286if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
287        sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
288fi
289%endif
290
291popd
292
293%install
294rm -rf ${RPM_BUILD_ROOT}
295mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
296mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
297
298%makeinstall STRIP=/bin/true -C dist/dist-tls
299
300# XXX Nuke non-versioned archives and symlinks
301rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
302
303chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
304
305# Move the header files to a subdirectory, in case we're deploying on a
306# system with multiple versions of DB installed.
307mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
308mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
309
310# Create symlinks to includes so that "use <db.h> and link with -ldb" works.
311for i in db.h db_cxx.h db_185.h; do
312        ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
313done
314
315%if %{with java}
316# Move java jar file to the correct place
317mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
318mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
319%endif
320
321# Eliminate installed doco
322rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
323
324# XXX Avoid Permission denied. strip when building as non-root.
325chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
326
327# remove unneeded .la files (#225675)
328rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
329
330# remove RPATHs
331#chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
332
333# unify documentation and examples, remove stuff we don't need
334rm -rf docs/csharp
335rm -rf examples/csharp
336rm -rf docs/installation
337mv examples docs
338
339%clean
340rm -rf ${RPM_BUILD_ROOT}
341
342%post
343/sbin/ldconfig
344
345%postun
346/sbin/ldconfig
347
348%post cxx
349/sbin/ldconfig
350
351%postun cxx
352/sbin/ldconfig
353
354%post sql
355/sbin/ldconfig
356
357%postun sql
358/sbin/ldconfig
359
360%post tcl
361/sbin/ldconfig
362
363%postun tcl
364/sbin/ldconfig
365
366%if %{with java}
367%post java
368/sbin/ldconfig
369
370%postun java
371/sbin/ldconfig
372
373%endif
374
375%files
376%defattr(-,root,root,-)
377%doc LICENSE README lgpl-2.1.txt
378%{_libdir}/libdb-%{__soversion}.so
379%{_libdir}/libdb-%{__soversion_major}.so
380
381%files devel
382%defattr(-,root,root,-)
383%{_libdir}/libdb.so
384%dir %{_includedir}/%{name}
385%{_includedir}/%{name}/db.h
386%{_includedir}/%{name}/db_185.h
387%{_includedir}/db.h
388%{_includedir}/db_185.h
389
390%files devel-doc
391%defattr(-,root,root,-)
392%doc    docs/*
393
394%files devel-static
395%defattr(-,root,root,-)
396%{_libdir}/libdb-%{__soversion}.a
397%{_libdir}/libdb_cxx-%{__soversion}.a
398%{_libdir}/libdb_tcl-%{__soversion}.a
399%{_libdir}/libdb_sql-%{__soversion}.a
400%if %{with java}
401%{_libdir}/libdb_java-%{__soversion}.a
402%endif
403
404%files utils
405%defattr(-,root,root,-)
406%{_bindir}/db*_archive
407%{_bindir}/db*_checkpoint
408%{_bindir}/db*_deadlock
409%{_bindir}/db*_dump*
410%{_bindir}/db*_hotbackup
411%{_bindir}/db*_load
412%{_bindir}/db*_printlog
413%{_bindir}/db*_recover
414%{_bindir}/db*_replicate
415%{_bindir}/db*_stat
416%{_bindir}/db*_upgrade
417%{_bindir}/db*_verify
418%{_bindir}/db*_tuner
419
420%files cxx
421%defattr(-,root,root,-)
422%{_libdir}/libdb_cxx-%{__soversion}.so
423%{_libdir}/libdb_cxx-%{__soversion_major}.so
424
425%files cxx-devel
426%defattr(-,root,root,-)
427%{_includedir}/%{name}/db_cxx.h
428%{_includedir}/db_cxx.h
429%{_libdir}/libdb_cxx.so
430
431%files tcl
432%defattr(-,root,root,-)
433%{_libdir}/libdb_tcl-%{__soversion}.so
434%{_libdir}/libdb_tcl-%{__soversion_major}.so
435
436%files tcl-devel
437%defattr(-,root,root,-)
438%{_libdir}/libdb_tcl.so
439
440%files sql
441%defattr(-,root,root,-)
442%{_libdir}/libdb_sql-%{__soversion}.so
443%{_libdir}/libdb_sql-%{__soversion_major}.so
444
445%files sql-devel
446%defattr(-,root,root,-)
447%{_bindir}/dbsql
448%{_libdir}/libdb_sql.so
449%{_includedir}/%{name}/dbsql.h
450
451%if %{with java}
452%files java
453%defattr(-,root,root,-)
454%{_libdir}/libdb_java-%{__soversion_major}*.so
455%{_datadir}/java/*.jar
456
457%files java-devel
458%defattr(-,root,root,-)
459%{_libdir}/libdb_java.so
460%endif
461
462%changelog
463* Sat Nov  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-7
464- updated Summary and Group
465
466* Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-6
467- added "Provides: db4-{utils,devel}".
468
469* Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
470- initial build for Vine Linux.
471
472* Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
473- Add some of the previous aarch64 bits back as the sub configure don't use the macro
474
475* Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
476- Fix configure macro usage for better aarch64 build fix
477
478* Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
479- Updated config files to allow build on aarch64 (#1022970)
480
481* Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
482- Added Sleepycat to the license list (#1013841)
483- Updated to 5.3.28 (#1013233)
484
485* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
486- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
487
488* Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
489- add copy of lgpl-2.1.txt
490
491* Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
492- Fix missing debuginfo issue for utils subpackage
493
494* Thu May  9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
495- add license clarification fix
496
497* Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
498- Added sqlite compability CFLAGS (#788496)
499
500* Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
501- Cleaning the specfile - removed gcc-java dependecy other way
502
503* Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
504- Removed dependency on obsolete gcc-java package (#927742)
505
506* Thu Mar  7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
507- add LGPLv2+ and remove Sleepycat in license tag (#886838)
508
509* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
510- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
511
512* Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
513- fix license tag
514
515* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
516- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
517
518* Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
519- Specify tag for libtool (fixes FTBFS # 838334 )
520
521* Thu Jul  5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
522- update to 5.3.21
523http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
524
525* Tue Jul  3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
526- move C++ header files to cxx-devel
527
528* Tue Jul  3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
529- fix -devel packages dependencies yet more (#832225)
530
531* Sun May  6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
532- package -devel packages correctly
533
534* Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
535- fix multiarch conflict in libdb-devel (#812901)
536- remove unneeded dos2unix BR
537
538* Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
539- update to 5.3.15
540  http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
541
542* Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
543- Resolves rhbz#794472
544- Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
545
546* Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
547- add filesystem guard
548
549* Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
550- install everything in /usr
551  https://fedoraproject.org/wiki/Features/UsrMove
552
553* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
554- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
555
556* Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
557- update to 5.2.36,
558  http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
559
560* Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
561- move development documentation to devel-doc subpackage (#705386)
562
563* Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
564- update to 5.2.28
565
566* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
567- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
568
569* Thu Feb  3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
570- update to 5.1.25
571
572* Wed Sep 29 2010 jkeating - 5.1.19-2
573- Rebuilt for gcc bug 634757
574
575* Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
576- update to 5.1.19
577- rename -devel-static to -static subpackage (#617800)
578- build java on all arches
579
580* Wed Jul  7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
581- update to 5.0.26
582- drop BR: ed
583
584* Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
585- add Requires: libdb-cxx to libdb-devel
586
587* Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
588- initial build
589
590* Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
591- remove C# documentation
592- disable/remove rpath
593- fix description
594- tighten dependencies
595- run ldconfig for cxx and sql subpackages
596
597* Fri Apr  9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
598- enable sql
599- package 5.0.21
Note: See TracBrowser for help on using the repository browser.