source: projects/specs/trunk/lib/libc/libcap-ng/libcap-ng-vl.spec @ 12372

Revision 12372, 7.6 KB checked in by tomop, 4 years ago (diff)

updated 14 packages

acpica-tools-20190509-1

ethtool-5.4-1

flac-1.3.3-1

iproute-5.6.0-1

libcap-ng-0.7.10-1

libestr-0.1.11-2

libfastjson-0.99.8-4

libproxy-0.4.15-2

libpwquality-1.4.2-1

libunistring-0.9.10-2

mdadm-4.1-1

python-six-1.14.0-1

rsyslog-8.2002.0-1

speexdsp-1.2-0.16.rc3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Summary:        An alternate posix capabilities library
5Name:           libcap-ng
6Version:        0.7.10
7Release:        1%{?_dist_release}
8Group:          System Environment/Libraries
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        LGPLv2+
13URL:            http://people.redhat.com/sgrubb/libcap-ng/
14Source0:        http://people.redhat.com/sgrubb/libcap-ng/%{name}-%{version}.tar.gz
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16BuildRequires:  kernel-headers >= 2.6.11
17BuildRequires:  libattr-devel
18
19
20%description
21Libcap-ng is a library that makes using posix capabilities easier
22
23%package        devel
24Summary:        Header files for libcap-ng library
25License:        LGPLv2+
26Group:          Development/Libraries
27Requires:       kernel-headers >= 2.6.11
28Requires:       %{name} = %{version}-%{release}
29Requires:       pkgconfig
30
31%description    devel
32The libcap-ng-devel package contains the files needed for developing
33applications that need to use the libcap-ng library.
34
35%package        python
36Summary:        Python bindings for libcap-ng library
37License:        LGPLv2+
38Group:          Development/Libraries
39BuildRequires:  python-devel swig
40BuildRequires:  python-rpm-macros
41Requires:       %{name} = %{version}-%{release}
42
43%description    python
44The libcap-ng-python package contains the bindings so that libcap-ng
45and can be used by python applications.
46
47%package        python3
48Summary:        Python3 bindings for libcap-ng library
49License:        LGPLv2+
50Group:          Development/Libraries
51BuildRequires:  python3-devel swig
52BuildRequires:  python3-rpm-macros
53Requires:       %{name} = %{version}-%{release}
54
55%description    python3
56The libcap-ng-python3 package contains the bindings so that libcap-ng
57and can be used by python3 applications.
58
59%package        utils
60Summary:        Utilities for analysing and setting file capabilities
61License:        GPLv2+
62Group:          Development/Libraries
63Requires:       %{name} = %{version}-%{release}
64
65%description    utils
66The libcap-ng-utils package contains applications to analyse the
67posix capabilities of all the program running on a system. It also
68lets you set the file system based capabilities.
69
70%package -n     compat32-%{name}
71Summary:        An alternate posix capabilities library
72Requires:       %{name} = %{version}-%{release}
73
74%description -n compat32-%{name}
75Libcap-ng is a library that makes using posix capabilities easier
76
77%package -n     compat32-%{name}-devel
78Summary:        Header files for libcap-ng library
79License:        LGPLv2+
80Group:          Development/Libraries
81Requires:       %{name}-devel = %{version}-%{release}
82
83%description -n compat32-%{name}-devel
84The libcap-ng-devel package contains the files needed for developing
85applications that need to use the libcap-ng library.
86
87
88%prep
89%setup -q
90
91%build
92%configure --libdir=/%{_lib} --with-python --with-python3
93make %{?_smp_mflags}
94
95%install
96rm -rf $RPM_BUILD_ROOT
97make DESTDIR="${RPM_BUILD_ROOT}" install
98
99# Move the symlink
100rm -f $RPM_BUILD_ROOT/%{_lib}/%{name}.so
101mkdir -p $RPM_BUILD_ROOT%{_libdir}
102VLIBNAME=$(ls $RPM_BUILD_ROOT/%{_lib}/%{name}.so.*.*.*)
103LIBNAME=$(basename $VLIBNAME)
104ln -s ../../%{_lib}/$LIBNAME $RPM_BUILD_ROOT%{_libdir}/%{name}.so
105
106# Move the pkgconfig file
107mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
108
109# Remove a couple things so they don't get picked up
110rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.la
111rm -f $RPM_BUILD_ROOT/%{_lib}/libcap-ng.a
112rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.a
113rm -f $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages/_capng.la
114
115%check
116make check
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123
124%post -n compat32-%{name} -p /sbin/ldconfig
125%postun -n compat32-%{name} -p /sbin/ldconfig
126
127%files
128%defattr(-,root,root,-)
129%license COPYING.LIB
130%attr(0755,root,root) /%{_lib}/libcap-ng.so.*
131
132%files devel
133%defattr(-,root,root,-)
134%attr(0644,root,root) %{_mandir}/man3/*
135%attr(0644,root,root) %{_includedir}/cap-ng.h
136%attr(0755,root,root) %{_libdir}/libcap-ng.so
137%attr(0644,root,root) %{_datadir}/aclocal/cap-ng.m4
138%{_libdir}/pkgconfig/libcap-ng.pc
139
140%files python
141%defattr(-,root,root,-)
142%attr(755,root,root) /%{_libdir}/python?.?/site-packages/_capng.so
143%{python_sitearch}/capng.py*
144
145%files python3
146%defattr(-,root,root,-)
147%attr(755,root,root) %{python3_sitearch}/*
148%{python3_sitearch}/capng.py*
149
150%files utils
151%defattr(-,root,root,-)
152%doc COPYING
153%attr(0755,root,root) %{_bindir}/*
154%attr(0644,root,root) %{_mandir}/man8/*
155
156%if %{build_compat32}
157%files -n compat32-%{name}
158%defattr(-,root,root,-)
159%attr(0755,root,root) /%{_lib}/libcap-ng.so.*
160
161%files -n compat32-%{name}-devel
162%defattr(-,root,root,-)
163%attr(0755,root,root) %{_libdir}/libcap-ng.so
164%{_libdir}/pkgconfig/libcap-ng.pc
165%endif
166
167%changelog
168* Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.7.10-1
169- new upstream release.
170
171* Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.7.9-1
172- new upstream release.
173- added compat32-* packages.
174- enabled python3 modules.
175
176* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
177- rebuild with VineSeed environment
178
179* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-1
180- new upstream release
181
182* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.1-1
183- new upstream release
184
185* Mon Feb 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-2
186- rebuild with python-2.7.2
187
188* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-1
189- initial build for Vine Linux
190
191
192* Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 0.6.6-1
193- New upstream release
194
195* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.5-2
196- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
197
198* Wed Nov 03 2010 Steve Grubb <sgrubb@redhat.com> 0.6.5-1
199- New upstream release fixing 2.6.36 kernel header issue
200
201* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.4-4
202- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
203
204* Thu Jun 17 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-3
205- Only open regular files in filecap
206
207* Mon May 24 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-2
208- In utils subpackage added a requires statement.
209
210* Thu May 06 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-1
211- New upstream release fixing multi-threading issue
212
213* Wed Apr 28 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-2
214- filecap shows full capabilities if a file has any
215
216* Thu Mar 11 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-1
217- New upstream release
218
219* Tue Feb 16 2010 Steve Grubb <sgrubb@redhat.com> 0.6.2-4
220- Use global macro and require pkgconfig for devel subpackage
221
222* Fri Oct 09 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-3
223- Apply patch to retain setpcap only if clearing bounding set
224
225* Sat Oct 03 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-2
226- Apply patch correcting pscap and netcap acct detection
227
228* Mon Sep 28 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-1
229- New upstream release
230
231* Sun Jul 26 2009 Steve Grubb <sgrubb@redhat.com> 0.6.1-1
232- New upstream release
233
234* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-2
235- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
236
237* Mon Jun 29 2009 Steve Grubb <sgrubb@redhat.com> 0.6-1
238- New upstream release
239
240* Sun Jun 21 2009 Steve Grubb <sgrubb@redhat.com> 0.5.1-1
241- New upstream release
242
243* Fri Jun 19 2009 Steve Grubb <sgrubb@redhat.com> 0.5-1
244- New upstream release
245
246* Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.2-1
247- New upstream release
248
249* Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.1-1
250- Initial build.
251
Note: See TracBrowser for help on using the repository browser.