source: projects/specs/trunk/lib/libX/libXp/libXp-vl.spec @ 8064

Revision 8064, 9.1 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1# libXp will be removed from future release.
2%define without_devel   0
3
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5
6Summary: X.Org X11 libXp runtime library
7Summary(ja): X.Org X11 libXp ランタイムライブラリ
8Name: libXp
9Version: 1.0.2
10Release: 2%{?_dist_release}
11License: MIT/X11
12Group: System Environment/Libraries
13URL: http://www.x.org
14
15Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
16Patch0: libXp-1.0.2-add-proto-files.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pkgconfig
20BuildRequires: xorg-x11-util-macros
21BuildRequires: xorg-x11-proto-devel
22BuildRequires: libX11-devel
23BuildRequires: libXext-devel
24BuildRequires: libXau-devel
25BuildRequires: libtool automake autoconf gettext
26Obsoletes: XFree86-libs, XOrg-libs
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: Takemikaduchi
31
32%description
33X.Org X11 libXp runtime library
34
35%package devel
36Summary: X.Org X11 libXp development package
37Summary(ja): X.Org X11 libXp 開発パッケージ
38Group: Development/Libraries
39Requires(pre): xorg-x11-filesystem
40Requires: libXau-devel
41Requires: libXext-devel
42Requires: %{name} = %{version}-%{release}
43BuildRequires: xorg-x11-proto-devel
44Obsoletes: XFree86-devel, XOrg-devel
45
46%description devel
47X.Org X11 libXp development package
48
49# compat32
50%package -n compat32-%{name}
51Summary: X.Org X11 libXp runtime library
52Summary(ja): X.Org X11 libXp ランタイムライブラリ
53Group: System Environment/Libraries
54Requires: %{name} = %{version}-%{release}
55
56%description -n compat32-%{name}
57X.Org X11 libXp runtime library
58
59%package -n compat32-%{name}-devel
60Summary: X.Org X11 libXp development package
61Summary(ja): X.Org X11 libXp 開発パッケージ
62Group: Development/Libraries
63Requires(pre): xorg-x11-filesystem
64Requires: %{name}-devel = %{version}-%{release}
65Requires: compat32-%{name} = %{version}-%{release}
66Requires: compat32-libXau-devel
67
68%description -n compat32-%{name}-devel
69X.Org X11 libXp development package
70
71%prep
72%setup -q
73
74%patch0 -p1 -b .add-proto-files
75
76# Disable static library creation by default.
77%define with_static 0
78
79%build
80
81# There is a patch that changes configure.ac, so we have
82# run autoreconf
83
84autoreconf -if
85CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
86export CPPFLAGS
87
88autoreconf -v --install
89
90%configure \
91%if ! %{with_static}
92        --disable-static
93%endif
94make
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99make install DESTDIR=$RPM_BUILD_ROOT
100
101%if %{without_devel}
102{
103   rm -f $RPM_BUILD_ROOT%{_libdir}/libXp.a
104   rm -f $RPM_BUILD_ROOT%{_libdir}/libXp.so
105   rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
106   rm -rf $RPM_BUILD_ROOT%{_mandir}
107}
108%endif
109
110# Don't encourage people to use the deprecated Xprint APIs.
111rm -rf $RPM_BUILD_ROOT%{_mandir}
112
113# We intentionally don't ship *.la files
114rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
122%post -n compat32-%{name} -p /sbin/ldconfig
123%postun -n compat32-%{name} -p /sbin/ldconfig
124
125%files
126%defattr(-,root,root,-)
127%doc AUTHORS COPYING README INSTALL ChangeLog
128%{_libdir}/libXp.so.6
129%{_libdir}/libXp.so.6.2.0
130
131%if ! %{without_devel}
132%files devel
133%defattr(-,root,root,-)
134%if %{with_static}
135%{_libdir}/libXp.a
136%endif
137%{_includedir}/X11/extensions/Print.h
138%{_includedir}/X11/extensions/Printstr.h
139%{_libdir}/pkgconfig/printproto.pc
140# FIXME: Should we remove the shared lib during deprecation, so that things
141# that keep linking to libXp, will always get the static lib and not break
142# when we eventually drop libXp?
143%{_libdir}/libXp.so
144%{_libdir}/pkgconfig/xp.pc
145#%dir %{_mandir}/man3x
146#%{_mandir}/man3/*.3x*
147%endif
148
149# compat32
150%if %{build_compat32}
151%files -n compat32-%{name}
152%defattr(-,root,root,-)
153%{_libdir}/libXp.so.6
154%{_libdir}/libXp.so.6.2.0
155
156%if ! %{without_devel}
157%files -n compat32-%{name}-devel
158%defattr(-,root,root,-)
159%if %{with_static}
160%{_libdir}/libXp.a
161%endif
162# FIXME: Should we remove the shared lib during deprecation, so that things
163# that keep linking to libXp, will always get the static lib and not break
164# when we eventually drop libXp?
165%{_libdir}/libXp.so
166%endif
167%endif
168
169%changelog
170* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
171- rebuild with VineSeed environment
172
173* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
174- new upstream release
175  (including security fix for CVE-2013-2062)
176- update Patch0 (libXp-1.0.2-add-proto-files.patch)
177
178* Sat Jan 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
179- new upstream release
180- update Patch0 (libXp-1.0.1-add-proto-files.patch)
181- add Requires: libXext-devel (devel package)
182
183* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-4
184- rebuild with rpm-4.8.1 for pkg-config file
185
186* Mon Jul 20 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.0-3
187- added compat32 package for x86_64 arch support
188
189* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
190- spec in utf-8
191
192* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
193- new versioning policy
194
195* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
196- initial build for Vine Linux
197
198* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.0-8
199- Rebuild for build id
200
201* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-8
202- rebuilt for unwind info generation, broken in gcc-4.1.1-21
203
204* Wed Sep 20 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0.7
205- Add requires for the devel package on libXau-devel (173530)
206
207* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
208- Add the proto files directly instead of attempting to build a separate
209  tarball. Also remove last traces of printproto-1.0.3.tar.gz
210
211* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com>
212- Remove printproto source.
213
214* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
215- BuildRequire autoconf automake libtool gettext
216
217* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
218- Run autoreconf to make sure changes to configure.ac take effect
219
220* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
221- Add patch to not check for printproto.pc. (Since it's part of this
222  package now, it isn't installed at the time libXp is configured).
223
224* Thu Aug 17 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-5
225- Moved Print.h, Printstr.h and printproto.pc into the devel package here
226  (they used to be in xorg-x11-proto-devel).
227
228* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
229- rebuild
230
231* Mon Jul 10 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-4
232- Renamed libXp_deprecated rpm macro to "with_devel" to avoid confusion.  This
233  library is still deprecated, we just decided to remove the word "deprecated"
234  from the package name for library naming consistency.
235
236* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-3
237- Replace "makeinstall" with "make install DESTDIR=..."
238- Added "Requires: xorg-x11-proto-devel" to devel for xp.pc
239- Remove package ownership of mandir/libdir/etc.
240
241* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
242- bump again for double-long bug on ppc(64)
243
244* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
245- rebuilt for new gcc4.1 snapshot and glibc changes
246
247* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
248- Bumped and rebuilt
249
250* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
251- Updated libXp to version 1.0.0 from X11R7 RC4
252
253* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
254- Updated libXp to version 0.99.2 from X11R7 RC3
255- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
256  that /usr/lib/X11 and /usr/include/X11 pre-exist.
257- Removed 'x' suffix from manpage directories to match RC3 upstream.
258
259* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
260- rebuilt
261
262* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-3
263- Added "Obsoletes: xorg-x11-deprecated-libs" to runtime package, and
264  "Obsoletes: xorg-x11-deprecated-libs-devel" to devel package.
265
266* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
267- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
268- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
269
270* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
271- Updated libXp to version 0.99.1 from X11R7 RC1
272
273* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
274- Renamed package to remove xorg-x11 from the name due to unanimous decision
275  between developers.
276- Use Fedora Extras style BuildRoot tag.
277- Disable static library creation by default.
278- Add missing defattr to devel subpackage
279- Add missing documentation files to doc macro
280
281* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
282- Renamed package to prepend "xorg-x11" to the name for consistency with
283  the rest of the X11R7 packages.
284- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
285  subpackage to ensure the devel package matches the installed shared libs.
286- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
287  allow applications to use implementation agnostic dependencies.
288- Added post/postun scripts which call ldconfig.
289- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
290  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
291
292* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
293- Initial build.
Note: See TracBrowser for help on using the repository browser.