source: projects/specs/trunk/lib/libX/libXp/libXp-vl.spec @ 7707

Revision 7707, 9.0 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1# libXp will be removed from future release.
2%define without_devel   0
3
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5
6Summary: X.Org X11 libXp runtime library
7Summary(ja): X.Org X11 libXp ランタイムライブラリ
8Name: libXp
9Version: 1.0.2
10Release: 1%{?_dist_release}
11License: MIT/X11
12Group: System Environment/Libraries
13URL: http://www.x.org
14
15Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
16Patch0: libXp-1.0.2-add-proto-files.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pkgconfig
20BuildRequires: xorg-x11-util-macros
21BuildRequires: xorg-x11-proto-devel
22BuildRequires: libX11-devel
23BuildRequires: libXext-devel
24BuildRequires: libXau-devel
25BuildRequires: libtool automake autoconf gettext
26Obsoletes: XFree86-libs, XOrg-libs
27
28%description
29X.Org X11 libXp runtime library
30
31%package devel
32Summary: X.Org X11 libXp development package
33Summary(ja): X.Org X11 libXp 開発パッケージ
34Group: Development/Libraries
35Requires(pre): xorg-x11-filesystem
36Requires: libXau-devel
37Requires: libXext-devel
38Requires: %{name} = %{version}-%{release}
39BuildRequires: xorg-x11-proto-devel
40Obsoletes: XFree86-devel, XOrg-devel
41
42%description devel
43X.Org X11 libXp development package
44
45# compat32
46%package -n compat32-%{name}
47Summary: X.Org X11 libXp runtime library
48Summary(ja): X.Org X11 libXp ランタイムライブラリ
49Group: System Environment/Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description -n compat32-%{name}
53X.Org X11 libXp runtime library
54
55%package -n compat32-%{name}-devel
56Summary: X.Org X11 libXp development package
57Summary(ja): X.Org X11 libXp 開発パッケージ
58Group: Development/Libraries
59Requires(pre): xorg-x11-filesystem
60Requires: %{name}-devel = %{version}-%{release}
61Requires: compat32-%{name} = %{version}-%{release}
62Requires: compat32-libXau-devel
63
64%description -n compat32-%{name}-devel
65X.Org X11 libXp development package
66
67%prep
68%setup -q
69
70%patch0 -p1 -b .add-proto-files
71
72# Disable static library creation by default.
73%define with_static 0
74
75%build
76
77# There is a patch that changes configure.ac, so we have
78# run autoreconf
79
80autoreconf -if
81CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
82export CPPFLAGS
83
84autoreconf -v --install
85
86%configure \
87%if ! %{with_static}
88        --disable-static
89%endif
90make
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95make install DESTDIR=$RPM_BUILD_ROOT
96
97%if %{without_devel}
98{
99   rm -f $RPM_BUILD_ROOT%{_libdir}/libXp.a
100   rm -f $RPM_BUILD_ROOT%{_libdir}/libXp.so
101   rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
102   rm -rf $RPM_BUILD_ROOT%{_mandir}
103}
104%endif
105
106# Don't encourage people to use the deprecated Xprint APIs.
107rm -rf $RPM_BUILD_ROOT%{_mandir}
108
109# We intentionally don't ship *.la files
110rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post -p /sbin/ldconfig
116%postun -p /sbin/ldconfig
117
118%post -n compat32-%{name} -p /sbin/ldconfig
119%postun -n compat32-%{name} -p /sbin/ldconfig
120
121%files
122%defattr(-,root,root,-)
123%doc AUTHORS COPYING README INSTALL ChangeLog
124%{_libdir}/libXp.so.6
125%{_libdir}/libXp.so.6.2.0
126
127%if ! %{without_devel}
128%files devel
129%defattr(-,root,root,-)
130%if %{with_static}
131%{_libdir}/libXp.a
132%endif
133%{_includedir}/X11/extensions/Print.h
134%{_includedir}/X11/extensions/Printstr.h
135%{_libdir}/pkgconfig/printproto.pc
136# FIXME: Should we remove the shared lib during deprecation, so that things
137# that keep linking to libXp, will always get the static lib and not break
138# when we eventually drop libXp?
139%{_libdir}/libXp.so
140%{_libdir}/pkgconfig/xp.pc
141#%dir %{_mandir}/man3x
142#%{_mandir}/man3/*.3x*
143%endif
144
145# compat32
146%if %{build_compat32}
147%files -n compat32-%{name}
148%defattr(-,root,root,-)
149%{_libdir}/libXp.so.6
150%{_libdir}/libXp.so.6.2.0
151
152%if ! %{without_devel}
153%files -n compat32-%{name}-devel
154%defattr(-,root,root,-)
155%if %{with_static}
156%{_libdir}/libXp.a
157%endif
158%{_libdir}/pkgconfig/printproto.pc
159# FIXME: Should we remove the shared lib during deprecation, so that things
160# that keep linking to libXp, will always get the static lib and not break
161# when we eventually drop libXp?
162%{_libdir}/libXp.so
163%{_libdir}/pkgconfig/xp.pc
164%endif
165%endif
166
167%changelog
168* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
169- new upstream release
170  (including security fix for CVE-2013-2062)
171- update Patch0 (libXp-1.0.2-add-proto-files.patch)
172
173* Sat Jan 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
174- new upstream release
175- update Patch0 (libXp-1.0.1-add-proto-files.patch)
176- add Requires: libXext-devel (devel package)
177
178* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-4
179- rebuild with rpm-4.8.1 for pkg-config file
180
181* Mon Jul 20 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.0-3
182- added compat32 package for x86_64 arch support
183
184* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
185- spec in utf-8
186
187* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
188- new versioning policy
189
190* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
191- initial build for Vine Linux
192
193* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.0-8
194- Rebuild for build id
195
196* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-8
197- rebuilt for unwind info generation, broken in gcc-4.1.1-21
198
199* Wed Sep 20 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0.7
200- Add requires for the devel package on libXau-devel (173530)
201
202* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
203- Add the proto files directly instead of attempting to build a separate
204  tarball. Also remove last traces of printproto-1.0.3.tar.gz
205
206* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com>
207- Remove printproto source.
208
209* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
210- BuildRequire autoconf automake libtool gettext
211
212* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
213- Run autoreconf to make sure changes to configure.ac take effect
214
215* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
216- Add patch to not check for printproto.pc. (Since it's part of this
217  package now, it isn't installed at the time libXp is configured).
218
219* Thu Aug 17 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-5
220- Moved Print.h, Printstr.h and printproto.pc into the devel package here
221  (they used to be in xorg-x11-proto-devel).
222
223* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
224- rebuild
225
226* Mon Jul 10 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-4
227- Renamed libXp_deprecated rpm macro to "with_devel" to avoid confusion.  This
228  library is still deprecated, we just decided to remove the word "deprecated"
229  from the package name for library naming consistency.
230
231* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-3
232- Replace "makeinstall" with "make install DESTDIR=..."
233- Added "Requires: xorg-x11-proto-devel" to devel for xp.pc
234- Remove package ownership of mandir/libdir/etc.
235
236* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
237- bump again for double-long bug on ppc(64)
238
239* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
240- rebuilt for new gcc4.1 snapshot and glibc changes
241
242* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
243- Bumped and rebuilt
244
245* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
246- Updated libXp to version 1.0.0 from X11R7 RC4
247
248* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
249- Updated libXp to version 0.99.2 from X11R7 RC3
250- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
251  that /usr/lib/X11 and /usr/include/X11 pre-exist.
252- Removed 'x' suffix from manpage directories to match RC3 upstream.
253
254* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
255- rebuilt
256
257* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-3
258- Added "Obsoletes: xorg-x11-deprecated-libs" to runtime package, and
259  "Obsoletes: xorg-x11-deprecated-libs-devel" to devel package.
260
261* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
262- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
263- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
264
265* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
266- Updated libXp to version 0.99.1 from X11R7 RC1
267
268* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
269- Renamed package to remove xorg-x11 from the name due to unanimous decision
270  between developers.
271- Use Fedora Extras style BuildRoot tag.
272- Disable static library creation by default.
273- Add missing defattr to devel subpackage
274- Add missing documentation files to doc macro
275
276* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
277- Renamed package to prepend "xorg-x11" to the name for consistency with
278  the rest of the X11R7 packages.
279- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
280  subpackage to ensure the devel package matches the installed shared libs.
281- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
282  allow applications to use implementation agnostic dependencies.
283- Added post/postun scripts which call ldconfig.
284- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
285  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
286
287* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
288- Initial build.
Note: See TracBrowser for help on using the repository browser.