source: projects/specs/trunk/lib/libX/libXp/libXp-vl.spec @ 12185

Revision 12185, 9.3 KB checked in by tomop, 5 years ago (diff)

updated X11 libs

Line 
1# libXp will be removed from future release.
2%define without_devel   0
3
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5
6Summary: X.Org X11 libXp runtime library
7Summary(ja): X.Org X11 libXp ランタイムライブラリ
8Name: libXp
9Version: 1.0.3
10Release: 2%{?_dist_release}
11License: MIT/X11
12Group: System Environment/Libraries
13URL: http://www.x.org
14
15Source0: ftp://ftp.x.org/pub/individual/lib/%{name}-%{version}.tar.bz2
16Patch0: libXp-1.0.3-add-proto-files.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pkgconfig
20BuildRequires: xorg-x11-util-macros
21BuildRequires: xorg-x11-proto-devel
22BuildRequires: libX11-devel
23BuildRequires: libXext-devel
24BuildRequires: libXau-devel
25BuildRequires: libtool automake autoconf gettext
26Obsoletes: XFree86-libs, XOrg-libs
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32X.Org X11 libXp runtime library
33
34%package devel
35Summary: X.Org X11 libXp development package
36Summary(ja): X.Org X11 libXp 開発パッケージ
37Group: Development/Libraries
38Requires(pre): xorg-x11-filesystem
39Requires: libXau-devel
40Requires: libXext-devel
41Requires: %{name} = %{version}-%{release}
42BuildRequires: xorg-x11-proto-devel
43Obsoletes: XFree86-devel, XOrg-devel
44
45%description devel
46X.Org X11 libXp development package
47
48# compat32
49%package -n compat32-%{name}
50Summary: X.Org X11 libXp runtime library
51Summary(ja): X.Org X11 libXp ランタイムライブラリ
52Group: System Environment/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description -n compat32-%{name}
56X.Org X11 libXp runtime library
57
58%package -n compat32-%{name}-devel
59Summary: X.Org X11 libXp development package
60Summary(ja): X.Org X11 libXp 開発パッケージ
61Group: Development/Libraries
62Requires(pre): xorg-x11-filesystem
63Requires: %{name}-devel = %{version}-%{release}
64Requires: compat32-%{name} = %{version}-%{release}
65Requires: compat32-libXau-devel
66
67%description -n compat32-%{name}-devel
68X.Org X11 libXp development package
69
70%prep
71%setup -q
72
73%patch0 -p1 -b .add-proto-files
74
75# Disable static library creation by default.
76%define with_static 0
77
78%build
79
80# There is a patch that changes configure.ac, so we have
81# run autoreconf
82
83autoreconf -if
84CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
85export CPPFLAGS
86
87autoreconf -v --install
88
89%configure \
90%if ! %{with_static}
91        --disable-static
92%endif
93make
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98make install DESTDIR=$RPM_BUILD_ROOT
99
100%if %{without_devel}
101{
102   rm -f $RPM_BUILD_ROOT%{_libdir}/libXp.a
103   rm -f $RPM_BUILD_ROOT%{_libdir}/libXp.so
104   rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
105   rm -rf $RPM_BUILD_ROOT%{_mandir}
106}
107%endif
108
109# Don't encourage people to use the deprecated Xprint APIs.
110rm -rf $RPM_BUILD_ROOT%{_mandir}
111
112# We intentionally don't ship *.la files
113rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post -p /sbin/ldconfig
119%postun -p /sbin/ldconfig
120
121%post -n compat32-%{name} -p /sbin/ldconfig
122%postun -n compat32-%{name} -p /sbin/ldconfig
123
124%files
125%defattr(-,root,root,-)
126%license COPYING
127%doc AUTHORS README INSTALL ChangeLog
128%{_libdir}/libXp.so.6
129%{_libdir}/libXp.so.6.2.0
130
131%if ! %{without_devel}
132%files devel
133%defattr(-,root,root,-)
134%if %{with_static}
135%{_libdir}/libXp.a
136%endif
137%{_includedir}/X11/extensions/Print.h
138%{_includedir}/X11/extensions/Printstr.h
139%{_libdir}/pkgconfig/printproto.pc
140# FIXME: Should we remove the shared lib during deprecation, so that things
141# that keep linking to libXp, will always get the static lib and not break
142# when we eventually drop libXp?
143%{_libdir}/libXp.so
144%{_libdir}/pkgconfig/xp.pc
145#%dir %{_mandir}/man3x
146#%{_mandir}/man3/*.3x*
147%endif
148
149# compat32
150%if %{build_compat32}
151%files -n compat32-%{name}
152%defattr(-,root,root,-)
153%{_libdir}/libXp.so.6
154%{_libdir}/libXp.so.6.2.0
155
156%if ! %{without_devel}
157%files -n compat32-%{name}-devel
158%defattr(-,root,root,-)
159%if %{with_static}
160%{_libdir}/libXp.a
161%endif
162# FIXME: Should we remove the shared lib during deprecation, so that things
163# that keep linking to libXp, will always get the static lib and not break
164# when we eventually drop libXp?
165%{_libdir}/libXp.so
166%endif
167%endif
168
169%changelog
170* Fri Sep 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.3-2
171- rebuilt with current environment.
172
173* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
174- new upstream release
175- update Patch0 (libXp-1.0.3-add-proto-files.patch)
176
177* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
178- rebuild with VineSeed environment
179
180* Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
181- new upstream release
182  (including security fix for CVE-2013-2062)
183- update Patch0 (libXp-1.0.2-add-proto-files.patch)
184
185* Sat Jan 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
186- new upstream release
187- update Patch0 (libXp-1.0.1-add-proto-files.patch)
188- add Requires: libXext-devel (devel package)
189
190* Fri Sep 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-4
191- rebuild with rpm-4.8.1 for pkg-config file
192
193* Mon Jul 20 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.0-3
194- added compat32 package for x86_64 arch support
195
196* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
197- spec in utf-8
198
199* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
200- new versioning policy
201
202* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
203- initial build for Vine Linux
204
205* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.0-8
206- Rebuild for build id
207
208* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-8
209- rebuilt for unwind info generation, broken in gcc-4.1.1-21
210
211* Wed Sep 20 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0.7
212- Add requires for the devel package on libXau-devel (173530)
213
214* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
215- Add the proto files directly instead of attempting to build a separate
216  tarball. Also remove last traces of printproto-1.0.3.tar.gz
217
218* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com>
219- Remove printproto source.
220
221* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
222- BuildRequire autoconf automake libtool gettext
223
224* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
225- Run autoreconf to make sure changes to configure.ac take effect
226
227* Fri Aug 18 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-6
228- Add patch to not check for printproto.pc. (Since it's part of this
229  package now, it isn't installed at the time libXp is configured).
230
231* Thu Aug 17 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.0-5
232- Moved Print.h, Printstr.h and printproto.pc into the devel package here
233  (they used to be in xorg-x11-proto-devel).
234
235* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
236- rebuild
237
238* Mon Jul 10 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-4
239- Renamed libXp_deprecated rpm macro to "with_devel" to avoid confusion.  This
240  library is still deprecated, we just decided to remove the word "deprecated"
241  from the package name for library naming consistency.
242
243* Fri Jun 09 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-3
244- Replace "makeinstall" with "make install DESTDIR=..."
245- Added "Requires: xorg-x11-proto-devel" to devel for xp.pc
246- Remove package ownership of mandir/libdir/etc.
247
248* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.2
249- bump again for double-long bug on ppc(64)
250
251* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.0-2.1
252- rebuilt for new gcc4.1 snapshot and glibc changes
253
254* Mon Jan 23 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-2
255- Bumped and rebuilt
256
257* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
258- Updated libXp to version 1.0.0 from X11R7 RC4
259
260* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
261- Updated libXp to version 0.99.2 from X11R7 RC3
262- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", to ensure
263  that /usr/lib/X11 and /usr/include/X11 pre-exist.
264- Removed 'x' suffix from manpage directories to match RC3 upstream.
265
266* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
267- rebuilt
268
269* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-3
270- Added "Obsoletes: xorg-x11-deprecated-libs" to runtime package, and
271  "Obsoletes: xorg-x11-deprecated-libs-devel" to devel package.
272
273* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
274- Changed 'Conflicts: XFree86-devel, xorg-x11-devel' to 'Obsoletes'
275- Changed 'Conflicts: XFree86-libs, xorg-x11-libs' to 'Obsoletes'
276
277* Mon Oct 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
278- Updated libXp to version 0.99.1 from X11R7 RC1
279
280* Thu Sep 29 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-3
281- Renamed package to remove xorg-x11 from the name due to unanimous decision
282  between developers.
283- Use Fedora Extras style BuildRoot tag.
284- Disable static library creation by default.
285- Add missing defattr to devel subpackage
286- Add missing documentation files to doc macro
287
288* Tue Aug 23 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
289- Renamed package to prepend "xorg-x11" to the name for consistency with
290  the rest of the X11R7 packages.
291- Added "Requires: %%{name} = %%{version}-%%{release}" dependency to devel
292  subpackage to ensure the devel package matches the installed shared libs.
293- Added virtual "Provides: lib<name>" and "Provides: lib<name>-devel" to
294  allow applications to use implementation agnostic dependencies.
295- Added post/postun scripts which call ldconfig.
296- Added Conflicts with XFree86-libs and xorg-x11-libs to runtime package,
297  and Conflicts with XFree86-devel and xorg-x11-devel to devel package.
298
299* Mon Aug 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
300- Initial build.
Note: See TracBrowser for help on using the repository browser.