source: projects/specs/trunk/l/lyx/lyx-vl.spec @ 11364

Revision 11364, 9.3 KB checked in by ara_t, 6 years ago (diff)

lyx: update to 2.2.3

Line 
1%define _fontdir %{_datadir}/fonts/%{name}
2
3%define texmf           %{_datadir}/texmf
4%define build_texmf     %{buildroot}%{texmf}
5
6%define exec_texhash  [ -x %{_bindir}/texhash     ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
7
8Summary: WYSIWYM (What You See Is What You Mean) word processor with LaTeX output
9Summary(ja): LaTeX 形式で保存できるワードプロセッサ
10Name: lyx
11Version: 2.2.3
12Release: 1%{?_dist_release}
13License: GPLv2+
14Group: Applications/Editors
15URL: http://www.lyx.org/
16Source0: ftp://ftp.lyx.org/pub/lyx/stable/lyx-%{version}.tar.xz
17
18Source1: lyxrc.dist
19Source10: lyx.desktop
20
21## upstreamable patches
22# submitted, but upstream rejected it.  we currently agree to disagree.
23# Patch50: lyx-2.0.6-xdg_open.patch
24# Patch from Debian (testing)
25Patch50: lyx-2.2.3-xdg_open.patch
26
27## vine
28# reverted checkLatex to lyx-1.6.5
29Patch100: lyx-2.0.1-configurepy-vine.patch
30
31
32# BuildRequires: aiksaurus-devel
33# BuildRequires:   aspell-devel
34BuildRequires:   enchant-devel
35BuildRequires:   hunspell-devel
36BuildRequires:   libboost-devel
37BuildRequires:   libboost-filesystem
38BuildRequires:   libboost-signals
39BuildRequires:   libboost-regex
40BuildRequires:   desktop-file-utils
41BuildRequires:   gettext
42BuildRequires:   python
43BuildRequires:   xorg-x11-devel
44# BuildRequires:   qt4-devel
45BuildRequires:   qt5-qtbase-devel
46BuildRequires:   qt5-qtsvg-devel
47BuildRequires:   libpng-devel
48BuildRequires:   glib2-devel
49BuildRequires:   zlib-devel
50BuildRequires:   bc
51
52Requires(post):  texlive-common
53Requires(postun): texlive-common
54Requires:        ghostscript
55Requires:        python
56
57# # optional minimal qt4 dep
58# %{?_qt_version:Requires: qt4 >= %{_qt4_version}}
59
60Requires:        %{name}-fonts = %{version}-%{release}
61
62Requires:        xdg-utils
63Requires:        rcs
64
65BuildRoot: %{_tmppath}/%{name}-%{version}-root
66
67Vendor:       Project Vine
68Distribution: Vine Linux
69
70
71%description
72LyX is a modern approach to writing documents which breaks with the
73obsolete "typewriter paradigm" of most other document preparation
74systems.
75
76It is designed for people who want professional quality output
77with a minimum of time and effort, without becoming specialists in
78typesetting.
79
80The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
81That is, the author focuses on content, not on the details of formatting.
82This allows for greater productivity, and leaves the final typesetting
83to the backends (like LaTeX) that are specifically designed for the task.
84
85With LyX, the author can concentrate on the contents of his writing,
86and let the computer take care of the rest.
87
88This is LyX built with the Qt frontend.
89
90%description -l ja
91LaTeX形式で出力もできるワードプロセッサです。数式の入力も簡単にできます。
92特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
93してあります。
94
95
96%package fonts
97Summary: Lyx/MathML fonts
98Group:   User Interface/X
99# The actual license says "The author of these fonts, Basil K. Malyshev, has
100# kindly granted permission to use and modify these fonts."
101# One of the font files (wasy10) is separately licensed GPL+.
102License: Copyright only and GPL+
103Obsoletes:       latex-xft-fonts
104BuildArch: noarch
105%description  fonts
106A collection of Math symbol fonts for %{name}.
107
108
109%prep
110%setup -q
111
112%patch50 -p1 -b .xdg_open
113%patch100 -p1 -b .vine
114
115#./autogen.sh
116
117
118%build
119%configure \
120    --disable-dependency-tracking \
121    --disable-rpath \
122    --enable-build-type=release \
123    --disable-debug \
124    --enable-optimization="%{optflags}" \
125    --without-included-boost \
126    --disable-stdlib-debug \
127    \
128    --with-enchant \
129    --with-hunspell \
130    --enable-qt5 \
131    ;
132    # --enable-shared \
133    # --disable-static \
134    # --with-frontend=qt4 \
135    # --without-aiksaurus \
136
137%__make %{?_smp_mflags}
138
139# # make sure all .gmo files are regenerated from .po files
140# (cd po; make update-gmo)
141
142%install
143%__rm -rf ${RPM_BUILD_ROOT}
144%__make DESTDIR=${RPM_BUILD_ROOT} install
145
146# misc/extras
147%__install -p -m644 -D %{SOURCE1} %{buildroot}%{_datadir}/lyx/lyxrc.dist
148
149# Set up the lyx-specific class files where TeX can see them
150%__mkdir_p %{build_texmf}/tex/latex
151%__mv %{buildroot}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
152
153# desktop & icon
154desktop-file-install --vendor="vine" \
155  --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
156%__install -p -D -m644 lib/images/lyx.png \
157  %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
158
159# ghost'd files
160touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
161touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
162
163# fonts
164install -m 0755 -d %{buildroot}%{_fontdir}
165mv %{buildroot}%{_datadir}/lyx/fonts/*.ttf %{buildroot}%{_fontdir}/
166rm -rf %{buildroot}%{_datadir}/lyx/fonts
167
168%find_lang %{name}
169
170%check
171# tests/test_filetools error bogus ( see http://bugzilla.redhat.com/723938 )
172%__make -k check ||:
173
174
175%clean
176%__rm -rf ${RPM_BUILD_ROOT}
177
178
179%post
180touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
181
182%postun
183if [ $1 -eq 0 ] ; then
184    %{exec_texhash} >& /dev/null
185    update-desktop-database -q &> /dev/null
186    touch --no-create %{_datadir}/icons/hicolor &> /dev/null
187    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
188fi
189
190%posttrans
191%{exec_texhash} >& /dev/null
192update-desktop-database -q &> /dev/null
193touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
194gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
195
196%post fonts
197%__font_install_post %{_fontdir}
198
199%postun fonts
200%__font_install_postun %{_fontdir}
201
202
203%files -f %{name}.lang
204%defattr(-,root,root,-)
205%doc ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
206%{_bindir}/*
207%{_datadir}/lyx/
208%{texmf}/tex/latex/lyx/
209%{_datadir}/applications/*.desktop
210%{_datadir}/icons/hicolor/*/*/*
211%{_mandir}/man*/*
212%config(noreplace) %{_datadir}/lyx/lyxrc.dist
213%ghost %{_datadir}/lyx/lyxrc.defaults
214%ghost %{_datadir}/lyx/*.lst
215%ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
216
217%files fonts
218%defattr(-,root,root,-)
219%dir %{_fontdir}/
220%{_fontdir}/*.ttf
221
222
223%changelog
224* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 2.2.3-1
225- new upstream release
226- update Patch50 (lyx-2.2.3-xdg_open.patch)
227- add BuildRequires: bc
228- use qt5 instead of qt4
229  - add --enable-qt5 option
230  - add BuildRequires: qt5-qtbase-devel, qt5-qtsvg-devel
231  - drop BuildRequires: qt4-devel
232- delete unused options
233
234* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.6-1
235- update to 2.0.6
236- update Patch50 (lyx-2.0.6-xdg_open.patch)
237
238* Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-2
239- rebuild with hunspell-devel
240
241* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
242- new upstream release
243- added subpackage "lyx-fonts"
244  - added Obsoletes: latex-xft-fonts
245
246* Sat Oct 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-2
247- applied lyx-2.0.1-configurepy-vine.patch
248  - reverted checkLatex to lyx-1.6.5
249
250* Fri Sep 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
251- new upstream release
252
253* Sat Jun 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
254- new upstream release
255- dropped BuildRequires: aspell-devel
256- added BuildRequires:
257  - libboost-regex
258  - enchant-devel
259  - hunspell-devel
260
261* Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.8-1
262- new upstream release
263
264* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
265- new upstream release
266- TeX Live 2009
267  - dropped Requires: xdvik, dvipdfmx
268
269* Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
270- new upstream release
271- updated Patch0: lyx-1.6.5-xdg_open.patch
272
273* Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
274- new upstream release
275  - dropped old source files
276- change License: GPLv2+
277- added lyx.desktop
278- added BuildRequires:
279  - aspell-devel
280  - desktop-file-utils
281  - gettext
282  - python
283  - qt4-devel
284  - zlib-devel
285  - libboost-devel
286  - libboost-filesystem
287  - libboost-signals
288  - libpng-devel
289  - glib2-devel
290- added Requires:
291  - ghostscript
292  - dvipdfmx
293  - xdvik
294  - qt4
295  - xdg-utils
296- optimized some configure options
297
298* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
299- applied new versioning policy, spec in utf-8
300
301* Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
302- updated to 1.4.4 with the most recent CJK patch
303- updated Patch1
304
305* Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
306- base spec file : Vine Linux BTS #219
307  * Mon Nov  6 2006 M.H
308  - new upstream release
309  - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
310
311* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
312- changed Group to Applications/Editors
313
314* Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
315- rebuild with qt-3.3.5
316
317* Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
318- new upstream version
319- change frontend, xforms -> qt
320- require tetex, qt, latex-xft-fonts
321- change applnk file
322- change Group
323
324* Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
325- new upstream version
326- add mime-info
327- minor change in spec file
328
329* Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
330- 1.0.3_jp-4
331- added BuildPrereq:
332
333* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
334- 1.0.3_jp-3
335- minor change in spec file
336- build for Vine Linux 2.1
337
338* Wed Jan  5 2000 Jun Nishii <jun@vinelinux.org>
339- change group
340
341* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
342- updated to lyx-1.0.3
343- rebuild for Vine Linux 2.0
344
345* Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
346- merged Japanese Documents
347
348* Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
349- first build
350
Note: See TracBrowser for help on using the repository browser.