source: projects/specs/trunk/l/lyx/lyx-vl.spec @ 11711

Revision 11711, 9.2 KB checked in by ara_t, 6 years ago (diff)

lyx: update to 2.3.0

Line 
1%define pkg_name    lyx
2%define pkg_version 2.3.0
3%define pkg_release 1%{?_dist_release}
4
5%define _fontdir %{_datadir}/fonts/%{name}
6%define texmf %{_datadir}/texmf
7%define build_texmf %{buildroot}%{texmf}
8
9%define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
10
11
12Summary: WYSIWYM (What You See Is What You Mean) word processor with LaTeX output
13Summary(ja): LaTeX 形式で保存できるワードプロセッサ
14Name:    %{pkg_name}
15Version: %{pkg_version}
16Release: %{pkg_release}
17
18License: GPLv2 or GPLv3
19Group:   Applications/Editors
20URL:     http://www.lyx.org/
21
22Source0: ftp://ftp.lyx.org/pub/lyx/stable/lyx-%{version}.tar.xz
23Source1: lyxrc.dist
24Source10: lyx.desktop
25
26## upstreamable patches
27# submitted, but upstream rejected it.  we currently agree to disagree.
28# Patch50: lyx-2.0.6-xdg_open.patch
29Patch50: lyx-2.3.0-xdg_open.patch
30
31## vine
32# reverted checkLatex to lyx-1.6.5
33Patch100: lyx-2.3.0-configurepy-vine.patch
34
35BuildRequires:   enchant-devel
36BuildRequires:   hunspell-devel
37BuildRequires:   libboost-devel
38BuildRequires:   libboost-filesystem
39BuildRequires:   libboost-signals
40BuildRequires:   libboost-regex
41BuildRequires:   desktop-file-utils
42BuildRequires:   gettext
43BuildRequires:   python
44BuildRequires:   xorg-x11-devel
45BuildRequires:   qt5-qtbase-devel
46BuildRequires:   qt5-qtsvg-devel
47BuildRequires:   libpng-devel
48BuildRequires:   glib2-devel
49BuildRequires:   zlib-devel
50BuildRequires:   bc
51
52Requires(post):   texlive-common
53Requires(postun): texlive-common
54Requires: ghostscript
55Requires: python
56Requires: %{name}-fonts = %{version}-%{release}
57Requires: xdg-utils
58Requires: rcs
59
60BuildRoot: %{_tmppath}/%{name}-%{version}-root
61
62Vendor:       Project Vine
63Distribution: Vine Linux
64
65
66%description
67LyX is a modern approach to writing documents which breaks with the
68obsolete "typewriter paradigm" of most other document preparation
69systems.
70
71It is designed for people who want professional quality output
72with a minimum of time and effort, without becoming specialists in
73typesetting.
74
75The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
76That is, the author focuses on content, not on the details of formatting.
77This allows for greater productivity, and leaves the final typesetting
78to the backends (like LaTeX) that are specifically designed for the task.
79
80With LyX, the author can concentrate on the contents of his writing,
81and let the computer take care of the rest.
82
83This is LyX built with the Qt frontend.
84
85%description -l ja
86LaTeX形式で出力もできるワードプロセッサです。数式の入力も簡単にできます。
87特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
88してあります。
89
90%package fonts
91Summary: Lyx/MathML fonts
92Group:   User Interface/X
93# The actual license says "The author of these fonts, Basil K. Malyshev, has
94# kindly granted permission to use and modify these fonts."
95# One of the font files (wasy10) is separately licensed GPL+.
96License:   Copyright only and GPL+
97Obsoletes: latex-xft-fonts
98BuildArch: noarch
99
100%description fonts
101A collection of Math symbol fonts for %{name}.
102
103
104%prep
105%setup -q
106
107%patch50 -b .xdg_open
108%patch100 -b .vine
109
110%build
111%{configure} \
112    --disable-dependency-tracking \
113    --disable-rpath \
114    --enable-build-type=release \
115    --disable-debug \
116    --enable-optimization="%{optflags}" \
117    --without-included-boost \
118    --disable-stdlib-debug \
119    --with-enchant \
120    --with-hunspell \
121    --enable-qt5 \
122    ;
123
124%{__make} %{?_smp_mflags}
125
126%install
127%{__rm} -rf ${RPM_BUILD_ROOT}
128%{__make} install DESTDIR=${RPM_BUILD_ROOT}
129
130# misc/extras
131%{__install} -p -m644 -D %{SOURCE1} %{buildroot}%{_datadir}/lyx/lyxrc.dist
132
133# Set up the lyx-specific class files where TeX can see them
134%{__mkdir_p} %{build_texmf}/tex/latex
135%{__mv} %{buildroot}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
136
137# desktop & icon
138desktop-file-install --vendor="vine" \
139  --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
140%__install -p -D -m644 lib/images/lyx.png \
141  %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
142
143%{__rm} -f ${RPM_BUILD_ROOT}%{_datadir}/applications/lyx.desktop
144
145# ghost'd files
146touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
147touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
148
149# fonts
150%{__install} -m 0755 -d %{buildroot}%{_fontdir}
151%{__mv} %{buildroot}%{_datadir}/lyx/fonts/*.ttf %{buildroot}%{_fontdir}/
152%{__rm} -rf %{buildroot}%{_datadir}/lyx/fonts
153
154%find_lang %{name}
155
156%check
157# tests/test_filetools error bogus ( see http://bugzilla.redhat.com/723938 )
158%{__make} -k check || :
159
160%clean
161%{__rm} -rf ${RPM_BUILD_ROOT}
162
163%post
164touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
165
166%postun
167if [ $1 -eq 0 ] ; then
168    %{exec_texhash} >& /dev/null
169    update-desktop-database -q &> /dev/null
170    touch --no-create %{_datadir}/icons/hicolor &> /dev/null
171    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
172fi
173
174%posttrans
175%{exec_texhash} >& /dev/null
176update-desktop-database -q &> /dev/null
177touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
178gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
179
180%post fonts
181%{__font_install_post} %{_fontdir}
182
183%postun fonts
184%{__font_install_postun} %{_fontdir}
185
186
187%files -f %{name}.lang
188%defattr(-,root,root,-)
189%doc ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
190%{_bindir}/*
191%{_datadir}/lyx/
192%{texmf}/tex/latex/lyx/
193%{_datadir}/applications/*.desktop
194%{_datadir}/icons/hicolor/*/*/*
195%{_mandir}/man*/*
196%config(noreplace) %{_datadir}/lyx/lyxrc.dist
197%ghost %{_datadir}/lyx/lyxrc.defaults
198%ghost %{_datadir}/lyx/*.lst
199%ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
200
201%files fonts
202%defattr(-,root,root,-)
203%dir %{_fontdir}/
204%{_fontdir}/*.ttf
205
206
207%changelog
208* Fri Jun 08 2018 Toshiaki Ara <ara_t@384.jp> 2.3.0-1
209- update to 2.3.0
210- update Patch50 and Patch100
211
212* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 2.2.3-1
213- new upstream release
214- update Patch50 (lyx-2.2.3-xdg_open.patch)
215- add BuildRequires: bc
216- use qt5 instead of qt4
217  - add --enable-qt5 option
218  - add BuildRequires: qt5-qtbase-devel, qt5-qtsvg-devel
219  - drop BuildRequires: qt4-devel
220- delete unused options
221
222* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.6-1
223- update to 2.0.6
224- update Patch50 (lyx-2.0.6-xdg_open.patch)
225
226* Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-2
227- rebuild with hunspell-devel
228
229* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
230- new upstream release
231- added subpackage "lyx-fonts"
232  - added Obsoletes: latex-xft-fonts
233
234* Sat Oct 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-2
235- applied lyx-2.0.1-configurepy-vine.patch
236  - reverted checkLatex to lyx-1.6.5
237
238* Fri Sep 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
239- new upstream release
240
241* Sat Jun 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
242- new upstream release
243- dropped BuildRequires: aspell-devel
244- added BuildRequires:
245  - libboost-regex
246  - enchant-devel
247  - hunspell-devel
248
249* Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.8-1
250- new upstream release
251
252* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
253- new upstream release
254- TeX Live 2009
255  - dropped Requires: xdvik, dvipdfmx
256
257* Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
258- new upstream release
259- updated Patch0: lyx-1.6.5-xdg_open.patch
260
261* Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
262- new upstream release
263  - dropped old source files
264- change License: GPLv2+
265- added lyx.desktop
266- added BuildRequires:
267  - aspell-devel
268  - desktop-file-utils
269  - gettext
270  - python
271  - qt4-devel
272  - zlib-devel
273  - libboost-devel
274  - libboost-filesystem
275  - libboost-signals
276  - libpng-devel
277  - glib2-devel
278- added Requires:
279  - ghostscript
280  - dvipdfmx
281  - xdvik
282  - qt4
283  - xdg-utils
284- optimized some configure options
285
286* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
287- applied new versioning policy, spec in utf-8
288
289* Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
290- updated to 1.4.4 with the most recent CJK patch
291- updated Patch1
292
293* Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
294- base spec file : Vine Linux BTS #219
295  * Mon Nov  6 2006 M.H
296  - new upstream release
297  - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
298
299* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
300- changed Group to Applications/Editors
301
302* Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
303- rebuild with qt-3.3.5
304
305* Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
306- new upstream version
307- change frontend, xforms -> qt
308- require tetex, qt, latex-xft-fonts
309- change applnk file
310- change Group
311
312* Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
313- new upstream version
314- add mime-info
315- minor change in spec file
316
317* Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
318- 1.0.3_jp-4
319- added BuildPrereq:
320
321* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
322- 1.0.3_jp-3
323- minor change in spec file
324- build for Vine Linux 2.1
325
326* Wed Jan  5 2000 Jun Nishii <jun@vinelinux.org>
327- change group
328
329* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
330- updated to lyx-1.0.3
331- rebuild for Vine Linux 2.0
332
333* Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
334- merged Japanese Documents
335
336* Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
337- first build
338
Note: See TracBrowser for help on using the repository browser.