source: projects/specs/trunk/l/lyx/lyx-vl.spec @ 12303

Revision 12303, 9.5 KB checked in by ara_t, 4 years ago (diff)

lyx: update to 2.3.3

Line 
1%define pkg_name    lyx
2%define pkg_version 2.3.3
3%define pkg_release 1%{?_dist_release}
4
5%define _fontdir %{_datadir}/fonts/%{name}
6%define texmf %{_datadir}/texmf
7%define build_texmf %{buildroot}%{texmf}
8
9%define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
10
11
12Summary: WYSIWYM (What You See Is What You Mean) word processor with LaTeX output
13Summary(ja): LaTeX 形式で保存できるワードプロセッサ
14Name:    %{pkg_name}
15Version: %{pkg_version}
16Release: %{pkg_release}
17
18License: GPLv2 or GPLv3
19Group:   Applications/Editors
20URL:     http://www.lyx.org/
21
22Source0: ftp://ftp.lyx.org/pub/lyx/stable/2.3.x/lyx-%{version}.tar.xz
23# Source0: ftp://ftp.lyx.org/pub/lyx/stable/lyx-%{version}-2.tar.xz
24Source1: lyxrc.dist
25Source10: lyx.desktop
26
27## upstreamable patches
28# submitted, but upstream rejected it.  we currently agree to disagree.
29# Patch50: lyx-2.0.6-xdg_open.patch
30Patch50: lyx-2.3.0-xdg_open.patch
31
32## vine
33# reverted checkLatex to lyx-1.6.5
34Patch100: lyx-2.3.0-configurepy-vine.patch
35
36BuildRequires:   enchant-devel
37BuildRequires:   hunspell-devel
38BuildRequires:   libboost-devel
39BuildRequires:   libboost-filesystem
40BuildRequires:   libboost-signals
41BuildRequires:   libboost-regex
42BuildRequires:   desktop-file-utils
43BuildRequires:   gettext
44BuildRequires:   python
45BuildRequires:   xorg-x11-devel
46BuildRequires:   qt5-qtbase-devel
47BuildRequires:   qt5-qtsvg-devel
48BuildRequires:   libpng-devel
49BuildRequires:   glib2-devel
50BuildRequires:   zlib-devel
51BuildRequires:   bc
52
53Requires(post):   texlive-common
54Requires(postun): texlive-common
55Requires: ghostscript
56Requires: python
57Requires: %{name}-fonts = %{version}-%{release}
58Requires: xdg-utils
59Requires: rcs
60
61BuildRoot: %{_tmppath}/%{name}-%{version}-root
62
63Vendor:       Project Vine
64Distribution: Vine Linux
65
66
67%description
68LyX is a modern approach to writing documents which breaks with the
69obsolete "typewriter paradigm" of most other document preparation
70systems.
71
72It is designed for people who want professional quality output
73with a minimum of time and effort, without becoming specialists in
74typesetting.
75
76The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
77That is, the author focuses on content, not on the details of formatting.
78This allows for greater productivity, and leaves the final typesetting
79to the backends (like LaTeX) that are specifically designed for the task.
80
81With LyX, the author can concentrate on the contents of his writing,
82and let the computer take care of the rest.
83
84This is LyX built with the Qt frontend.
85
86%description -l ja
87LaTeX形式で出力もできるワードプロセッサです。数式の入力も簡単にできます。
88特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
89してあります。
90
91%package fonts
92Summary: Lyx/MathML fonts
93Group:   User Interface/X
94# The actual license says "The author of these fonts, Basil K. Malyshev, has
95# kindly granted permission to use and modify these fonts."
96# One of the font files (wasy10) is separately licensed GPL+.
97License:   Copyright only and GPL+
98Obsoletes: latex-xft-fonts
99BuildArch: noarch
100
101%description fonts
102A collection of Math symbol fonts for %{name}.
103
104
105%prep
106%setup -q
107
108%patch50 -b .xdg_open
109%patch100 -b .vine
110
111%build
112%{configure} \
113    --disable-dependency-tracking \
114    --disable-rpath \
115    --enable-build-type=release \
116    --disable-debug \
117    --enable-optimization="%{optflags}" \
118    --without-included-boost \
119    --disable-stdlib-debug \
120    --with-enchant \
121    --with-hunspell \
122    --enable-qt5 \
123    ;
124
125%{__make} %{?_smp_mflags}
126
127%install
128%{__rm} -rf ${RPM_BUILD_ROOT}
129%{__make} install DESTDIR=${RPM_BUILD_ROOT}
130
131# misc/extras
132%{__install} -p -m644 -D %{SOURCE1} %{buildroot}%{_datadir}/lyx/lyxrc.dist
133
134# Set up the lyx-specific class files where TeX can see them
135%{__mkdir_p} %{build_texmf}/tex/latex
136%{__mv} %{buildroot}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
137
138# desktop & icon
139desktop-file-install --vendor="vine" \
140  --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
141%__install -p -D -m644 lib/images/lyx.png \
142  %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
143
144%{__rm} -f ${RPM_BUILD_ROOT}%{_datadir}/applications/lyx.desktop
145
146# ghost'd files
147touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
148touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
149
150# fonts
151%{__install} -m 0755 -d %{buildroot}%{_fontdir}
152%{__mv} %{buildroot}%{_datadir}/lyx/fonts/*.ttf %{buildroot}%{_fontdir}/
153%{__rm} -rf %{buildroot}%{_datadir}/lyx/fonts
154
155%find_lang %{name}
156
157%check
158# tests/test_filetools error bogus ( see http://bugzilla.redhat.com/723938 )
159%{__make} -k check || :
160
161%clean
162%{__rm} -rf ${RPM_BUILD_ROOT}
163
164%post
165touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
166
167%postun
168if [ $1 -eq 0 ] ; then
169    %{exec_texhash} >& /dev/null
170    update-desktop-database -q &> /dev/null
171    touch --no-create %{_datadir}/icons/hicolor &> /dev/null
172    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
173fi
174
175%posttrans
176%{exec_texhash} >& /dev/null
177update-desktop-database -q &> /dev/null
178touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
179gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
180
181%post fonts
182%{__font_install_post} %{_fontdir}
183
184%postun fonts
185%{__font_install_postun} %{_fontdir}
186
187
188%files -f %{name}.lang
189%defattr(-,root,root,-)
190%doc ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
191%{_bindir}/*
192%{_datadir}/lyx/
193%{texmf}/tex/latex/lyx/
194%{_datadir}/applications/*.desktop
195%{_datadir}/icons/hicolor/*/*/*
196%{_mandir}/man*/*
197%config(noreplace) %{_datadir}/lyx/lyxrc.dist
198%ghost %{_datadir}/lyx/lyxrc.defaults
199%ghost %{_datadir}/lyx/*.lst
200%ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
201
202%files fonts
203%defattr(-,root,root,-)
204%dir %{_fontdir}/
205%{_fontdir}/*.ttf
206
207
208%changelog
209* Tue Oct 29 2019 Toshiaki Ara <ara_t@384.jp> 2.3.3-1
210- update to 2.3.3
211
212* Tue Jan 29 2019 Toshiaki Ara <ara_t@384.jp> 2.3.2-1
213- update to 2.3.2
214
215* Sun Oct 07 2018 Toshiaki Ara <ara_t@384.jp> 2.3.1-1
216- update to 2.3.1
217
218* Fri Jun 08 2018 Toshiaki Ara <ara_t@384.jp> 2.3.0-1
219- update to 2.3.0
220- update Patch50 and Patch100
221
222* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 2.2.3-1
223- new upstream release
224- update Patch50 (lyx-2.2.3-xdg_open.patch)
225- add BuildRequires: bc
226- use qt5 instead of qt4
227  - add --enable-qt5 option
228  - add BuildRequires: qt5-qtbase-devel, qt5-qtsvg-devel
229  - drop BuildRequires: qt4-devel
230- delete unused options
231
232* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.6-1
233- update to 2.0.6
234- update Patch50 (lyx-2.0.6-xdg_open.patch)
235
236* Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-2
237- rebuild with hunspell-devel
238
239* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
240- new upstream release
241- added subpackage "lyx-fonts"
242  - added Obsoletes: latex-xft-fonts
243
244* Sat Oct 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-2
245- applied lyx-2.0.1-configurepy-vine.patch
246  - reverted checkLatex to lyx-1.6.5
247
248* Fri Sep 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
249- new upstream release
250
251* Sat Jun 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
252- new upstream release
253- dropped BuildRequires: aspell-devel
254- added BuildRequires:
255  - libboost-regex
256  - enchant-devel
257  - hunspell-devel
258
259* Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.8-1
260- new upstream release
261
262* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
263- new upstream release
264- TeX Live 2009
265  - dropped Requires: xdvik, dvipdfmx
266
267* Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
268- new upstream release
269- updated Patch0: lyx-1.6.5-xdg_open.patch
270
271* Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
272- new upstream release
273  - dropped old source files
274- change License: GPLv2+
275- added lyx.desktop
276- added BuildRequires:
277  - aspell-devel
278  - desktop-file-utils
279  - gettext
280  - python
281  - qt4-devel
282  - zlib-devel
283  - libboost-devel
284  - libboost-filesystem
285  - libboost-signals
286  - libpng-devel
287  - glib2-devel
288- added Requires:
289  - ghostscript
290  - dvipdfmx
291  - xdvik
292  - qt4
293  - xdg-utils
294- optimized some configure options
295
296* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
297- applied new versioning policy, spec in utf-8
298
299* Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
300- updated to 1.4.4 with the most recent CJK patch
301- updated Patch1
302
303* Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
304- base spec file : Vine Linux BTS #219
305  * Mon Nov  6 2006 M.H
306  - new upstream release
307  - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
308
309* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
310- changed Group to Applications/Editors
311
312* Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
313- rebuild with qt-3.3.5
314
315* Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
316- new upstream version
317- change frontend, xforms -> qt
318- require tetex, qt, latex-xft-fonts
319- change applnk file
320- change Group
321
322* Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
323- new upstream version
324- add mime-info
325- minor change in spec file
326
327* Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
328- 1.0.3_jp-4
329- added BuildPrereq:
330
331* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
332- 1.0.3_jp-3
333- minor change in spec file
334- build for Vine Linux 2.1
335
336* Wed Jan  5 2000 Jun Nishii <jun@vinelinux.org>
337- change group
338
339* Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
340- updated to lyx-1.0.3
341- rebuild for Vine Linux 2.0
342
343* Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
344- merged Japanese Documents
345
346* Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
347- first build
348
Note: See TracBrowser for help on using the repository browser.