source: projects/specs/trunk/l/lsb/lsb-vl.spec @ 521

Revision 521, 22.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Define this to link to which library version  eg. /lib64/ld-lsb-x86-64.so.3
2%define lsbsover 3
3
4%ifarch %{ix86}
5%define ldso ld-linux.so.2
6%define lsbldso ld-lsb.so
7%endif
8
9%ifarch ia64
10%define ldso ld-linux-ia64.so.2
11%define lsbldso ld-lsb-ia64.so
12%endif
13
14%ifarch ppc
15%define ldso ld.so.1
16%define lsbldso ld-lsb-ppc32.so
17%endif
18
19%ifarch ppc64
20%define ldso ld64.so.1
21%define lsbldso ld-lsb-ppc64.so
22%endif
23
24%ifarch s390
25%define ldso ld.so.1
26%define lsbldso ld-lsb-s390.so
27%endif
28
29%ifarch s390x
30%define ldso ld64.so.1
31%define lsbldso ld-lsb-s390x.so
32%endif
33
34%ifarch x86_64
35%define ldso ld-linux-x86-64.so.2
36%define lsbldso ld-lsb-x86-64.so
37%endif
38
39%ifarch ia64 ppc64 s390x x86_64
40%define qual ()(64bit)
41%else
42%define qual %{nil}
43%endif
44
45%define upstreamlsbrelver 2.0
46%define lsbrelver 3.0
47%define srcrelease 1
48
49Summary: LSB support for Vine Linux
50Summary(ja): Vine Linux の LSB サポート
51Name: lsb
52Version: 3.2
53Release: 1%{?_dist_release}
54URL: http://www.linuxfoundation.org/
55Source0: %{name}-vine-%{version}.tar.bz2
56License: GPLv2
57Group: System Environment/Base
58BuildRoot: %{_tmppath}/%{name}-root
59# dependency for primary LSB application for v1.3
60Provides: lsb = %{version}
61# dependency for primary LSB application for v2.0 and v3.0
62%ifarch %{ix86}
63%define archname ia32
64%endif
65%ifarch ia64
66%define archname ia64
67%endif
68%ifarch ppc
69%define archname ppc32
70%endif
71%ifarch ppc64
72%define archname ppc64
73%endif
74%ifarch s390
75%define archname s390
76%endif
77%ifarch s390x
78%define archname s390x
79%endif
80%ifarch x86_64
81%define archname amd64
82%endif
83Provides: lsb-core-%{archname} = %{version}
84Provides: lsb-graphics-%{archname} = %{version}
85Provides: lsb-core-noarch = %{version}
86Provides: lsb-graphics-noarch = %{version}
87
88ExclusiveArch: i386 ia64 x86_64 ppc ppc64 s390 s390x
89
90%ifarch %{ix86}
91# archLSB IA32 Base Libraries
92Requires: libatk-1.0.so.0
93Requires: libc.so.6
94Requires: libcrypt.so.1
95Requires: libdl.so.2
96Requires: libgcc_s.so.1
97Requires: libgdk-x11-2.0.so.0
98Requires: libgdk_pixbuf-2.0.so.0
99Requires: libgdk_pixbuf_xlib-2.0.so.0
100Requires: libglib-2.0.so.0
101Requires: libgmodule-2.0.so.0
102Requires: libgobject-2.0.so.0
103Requires: libgthread-2.0.so.0
104Requires: libgtk-x11-2.0.so.0
105Requires: libm.so.6
106Requires: libncurses.so.5
107Requires: libpango-1.0.so.0
108Requires: libpangoft2-1.0.so.0
109Requires: libpangoxft-1.0.so.0
110Requires: libpthread.so.0
111Requires: libqt-mt.so.3
112Requires: libQtCore.so.4
113Requires: libQtGui.so.4
114Requires: libQtNetwork.so.4
115Requires: libQtOpenGL.so.4
116Requires: libQtSql.so.4
117Requires: libQtSvg.so.4
118Requires: libQtXml.so.4
119Requires: libstdc++.so.6
120Requires: libutil.so.1
121Requires: libz.so.1
122%endif
123
124%ifarch ia64
125# archLSB IA64 Base Libraries
126Requires: libatk-1.0.so.0()(64bit)
127Requires: libc.so.6.1()(64bit)
128Requires: libcrypt.so.1()(64bit)
129Requires: libdl.so.2()(64bit)
130Requires: libgcc_s.so.1()(64bit)
131Requires: libgdk-x11-2.0.so.0()(64bit)
132Requires: libgdk_pixbuf-2.0.so.0()(64bit)
133Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
134Requires: libglib-2.0.so.0()(64bit)
135Requires: libgmodule-2.0.so.0()(64bit)
136Requires: libgobject-2.0.so.0()(64bit)
137Requires: libgthread-2.0.so.0()(64bit)
138Requires: libgtk-x11-2.0.so.0()(64bit)
139Requires: libm.so.6.1()(64bit)
140Requires: libncurses.so.5()(64bit)
141Requires: libpango-1.0.so.0()(64bit)
142Requires: libpangoft2-1.0.so.0()(64bit)
143Requires: libpangoxft-1.0.so.0()(64bit)
144Requires: libpthread.so.0()(64bit)
145Requires: libqt-mt.so.3()(64bit)
146Requires: libQtCore.so.4()(64bit)
147Requires: libQtGui.so.4()(64bit)
148Requires: libQtNetwork.so.4()(64bit)
149Requires: libQtOpenGL.so.4()(64bit)
150Requires: libQtSql.so.4()(64bit)
151Requires: libQtSvg.so.4()(64bit)
152Requires: libQtXml.so.4()(64bit)
153Requires: libstdc++.so.6()(64bit)
154Requires: libutil.so.1()(64bit)
155Requires: libz.so.1()(64bit)
156%endif
157
158%ifarch ppc
159# archLSB PPC32 Base Libraries
160Requires: libatk-1.0.so.0
161Requires: libc.so.6
162Requires: libcrypt.so.1
163Requires: libdl.so.2
164Requires: libgcc_s.so.1
165Requires: libgdk-x11-2.0.so.0
166Requires: libgdk_pixbuf-2.0.so.0
167Requires: libgdk_pixbuf_xlib-2.0.so.0
168Requires: libglib-2.0.so.0
169Requires: libgmodule-2.0.so.0
170Requires: libgobject-2.0.so.0
171Requires: libgthread-2.0.so.0
172Requires: libgtk-x11-2.0.so.0
173Requires: libm.so.6
174Requires: libncurses.so.5
175Requires: libpango-1.0.so.0
176Requires: libpangoft2-1.0.so.0
177Requires: libpangoxft-1.0.so.0
178Requires: libpthread.so.0
179Requires: libqt-mt.so.3
180Requires: libQtCore.so.4
181Requires: libQtGui.so.4
182Requires: libQtNetwork.so.4
183Requires: libQtOpenGL.so.4
184Requires: libQtSql.so.4
185Requires: libQtSvg.so.4
186Requires: libQtXml.so.4
187Requires: libstdc++.so.6
188Requires: libutil.so.1
189Requires: libz.so.1
190%endif
191
192%ifarch ppc64
193# archLSB PPC64 Base Libraries
194Requires: libatk-1.0.so.0()(64bit)
195Requires: libc.so.6()(64bit)
196Requires: libcrypt.so.1()(64bit)
197Requires: libdl.so.2()(64bit)
198Requires: libgcc_s.so.1()(64bit)
199Requires: libgdk-x11-2.0.so.0()(64bit)
200Requires: libgdk_pixbuf-2.0.so.0()(64bit)
201Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
202Requires: libglib-2.0.so.0()(64bit)
203Requires: libgmodule-2.0.so.0()(64bit)
204Requires: libgobject-2.0.so.0()(64bit)
205Requires: libgthread-2.0.so.0()(64bit)
206Requires: libgtk-x11-2.0.so.0()(64bit)
207Requires: libm.so.6()(64bit)
208Requires: libncurses.so.5()(64bit)
209Requires: libpango-1.0.so.0()(64bit)
210Requires: libpangoft2-1.0.so.0()(64bit)
211Requires: libpangoxft-1.0.so.0()(64bit)
212Requires: libpthread.so.0()(64bit)
213Requires: libqt-mt.so.3()(64bit)
214Requires: libQtCore.so.4()(64bit)
215Requires: libQtGui.so.4()(64bit)
216Requires: libQtNetwork.so.4()(64bit)
217Requires: libQtOpenGL.so.4()(64bit)
218Requires: libQtSql.so.4()(64bit)
219Requires: libQtSvg.so.4()(64bit)
220Requires: libQtXml.so.4()(64bit)
221Requires: libstdc++.so.6()(64bit)
222Requires: libutil.so.1()(64bit)
223Requires: libz.so.1()(64bit)
224%endif
225
226%ifarch s390
227# archLSB S390 Base Libraries
228Requires: libatk-1.0.so.0
229Requires: libc.so.6
230Requires: libcrypt.so.1
231Requires: libdl.so.2
232Requires: libgcc_s.so.1
233Requires: libgdk-x11-2.0.so.0
234Requires: libgdk_pixbuf-2.0.so.0
235Requires: libgdk_pixbuf_xlib-2.0.so.0
236Requires: libglib-2.0.so.0
237Requires: libgmodule-2.0.so.0
238Requires: libgobject-2.0.so.0
239Requires: libgthread-2.0.so.0
240Requires: libgtk-x11-2.0.so.0
241Requires: libm.so.6
242Requires: libncurses.so.5
243Requires: libpango-1.0.so.0
244Requires: libpangoft2-1.0.so.0
245Requires: libpangoxft-1.0.so.0
246Requires: libpthread.so.0
247Requires: libqt-mt.so.3
248Requires: libQtCore.so.4
249Requires: libQtGui.so.4
250Requires: libQtNetwork.so.4
251Requires: libQtOpenGL.so.4
252Requires: libQtSql.so.4
253Requires: libQtSvg.so.4
254Requires: libQtXml.so.4
255Requires: libstdc++.so.6
256Requires: libutil.so.1
257Requires: libz.so.1
258%endif
259
260%ifarch s390x
261# archLSB S390X Base Libraries
262Requires: libatk-1.0.so.0()(64bit)
263Requires: libc.so.6()(64bit)
264Requires: libcrypt.so.1()(64bit)
265Requires: libdl.so.2()(64bit)
266Requires: libgcc_s.so.1()(64bit)
267Requires: libgdk-x11-2.0.so.0()(64bit)
268Requires: libgdk_pixbuf-2.0.so.0()(64bit)
269Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
270Requires: libglib-2.0.so.0()(64bit)
271Requires: libgmodule-2.0.so.0()(64bit)
272Requires: libgobject-2.0.so.0()(64bit)
273Requires: libgthread-2.0.so.0()(64bit)
274Requires: libgtk-x11-2.0.so.0()(64bit)
275Requires: libm.so.6()(64bit)
276Requires: libncurses.so.5()(64bit)
277Requires: libpango-1.0.so.0()(64bit)
278Requires: libpangoft2-1.0.so.0()(64bit)
279Requires: libpangoxft-1.0.so.0()(64bit)
280Requires: libpthread.so.0()(64bit)
281Requires: libqt-mt.so.3()(64bit)
282Requires: libQtCore.so.4()(64bit)
283Requires: libQtGui.so.4()(64bit)
284Requires: libQtNetwork.so.4()(64bit)
285Requires: libQtOpenGL.so.4()(64bit)
286Requires: libQtSql.so.4()(64bit)
287Requires: libQtSvg.so.4()(64bit)
288Requires: libQtXml.so.4()(64bit)
289Requires: libstdc++.so.6()(64bit)
290Requires: libutil.so.1()(64bit)
291Requires: libz.so.1()(64bit)
292%endif
293
294%ifarch x86_64
295# archLSB AMD64 Base Libraries
296Requires: libatk-1.0.so.0()(64bit)
297Requires: libc.so.6()(64bit)
298Requires: libcrypt.so.1()(64bit)
299Requires: libdl.so.2()(64bit)
300Requires: libgcc_s.so.1()(64bit)
301Requires: libgdk-x11-2.0.so.0()(64bit)
302Requires: libgdk_pixbuf-2.0.so.0()(64bit)
303Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
304Requires: libglib-2.0.so.0()(64bit)
305Requires: libgmodule-2.0.so.0()(64bit)
306Requires: libgobject-2.0.so.0()(64bit)
307Requires: libgthread-2.0.so.0()(64bit)
308Requires: libgtk-x11-2.0.so.0()(64bit)
309Requires: libm.so.6()(64bit)
310Requires: libncurses.so.5()(64bit)
311Requires: libpango-1.0.so.0()(64bit)
312Requires: libpangoft2-1.0.so.0()(64bit)
313Requires: libpangoxft-1.0.so.0()(64bit)
314Requires: libpthread.so.0()(64bit)
315Requires: libqt-mt.so.3()(64bit)
316Requires: libQtCore.so.4()(64bit)
317Requires: libQtGui.so.4()(64bit)
318Requires: libQtNetwork.so.4()(64bit)
319Requires: libQtOpenGL.so.4()(64bit)
320Requires: libQtSql.so.4()(64bit)
321Requires: libQtSvg.so.4()(64bit)
322Requires: libQtXml.so.4()(64bit)
323Requires: libstdc++.so.6()(64bit)
324Requires: libutil.so.1()(64bit)
325Requires: libz.so.1()(64bit)
326%endif
327
328# gLSB Base/Utility/Stdc++/Graphics Libraries
329Requires: libasound.so.2%{qual}
330Requires: libatk-1.0.so.0%{qual}
331Requires: libcrypt.so.1%{qual}
332Requires: libcups.so.2%{qual}
333Requires: libcupsimage.so.2%{qual}
334Requires: libdl.so.2%{qual}
335Requires: libfontconfig.so.1%{qual}
336Requires: libfreetype.so.6%{qual}
337Requires: libgcc_s.so.1%{qual}
338Requires: libgdk-x11-2.0.so.0%{qual}
339Requires: libgdk_pixbuf-2.0.so.0%{qual}
340Requires: libgdk_pixbuf_xlib-2.0.so.0%{qual}
341Requires: libGL.so.1%{qual}
342Requires: libglib-2.0.so.0%{qual}
343Requires: libgmodule-2.0.so.0%{qual}
344Requires: libgobject-2.0.so.0%{qual}
345Requires: libgthread-2.0.so.0%{qual}
346Requires: libgtk-x11-2.0.so.0%{qual}
347Requires: libICE.so.6%{qual}
348Requires: libjpeg.so.62%{qual}
349Requires: libncurses.so.5%{qual}
350Requires: libpam.so.0%{qual}
351Requires: libpango-1.0.so.0%{qual}
352Requires: libpangoft2-1.0.so.0%{qual}
353Requires: libpangoxft-1.0.so.0%{qual}
354Requires: libpng12.so.0%{qual}
355Requires: libpthread.so.0%{qual}
356Requires: libqt-mt.so.3%{qual}
357Requires: libQtCore.so.4%{qual}
358Requires: libQtGui.so.4%{qual}
359Requires: libQtNetwork.so.4%{qual}
360Requires: libQtOpenGL.so.4%{qual}
361Requires: libQtSql.so.4%{qual}
362Requires: libQtSvg.so.4%{qual}
363Requires: libQtXml.so.4%{qual}
364Requires: librt.so.1%{qual}
365Requires: libSM.so.6%{qual}
366Requires: libstdc++.so.6%{qual}
367Requires: libutil.so.1%{qual}
368Requires: libX11.so.6%{qual}
369Requires: libXext.so.6%{qual}
370Requires: libXft.so.2%{qual}
371Requires: libXi.so.6%{qual}
372Requires: libxml2.so.2%{qual}
373Requires: libXrender.so.1%{qual}
374Requires: libXt.so.6%{qual}
375Requires: libz.so.1%{qual}
376
377# gLSB Command and Utilities
378Requires: /bin/awk
379Requires: /bin/basename
380Requires: /bin/cat
381Requires: /bin/chgrp
382Requires: /bin/chmod
383Requires: /bin/chown
384Requires: /bin/cp
385Requires: /bin/cpio
386Requires: /bin/cut
387Requires: /bin/date
388Requires: /bin/dd
389Requires: /bin/df
390Requires: /bin/dmesg
391Requires: /bin/echo
392Requires: /bin/ed
393Requires: /bin/egrep
394Requires: /bin/env
395Requires: /bin/false
396Requires: /bin/fgrep
397Requires: /bin/gettext
398Requires: /bin/grep
399Requires: /bin/gunzip
400Requires: /bin/gzip
401Requires: /bin/hostname
402Requires: /bin/kill
403Requires: /bin/ln
404Requires: /bin/ls
405Requires: mailx
406Requires: /bin/mkdir
407Requires: /bin/mknod
408Requires: /bin/mktemp
409Requires: /bin/more
410Requires: /bin/mount
411Requires: /bin/mv
412Requires: /bin/nice
413Requires: /bin/ps
414Requires: /bin/pwd
415Requires: /bin/rm
416Requires: /bin/rmdir
417Requires: /bin/sed
418Requires: /bin/sh
419Requires: /bin/sleep
420Requires: /bin/sort
421Requires: /bin/stty
422Requires: /bin/su
423Requires: /bin/sync
424Requires: /bin/tar
425Requires: /bin/touch
426Requires: /bin/true
427Requires: /bin/umount
428Requires: /bin/uname
429Requires: /bin/zcat
430Requires: /sbin/fuser
431Requires: /sbin/pidof
432Requires: /sbin/shutdown
433Requires: /usr/bin/[
434Requires: /usr/bin/ar
435Requires: /usr/bin/at
436Requires: /usr/bin/batch
437Requires: /usr/bin/bc
438Requires: /usr/bin/chfn
439Requires: /usr/bin/chsh
440Requires: /usr/bin/cksum
441Requires: /usr/bin/cmp
442Requires: /usr/bin/col
443Requires: /usr/bin/comm
444Requires: /usr/bin/crontab
445Requires: /usr/bin/csplit
446Requires: /usr/bin/diff
447Requires: /usr/bin/dirname
448Requires: /usr/bin/du
449Requires: /usr/bin/expand
450Requires: /usr/bin/expr
451Requires: /usr/bin/fc-cache
452Requires: /usr/bin/fc-list
453Requires: /usr/bin/fc-match
454Requires: /usr/bin/file
455Requires: /usr/bin/find
456Requires: /usr/bin/fold
457Requires: /usr/bin/foomatic-rip
458Requires: /usr/bin/gencat
459Requires: /usr/bin/getconf
460Requires: /usr/bin/groups
461Requires: /usr/bin/gs
462Requires: /usr/bin/head
463Requires: /usr/bin/iconv
464Requires: /usr/bin/id
465Requires: /usr/bin/install
466Requires: /usr/bin/ipcrm
467Requires: /usr/bin/ipcs
468Requires: /usr/bin/join
469Requires: /usr/bin/killall
470Requires: /usr/bin/locale
471Requires: /usr/bin/localedef
472Requires: /usr/bin/logger
473Requires: /usr/bin/logname
474Requires: /usr/bin/lp
475Requires: /usr/bin/lpr
476Requires: /usr/bin/m4
477Requires: /usr/bin/make
478Requires: /usr/bin/man
479Requires: /usr/bin/md5sum
480Requires: /usr/bin/mkfifo
481Requires: /usr/bin/msgfmt
482Requires: /usr/bin/newgrp
483Requires: /usr/bin/nl
484Requires: /usr/bin/nohup
485Requires: /usr/bin/od
486Requires: /usr/bin/passwd
487Requires: /usr/bin/paste
488Requires: /usr/bin/patch
489Requires: /usr/bin/pathchk
490Requires: /usr/bin/pax
491Requires: /usr/bin/perl
492Requires: /usr/bin/pr
493Requires: /usr/bin/printf
494Requires: /usr/bin/python
495Requires: /usr/bin/renice
496Requires: /usr/bin/split
497Requires: /usr/bin/strip
498Requires: /usr/bin/tail
499Requires: /usr/bin/tee
500Requires: /usr/bin/test
501Requires: /usr/bin/time
502Requires: /usr/bin/tr
503Requires: /usr/bin/tsort
504Requires: /usr/bin/tty
505Requires: /usr/bin/unexpand
506Requires: /usr/bin/uniq
507Requires: /usr/bin/wc
508Requires: /usr/bin/xargs
509Requires: /usr/sbin/groupadd
510Requires: /usr/sbin/groupdel
511Requires: /usr/sbin/groupmod
512Requires: /usr/sbin/sendmail
513Requires: /usr/sbin/useradd
514Requires: /usr/sbin/userdel
515Requires: /usr/sbin/usermod
516
517%description
518The Linux Standard Base (LSB) is an attempt to develop a set of
519standards that will increase compatibility among Linux distributions.
520The lsb package provides utilities needed for LSB Compliant
521Applications.  It also contains requirements that will ensure that all
522components required by the LSB that are provided by Red Hat Linux are
523installed on the system.
524
525%prep
526%setup -q -n %{name}-vine-%{version}
527
528%build
529cd lsb-release-%{upstreamlsbrelver}
530make
531
532%install
533rm -rf $RPM_BUILD_ROOT
534# LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
535mkdir -p $RPM_BUILD_ROOT%{_sysconfdir} $RPM_BUILD_ROOT/%{_lib} $RPM_BUILD_ROOT%{_mandir} \
536         $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT/usr/lib/lsb \
537         $RPM_BUILD_ROOT%{_sysconfdir}/lsb-release.d/ $RPM_BUILD_ROOT%{_sbindir}
538make DESTDIR=$RPM_BUILD_ROOT install
539cd lsb-release-%{upstreamlsbrelver}
540make mandir=$RPM_BUILD_ROOT/%{_mandir} prefix=$RPM_BUILD_ROOT/%{_prefix} install
541cd ..
542touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-%{archname}
543touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-noarch
544touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-%{archname}
545touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-noarch
546# and claim LSB 3.1 is supported as well
547touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-%{archname}
548touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-noarch
549touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-%{archname}
550touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-noarch
551
552for LSBVER in %{lsbsover}; do
553  ln -s %{ldso} $RPM_BUILD_ROOT/%{_lib}/%{lsbldso}.$LSBVER
554done
555
556mkdir -p $RPM_BUILD_ROOT/bin
557
558# LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
559# According to the lsb-core documentation provided by
560# http://refspecs.linux-foundation.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic.pdf
561# it's OK to put non binary in /usr/lib.
562ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/install_initd
563ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/remove_initd
564ln -snf mail $RPM_BUILD_ROOT/bin/mailx
565
566gcc $RPM_OPT_FLAGS -Os -static -o lsb_vine_trigger{.%{_target_cpu},.c} -DLSBSOVER='"%{lsbsover}"' \
567  -DLDSO='"%{ldso}"' -DLSBLDSO='"/%{_lib}/%{lsbldso}"' -D_GNU_SOURCE
568install -m 700 lsb_vine_trigger.%{_target_cpu} \
569  $RPM_BUILD_ROOT%{_sbindir}/lsb_vine_trigger.%{_target_cpu}
570
571cp -p lsb_vine_init $RPM_BUILD_ROOT/bin/lsb_vine_init
572
573%clean
574rm -rf $RPM_BUILD_ROOT
575
576%triggerpostun -- glibc
577if [ -x /usr/sbin/lsb_vine_trigger.%{_target_cpu} ]; then
578  /usr/sbin/lsb_vine_trigger.%{_target_cpu}
579fi
580
581%ifnarch %{ix86}
582  /sbin/sln %{ldso} /%{_lib}/%{lsbldso} || :
583%else
584  if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
585    for LSBVER in %{lsbsover}; do
586      /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
587    done
588  else
589    for LSBVER in %{lsbsover}; do
590      /sbin/sln %{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
591    done
592  fi
593%endif
594
595%ifarch %{ix86}
596%post
597# make this softlink again for /emul
598  if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
599    for LSBVER in %{lsbsover}; do
600      /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
601    done
602  fi
603%endif
604
605%files
606#/usr/X11R6/lib/X11/fonts
607#/usr/X11R6/lib/X11/rgb.txt
608%defattr(-,root,root)
609%{_sysconfdir}/lsb-vine
610%dir %{_sysconfdir}/lsb-release.d
611# These files are needed because they shows which LSB we're supporting now,
612# for example, if core-3.1-noarch exists, it means we are supporting LSB3.1 now
613%{_sysconfdir}/lsb-release.d/*
614%{_mandir}/*/*
615%{_bindir}/*
616/bin/lsb_vine_init
617/usr/lib/lsb
618/%{_lib}/*so*
619/lib/lsb*
620%{_sbindir}/lsb_vine_trigger.%{_target_cpu}
621/bin/mailx
622
623%changelog
624* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-1
625- initial build for Vine Linux
626
627* Thu Aug 28 2008 Hao Liu <hliu@redhat.com> 3.2-2
628- Modify "Requires: /usr/bin/mailx" to "Requires: mailx" (Bug #460249)
629
630* Wed Aug 18 2008 Hao Liu <hliu@redhat.com> 3.2-1
631- Port forward to LSB 3.2
632- Remove symlink for mailx if user is upgrading from the redhat-lsb of older version
633- Since F10 put mailx under /usr/bin, change the corresponding requires
634
635* Thu Aug 5 2008 Hao Liu <hliu@redhat.com> - 3.1-22
636- Remove 2 requires which provided by redhat-lsb
637- Add comments explaining why hard-coded path is kept
638- Resolve some hard-coded path problems
639- Add comments explaining why importing '-static' option while compiling redhat_lsb_trigger
640- Replace %{_libdir}/lsb with /usr/lib/lsb
641- Replace /%{_lib}/* with /%{_lib}/*so*
642- Replace /lib/lsb with /lib/lsb*
643
644* Thu Jul 31 2008 Lawrence Lim <llim@redhat.com> - 3.1-21
645- remove symlink for mailx (Bug #457241)
646
647* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.1-20
648- Autorebuild for GCC 4.3
649
650* Wed Oct 3 2007 Lawrence Lim <llim@redhat.com> - 3.1-19
651- fix build issue on ppc - (.opd+0x10): multiple definition of `__libc_start_main'
652
653* Fri Sep 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-18
654- fix build issue in minimal build root (Bug #265241)
655
656* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 3.1-17
657- Rebuild for selinux ppc32 issue.
658
659* Fri Aug 20 2007 Lawrence Lim <llim@redhat.com> - 3.1-16
660- update spec file in accordance to feedback provided through merge review - merge-review.patch - #226363
661
662* Wed Jul 18 2007 Lawrence Lim <llim@redhat.com> - 3.1-15.f8
663- Resolved: #239842 - /lib/lsb/init-functions shall use aliases but not functions
664- forward port the patch from 3.1-12.3.EL which fix #217566, #233530, #240916
665
666* Wed May 2 2007 Lawrence Lim <llim@redhat.com> - 3.1-14.fc7
667- fixed Bug 232918 for new glibc version
668
669* Wed Feb 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-13
670- fixed Bug 226363
671
672* Wed Nov 29 2006 Lawrence Lim <llim@redhat.com> - 3.1-12
673- replaced aliases with functions in /lib/lsb/init-functions; Bug 217566
674
675* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 3.1-11
676- rebuilt for unwind info generation, broken in gcc-4.1.1-21
677
678* Thu Sep 21 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.3
679- Fix upgrade issue; Bug 202548
680
681* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1-10.2.1
682- rebuild
683
684* Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.2
685- for some strange reason, ld-lsb-x86-64.so need to be ld-lsb-x86-64.so.3 (LSB3.0) rather than ld-lsb-x86-64.so.3.1 (LSB3.1)
686
687* Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.1
688- generate spec file on RHEL5-Alpha system
689- fix vsw4 test suite setup by creating symlink for X11 SecurityPolicy and XFontPath
690
691* Thu Jun 22 2006 Lawrence Lim <llim@redhat.com> - 3.0-10
692- Rewrite most part of the mkredhat-lsb to obtain information directly via specdb
693  rather than sniffing through sgml
694- remove redundent script and bump up tarball version
695
696* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.2
697- bump again for double-long bug on ppc(64)
698
699* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.1
700- rebuilt for new gcc4.1 snapshot and glibc changes
701
702* Fri Jan 13 2006 Leon Ho <llch@redhat.com> 3.0-9
703- Migrated back to rawhide
704
705* Wed Aug  3 2005 Leon Ho <llch@redhat.com> 3.0-8.EL
706- Added libstdc++.so.6/libGL.so.1 requirement (RH#154605)
707
708* Wed Aug  3 2005 Leon Ho <llch@redhat.com> 3.0-7.EL
709- Fixed multilib problem on lsb_release not to read /etc/lsb-release and solely
710  depends on /etc/lsb-release.d/ (Advised by LSB committee)
711- Removed /etc/lsb-release (Advised by LSB committee)
712
713* Mon Aug  1 2005 Leon Ho <llch@redhat.com> 3.0-6.EL
714- Made the /etc/lsb-release useful (RH#154605)
715- Added redhat_lsb_trigger to fix RH#160585 (Jakub Jelinek)
716- Fixed AMD64 base libraries requirement parsing (RH#154605)
717
718* Tue Jul 26 2005 Leon Ho <llch@redhat.com> 3.0-5.EL
719- Fixed redhat-lsb's mkredhat-lsb on fetching lib and
720  cmd requirements
721
722* Mon Jul 18 2005 Leon Ho <llch@redhat.com> 3.0-4.EL
723- Rebuilt
724
725* Tue Jul 05 2005 Leon Ho <llch@redhat.com> 3.0-3.EL
726- Disabled support for LSB 1.3 and 2.0
727
728* Mon Jun 20 2005 Leon Ho <llch@redhat.com> 3.0-2.EL
729- Upgraded to lsb-release 2.0
730
731* Thu Jun 09 2005 Leon Ho <llch@redhat.com> 3.0-1.EL
732- Moved to LSB 3.0
733
734* Wed Apr 13 2005 Leon Ho <llch@redhat.com> 1.3-10
735- Fixed ix86 package with ia32 emul support
736
737* Tue Feb 01 2005 Leon Ho <llch@redhat.com> 1.3-9
738- Sync what we have changed on the branches
739  Wed Nov 24 2004 Harald Hoyer <harald@redhat.com>
740  - added post section to recreate the softlink in emul mode (bug 140739)
741  Mon Nov 15 2004 Phil Knirsch <pknirsch@redhat.com>
742  Tiny correction of bug in new triggers
743
744* Mon Jan 24 2005 Leon Ho <llch@redhat.com> 1.3-8
745- Add support provide on lsb-core-* for each arch
746
747* Fri Jan 21 2005 Leon Ho <llch@redhat.com> 1.3-7
748- Add to support multiple LSB test suite version
749- Add %%endif in trigger postun
750
751* Thu Nov 11 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-6
752- Fixed invalid sln call for trigger in postun on ia64 (#137647)
753
754* Mon Aug 09 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-4
755- Bump release and rebuilt for RHEL4.
756
757* Thu Jul 24 2003 Matt Wilson <msw@redhat.com> 1.3-3
758- fix lsb ld.so name for ia64 (#100613)
759
760* Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
761- use /usr/lib/lsb for install_initd, remove_initd
762
763* Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
764- add ia64 x86_64 ppc ppc64 s390 s390x
765
766* Tue Feb 18 2003 Matt Wilson <msw@redhat.com> 1.3-1
767- 1.3
768
769* Wed Sep  4 2002 Matt Wilson <msw@redhat.com>
770- 1.2.0
771
772* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
773- automated rebuild
774
775* Thu May 23 2002 Tim Powers <timp@redhat.com>
776- automated rebuild
777
778* Wed Mar 27 2002 Matt Wilson <msw@redhat.com>
779- addeed trigger on glibc to re-establish the ld-lsb.so.1 symlink in the
780  forced downgrade case.
781
782* Tue Mar 12 2002 Bill Nottingham <notting@redhat.com>
783- add initscripts support
784
785* Thu Jan 24 2002 Matt Wilson <msw@redhat.com>
786- Initial build.
787
Note: See TracBrowser for help on using the repository browser.