source: projects/specs/trunk/l/lsb/lsb-vl.spec @ 4089

Revision 4089, 23.1 KB checked in by daisuke, 13 years ago (diff)

lsb: update to 4.0

Line 
1# Define this to link to which library version  eg. /lib64/ld-lsb-x86-64.so.3
2%define lsbsover 3
3
4%ifarch %{ix86}
5%define ldso ld-linux.so.2
6%define lsbldso ld-lsb.so
7%endif
8
9%ifarch ia64
10%define ldso ld-linux-ia64.so.2
11%define lsbldso ld-lsb-ia64.so
12%endif
13
14%ifarch ppc
15%define ldso ld.so.1
16%define lsbldso ld-lsb-ppc32.so
17%endif
18
19%ifarch ppc64
20%define ldso ld64.so.1
21%define lsbldso ld-lsb-ppc64.so
22%endif
23
24%ifarch s390
25%define ldso ld.so.1
26%define lsbldso ld-lsb-s390.so
27%endif
28
29%ifarch s390x
30%define ldso ld64.so.1
31%define lsbldso ld-lsb-s390x.so
32%endif
33
34%ifarch x86_64
35%define ldso ld-linux-x86-64.so.2
36%define lsbldso ld-lsb-x86-64.so
37%endif
38
39%ifarch ia64 ppc64 s390x x86_64
40%define qual ()(64bit)
41%else
42%define qual %{nil}
43%endif
44
45%define upstreamlsbrelver 2.0
46%define lsbrelver 4.0
47%define srcrelease 1
48
49Summary: LSB support for Vine Linux
50Summary(ja): Vine Linux の LSB サポート
51Name: lsb
52Version: 4.0
53Release: 1%{?_dist_release}
54URL: http://www.linuxfoundation.org/
55Source0: %{name}-vine-%{version}.tar.bz2
56License: GPLv2
57Group: System Environment/Base
58BuildRoot: %{_tmppath}/%{name}-root
59# dependency for primary LSB application for v1.3
60Provides: lsb = %{version}
61# dependency for primary LSB application for v2.0, v3.0 and v4.0
62%ifarch %{ix86}
63%define archname ia32
64%endif
65%ifarch ia64
66%define archname ia64
67%endif
68%ifarch ppc
69%define archname ppc32
70%endif
71%ifarch ppc64
72%define archname ppc64
73%endif
74%ifarch s390
75%define archname s390
76%endif
77%ifarch s390x
78%define archname s390x
79%endif
80%ifarch x86_64
81%define archname amd64
82%endif
83Provides: lsb-core-%{archname} = %{version}
84Provides: lsb-graphics-%{archname} = %{version}
85Provides: lsb-core-noarch = %{version}
86Provides: lsb-graphics-noarch = %{version}
87Provides: lsb-printing-%{archname} = %{version}
88Provides: lsb-printing-noarch = %{version}
89
90ExclusiveArch: %{ix86} ia64 x86_64 ppc ppc64 s390 s390x
91
92%ifarch %{ix86}
93# archLSB IA32 Base Libraries
94Requires: libatk-1.0.so.0
95Requires: libc.so.6
96Requires: libcrypt.so.1
97Requires: libdl.so.2
98Requires: libgcc_s.so.1
99Requires: libgdk-x11-2.0.so.0
100Requires: libgdk_pixbuf-2.0.so.0
101Requires: libgdk_pixbuf_xlib-2.0.so.0
102Requires: libglib-2.0.so.0
103Requires: libgmodule-2.0.so.0
104Requires: libgobject-2.0.so.0
105Requires: libgthread-2.0.so.0
106Requires: libgtk-x11-2.0.so.0
107Requires: libm.so.6
108Requires: libncurses.so.5
109Requires: libpango-1.0.so.0
110Requires: libpangoft2-1.0.so.0
111Requires: libpangoxft-1.0.so.0
112Requires: libpthread.so.0
113Requires: libqt-mt.so.3
114Requires: libQtCore.so.4
115Requires: libQtGui.so.4
116Requires: libQtNetwork.so.4
117Requires: libQtOpenGL.so.4
118Requires: libQtSql.so.4
119Requires: libQtSvg.so.4
120Requires: libQtXml.so.4
121Requires: libstdc++.so.6
122Requires: libutil.so.1
123Requires: libz.so.1
124%endif
125
126%ifarch ia64
127# archLSB IA64 Base Libraries
128Requires: libatk-1.0.so.0()(64bit)
129Requires: libc.so.6.1()(64bit)
130Requires: libcrypt.so.1()(64bit)
131Requires: libdl.so.2()(64bit)
132Requires: libgcc_s.so.1()(64bit)
133Requires: libgdk-x11-2.0.so.0()(64bit)
134Requires: libgdk_pixbuf-2.0.so.0()(64bit)
135Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
136Requires: libglib-2.0.so.0()(64bit)
137Requires: libgmodule-2.0.so.0()(64bit)
138Requires: libgobject-2.0.so.0()(64bit)
139Requires: libgthread-2.0.so.0()(64bit)
140Requires: libgtk-x11-2.0.so.0()(64bit)
141Requires: libm.so.6.1()(64bit)
142Requires: libncurses.so.5()(64bit)
143Requires: libpango-1.0.so.0()(64bit)
144Requires: libpangoft2-1.0.so.0()(64bit)
145Requires: libpangoxft-1.0.so.0()(64bit)
146Requires: libpthread.so.0()(64bit)
147Requires: libqt-mt.so.3()(64bit)
148Requires: libQtCore.so.4()(64bit)
149Requires: libQtGui.so.4()(64bit)
150Requires: libQtNetwork.so.4()(64bit)
151Requires: libQtOpenGL.so.4()(64bit)
152Requires: libQtSql.so.4()(64bit)
153Requires: libQtSvg.so.4()(64bit)
154Requires: libQtXml.so.4()(64bit)
155Requires: libstdc++.so.6()(64bit)
156Requires: libutil.so.1()(64bit)
157Requires: libz.so.1()(64bit)
158%endif
159
160%ifarch ppc
161# archLSB PPC32 Base Libraries
162Requires: libatk-1.0.so.0
163Requires: libc.so.6
164Requires: libcrypt.so.1
165Requires: libdl.so.2
166Requires: libgcc_s.so.1
167Requires: libgdk-x11-2.0.so.0
168Requires: libgdk_pixbuf-2.0.so.0
169Requires: libgdk_pixbuf_xlib-2.0.so.0
170Requires: libglib-2.0.so.0
171Requires: libgmodule-2.0.so.0
172Requires: libgobject-2.0.so.0
173Requires: libgthread-2.0.so.0
174Requires: libgtk-x11-2.0.so.0
175Requires: libm.so.6
176Requires: libncurses.so.5
177Requires: libpango-1.0.so.0
178Requires: libpangoft2-1.0.so.0
179Requires: libpangoxft-1.0.so.0
180Requires: libpthread.so.0
181Requires: libqt-mt.so.3
182Requires: libQtCore.so.4
183Requires: libQtGui.so.4
184Requires: libQtNetwork.so.4
185Requires: libQtOpenGL.so.4
186Requires: libQtSql.so.4
187Requires: libQtSvg.so.4
188Requires: libQtXml.so.4
189Requires: libstdc++.so.6
190Requires: libutil.so.1
191Requires: libz.so.1
192%endif
193
194%ifarch ppc64
195# archLSB PPC64 Base Libraries
196Requires: libatk-1.0.so.0()(64bit)
197Requires: libc.so.6()(64bit)
198Requires: libcrypt.so.1()(64bit)
199Requires: libdl.so.2()(64bit)
200Requires: libgcc_s.so.1()(64bit)
201Requires: libgdk-x11-2.0.so.0()(64bit)
202Requires: libgdk_pixbuf-2.0.so.0()(64bit)
203Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
204Requires: libglib-2.0.so.0()(64bit)
205Requires: libgmodule-2.0.so.0()(64bit)
206Requires: libgobject-2.0.so.0()(64bit)
207Requires: libgthread-2.0.so.0()(64bit)
208Requires: libgtk-x11-2.0.so.0()(64bit)
209Requires: libm.so.6()(64bit)
210Requires: libncurses.so.5()(64bit)
211Requires: libpango-1.0.so.0()(64bit)
212Requires: libpangoft2-1.0.so.0()(64bit)
213Requires: libpangoxft-1.0.so.0()(64bit)
214Requires: libpthread.so.0()(64bit)
215Requires: libqt-mt.so.3()(64bit)
216Requires: libQtCore.so.4()(64bit)
217Requires: libQtGui.so.4()(64bit)
218Requires: libQtNetwork.so.4()(64bit)
219Requires: libQtOpenGL.so.4()(64bit)
220Requires: libQtSql.so.4()(64bit)
221Requires: libQtSvg.so.4()(64bit)
222Requires: libQtXml.so.4()(64bit)
223Requires: libstdc++.so.6()(64bit)
224Requires: libutil.so.1()(64bit)
225Requires: libz.so.1()(64bit)
226%endif
227
228%ifarch s390
229# archLSB S390 Base Libraries
230Requires: libatk-1.0.so.0
231Requires: libc.so.6
232Requires: libcrypt.so.1
233Requires: libdl.so.2
234Requires: libgcc_s.so.1
235Requires: libgdk-x11-2.0.so.0
236Requires: libgdk_pixbuf-2.0.so.0
237Requires: libgdk_pixbuf_xlib-2.0.so.0
238Requires: libglib-2.0.so.0
239Requires: libgmodule-2.0.so.0
240Requires: libgobject-2.0.so.0
241Requires: libgthread-2.0.so.0
242Requires: libgtk-x11-2.0.so.0
243Requires: libm.so.6
244Requires: libncurses.so.5
245Requires: libpango-1.0.so.0
246Requires: libpangoft2-1.0.so.0
247Requires: libpangoxft-1.0.so.0
248Requires: libpthread.so.0
249Requires: libqt-mt.so.3
250Requires: libQtCore.so.4
251Requires: libQtGui.so.4
252Requires: libQtNetwork.so.4
253Requires: libQtOpenGL.so.4
254Requires: libQtSql.so.4
255Requires: libQtSvg.so.4
256Requires: libQtXml.so.4
257Requires: libstdc++.so.6
258Requires: libutil.so.1
259Requires: libz.so.1
260%endif
261
262%ifarch s390x
263# archLSB S390X Base Libraries
264Requires: libatk-1.0.so.0()(64bit)
265Requires: libc.so.6()(64bit)
266Requires: libcrypt.so.1()(64bit)
267Requires: libdl.so.2()(64bit)
268Requires: libgcc_s.so.1()(64bit)
269Requires: libgdk-x11-2.0.so.0()(64bit)
270Requires: libgdk_pixbuf-2.0.so.0()(64bit)
271Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
272Requires: libglib-2.0.so.0()(64bit)
273Requires: libgmodule-2.0.so.0()(64bit)
274Requires: libgobject-2.0.so.0()(64bit)
275Requires: libgthread-2.0.so.0()(64bit)
276Requires: libgtk-x11-2.0.so.0()(64bit)
277Requires: libm.so.6()(64bit)
278Requires: libncurses.so.5()(64bit)
279Requires: libpango-1.0.so.0()(64bit)
280Requires: libpangoft2-1.0.so.0()(64bit)
281Requires: libpangoxft-1.0.so.0()(64bit)
282Requires: libpthread.so.0()(64bit)
283Requires: libqt-mt.so.3()(64bit)
284Requires: libQtCore.so.4()(64bit)
285Requires: libQtGui.so.4()(64bit)
286Requires: libQtNetwork.so.4()(64bit)
287Requires: libQtOpenGL.so.4()(64bit)
288Requires: libQtSql.so.4()(64bit)
289Requires: libQtSvg.so.4()(64bit)
290Requires: libQtXml.so.4()(64bit)
291Requires: libstdc++.so.6()(64bit)
292Requires: libutil.so.1()(64bit)
293Requires: libz.so.1()(64bit)
294%endif
295
296%ifarch x86_64
297# archLSB AMD64 Base Libraries
298Requires: libatk-1.0.so.0()(64bit)
299Requires: libc.so.6()(64bit)
300Requires: libcrypt.so.1()(64bit)
301Requires: libdl.so.2()(64bit)
302Requires: libgcc_s.so.1()(64bit)
303Requires: libgdk-x11-2.0.so.0()(64bit)
304Requires: libgdk_pixbuf-2.0.so.0()(64bit)
305Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
306Requires: libglib-2.0.so.0()(64bit)
307Requires: libgmodule-2.0.so.0()(64bit)
308Requires: libgobject-2.0.so.0()(64bit)
309Requires: libgthread-2.0.so.0()(64bit)
310Requires: libgtk-x11-2.0.so.0()(64bit)
311Requires: libm.so.6()(64bit)
312Requires: libncurses.so.5()(64bit)
313Requires: libpango-1.0.so.0()(64bit)
314Requires: libpangoft2-1.0.so.0()(64bit)
315Requires: libpangoxft-1.0.so.0()(64bit)
316Requires: libpthread.so.0()(64bit)
317Requires: libqt-mt.so.3()(64bit)
318Requires: libQtCore.so.4()(64bit)
319Requires: libQtGui.so.4()(64bit)
320Requires: libQtNetwork.so.4()(64bit)
321Requires: libQtOpenGL.so.4()(64bit)
322Requires: libQtSql.so.4()(64bit)
323Requires: libQtSvg.so.4()(64bit)
324Requires: libQtXml.so.4()(64bit)
325Requires: libstdc++.so.6()(64bit)
326Requires: libutil.so.1()(64bit)
327Requires: libz.so.1()(64bit)
328%endif
329
330# gLSB Base/Utility/Stdc++/Graphics Libraries
331Requires: libasound.so.2%{qual}
332Requires: libatk-1.0.so.0%{qual}
333Requires: libcrypt.so.1%{qual}
334Requires: libcups.so.2%{qual}
335Requires: libcupsimage.so.2%{qual}
336Requires: libdl.so.2%{qual}
337Requires: libfontconfig.so.1%{qual}
338Requires: libfreetype.so.6%{qual}
339Requires: libgcc_s.so.1%{qual}
340Requires: libgdk-x11-2.0.so.0%{qual}
341Requires: libgdk_pixbuf-2.0.so.0%{qual}
342Requires: libgdk_pixbuf_xlib-2.0.so.0%{qual}
343Requires: libGL.so.1%{qual}
344Requires: libglib-2.0.so.0%{qual}
345Requires: libgmodule-2.0.so.0%{qual}
346Requires: libgobject-2.0.so.0%{qual}
347Requires: libgthread-2.0.so.0%{qual}
348Requires: libgtk-x11-2.0.so.0%{qual}
349Requires: libICE.so.6%{qual}
350Requires: libjpeg.so.62%{qual}
351Requires: libncurses.so.5%{qual}
352Requires: libpam.so.0%{qual}
353Requires: libpango-1.0.so.0%{qual}
354Requires: libpangoft2-1.0.so.0%{qual}
355Requires: libpangoxft-1.0.so.0%{qual}
356Requires: libpng12.so.0%{qual}
357Requires: libpthread.so.0%{qual}
358Requires: libqt-mt.so.3%{qual}
359Requires: libQtCore.so.4%{qual}
360Requires: libQtGui.so.4%{qual}
361Requires: libQtNetwork.so.4%{qual}
362Requires: libQtOpenGL.so.4%{qual}
363Requires: libQtSql.so.4%{qual}
364Requires: libQtSvg.so.4%{qual}
365Requires: libQtXml.so.4%{qual}
366Requires: librt.so.1%{qual}
367Requires: libSM.so.6%{qual}
368Requires: libstdc++.so.6%{qual}
369Requires: libutil.so.1%{qual}
370Requires: libX11.so.6%{qual}
371Requires: libXext.so.6%{qual}
372Requires: libXft.so.2%{qual}
373Requires: libXi.so.6%{qual}
374Requires: libxml2.so.2%{qual}
375Requires: libXrender.so.1%{qual}
376Requires: libXt.so.6%{qual}
377Requires: libz.so.1%{qual}
378
379# gLSB Command and Utilities
380Requires: /bin/awk
381Requires: /bin/basename
382Requires: /bin/cat
383Requires: /bin/chgrp
384Requires: /bin/chmod
385Requires: /bin/chown
386Requires: /bin/cp
387Requires: /bin/cpio
388Requires: /bin/cut
389Requires: /bin/date
390Requires: /bin/dd
391Requires: /bin/df
392Requires: /bin/dmesg
393Requires: /bin/echo
394Requires: /bin/ed
395Requires: /bin/egrep
396Requires: /bin/env
397Requires: /bin/false
398Requires: /bin/fgrep
399Requires: /bin/gettext
400Requires: /bin/grep
401Requires: /bin/gunzip
402Requires: /bin/gzip
403Requires: /bin/hostname
404Requires: /bin/kill
405Requires: /bin/ln
406Requires: /bin/ls
407Requires: mailx
408Requires: /bin/mkdir
409Requires: /bin/mknod
410Requires: /bin/mktemp
411Requires: /bin/more
412Requires: /bin/mount
413Requires: /bin/mv
414Requires: /bin/nice
415Requires: /bin/ps
416Requires: /bin/pwd
417Requires: /bin/rm
418Requires: /bin/rmdir
419Requires: /bin/sed
420Requires: /bin/sh
421Requires: /bin/sleep
422Requires: /bin/sort
423Requires: /bin/stty
424Requires: /bin/su
425Requires: /bin/sync
426Requires: /bin/tar
427Requires: /bin/touch
428Requires: /bin/true
429Requires: /bin/umount
430Requires: /bin/uname
431Requires: /bin/zcat
432Requires: /sbin/fuser
433Requires: /sbin/pidof
434Requires: /sbin/shutdown
435Requires: /usr/bin/[
436Requires: /usr/bin/ar
437Requires: /usr/bin/at
438Requires: /usr/bin/batch
439Requires: /usr/bin/bc
440Requires: /usr/bin/chfn
441Requires: /usr/bin/chsh
442Requires: /usr/bin/cksum
443Requires: /usr/bin/cmp
444Requires: /usr/bin/col
445Requires: /usr/bin/comm
446Requires: /usr/bin/crontab
447Requires: /usr/bin/csplit
448Requires: /usr/bin/diff
449Requires: /usr/bin/dirname
450Requires: /usr/bin/du
451Requires: /usr/bin/expand
452Requires: /usr/bin/expr
453Requires: /usr/bin/fc-cache
454Requires: /usr/bin/fc-list
455Requires: /usr/bin/fc-match
456Requires: /usr/bin/file
457Requires: /usr/bin/find
458Requires: /usr/bin/fold
459Requires: /usr/bin/foomatic-rip
460Requires: /usr/bin/gencat
461Requires: /usr/bin/getconf
462Requires: /usr/bin/groups
463Requires: /usr/bin/gs
464Requires: /usr/bin/head
465Requires: /usr/bin/iconv
466Requires: /usr/bin/id
467Requires: /usr/bin/install
468Requires: /usr/bin/ipcrm
469Requires: /usr/bin/ipcs
470Requires: /usr/bin/join
471Requires: /usr/bin/killall
472Requires: /usr/bin/locale
473Requires: /usr/bin/localedef
474Requires: /usr/bin/logger
475Requires: /usr/bin/logname
476Requires: /usr/bin/lp
477Requires: /usr/bin/lpr
478Requires: /usr/bin/m4
479Requires: /usr/bin/make
480Requires: /usr/bin/man
481Requires: /usr/bin/md5sum
482Requires: /usr/bin/mkfifo
483Requires: /usr/bin/msgfmt
484Requires: /usr/bin/newgrp
485Requires: /usr/bin/nl
486Requires: /usr/bin/nohup
487Requires: /usr/bin/od
488Requires: /usr/bin/passwd
489Requires: /usr/bin/paste
490Requires: /usr/bin/patch
491Requires: /usr/bin/pathchk
492Requires: /usr/bin/pax
493Requires: /usr/bin/perl
494Requires: /usr/bin/pr
495Requires: /usr/bin/printf
496Requires: /usr/bin/python
497Requires: /usr/bin/renice
498Requires: /usr/bin/split
499Requires: /usr/bin/strip
500Requires: /usr/bin/tail
501Requires: /usr/bin/tee
502Requires: /usr/bin/test
503Requires: /usr/bin/time
504Requires: /usr/bin/tr
505Requires: /usr/bin/tsort
506Requires: /usr/bin/tty
507Requires: /usr/bin/unexpand
508Requires: /usr/bin/uniq
509Requires: /usr/bin/wc
510Requires: /usr/bin/xargs
511Requires: /usr/sbin/groupadd
512Requires: /usr/sbin/groupdel
513Requires: /usr/sbin/groupmod
514Requires: /usr/sbin/sendmail
515Requires: /usr/sbin/useradd
516Requires: /usr/sbin/userdel
517Requires: /usr/sbin/usermod
518
519%description
520The Linux Standard Base (LSB) is an attempt to develop a set of
521standards that will increase compatibility among Linux distributions.
522The lsb package provides utilities needed for LSB Compliant
523Applications.  It also contains requirements that will ensure that all
524components required by the LSB that are provided by Red Hat Linux are
525installed on the system.
526
527%prep
528%setup -q -n %{name}-vine-%{version}
529
530%build
531cd lsb-release-%{upstreamlsbrelver}
532make
533
534%install
535rm -rf $RPM_BUILD_ROOT
536# LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
537mkdir -p $RPM_BUILD_ROOT%{_sysconfdir} $RPM_BUILD_ROOT/%{_lib} $RPM_BUILD_ROOT%{_mandir} \
538         $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT/usr/lib/lsb \
539         $RPM_BUILD_ROOT%{_sysconfdir}/lsb-release.d/ $RPM_BUILD_ROOT%{_sbindir}
540make DESTDIR=$RPM_BUILD_ROOT install
541cd lsb-release-%{upstreamlsbrelver}
542make mandir=$RPM_BUILD_ROOT/%{_mandir} prefix=$RPM_BUILD_ROOT/%{_prefix} install
543cd ..
544touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-4.0-%{archname}
545touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-4.0-noarch
546touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-4.0-%{archname}
547touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-4.0-noarch
548touch $RPM_BUILD_ROOT/etc/lsb-release.d/printing-4.0-%{archname}
549touch $RPM_BUILD_ROOT/etc/lsb-release.d/printing-4.0-noarch
550# and claim LSB 3.1/3.2 is supported as well
551touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-%{archname}
552touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-noarch
553touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-%{archname}
554touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-noarch
555touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-%{archname}
556touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-noarch
557touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-%{archname}
558touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-noarch
559
560for LSBVER in %{lsbsover}; do
561  ln -s %{ldso} $RPM_BUILD_ROOT/%{_lib}/%{lsbldso}.$LSBVER
562done
563
564mkdir -p $RPM_BUILD_ROOT/bin
565
566# LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
567# According to the lsb-core documentation provided by
568# http://refspecs.linux-foundation.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic.pdf
569# it's OK to put non binary in /usr/lib.
570ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/install_initd
571ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/remove_initd
572ln -snf mail $RPM_BUILD_ROOT/bin/mailx
573
574gcc $RPM_OPT_FLAGS -Os -static -o lsb_vine_trigger{.%{_target_cpu},.c} -DLSBSOVER='"%{lsbsover}"' \
575  -DLDSO='"%{ldso}"' -DLSBLDSO='"/%{_lib}/%{lsbldso}"' -D_GNU_SOURCE
576install -m 700 lsb_vine_trigger.%{_target_cpu} \
577  $RPM_BUILD_ROOT%{_sbindir}/lsb_vine_trigger.%{_target_cpu}
578
579cp -p lsb_vine_init $RPM_BUILD_ROOT/bin/lsb_vine_init
580
581%clean
582rm -rf $RPM_BUILD_ROOT
583
584%triggerpostun -- glibc
585if [ -x /usr/sbin/lsb_vine_trigger.%{_target_cpu} ]; then
586  /usr/sbin/lsb_vine_trigger.%{_target_cpu}
587fi
588
589%ifnarch %{ix86}
590  /sbin/sln %{ldso} /%{_lib}/%{lsbldso} || :
591%else
592  if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
593    for LSBVER in %{lsbsover}; do
594      /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
595    done
596  else
597    for LSBVER in %{lsbsover}; do
598      /sbin/sln %{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
599    done
600  fi
601%endif
602
603%ifarch %{ix86}
604%post
605# make this softlink again for /emul
606  if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
607    for LSBVER in %{lsbsover}; do
608      /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
609    done
610  fi
611%endif
612
613%files
614%defattr(-,root,root)
615%{_sysconfdir}/lsb-vine
616%dir %{_sysconfdir}/lsb-release.d
617%{_sysconfdir}/lsb-release.d/*
618%{_mandir}/*/*
619%{_bindir}/*
620/bin/lsb_vine_init
621/usr/lib/lsb
622/%{_lib}/*so*
623/lib/lsb*
624%{_sbindir}/lsb_vine_trigger.%{_target_cpu}
625/bin/mailx
626
627%changelog
628* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-1
629- update to LSB4.0
630- provide lsb-printing{,-noarch}
631
632* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-1
633- initial build for Vine Linux
634
635* Thu Aug 28 2008 Hao Liu <hliu@redhat.com> 3.2-2
636- Modify "Requires: /usr/bin/mailx" to "Requires: mailx" (Bug #460249)
637
638* Wed Aug 18 2008 Hao Liu <hliu@redhat.com> 3.2-1
639- Port forward to LSB 3.2
640- Remove symlink for mailx if user is upgrading from the redhat-lsb of older version
641- Since F10 put mailx under /usr/bin, change the corresponding requires
642
643* Thu Aug 5 2008 Hao Liu <hliu@redhat.com> - 3.1-22
644- Remove 2 requires which provided by redhat-lsb
645- Add comments explaining why hard-coded path is kept
646- Resolve some hard-coded path problems
647- Add comments explaining why importing '-static' option while compiling redhat_lsb_trigger
648- Replace %{_libdir}/lsb with /usr/lib/lsb
649- Replace /%{_lib}/* with /%{_lib}/*so*
650- Replace /lib/lsb with /lib/lsb*
651
652* Thu Jul 31 2008 Lawrence Lim <llim@redhat.com> - 3.1-21
653- remove symlink for mailx (Bug #457241)
654
655* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.1-20
656- Autorebuild for GCC 4.3
657
658* Wed Oct 3 2007 Lawrence Lim <llim@redhat.com> - 3.1-19
659- fix build issue on ppc - (.opd+0x10): multiple definition of `__libc_start_main'
660
661* Fri Sep 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-18
662- fix build issue in minimal build root (Bug #265241)
663
664* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 3.1-17
665- Rebuild for selinux ppc32 issue.
666
667* Fri Aug 20 2007 Lawrence Lim <llim@redhat.com> - 3.1-16
668- update spec file in accordance to feedback provided through merge review - merge-review.patch - #226363
669
670* Wed Jul 18 2007 Lawrence Lim <llim@redhat.com> - 3.1-15.f8
671- Resolved: #239842 - /lib/lsb/init-functions shall use aliases but not functions
672- forward port the patch from 3.1-12.3.EL which fix #217566, #233530, #240916
673
674* Wed May 2 2007 Lawrence Lim <llim@redhat.com> - 3.1-14.fc7
675- fixed Bug 232918 for new glibc version
676
677* Wed Feb 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-13
678- fixed Bug 226363
679
680* Wed Nov 29 2006 Lawrence Lim <llim@redhat.com> - 3.1-12
681- replaced aliases with functions in /lib/lsb/init-functions; Bug 217566
682
683* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 3.1-11
684- rebuilt for unwind info generation, broken in gcc-4.1.1-21
685
686* Thu Sep 21 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.3
687- Fix upgrade issue; Bug 202548
688
689* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1-10.2.1
690- rebuild
691
692* Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.2
693- for some strange reason, ld-lsb-x86-64.so need to be ld-lsb-x86-64.so.3 (LSB3.0) rather than ld-lsb-x86-64.so.3.1 (LSB3.1)
694
695* Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.1
696- generate spec file on RHEL5-Alpha system
697- fix vsw4 test suite setup by creating symlink for X11 SecurityPolicy and XFontPath
698
699* Thu Jun 22 2006 Lawrence Lim <llim@redhat.com> - 3.0-10
700- Rewrite most part of the mkredhat-lsb to obtain information directly via specdb
701  rather than sniffing through sgml
702- remove redundent script and bump up tarball version
703
704* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.2
705- bump again for double-long bug on ppc(64)
706
707* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.1
708- rebuilt for new gcc4.1 snapshot and glibc changes
709
710* Fri Jan 13 2006 Leon Ho <llch@redhat.com> 3.0-9
711- Migrated back to rawhide
712
713* Wed Aug  3 2005 Leon Ho <llch@redhat.com> 3.0-8.EL
714- Added libstdc++.so.6/libGL.so.1 requirement (RH#154605)
715
716* Wed Aug  3 2005 Leon Ho <llch@redhat.com> 3.0-7.EL
717- Fixed multilib problem on lsb_release not to read /etc/lsb-release and solely
718  depends on /etc/lsb-release.d/ (Advised by LSB committee)
719- Removed /etc/lsb-release (Advised by LSB committee)
720
721* Mon Aug  1 2005 Leon Ho <llch@redhat.com> 3.0-6.EL
722- Made the /etc/lsb-release useful (RH#154605)
723- Added redhat_lsb_trigger to fix RH#160585 (Jakub Jelinek)
724- Fixed AMD64 base libraries requirement parsing (RH#154605)
725
726* Tue Jul 26 2005 Leon Ho <llch@redhat.com> 3.0-5.EL
727- Fixed redhat-lsb's mkredhat-lsb on fetching lib and
728  cmd requirements
729
730* Mon Jul 18 2005 Leon Ho <llch@redhat.com> 3.0-4.EL
731- Rebuilt
732
733* Tue Jul 05 2005 Leon Ho <llch@redhat.com> 3.0-3.EL
734- Disabled support for LSB 1.3 and 2.0
735
736* Mon Jun 20 2005 Leon Ho <llch@redhat.com> 3.0-2.EL
737- Upgraded to lsb-release 2.0
738
739* Thu Jun 09 2005 Leon Ho <llch@redhat.com> 3.0-1.EL
740- Moved to LSB 3.0
741
742* Wed Apr 13 2005 Leon Ho <llch@redhat.com> 1.3-10
743- Fixed ix86 package with ia32 emul support
744
745* Tue Feb 01 2005 Leon Ho <llch@redhat.com> 1.3-9
746- Sync what we have changed on the branches
747  Wed Nov 24 2004 Harald Hoyer <harald@redhat.com>
748  - added post section to recreate the softlink in emul mode (bug 140739)
749  Mon Nov 15 2004 Phil Knirsch <pknirsch@redhat.com>
750  Tiny correction of bug in new triggers
751
752* Mon Jan 24 2005 Leon Ho <llch@redhat.com> 1.3-8
753- Add support provide on lsb-core-* for each arch
754
755* Fri Jan 21 2005 Leon Ho <llch@redhat.com> 1.3-7
756- Add to support multiple LSB test suite version
757- Add %%endif in trigger postun
758
759* Thu Nov 11 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-6
760- Fixed invalid sln call for trigger in postun on ia64 (#137647)
761
762* Mon Aug 09 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-4
763- Bump release and rebuilt for RHEL4.
764
765* Thu Jul 24 2003 Matt Wilson <msw@redhat.com> 1.3-3
766- fix lsb ld.so name for ia64 (#100613)
767
768* Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
769- use /usr/lib/lsb for install_initd, remove_initd
770
771* Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
772- add ia64 x86_64 ppc ppc64 s390 s390x
773
774* Tue Feb 18 2003 Matt Wilson <msw@redhat.com> 1.3-1
775- 1.3
776
777* Wed Sep  4 2002 Matt Wilson <msw@redhat.com>
778- 1.2.0
779
780* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
781- automated rebuild
782
783* Thu May 23 2002 Tim Powers <timp@redhat.com>
784- automated rebuild
785
786* Wed Mar 27 2002 Matt Wilson <msw@redhat.com>
787- addeed trigger on glibc to re-establish the ld-lsb.so.1 symlink in the
788  forced downgrade case.
789
790* Tue Mar 12 2002 Bill Nottingham <notting@redhat.com>
791- add initscripts support
792
793* Thu Jan 24 2002 Matt Wilson <msw@redhat.com>
794- Initial build.
795
Note: See TracBrowser for help on using the repository browser.