source: projects/specs/trunk/l/lsb/lsb-vl.spec @ 12273

Revision 12273, 18.7 KB checked in by tomop, 5 years ago (diff)

updated 7 packages

cups-filters-1.25.11-1

icu-65.1-2

lsb-4.0-5

openjpeg2-2.3.1-2

poppler-data-0.4.9-1

poppler-0.81.0-2

poppler061-0.61.1-2

Line 
1# Define this to link to which library version  eg. /lib64/ld-lsb-x86-64.so.3
2%define lsbsover 3
3
4%ifarch %{ix86}
5%define ldso ld-linux.so.2
6%define lsbldso ld-lsb.so
7%endif
8
9%ifarch ia64
10%define ldso ld-linux-ia64.so.2
11%define lsbldso ld-lsb-ia64.so
12%endif
13
14%ifarch ppc
15%define ldso ld.so.1
16%define lsbldso ld-lsb-ppc32.so
17%endif
18
19%ifarch ppc64
20%define ldso ld64.so.1
21%define lsbldso ld-lsb-ppc64.so
22%endif
23
24%ifarch s390
25%define ldso ld.so.1
26%define lsbldso ld-lsb-s390.so
27%endif
28
29%ifarch s390x
30%define ldso ld64.so.1
31%define lsbldso ld-lsb-s390x.so
32%endif
33
34%ifarch x86_64
35%define ldso ld-linux-x86-64.so.2
36%define lsbldso ld-lsb-x86-64.so
37%endif
38
39%ifarch ia64 ppc64 s390x x86_64
40%define qual ()(64bit)
41%else
42%define qual %{nil}
43%endif
44
45%define upstreamlsbrelver 2.0
46%define lsbrelver 4.0
47%define srcrelease 1
48
49Summary: LSB support for Vine Linux
50Summary(ja): Vine Linux の LSB サポート
51Name: lsb
52Version: 4.0
53Release: 5%{?_dist_release}
54URL: http://www.linuxfoundation.org/
55Source0: %{name}-vine-%{version}.tar.bz2
56License: GPLv2
57Group: System Environment/Base
58BuildRoot: %{_tmppath}/%{name}-root
59BuildRequires: glibc-static
60# dependency for primary LSB application for v1.3
61Provides: lsb = %{version}
62# dependency for primary LSB application for v2.0, v3.0 and v4.0
63%ifarch %{ix86}
64%define archname ia32
65%endif
66%ifarch ia64
67%define archname ia64
68%endif
69%ifarch ppc
70%define archname ppc32
71%endif
72%ifarch ppc64
73%define archname ppc64
74%endif
75%ifarch s390
76%define archname s390
77%endif
78%ifarch s390x
79%define archname s390x
80%endif
81%ifarch x86_64
82%define archname amd64
83%endif
84Provides: lsb-core-%{archname} = %{version}
85Provides: lsb-graphics-%{archname} = %{version}
86Provides: lsb-core-noarch = %{version}
87Provides: lsb-graphics-noarch = %{version}
88Provides: lsb-printing-%{archname} = %{version}
89Provides: lsb-printing-noarch = %{version}
90
91ExclusiveArch: %{ix86} ia64 x86_64 ppc ppc64 s390 s390x
92
93%ifarch %{ix86}
94# archLSB IA32 Base Libraries
95Requires: libatk-1.0.so.0
96Requires: libc.so.6
97Requires: libcrypt.so.1
98Requires: libdl.so.2
99Requires: libgcc_s.so.1
100Requires: libgdk-x11-2.0.so.0
101Requires: libgdk_pixbuf-2.0.so.0
102Requires: libgdk_pixbuf_xlib-2.0.so.0
103Requires: libglib-2.0.so.0
104Requires: libgmodule-2.0.so.0
105Requires: libgobject-2.0.so.0
106Requires: libgthread-2.0.so.0
107Requires: libgtk-x11-2.0.so.0
108Requires: libm.so.6
109Requires: libncurses.so.5
110Requires: libpango-1.0.so.0
111Requires: libpangoft2-1.0.so.0
112Requires: libpangoxft-1.0.so.0
113Requires: libpthread.so.0
114#Requires: libqt-mt.so.3
115Requires: libQtCore.so.4
116Requires: libQtGui.so.4
117Requires: libQtNetwork.so.4
118Requires: libQtOpenGL.so.4
119Requires: libQtSql.so.4
120Requires: libQtSvg.so.4
121Requires: libQtXml.so.4
122Requires: libstdc++.so.6
123Requires: libutil.so.1
124Requires: libz.so.1
125%endif
126
127%ifarch x86_64
128# archLSB AMD64 Base Libraries
129Requires: libatk-1.0.so.0()(64bit)
130Requires: libc.so.6()(64bit)
131Requires: libcrypt.so.1()(64bit)
132Requires: libdl.so.2()(64bit)
133Requires: libgcc_s.so.1()(64bit)
134Requires: libgdk-x11-2.0.so.0()(64bit)
135Requires: libgdk_pixbuf-2.0.so.0()(64bit)
136Requires: libgdk_pixbuf_xlib-2.0.so.0()(64bit)
137Requires: libglib-2.0.so.0()(64bit)
138Requires: libgmodule-2.0.so.0()(64bit)
139Requires: libgobject-2.0.so.0()(64bit)
140Requires: libgthread-2.0.so.0()(64bit)
141Requires: libgtk-x11-2.0.so.0()(64bit)
142Requires: libm.so.6()(64bit)
143Requires: libncurses.so.5()(64bit)
144Requires: libpango-1.0.so.0()(64bit)
145Requires: libpangoft2-1.0.so.0()(64bit)
146Requires: libpangoxft-1.0.so.0()(64bit)
147Requires: libpthread.so.0()(64bit)
148#Requires: libqt-mt.so.3()(64bit)
149Requires: libQtCore.so.4()(64bit)
150Requires: libQtGui.so.4()(64bit)
151Requires: libQtNetwork.so.4()(64bit)
152Requires: libQtOpenGL.so.4()(64bit)
153Requires: libQtSql.so.4()(64bit)
154Requires: libQtSvg.so.4()(64bit)
155Requires: libQtXml.so.4()(64bit)
156Requires: libstdc++.so.6()(64bit)
157Requires: libutil.so.1()(64bit)
158Requires: libz.so.1()(64bit)
159%endif
160
161# gLSB Base/Utility/Stdc++/Graphics Libraries
162Requires: libasound.so.2%{qual}
163Requires: libatk-1.0.so.0%{qual}
164Requires: libcrypt.so.1%{qual}
165Requires: libcups.so.2%{qual}
166Requires: libcupsimage.so.2%{qual}
167Requires: libdl.so.2%{qual}
168Requires: libfontconfig.so.1%{qual}
169Requires: libfreetype.so.6%{qual}
170Requires: libgcc_s.so.1%{qual}
171Requires: libgdk-x11-2.0.so.0%{qual}
172Requires: libgdk_pixbuf-2.0.so.0%{qual}
173Requires: libgdk_pixbuf_xlib-2.0.so.0%{qual}
174Requires: libGL.so.1%{qual}
175Requires: libglib-2.0.so.0%{qual}
176Requires: libgmodule-2.0.so.0%{qual}
177Requires: libgobject-2.0.so.0%{qual}
178Requires: libgthread-2.0.so.0%{qual}
179Requires: libgtk-x11-2.0.so.0%{qual}
180Requires: libICE.so.6%{qual}
181Requires: libjpeg.so.62%{qual}
182Requires: libncurses.so.5%{qual}
183Requires: libpam.so.0%{qual}
184Requires: libpango-1.0.so.0%{qual}
185Requires: libpangoft2-1.0.so.0%{qual}
186Requires: libpangoxft-1.0.so.0%{qual}
187Requires: libpng16.so.16%{qual}
188Requires: libpthread.so.0%{qual}
189#Requires: libqt-mt.so.3%{qual}
190Requires: libQtCore.so.4%{qual}
191Requires: libQtGui.so.4%{qual}
192Requires: libQtNetwork.so.4%{qual}
193Requires: libQtOpenGL.so.4%{qual}
194Requires: libQtSql.so.4%{qual}
195Requires: libQtSvg.so.4%{qual}
196Requires: libQtXml.so.4%{qual}
197Requires: librt.so.1%{qual}
198Requires: libSM.so.6%{qual}
199Requires: libstdc++.so.6%{qual}
200Requires: libutil.so.1%{qual}
201Requires: libX11.so.6%{qual}
202Requires: libXext.so.6%{qual}
203Requires: libXft.so.2%{qual}
204Requires: libXi.so.6%{qual}
205Requires: libxml2.so.2%{qual}
206Requires: libXrender.so.1%{qual}
207Requires: libXt.so.6%{qual}
208Requires: libz.so.1%{qual}
209
210# gLSB Command and Utilities
211Requires: /bin/awk
212Requires: /bin/basename
213Requires: /bin/cat
214Requires: /bin/chgrp
215Requires: /bin/chmod
216Requires: /bin/chown
217Requires: /bin/cp
218Requires: /bin/cpio
219Requires: /bin/cut
220Requires: /bin/date
221Requires: /bin/dd
222Requires: /bin/df
223Requires: /bin/dmesg
224Requires: /bin/echo
225Requires: /bin/ed
226Requires: /bin/egrep
227Requires: /bin/env
228Requires: /bin/false
229Requires: /bin/fgrep
230Requires: /bin/gettext
231Requires: /bin/grep
232Requires: /bin/gunzip
233Requires: /bin/gzip
234Requires: /bin/hostname
235Requires: /bin/kill
236Requires: /bin/ln
237Requires: /bin/ls
238Requires: mailx
239Requires: /bin/mkdir
240Requires: /bin/mknod
241Requires: /bin/mktemp
242Requires: /bin/more
243Requires: /bin/mount
244Requires: /bin/mv
245Requires: /bin/nice
246Requires: /bin/ps
247Requires: /bin/pwd
248Requires: /bin/rm
249Requires: /bin/rmdir
250Requires: /bin/sed
251Requires: /bin/sh
252Requires: /bin/sleep
253Requires: /bin/sort
254Requires: /bin/stty
255Requires: /bin/su
256Requires: /bin/sync
257Requires: /bin/tar
258Requires: /bin/touch
259Requires: /bin/true
260Requires: /bin/umount
261Requires: /bin/uname
262Requires: /bin/zcat
263Requires: /sbin/fuser
264Requires: /sbin/pidof
265Requires: /sbin/shutdown
266Requires: /usr/bin/[
267Requires: /usr/bin/ar
268Requires: /usr/bin/at
269Requires: /usr/bin/batch
270Requires: /usr/bin/bc
271Requires: /usr/bin/chfn
272Requires: /usr/bin/chsh
273Requires: /usr/bin/cksum
274Requires: /usr/bin/cmp
275Requires: /usr/bin/col
276Requires: /usr/bin/comm
277Requires: /usr/bin/crontab
278Requires: /usr/bin/csplit
279Requires: /usr/bin/diff
280Requires: /usr/bin/dirname
281Requires: /usr/bin/du
282Requires: /usr/bin/expand
283Requires: /usr/bin/expr
284Requires: /usr/bin/fc-cache
285Requires: /usr/bin/fc-list
286Requires: /usr/bin/fc-match
287Requires: /usr/bin/file
288Requires: /usr/bin/find
289Requires: /usr/bin/fold
290Requires: /usr/bin/foomatic-rip
291Requires: /usr/bin/gencat
292Requires: /usr/bin/getconf
293Requires: /usr/bin/groups
294Requires: /usr/bin/gs
295Requires: /usr/bin/head
296Requires: /usr/bin/iconv
297Requires: /usr/bin/id
298Requires: /usr/bin/install
299Requires: /usr/bin/ipcrm
300Requires: /usr/bin/ipcs
301Requires: /usr/bin/join
302Requires: /usr/bin/killall
303Requires: /usr/bin/locale
304Requires: /usr/bin/localedef
305Requires: /usr/bin/logger
306Requires: /usr/bin/logname
307Requires: /usr/bin/lp
308Requires: /usr/bin/lpr
309Requires: /usr/bin/m4
310Requires: /usr/bin/make
311Requires: /usr/bin/man
312Requires: /usr/bin/md5sum
313Requires: /usr/bin/mkfifo
314Requires: /usr/bin/msgfmt
315Requires: /usr/bin/newgrp
316Requires: /usr/bin/nl
317Requires: /usr/bin/nohup
318Requires: /usr/bin/od
319Requires: /usr/bin/passwd
320Requires: /usr/bin/paste
321Requires: /usr/bin/patch
322Requires: /usr/bin/pathchk
323# better POSIX compatible
324Requires: spax
325Requires: /usr/bin/perl
326Requires: /usr/bin/pr
327Requires: /usr/bin/printf
328Requires: /usr/bin/python
329Requires: /usr/bin/renice
330Requires: /usr/bin/split
331Requires: /usr/bin/strip
332Requires: /usr/bin/tail
333Requires: /usr/bin/tee
334Requires: /usr/bin/test
335Requires: /usr/bin/time
336Requires: /usr/bin/tr
337Requires: /usr/bin/tsort
338Requires: /usr/bin/tty
339Requires: /usr/bin/unexpand
340Requires: /usr/bin/uniq
341Requires: /usr/bin/wc
342Requires: /usr/bin/xargs
343Requires: /usr/sbin/groupadd
344Requires: /usr/sbin/groupdel
345Requires: /usr/sbin/groupmod
346Requires: /usr/sbin/sendmail
347Requires: /usr/sbin/useradd
348Requires: /usr/sbin/userdel
349Requires: /usr/sbin/usermod
350
351%description
352The Linux Standard Base (LSB) is an attempt to develop a set of
353standards that will increase compatibility among Linux distributions.
354The lsb package provides utilities needed for LSB Compliant
355Applications.  It also contains requirements that will ensure that all
356components required by the LSB that are provided by Red Hat Linux are
357installed on the system.
358
359%prep
360%setup -q -n %{name}-vine-%{version}
361
362%build
363cd lsb-release-%{upstreamlsbrelver}
364make
365
366%install
367rm -rf $RPM_BUILD_ROOT
368# LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
369mkdir -p $RPM_BUILD_ROOT%{_sysconfdir} $RPM_BUILD_ROOT/%{_lib} $RPM_BUILD_ROOT%{_mandir} \
370         $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT/usr/lib/lsb \
371         $RPM_BUILD_ROOT%{_sysconfdir}/lsb-release.d/ $RPM_BUILD_ROOT%{_sbindir}
372make DESTDIR=$RPM_BUILD_ROOT install
373cd lsb-release-%{upstreamlsbrelver}
374make mandir=$RPM_BUILD_ROOT/%{_mandir} prefix=$RPM_BUILD_ROOT/%{_prefix} install
375cd ..
376touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-4.0-%{archname}
377touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-4.0-noarch
378touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-4.0-%{archname}
379touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-4.0-noarch
380touch $RPM_BUILD_ROOT/etc/lsb-release.d/printing-4.0-%{archname}
381touch $RPM_BUILD_ROOT/etc/lsb-release.d/printing-4.0-noarch
382# and claim LSB 3.1/3.2 is supported as well
383touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-%{archname}
384touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.2-noarch
385touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-%{archname}
386touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.2-noarch
387touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-%{archname}
388touch $RPM_BUILD_ROOT/etc/lsb-release.d/core-3.1-noarch
389touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-%{archname}
390touch $RPM_BUILD_ROOT/etc/lsb-release.d/desktop-3.1-noarch
391
392for LSBVER in %{lsbsover}; do
393  ln -s %{ldso} $RPM_BUILD_ROOT/%{_lib}/%{lsbldso}.$LSBVER
394done
395
396mkdir -p $RPM_BUILD_ROOT/bin
397
398# LSB uses /usr/lib rather than /usr/lib64 even for 64bit OS
399# According to the lsb-core documentation provided by
400# http://refspecs.linux-foundation.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic.pdf
401# it's OK to put non binary in /usr/lib.
402ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/install_initd
403ln -snf ../../../sbin/chkconfig $RPM_BUILD_ROOT/usr/lib/lsb/remove_initd
404ln -snf mail $RPM_BUILD_ROOT/bin/mailx
405
406gcc $RPM_OPT_FLAGS -Os -static -o lsb_vine_trigger{.%{_target_cpu},.c} -DLSBSOVER='"%{lsbsover}"' \
407  -DLDSO='"%{ldso}"' -DLSBLDSO='"/%{_lib}/%{lsbldso}"' -D_GNU_SOURCE
408install -m 700 lsb_vine_trigger.%{_target_cpu} \
409  $RPM_BUILD_ROOT%{_sbindir}/lsb_vine_trigger.%{_target_cpu}
410
411cp -p lsb_vine_init $RPM_BUILD_ROOT/bin/lsb_vine_init
412
413%clean
414rm -rf $RPM_BUILD_ROOT
415
416%triggerpostun -- glibc
417if [ -x /usr/sbin/lsb_vine_trigger.%{_target_cpu} ]; then
418  /usr/sbin/lsb_vine_trigger.%{_target_cpu}
419fi
420
421%ifnarch %{ix86}
422  /sbin/sln %{ldso} /%{_lib}/%{lsbldso} || :
423%else
424  if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
425    for LSBVER in %{lsbsover}; do
426      /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
427    done
428  else
429    for LSBVER in %{lsbsover}; do
430      /sbin/sln %{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
431    done
432  fi
433%endif
434
435%ifarch %{ix86}
436%post
437# make this softlink again for /emul
438  if [ -f /emul/ia32-linux/lib/%{ldso} ]; then
439    for LSBVER in %{lsbsover}; do
440      /sbin/sln /emul/ia32-linux/lib/%{ldso} /%{_lib}/%{lsbldso}.$LSBVER || :
441    done
442  fi
443%endif
444
445%files
446%defattr(-,root,root)
447%{_sysconfdir}/lsb-vine
448%dir %{_sysconfdir}/lsb-release.d
449%{_sysconfdir}/lsb-release.d/*
450%{_mandir}/*/*
451%{_bindir}/*
452/bin/lsb_vine_init
453/usr/lib/lsb
454/%{_lib}/*so*
455/lib/lsb*
456%{_sbindir}/lsb_vine_trigger.%{_target_cpu}
457/bin/mailx
458
459%changelog
460* Mon Oct 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0-5
461- made not to require qt3.
462- removed stuff for unsuppoted architectures.
463
464* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 4.0-4
465- rebuild with gcc-5.4.0
466
467* Wed Jan 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0-3
468- change Requires: libpng16.so.16 instead of libpng12.so.0
469
470* Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.0-2
471- require spax instead of pax (more POSIX compatible)
472
473* Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-1
474- update to LSB4.0
475- add Provide lsb-printing{,-noarch}
476- add BR: glibc-static
477
478* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-1
479- initial build for Vine Linux
480
481* Thu Aug 28 2008 Hao Liu <hliu@redhat.com> 3.2-2
482- Modify "Requires: /usr/bin/mailx" to "Requires: mailx" (Bug #460249)
483
484* Mon Aug 18 2008 Hao Liu <hliu@redhat.com> 3.2-1
485- Port forward to LSB 3.2
486- Remove symlink for mailx if user is upgrading from the redhat-lsb of older version
487- Since F10 put mailx under /usr/bin, change the corresponding requires
488
489* Tue Aug 5 2008 Hao Liu <hliu@redhat.com> - 3.1-22
490- Remove 2 requires which provided by redhat-lsb
491- Add comments explaining why hard-coded path is kept
492- Resolve some hard-coded path problems
493- Add comments explaining why importing '-static' option while compiling redhat_lsb_trigger
494- Replace %{_libdir}/lsb with /usr/lib/lsb
495- Replace /%{_lib}/* with /%{_lib}/*so*
496- Replace /lib/lsb with /lib/lsb*
497
498* Thu Jul 31 2008 Lawrence Lim <llim@redhat.com> - 3.1-21
499- remove symlink for mailx (Bug #457241)
500
501* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.1-20
502- Autorebuild for GCC 4.3
503
504* Wed Oct 3 2007 Lawrence Lim <llim@redhat.com> - 3.1-19
505- fix build issue on ppc - (.opd+0x10): multiple definition of `__libc_start_main'
506
507* Fri Sep 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-18
508- fix build issue in minimal build root (Bug #265241)
509
510* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 3.1-17
511- Rebuild for selinux ppc32 issue.
512
513* Mon Aug 20 2007 Lawrence Lim <llim@redhat.com> - 3.1-16
514- update spec file in accordance to feedback provided through merge review - merge-review.patch - #226363
515
516* Wed Jul 18 2007 Lawrence Lim <llim@redhat.com> - 3.1-15.f8
517- Resolved: #239842 - /lib/lsb/init-functions shall use aliases but not functions
518- forward port the patch from 3.1-12.3.EL which fix #217566, #233530, #240916
519
520* Wed May 2 2007 Lawrence Lim <llim@redhat.com> - 3.1-14.fc7
521- fixed Bug 232918 for new glibc version
522
523* Wed Feb 21 2007 Lawrence Lim <llim@redhat.com> - 3.1-13
524- fixed Bug 226363
525
526* Wed Nov 29 2006 Lawrence Lim <llim@redhat.com> - 3.1-12
527- replaced aliases with functions in /lib/lsb/init-functions; Bug 217566
528
529* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 3.1-11
530- rebuilt for unwind info generation, broken in gcc-4.1.1-21
531
532* Thu Sep 21 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.3
533- Fix upgrade issue; Bug 202548
534
535* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1-10.2.1
536- rebuild
537
538* Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.2
539- for some strange reason, ld-lsb-x86-64.so need to be ld-lsb-x86-64.so.3 (LSB3.0) rather than ld-lsb-x86-64.so.3.1 (LSB3.1)
540
541* Thu Jul 6 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.1
542- generate spec file on RHEL5-Alpha system
543- fix vsw4 test suite setup by creating symlink for X11 SecurityPolicy and XFontPath
544
545* Thu Jun 22 2006 Lawrence Lim <llim@redhat.com> - 3.0-10
546- Rewrite most part of the mkredhat-lsb to obtain information directly via specdb
547  rather than sniffing through sgml
548- remove redundent script and bump up tarball version
549
550* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.2
551- bump again for double-long bug on ppc(64)
552
553* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.0-9.1
554- rebuilt for new gcc4.1 snapshot and glibc changes
555
556* Fri Jan 13 2006 Leon Ho <llch@redhat.com> 3.0-9
557- Migrated back to rawhide
558
559* Wed Aug  3 2005 Leon Ho <llch@redhat.com> 3.0-8.EL
560- Added libstdc++.so.6/libGL.so.1 requirement (RH#154605)
561
562* Wed Aug  3 2005 Leon Ho <llch@redhat.com> 3.0-7.EL
563- Fixed multilib problem on lsb_release not to read /etc/lsb-release and solely
564  depends on /etc/lsb-release.d/ (Advised by LSB committee)
565- Removed /etc/lsb-release (Advised by LSB committee)
566
567* Mon Aug  1 2005 Leon Ho <llch@redhat.com> 3.0-6.EL
568- Made the /etc/lsb-release useful (RH#154605)
569- Added redhat_lsb_trigger to fix RH#160585 (Jakub Jelinek)
570- Fixed AMD64 base libraries requirement parsing (RH#154605)
571
572* Tue Jul 26 2005 Leon Ho <llch@redhat.com> 3.0-5.EL
573- Fixed redhat-lsb's mkredhat-lsb on fetching lib and
574  cmd requirements
575
576* Mon Jul 18 2005 Leon Ho <llch@redhat.com> 3.0-4.EL
577- Rebuilt
578
579* Tue Jul 05 2005 Leon Ho <llch@redhat.com> 3.0-3.EL
580- Disabled support for LSB 1.3 and 2.0
581
582* Mon Jun 20 2005 Leon Ho <llch@redhat.com> 3.0-2.EL
583- Upgraded to lsb-release 2.0
584
585* Thu Jun 09 2005 Leon Ho <llch@redhat.com> 3.0-1.EL
586- Moved to LSB 3.0
587
588* Wed Apr 13 2005 Leon Ho <llch@redhat.com> 1.3-10
589- Fixed ix86 package with ia32 emul support
590
591* Tue Feb 01 2005 Leon Ho <llch@redhat.com> 1.3-9
592- Sync what we have changed on the branches
593  Wed Nov 24 2004 Harald Hoyer <harald@redhat.com>
594  - added post section to recreate the softlink in emul mode (bug 140739)
595  Mon Nov 15 2004 Phil Knirsch <pknirsch@redhat.com>
596  Tiny correction of bug in new triggers
597
598* Mon Jan 24 2005 Leon Ho <llch@redhat.com> 1.3-8
599- Add support provide on lsb-core-* for each arch
600
601* Fri Jan 21 2005 Leon Ho <llch@redhat.com> 1.3-7
602- Add to support multiple LSB test suite version
603- Add %%endif in trigger postun
604
605* Thu Nov 11 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-6
606- Fixed invalid sln call for trigger in postun on ia64 (#137647)
607
608* Mon Aug 09 2004 Phil Knirsch <pknirsch@redhat.com> 1.3-4
609- Bump release and rebuilt for RHEL4.
610
611* Thu Jul 24 2003 Matt Wilson <msw@redhat.com> 1.3-3
612- fix lsb ld.so name for ia64 (#100613)
613
614* Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
615- use /usr/lib/lsb for install_initd, remove_initd
616
617* Fri May 23 2003 Matt Wilson <msw@redhat.com> 1.3-2
618- add ia64 x86_64 ppc ppc64 s390 s390x
619
620* Tue Feb 18 2003 Matt Wilson <msw@redhat.com> 1.3-1
621- 1.3
622
623* Wed Sep  4 2002 Matt Wilson <msw@redhat.com>
624- 1.2.0
625
626* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
627- automated rebuild
628
629* Thu May 23 2002 Tim Powers <timp@redhat.com>
630- automated rebuild
631
632* Wed Mar 27 2002 Matt Wilson <msw@redhat.com>
633- addeed trigger on glibc to re-establish the ld-lsb.so.1 symlink in the
634  forced downgrade case.
635
636* Tue Mar 12 2002 Bill Nottingham <notting@redhat.com>
637- add initscripts support
638
639* Thu Jan 24 2002 Matt Wilson <msw@redhat.com>
640- Initial build.
641
Note: See TracBrowser for help on using the repository browser.