source: projects/specs/trunk/l/lighttpd/lighttpd-vl.spec @ 8121

Revision 8121, 13.3 KB checked in by iwaim, 10 years ago (diff)

lighttpd 1.4.33-1

Line 
1%define webroot /var/www/lighttpd
2
3%if %{?_dist_release} == "vl6"
4%define owneruser lighttpd
5%define ownergroup lighttpd
6%else
7%define owneruser www-data
8%define ownergroup www-data
9%endif
10
11Summary: Lightning fast webserver with light system requirements
12Summary(ja): 少ないシステムリソースで動く超高速なウェブサーバ
13Name: lighttpd
14Version: 1.4.33
15Release: 1%{?_dist_release}
16License: BSD
17Group: System Environment/Daemons
18URL: http://www.lighttpd.net/
19Source0: http://www.lighttpd.net/download/lighttpd-%{version}.tar.xz
20Source1: lighttpd.logrotate
21Source2: php.d-lighttpd.ini
22Source3: lighttpd.init
23Source10: index.html
24Source11: http://www.lighttpd.net/favicon.ico
25Source13: http://www.lighttpd.net/light_button.png
26Source14: http://www.lighttpd.net/light_logo.png
27# config file patches
28## for vl7 and later
29Patch0: lighttpd-1.4.31-vine.patch
30## for vl6
31Patch1: lighttpd-1.4.31-vine6.patch
32# security patch(es)
33Patch1001: http://download.lighttpd.net/lighttpd/security/lighttpd-1.4.33_fix_ssl_sni.patch
34BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
35Requires(pre): shadow-utils
36%if %{?_dist_release} != "vl6"
37Requires(pre): www-common
38%endif
39Requires(post): chkconfig
40Requires(preun): chkconfig
41Requires(postun): chkconfig
42BuildRequires: openssl-devel, pcre-devel, bzip2-devel, zlib-devel, gcc-c++
43%{?_with_ldap:BuildRequires: openldap-devel}
44BuildRequires: gamin-devel
45BuildRequires: gdbm-devel
46BuildRequires: lua-devel
47
48%description
49Secure, fast, compliant and very flexible web-server which has been optimized
50for high-performance environments. It has a very low memory footprint compared
51to other webservers and takes care of cpu-load. Its advanced feature-set
52(FastCGI, CGI, Auth, Output-Compression, URL-Rewriting and many more) make
53it the perfect webserver-software for every server that is suffering load
54problems.
55
56Available rpmbuild rebuild options :
57--with : memcache webdavprops ldap
58--without: lua
59
60%package mod_mysql_vhost
61Summary: Virtual host module for lighttpd that uses a MySQL database
62Group: System Environment/Daemons
63Requires: %{name} = %{version}
64BuildRequires: mysql-devel
65
66%description mod_mysql_vhost
67Virtual host module for lighttpd that uses a MySQL database.
68
69
70%package fastcgi
71Summary: FastCGI module and spawning helper for lighttpd and PHP configuration
72Group: System Environment/Daemons
73Requires: %{name} = %{version}
74Requires: spawn-fcgi
75
76%description fastcgi
77This package contains the spawn-fcgi helper for lighttpd's automatic spawning
78of local FastCGI programs. Included is also a PHP .ini file to change a few
79defaults needed for correct FastCGI behavior.
80Note that for FastCGI to work with PHP, you will most likely need to find a
81tweaked PHP package (--enable-fastcgi and --enable-discard-path added) or
82recompile PHP yourself.
83
84
85%prep
86%setup -q
87%if %{?_dist_release} == "vl6"
88%patch1 -p1 -b .vine6
89%else
90%patch0 -p1 -b .vine
91%endif
92%patch1001 -p1
93
94%build
95%configure \
96    --libdir="%{_libdir}/lighttpd" \
97    --with-mysql \
98    %{?_with_ldap:--with-ldap} \
99    --with-openssl \
100    --with-fam \
101    --with-gdbm \
102    --with-pcre \
103    %{?_with_memcache:--with-memcache} \
104    %{?_with_webdavprops:--with-webdav-props} \
105    %{?_with_webdavlocks:--with-webdav-locks} \
106    %{?!_without_lua:--with-lua}
107%{__make}
108
109
110%install
111%{__rm} -rf %{buildroot}
112%{__make} install DESTDIR=%{buildroot}
113
114# Install included init script and sysconfig entry
115%{__install} -D -p -m 0755 doc/initscripts/rc.lighttpd.redhat \
116    %{buildroot}%{_sysconfdir}/rc.d/init.d/lighttpd
117%{__install} -D -p -m 0644 doc/initscripts/sysconfig.lighttpd \
118    %{buildroot}%{_sysconfdir}/sysconfig/lighttpd
119
120# Install (*patched above*) sample config file
121%{__install} -D -p -m 0640 doc/config/lighttpd.conf \
122    %{buildroot}%{_sysconfdir}/lighttpd/lighttpd.conf
123%{__install} -D -p -m 0640 doc/config/modules.conf \
124    %{buildroot}%{_sysconfdir}/lighttpd/modules.conf
125
126mkdir -p %{buildroot}%{_sysconfdir}/lighttpd/conf.d/
127%{__install} -D -p -m 0640 doc/config/conf.d/*.conf \
128    %{buildroot}%{_sysconfdir}/lighttpd/conf.d/
129mkdir -p %{buildroot}%{_sysconfdir}/lighttpd/vhosts.d/
130%{__install} -D -p -m 0640 doc/config/vhosts.d/vhosts.template \
131    %{buildroot}%{_sysconfdir}/lighttpd/vhosts.d/
132
133# Install our own logrotate entry
134%{__install} -D -p -m 0644 %{SOURCE1} \
135    %{buildroot}%{_sysconfdir}/logrotate.d/lighttpd
136
137# Install our own php.d ini file
138%{__install} -D -p -m 0644 %{SOURCE2} \
139    %{buildroot}%{_sysconfdir}/php.d/lighttpd.ini
140
141# Install our own init script
142%{__install} -D -p -m 0755 %{SOURCE3} \
143    %{buildroot}%{_sysconfdir}/rc.d/init.d/lighttpd
144
145# Install our own default web page and images
146%{__mkdir_p} %{buildroot}%{webroot}
147%{__install} -p -m 0644 %{SOURCE10} %{SOURCE11} %{SOURCE13} \
148    %{SOURCE14} \
149    %{buildroot}%{webroot}/
150
151# Install empty log directory to include
152%{__mkdir_p} %{buildroot}%{_var}/log/lighttpd
153
154# Install empty run directory to include (for the example fastcgi socket)
155%{__mkdir_p} %{buildroot}%{_var}/run/lighttpd
156
157
158%clean
159%{__rm} -rf %{buildroot}
160
161%if %{?_dist_release} == "vl6"
162%pre
163/usr/sbin/useradd -s /sbin/nologin -M -r -d %{webroot} \
164    -c "lighttpd web server" lighttpd &>/dev/null || :
165%endif
166
167%post
168/sbin/chkconfig --add lighttpd
169
170%preun
171if [ $1 -eq 0 ]; then
172  /sbin/service lighttpd stop &>/dev/null || :
173  /sbin/chkconfig --del lighttpd
174fi
175
176%postun
177if [ $1 -ge 1 ]; then
178    /sbin/service lighttpd condrestart &>/dev/null || :
179fi
180
181
182%files
183%defattr(-, root, root, 0755)
184%doc AUTHORS NEWS COPYING README
185%doc doc/config/lighttpd.conf
186%dir %{_sysconfdir}/lighttpd/
187%config(noreplace) %{_sysconfdir}/lighttpd/lighttpd.conf
188%config(noreplace) %{_sysconfdir}/lighttpd/modules.conf
189%config(noreplace) %{_sysconfdir}/lighttpd/conf.d/*
190%config(noreplace) %{_sysconfdir}/lighttpd/vhosts.d/*
191%config(noreplace) %{_sysconfdir}/logrotate.d/lighttpd
192%config(noreplace) %{_sysconfdir}/sysconfig/lighttpd
193%{_sysconfdir}/rc.d/init.d/lighttpd
194%{_sbindir}/lighttpd
195%{_sbindir}/lighttpd-angel
196%{_libdir}/lighttpd/
197%exclude %{_libdir}/lighttpd/*.la
198%exclude %{_libdir}/lighttpd/mod_fastcgi.so
199%exclude %{_libdir}/lighttpd/mod_mysql_vhost.so
200%exclude %{_sysconfdir}/lighttpd/conf.d/fastcgi.conf
201%exclude %{_sysconfdir}/lighttpd/conf.d/mysql_vhost.conf
202%{_mandir}/man8/lighttpd.8*
203%attr(0750, %{owneruser}, %{ownergroup}) %{_var}/log/lighttpd/
204%{webroot}/
205
206%files mod_mysql_vhost
207%defattr(-, root, root, 0755)
208%dir %{_libdir}/lighttpd/
209%{_sysconfdir}/lighttpd/conf.d/mysql_vhost.conf
210%{_libdir}/lighttpd/mod_mysql_vhost.so
211
212%files fastcgi
213%defattr(-, root, root, 0755)
214%config(noreplace) %{_sysconfdir}/php.d/lighttpd.ini
215%dir %{_libdir}/lighttpd/
216%{_libdir}/lighttpd/mod_fastcgi.so
217%{_sysconfdir}/lighttpd/conf.d/fastcgi.conf
218
219
220%changelog
221* Sun Jan  5 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.33-1
222- update to 1.4.33
223- add CVE-2013-4508 patch (Patch1001)
224- require www-common without vl6
225- drop outdated mod_mysql_vhost document
226 - see upstream #2248: http://redmine.lighttpd.net/issues/2248
227- come back useradd pre script for Vine Linux 6
228
229* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.32-1
230- new upstream release
231
232* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.31-1
233- update to 1.4.31
234- build with pcre-8.31
235- require www-common, change docroot owner to www-data
236
237* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.22-2
238- rebuild with openssl-1.0.0c
239
240* Fri Jun 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
241- new upstream release
242- build with lua, add BR: lua-devel
243- update init script
244
245* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.20-2
246- rebuilt with MySQL-5.1.34.
247
248* Wed Oct 08 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.20-1
249- updated to 1.4.20 release with many bug/security fixes, including:
250  - CVE-2008-4298: fix memory leak in request header handling
251  - CVE-2008-4360: fix mod_userdir information disclosure
252  - CVE-2008-4359: fix bypassing rewrite/redirect rules with encoded urls
253  - CVE-2008-1531: fix DoS of ssl connections
254- modified Patch0 for version 1.4.20
255- add %{_sbindir}/lighttpd-angel to the filelist
256
257* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.16-1vl5
258- applied new versioning policy, spec in utf-8
259
260* Tue Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.16-0vl1
261- new upstream release
262
263* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.13-0vl1
264- initial build for Vine Linux
265
266* Wed Oct 11 2006 Matthias Saou <http://freshrpms.net/> 1.4.13-1
267- Update to 1.4.13, which contains the previous fix.
268
269* Tue Oct  3 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-3
270- Include fix for segfaults (lighttpd bug #876, changeset 1352).
271
272* Mon Sep 25 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-1
273- Update to 1.4.12 final.
274
275* Fri Sep 22 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-0.1.r1332
276- Update to latest 1.4.12 pre-release, fixes SSL issues and other bugs.
277- Update powered_by_fedora.png to the new logo.
278
279* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.4.11-2
280- FC6 rebuild.
281
282* Thu Mar  9 2006 Matthias Saou <http://freshrpms.net/> 1.4.11-1
283- Update to 1.4.11.
284
285* Mon Mar  6 2006 Matthias Saou <http://freshrpms.net/> 1.4.10-2
286- FC5 rebuild.
287
288* Wed Feb  8 2006 Matthias Saou <http://freshrpms.net/> 1.4.10-1
289- Update to 1.4.10.
290- Remove now included fix.
291
292* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 1.4.9-2
293- Add mod_fastcgi-fix patch to fix crash on backend overload.
294
295* Mon Jan 16 2006 Matthias Saou <http://freshrpms.net/> 1.4.9-1
296- Update to 1.4.9.
297
298* Wed Nov 23 2005 Matthias Saou <http://freshrpms.net/> 1.4.8-1
299- Update to 1.4.8.
300
301* Fri Nov  4 2005 Matthias Saou <http://freshrpms.net/> 1.4.7-1
302- Update to 1.4.7.
303
304* Wed Oct 12 2005 Matthias Saou <http://freshrpms.net/> 1.4.6-1
305- Update to 1.4.6.
306
307* Mon Oct  3 2005 Matthias Saou <http://freshrpms.net/> 1.4.5-1
308- Update to 1.4.5.
309- Disable gamin/fam support for now, it does not work.
310
311* Tue Sep 27 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-3
312- Update to current SVN to check if it fixes the remaining load problems.
313
314* Wed Sep 21 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-2
315- Patch to SVN 722 revision : Fixes a crash in mod_mysql_vhost and a problem
316  with keepalive and certain browsers.
317
318* Mon Sep 19 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-1
319- Update to 1.4.4 final.
320- Enable ldap auth, gdbm and gamin/fam support by default.
321
322* Thu Sep 15 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-0
323- Update to 1.4.4 pre-release (fixes another fastcgi memleak).
324- Enable lua (cml module) by default.
325- Add --with-webdav-props conditional option.
326
327* Tue Sep 13 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-2
328- Include lighttpd-1.4.3-stat_cache.patch to fix memleak.
329
330* Fri Sep  2 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-1.1
331- Rearrange the included index.html to include the new logo, button and
332  favicon from lighttpd.net.
333
334* Fri Sep  2 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-1
335- Update to 1.4.3.
336- No longer override libdir at make install stage, use DESTDIR instead, as
337  the resulting binary would now have referenced to %%{buildroot} :-(
338
339* Tue Aug 30 2005 Matthias Saou <http://freshrpms.net/> 1.4.2-1
340- Update to 1.4.2.
341
342* Mon Aug 22 2005 Matthias Saou <http://freshrpms.net/> 1.4.1-1
343- Update to 1.4.1.
344
345* Sun Aug 21 2005 Matthias Saou <http://freshrpms.net/> 1.4.0-1
346- Update to 1.4.0.
347- Add conditional of gamin, gdbm, memcache and lua options.
348
349* Mon Aug  1 2005 Matthias Saou <http://freshrpms.net/> 1.3.16-2
350- Update to 1.3.16, rebuild.
351
352* Mon Jul 18 2005 Matthias Saou <http://freshrpms.net/> 1.3.15-1
353- Update to 1.3.15.
354
355* Mon Jun 20 2005 Matthias Saou <http://freshrpms.net/> 1.3.14-1
356- Update to 1.3.14.
357
358* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.3.13-5
359- rebuild on all arches
360
361* Mon Apr  4 2005 Matthias Saou <http://freshrpms.net/> 1.3.13-4
362- Change signal sent from the logrotate script from USR1 to HUP, as that's the
363  correct one.
364
365* Fri Apr  1 2005 Michael Schwendt <mschwendt[AT]users.sf.net> 1.3.13-2
366- Include /etc/lighttpd directory.
367
368* Sun Mar  6 2005 Matthias Saou <http://freshrpms.net/> 1.3.13-1
369- Update to 1.3.13.
370
371* Wed Mar  2 2005 Matthias Saou <http://freshrpms.net/> 1.3.12-1
372- Update to 1.3.12.
373- Remove obsolete empty_cgi_handler patch.
374
375* Tue Mar  1 2005 Matthias Saou <http://freshrpms.net/> 1.3.11-2
376- Add missing defattr to sub-packages (#150018).
377
378* Mon Feb 21 2005 Matthias Saou <http://freshrpms.net/> 1.3.11-0
379- Update to 1.3.11.
380- Remove cleanconf and init.d patches (merged upstream).
381- Add empty_cgi_handler patch.
382
383* Fri Feb 18 2005 Matthias Saou <http://freshrpms.net/> 1.3.10-0
384- Split off -fastcgi sub-package.
385- Include php.d entry to set sane FastCGI defaults.
386
387* Wed Feb 16 2005 Matthias Saou <http://freshrpms.net/> 1.3.10-0
388- Spec file cleanup for freshrpms.net/Extras.
389- Compile OpenSSL support unconditionally.
390- Put modules in a subdirectory of libdir.
391- Don't include all of libdir's content to avoid debuginfo content.
392- Add optional LDAP support.
393- Add patch to change the default configuration.
394- Add dedicated lighttpd user/group creation.
395- Add logrotate entry.
396- Include a nice little default page for the default setup.
397- Split off mod_mysql_vhost sub-package, get dep only there.
398- Use webroot in /srv by default.
399- Exclude .la files, I doubt anyone will need them.
400
401* Thu Sep 30 2004 <jan@kneschke.de> 1.3.1
402- upgraded to 1.3.1
403
404* Tue Jun 29 2004 <jan@kneschke.de> 1.2.3
405- rpmlint'ed the package
406- added URL
407- added (noreplace) to start-script
408- change group to Networking/Daemon (like apache)
409
410* Sun Feb 23 2003 <jan@kneschke.de>
411- initial version
412
Note: See TracBrowser for help on using the repository browser.