source: projects/specs/trunk/l/lighttpd/lighttpd-vl.spec @ 10290

Revision 10290, 13.4 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with openssl-1.0.2

Line 
1%define webroot /var/www/lighttpd
2
3%if %{?_dist_release} == "vl6"
4%define owneruser lighttpd
5%define ownergroup lighttpd
6%else
7%define owneruser www-data
8%define ownergroup www-data
9%endif
10
11Summary: Lightning fast webserver with light system requirements
12Summary(ja): 少ないシステムリソースで動く超高速なウェブサーバ
13Name: lighttpd
14Version: 1.4.33
15Release: 2%{?_dist_release}
16License: BSD
17Group: System Environment/Daemons
18URL: http://www.lighttpd.net/
19Source0: http://www.lighttpd.net/download/lighttpd-%{version}.tar.xz
20Source1: lighttpd.logrotate
21Source2: php.d-lighttpd.ini
22Source3: lighttpd.init
23Source10: index.html
24Source11: http://www.lighttpd.net/favicon.ico
25Source13: http://www.lighttpd.net/light_button.png
26Source14: http://www.lighttpd.net/light_logo.png
27# config file patches
28## for vl7 and later
29Patch0: lighttpd-1.4.31-vine.patch
30## for vl6
31Patch1: lighttpd-1.4.31-vine6.patch
32# security patch(es)
33Patch1001: http://download.lighttpd.net/lighttpd/security/lighttpd-1.4.33_fix_ssl_sni.patch
34BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
35Requires(pre): shadow-utils
36%if %{?_dist_release} != "vl6"
37Requires(pre): www-common
38%endif
39Requires(post): chkconfig
40Requires(preun): chkconfig
41Requires(postun): chkconfig
42BuildRequires: openssl-devel, pcre-devel, bzip2-devel, zlib-devel, gcc-c++
43%{?_with_ldap:BuildRequires: openldap-devel}
44BuildRequires: gamin-devel
45BuildRequires: gdbm-devel
46BuildRequires: lua-devel
47
48%description
49Secure, fast, compliant and very flexible web-server which has been optimized
50for high-performance environments. It has a very low memory footprint compared
51to other webservers and takes care of cpu-load. Its advanced feature-set
52(FastCGI, CGI, Auth, Output-Compression, URL-Rewriting and many more) make
53it the perfect webserver-software for every server that is suffering load
54problems.
55
56Available rpmbuild rebuild options :
57--with : memcache webdavprops ldap
58--without: lua
59
60%package mod_mysql_vhost
61Summary: Virtual host module for lighttpd that uses a MySQL database
62Group: System Environment/Daemons
63Requires: %{name} = %{version}
64BuildRequires: mysql-devel
65
66%description mod_mysql_vhost
67Virtual host module for lighttpd that uses a MySQL database.
68
69
70%package fastcgi
71Summary: FastCGI module and spawning helper for lighttpd and PHP configuration
72Group: System Environment/Daemons
73Requires: %{name} = %{version}
74Requires: spawn-fcgi
75
76%description fastcgi
77This package contains the spawn-fcgi helper for lighttpd's automatic spawning
78of local FastCGI programs. Included is also a PHP .ini file to change a few
79defaults needed for correct FastCGI behavior.
80Note that for FastCGI to work with PHP, you will most likely need to find a
81tweaked PHP package (--enable-fastcgi and --enable-discard-path added) or
82recompile PHP yourself.
83
84
85%prep
86%setup -q
87%if %{?_dist_release} == "vl6"
88%patch1 -p1 -b .vine6
89%else
90%patch0 -p1 -b .vine
91%endif
92%patch1001 -p1
93
94%build
95%configure \
96    --libdir="%{_libdir}/lighttpd" \
97    --with-mysql \
98    %{?_with_ldap:--with-ldap} \
99    --with-openssl \
100    --with-fam \
101    --with-gdbm \
102    --with-pcre \
103    %{?_with_memcache:--with-memcache} \
104    %{?_with_webdavprops:--with-webdav-props} \
105    %{?_with_webdavlocks:--with-webdav-locks} \
106    %{?!_without_lua:--with-lua}
107%{__make}
108
109
110%install
111%{__rm} -rf %{buildroot}
112%{__make} install DESTDIR=%{buildroot}
113
114# Install included init script and sysconfig entry
115%{__install} -D -p -m 0755 doc/initscripts/rc.lighttpd.redhat \
116    %{buildroot}%{_sysconfdir}/rc.d/init.d/lighttpd
117%{__install} -D -p -m 0644 doc/initscripts/sysconfig.lighttpd \
118    %{buildroot}%{_sysconfdir}/sysconfig/lighttpd
119
120# Install (*patched above*) sample config file
121%{__install} -D -p -m 0640 doc/config/lighttpd.conf \
122    %{buildroot}%{_sysconfdir}/lighttpd/lighttpd.conf
123%{__install} -D -p -m 0640 doc/config/modules.conf \
124    %{buildroot}%{_sysconfdir}/lighttpd/modules.conf
125
126mkdir -p %{buildroot}%{_sysconfdir}/lighttpd/conf.d/
127%{__install} -D -p -m 0640 doc/config/conf.d/*.conf \
128    %{buildroot}%{_sysconfdir}/lighttpd/conf.d/
129mkdir -p %{buildroot}%{_sysconfdir}/lighttpd/vhosts.d/
130%{__install} -D -p -m 0640 doc/config/vhosts.d/vhosts.template \
131    %{buildroot}%{_sysconfdir}/lighttpd/vhosts.d/
132
133# Install our own logrotate entry
134%{__install} -D -p -m 0644 %{SOURCE1} \
135    %{buildroot}%{_sysconfdir}/logrotate.d/lighttpd
136
137# Install our own php.d ini file
138%{__install} -D -p -m 0644 %{SOURCE2} \
139    %{buildroot}%{_sysconfdir}/php.d/lighttpd.ini
140
141# Install our own init script
142%{__install} -D -p -m 0755 %{SOURCE3} \
143    %{buildroot}%{_sysconfdir}/rc.d/init.d/lighttpd
144
145# Install our own default web page and images
146%{__mkdir_p} %{buildroot}%{webroot}
147%{__install} -p -m 0644 %{SOURCE10} %{SOURCE11} %{SOURCE13} \
148    %{SOURCE14} \
149    %{buildroot}%{webroot}/
150
151# Install empty log directory to include
152%{__mkdir_p} %{buildroot}%{_var}/log/lighttpd
153
154# Install empty run directory to include (for the example fastcgi socket)
155%{__mkdir_p} %{buildroot}%{_var}/run/lighttpd
156
157
158%clean
159%{__rm} -rf %{buildroot}
160
161%if %{?_dist_release} == "vl6"
162%pre
163/usr/sbin/useradd -s /sbin/nologin -M -r -d %{webroot} \
164    -c "lighttpd web server" lighttpd &>/dev/null || :
165%endif
166
167%post
168/sbin/chkconfig --add lighttpd
169
170%preun
171if [ $1 -eq 0 ]; then
172  /sbin/service lighttpd stop &>/dev/null || :
173  /sbin/chkconfig --del lighttpd
174fi
175
176%postun
177if [ $1 -ge 1 ]; then
178    /sbin/service lighttpd condrestart &>/dev/null || :
179fi
180
181
182%files
183%defattr(-, root, root, 0755)
184%doc AUTHORS NEWS COPYING README
185%doc doc/config/lighttpd.conf
186%dir %{_sysconfdir}/lighttpd/
187%config(noreplace) %{_sysconfdir}/lighttpd/lighttpd.conf
188%config(noreplace) %{_sysconfdir}/lighttpd/modules.conf
189%config(noreplace) %{_sysconfdir}/lighttpd/conf.d/*
190%config(noreplace) %{_sysconfdir}/lighttpd/vhosts.d/*
191%config(noreplace) %{_sysconfdir}/logrotate.d/lighttpd
192%config(noreplace) %{_sysconfdir}/sysconfig/lighttpd
193%{_sysconfdir}/rc.d/init.d/lighttpd
194%{_sbindir}/lighttpd
195%{_sbindir}/lighttpd-angel
196%{_libdir}/lighttpd/
197%exclude %{_libdir}/lighttpd/*.la
198%exclude %{_libdir}/lighttpd/mod_fastcgi.so
199%exclude %{_libdir}/lighttpd/mod_mysql_vhost.so
200%exclude %{_sysconfdir}/lighttpd/conf.d/fastcgi.conf
201%exclude %{_sysconfdir}/lighttpd/conf.d/mysql_vhost.conf
202%{_mandir}/man8/lighttpd.8*
203%attr(0750, %{owneruser}, %{ownergroup}) %{_var}/log/lighttpd/
204%{webroot}/
205
206%files mod_mysql_vhost
207%defattr(-, root, root, 0755)
208%dir %{_libdir}/lighttpd/
209%{_sysconfdir}/lighttpd/conf.d/mysql_vhost.conf
210%{_libdir}/lighttpd/mod_mysql_vhost.so
211
212%files fastcgi
213%defattr(-, root, root, 0755)
214%config(noreplace) %{_sysconfdir}/php.d/lighttpd.ini
215%dir %{_libdir}/lighttpd/
216%{_libdir}/lighttpd/mod_fastcgi.so
217%{_sysconfdir}/lighttpd/conf.d/fastcgi.conf
218
219
220%changelog
221* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.33-2
222- rebuild with openssl-1.0.2
223
224* Sun Jan  5 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.33-1
225- update to 1.4.33
226- add CVE-2013-4508 patch (Patch1001)
227- require www-common without vl6
228- drop outdated mod_mysql_vhost document
229 - see upstream #2248: http://redmine.lighttpd.net/issues/2248
230- come back useradd pre script for Vine Linux 6
231
232* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.32-1
233- new upstream release
234
235* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.31-1
236- update to 1.4.31
237- build with pcre-8.31
238- require www-common, change docroot owner to www-data
239
240* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.22-2
241- rebuild with openssl-1.0.0c
242
243* Fri Jun 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
244- new upstream release
245- build with lua, add BR: lua-devel
246- update init script
247
248* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.20-2
249- rebuilt with MySQL-5.1.34.
250
251* Wed Oct 08 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.20-1
252- updated to 1.4.20 release with many bug/security fixes, including:
253  - CVE-2008-4298: fix memory leak in request header handling
254  - CVE-2008-4360: fix mod_userdir information disclosure
255  - CVE-2008-4359: fix bypassing rewrite/redirect rules with encoded urls
256  - CVE-2008-1531: fix DoS of ssl connections
257- modified Patch0 for version 1.4.20
258- add %{_sbindir}/lighttpd-angel to the filelist
259
260* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.16-1vl5
261- applied new versioning policy, spec in utf-8
262
263* Tue Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.16-0vl1
264- new upstream release
265
266* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.13-0vl1
267- initial build for Vine Linux
268
269* Wed Oct 11 2006 Matthias Saou <http://freshrpms.net/> 1.4.13-1
270- Update to 1.4.13, which contains the previous fix.
271
272* Tue Oct  3 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-3
273- Include fix for segfaults (lighttpd bug #876, changeset 1352).
274
275* Mon Sep 25 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-1
276- Update to 1.4.12 final.
277
278* Fri Sep 22 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-0.1.r1332
279- Update to latest 1.4.12 pre-release, fixes SSL issues and other bugs.
280- Update powered_by_fedora.png to the new logo.
281
282* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.4.11-2
283- FC6 rebuild.
284
285* Thu Mar  9 2006 Matthias Saou <http://freshrpms.net/> 1.4.11-1
286- Update to 1.4.11.
287
288* Mon Mar  6 2006 Matthias Saou <http://freshrpms.net/> 1.4.10-2
289- FC5 rebuild.
290
291* Wed Feb  8 2006 Matthias Saou <http://freshrpms.net/> 1.4.10-1
292- Update to 1.4.10.
293- Remove now included fix.
294
295* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 1.4.9-2
296- Add mod_fastcgi-fix patch to fix crash on backend overload.
297
298* Mon Jan 16 2006 Matthias Saou <http://freshrpms.net/> 1.4.9-1
299- Update to 1.4.9.
300
301* Wed Nov 23 2005 Matthias Saou <http://freshrpms.net/> 1.4.8-1
302- Update to 1.4.8.
303
304* Fri Nov  4 2005 Matthias Saou <http://freshrpms.net/> 1.4.7-1
305- Update to 1.4.7.
306
307* Wed Oct 12 2005 Matthias Saou <http://freshrpms.net/> 1.4.6-1
308- Update to 1.4.6.
309
310* Mon Oct  3 2005 Matthias Saou <http://freshrpms.net/> 1.4.5-1
311- Update to 1.4.5.
312- Disable gamin/fam support for now, it does not work.
313
314* Tue Sep 27 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-3
315- Update to current SVN to check if it fixes the remaining load problems.
316
317* Wed Sep 21 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-2
318- Patch to SVN 722 revision : Fixes a crash in mod_mysql_vhost and a problem
319  with keepalive and certain browsers.
320
321* Mon Sep 19 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-1
322- Update to 1.4.4 final.
323- Enable ldap auth, gdbm and gamin/fam support by default.
324
325* Thu Sep 15 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-0
326- Update to 1.4.4 pre-release (fixes another fastcgi memleak).
327- Enable lua (cml module) by default.
328- Add --with-webdav-props conditional option.
329
330* Tue Sep 13 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-2
331- Include lighttpd-1.4.3-stat_cache.patch to fix memleak.
332
333* Fri Sep  2 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-1.1
334- Rearrange the included index.html to include the new logo, button and
335  favicon from lighttpd.net.
336
337* Fri Sep  2 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-1
338- Update to 1.4.3.
339- No longer override libdir at make install stage, use DESTDIR instead, as
340  the resulting binary would now have referenced to %%{buildroot} :-(
341
342* Tue Aug 30 2005 Matthias Saou <http://freshrpms.net/> 1.4.2-1
343- Update to 1.4.2.
344
345* Mon Aug 22 2005 Matthias Saou <http://freshrpms.net/> 1.4.1-1
346- Update to 1.4.1.
347
348* Sun Aug 21 2005 Matthias Saou <http://freshrpms.net/> 1.4.0-1
349- Update to 1.4.0.
350- Add conditional of gamin, gdbm, memcache and lua options.
351
352* Mon Aug  1 2005 Matthias Saou <http://freshrpms.net/> 1.3.16-2
353- Update to 1.3.16, rebuild.
354
355* Mon Jul 18 2005 Matthias Saou <http://freshrpms.net/> 1.3.15-1
356- Update to 1.3.15.
357
358* Mon Jun 20 2005 Matthias Saou <http://freshrpms.net/> 1.3.14-1
359- Update to 1.3.14.
360
361* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.3.13-5
362- rebuild on all arches
363
364* Mon Apr  4 2005 Matthias Saou <http://freshrpms.net/> 1.3.13-4
365- Change signal sent from the logrotate script from USR1 to HUP, as that's the
366  correct one.
367
368* Fri Apr  1 2005 Michael Schwendt <mschwendt[AT]users.sf.net> 1.3.13-2
369- Include /etc/lighttpd directory.
370
371* Sun Mar  6 2005 Matthias Saou <http://freshrpms.net/> 1.3.13-1
372- Update to 1.3.13.
373
374* Wed Mar  2 2005 Matthias Saou <http://freshrpms.net/> 1.3.12-1
375- Update to 1.3.12.
376- Remove obsolete empty_cgi_handler patch.
377
378* Tue Mar  1 2005 Matthias Saou <http://freshrpms.net/> 1.3.11-2
379- Add missing defattr to sub-packages (#150018).
380
381* Mon Feb 21 2005 Matthias Saou <http://freshrpms.net/> 1.3.11-0
382- Update to 1.3.11.
383- Remove cleanconf and init.d patches (merged upstream).
384- Add empty_cgi_handler patch.
385
386* Fri Feb 18 2005 Matthias Saou <http://freshrpms.net/> 1.3.10-0
387- Split off -fastcgi sub-package.
388- Include php.d entry to set sane FastCGI defaults.
389
390* Wed Feb 16 2005 Matthias Saou <http://freshrpms.net/> 1.3.10-0
391- Spec file cleanup for freshrpms.net/Extras.
392- Compile OpenSSL support unconditionally.
393- Put modules in a subdirectory of libdir.
394- Don't include all of libdir's content to avoid debuginfo content.
395- Add optional LDAP support.
396- Add patch to change the default configuration.
397- Add dedicated lighttpd user/group creation.
398- Add logrotate entry.
399- Include a nice little default page for the default setup.
400- Split off mod_mysql_vhost sub-package, get dep only there.
401- Use webroot in /srv by default.
402- Exclude .la files, I doubt anyone will need them.
403
404* Thu Sep 30 2004 <jan@kneschke.de> 1.3.1
405- upgraded to 1.3.1
406
407* Tue Jun 29 2004 <jan@kneschke.de> 1.2.3
408- rpmlint'ed the package
409- added URL
410- added (noreplace) to start-script
411- change group to Networking/Daemon (like apache)
412
413* Sun Feb 23 2003 <jan@kneschke.de>
414- initial version
415
Note: See TracBrowser for help on using the repository browser.