source: projects/specs/trunk/l/lighttpd/lighttpd-vl.spec @ 12093

Revision 12093, 13.5 KB checked in by tomop, 5 years ago (diff)

lighttpd-1.4.53-1

Line 
1%define webroot /var/www/lighttpd
2
3%if %{?_dist_release} == "vl6"
4%define owneruser lighttpd
5%define ownergroup lighttpd
6%else
7%define owneruser www-data
8%define ownergroup www-data
9%endif
10
11Summary: Lightning fast webserver with light system requirements
12Summary(ja): 少ないシステムリソースで動く超高速なウェブサーバ
13Name: lighttpd
14Version: 1.4.53
15Release: 1%{?_dist_release}
16License: BSD
17Group: System Environment/Daemons
18URL: http://www.lighttpd.net/
19Source0: http://www.lighttpd.net/download/lighttpd-%{version}.tar.xz
20Source1: lighttpd.logrotate
21Source2: php.d-lighttpd.ini
22Source3: lighttpd.init
23Source4: sysconfig.lighttpd
24Source10: index.html
25Source11: http://www.lighttpd.net/favicon.ico
26Source13: http://www.lighttpd.net/light_button.png
27Source14: http://www.lighttpd.net/light_logo.png
28# config file patches
29## for vl7 and later
30Patch0: lighttpd-1.4.31-vine.patch
31## for vl6
32Patch1: lighttpd-1.4.31-vine6.patch
33# security patch(es)
34BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
35Requires(pre): shadow-utils
36%if %{?_dist_release} != "vl6"
37Requires(pre): www-common
38%endif
39Requires(post): chkconfig
40Requires(preun): chkconfig
41Requires(postun): chkconfig
42BuildRequires: openssl-devel, pcre-devel, bzip2-devel, zlib-devel, gcc-c++
43%{?_with_ldap:BuildRequires: openldap-devel}
44BuildRequires: libxcrypt-devel
45BuildRequires: gamin-devel
46BuildRequires: gdbm-devel
47BuildRequires: lua-devel
48
49%description
50Secure, fast, compliant and very flexible web-server which has been optimized
51for high-performance environments. It has a very low memory footprint compared
52to other webservers and takes care of cpu-load. Its advanced feature-set
53(FastCGI, CGI, Auth, Output-Compression, URL-Rewriting and many more) make
54it the perfect webserver-software for every server that is suffering load
55problems.
56
57Available rpmbuild rebuild options :
58--with : memcache webdavprops ldap
59--without: lua
60
61%package mod_mysql_vhost
62Summary: Virtual host module for lighttpd that uses a MySQL database
63Group: System Environment/Daemons
64Requires: %{name} = %{version}
65BuildRequires: libmariadb-devel
66
67%description mod_mysql_vhost
68Virtual host module for lighttpd that uses a MySQL database.
69
70
71%package fastcgi
72Summary: FastCGI module and spawning helper for lighttpd and PHP configuration
73Group: System Environment/Daemons
74Requires: %{name} = %{version}
75Requires: spawn-fcgi
76
77%description fastcgi
78This package contains the spawn-fcgi helper for lighttpd's automatic spawning
79of local FastCGI programs. Included is also a PHP .ini file to change a few
80defaults needed for correct FastCGI behavior.
81Note that for FastCGI to work with PHP, you will most likely need to find a
82tweaked PHP package (--enable-fastcgi and --enable-discard-path added) or
83recompile PHP yourself.
84
85
86%prep
87%setup -q
88%if %{?_dist_release} == "vl6"
89%patch1 -p1 -b .vine6
90%else
91%patch0 -p1 -b .vine
92%endif
93
94%build
95%configure \
96    --libdir="%{_libdir}/lighttpd" \
97    --with-mysql \
98    %{?_with_ldap:--with-ldap} \
99    --with-openssl \
100    --with-fam \
101    --with-gdbm \
102    --with-pcre \
103    %{?_with_memcache:--with-memcache} \
104    %{?_with_webdavprops:--with-webdav-props} \
105    %{?_with_webdavlocks:--with-webdav-locks} \
106    %{?!_without_lua:--with-lua}
107%{__make}
108
109
110%install
111%{__rm} -rf %{buildroot}
112%{__make} install DESTDIR=%{buildroot}
113
114# Install included init script and sysconfig entry
115%{__install} -D -p -m 0755 %{SOURCE3} \
116    %{buildroot}%{_sysconfdir}/rc.d/init.d/lighttpd
117%{__install} -D -p -m 0644 %{SOURCE4} \
118    %{buildroot}%{_sysconfdir}/sysconfig/lighttpd
119
120# Install (*patched above*) sample config file
121%{__install} -D -p -m 0640 doc/config/lighttpd.conf \
122    %{buildroot}%{_sysconfdir}/lighttpd/lighttpd.conf
123%{__install} -D -p -m 0640 doc/config/modules.conf \
124    %{buildroot}%{_sysconfdir}/lighttpd/modules.conf
125
126mkdir -p %{buildroot}%{_sysconfdir}/lighttpd/conf.d/
127%{__install} -D -p -m 0640 doc/config/conf.d/*.conf \
128    %{buildroot}%{_sysconfdir}/lighttpd/conf.d/
129mkdir -p %{buildroot}%{_sysconfdir}/lighttpd/vhosts.d/
130%{__install} -D -p -m 0640 doc/config/vhosts.d/vhosts.template \
131    %{buildroot}%{_sysconfdir}/lighttpd/vhosts.d/
132
133# Install our own logrotate entry
134%{__install} -D -p -m 0644 %{SOURCE1} \
135    %{buildroot}%{_sysconfdir}/logrotate.d/lighttpd
136
137# Install our own php.d ini file
138%{__install} -D -p -m 0644 %{SOURCE2} \
139    %{buildroot}%{_sysconfdir}/php.d/lighttpd.ini
140
141# Install our own init script
142%{__install} -D -p -m 0755 %{SOURCE3} \
143    %{buildroot}%{_sysconfdir}/rc.d/init.d/lighttpd
144
145# Install our own default web page and images
146%{__mkdir_p} %{buildroot}%{webroot}
147%{__install} -p -m 0644 %{SOURCE10} %{SOURCE11} %{SOURCE13} \
148    %{SOURCE14} \
149    %{buildroot}%{webroot}/
150
151# Install empty log directory to include
152%{__mkdir_p} %{buildroot}%{_var}/log/lighttpd
153
154# Install empty run directory to include (for the example fastcgi socket)
155%{__mkdir_p} %{buildroot}%{_var}/run/lighttpd
156
157
158%clean
159%{__rm} -rf %{buildroot}
160
161%if %{?_dist_release} == "vl6"
162%pre
163/usr/sbin/useradd -s /sbin/nologin -M -r -d %{webroot} \
164    -c "lighttpd web server" lighttpd &>/dev/null || :
165%endif
166
167%post
168/sbin/chkconfig --add lighttpd
169
170%preun
171if [ $1 -eq 0 ]; then
172  /sbin/service lighttpd stop &>/dev/null || :
173  /sbin/chkconfig --del lighttpd
174fi
175
176%postun
177if [ $1 -ge 1 ]; then
178    /sbin/service lighttpd condrestart &>/dev/null || :
179fi
180
181
182%files
183%defattr(-, root, root, 0755)
184%doc AUTHORS NEWS COPYING README
185%doc doc/config/lighttpd.conf
186%dir %{_sysconfdir}/lighttpd/
187%config(noreplace) %{_sysconfdir}/lighttpd/lighttpd.conf
188%config(noreplace) %{_sysconfdir}/lighttpd/modules.conf
189%config(noreplace) %{_sysconfdir}/lighttpd/conf.d/*
190%config(noreplace) %{_sysconfdir}/lighttpd/vhosts.d/*
191%config(noreplace) %{_sysconfdir}/logrotate.d/lighttpd
192%config(noreplace) %{_sysconfdir}/sysconfig/lighttpd
193%{_sysconfdir}/rc.d/init.d/lighttpd
194%{_sbindir}/lighttpd
195%{_sbindir}/lighttpd-angel
196%{_libdir}/lighttpd/
197%exclude %{_libdir}/lighttpd/*.la
198%exclude %{_libdir}/lighttpd/mod_fastcgi.so
199%exclude %{_libdir}/lighttpd/mod_mysql_vhost.so
200%exclude %{_sysconfdir}/lighttpd/conf.d/fastcgi.conf
201%exclude %{_sysconfdir}/lighttpd/conf.d/mysql_vhost.conf
202%{_mandir}/man8/lighttpd.8*
203%{_mandir}/man8/lighttpd-angel.8*
204%attr(0750, %{owneruser}, %{ownergroup}) %{_var}/log/lighttpd/
205%{webroot}/
206
207%files mod_mysql_vhost
208%defattr(-, root, root, 0755)
209%dir %{_libdir}/lighttpd/
210%{_sysconfdir}/lighttpd/conf.d/mysql_vhost.conf
211%{_libdir}/lighttpd/mod_mysql_vhost.so
212
213%files fastcgi
214%defattr(-, root, root, 0755)
215%config(noreplace) %{_sysconfdir}/php.d/lighttpd.ini
216%dir %{_libdir}/lighttpd/
217%{_libdir}/lighttpd/mod_fastcgi.so
218%{_sysconfdir}/lighttpd/conf.d/fastcgi.conf
219
220
221%changelog
222* Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.53-1
223- new upstream release.
224- added BR:libxcrypt-devel.
225- dropped Patch1001.
226
227* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.33-2
228- rebuild with openssl-1.0.2
229
230* Sun Jan  5 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.33-1
231- update to 1.4.33
232- add CVE-2013-4508 patch (Patch1001)
233- require www-common without vl6
234- drop outdated mod_mysql_vhost document
235 - see upstream #2248: http://redmine.lighttpd.net/issues/2248
236- come back useradd pre script for Vine Linux 6
237
238* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.32-1
239- new upstream release
240
241* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.31-1
242- update to 1.4.31
243- build with pcre-8.31
244- require www-common, change docroot owner to www-data
245
246* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.22-2
247- rebuild with openssl-1.0.0c
248
249* Fri Jun 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
250- new upstream release
251- build with lua, add BR: lua-devel
252- update init script
253
254* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.20-2
255- rebuilt with MySQL-5.1.34.
256
257* Wed Oct 08 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.20-1
258- updated to 1.4.20 release with many bug/security fixes, including:
259  - CVE-2008-4298: fix memory leak in request header handling
260  - CVE-2008-4360: fix mod_userdir information disclosure
261  - CVE-2008-4359: fix bypassing rewrite/redirect rules with encoded urls
262  - CVE-2008-1531: fix DoS of ssl connections
263- modified Patch0 for version 1.4.20
264- add %{_sbindir}/lighttpd-angel to the filelist
265
266* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.16-1vl5
267- applied new versioning policy, spec in utf-8
268
269* Tue Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.16-0vl1
270- new upstream release
271
272* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.13-0vl1
273- initial build for Vine Linux
274
275* Wed Oct 11 2006 Matthias Saou <http://freshrpms.net/> 1.4.13-1
276- Update to 1.4.13, which contains the previous fix.
277
278* Tue Oct  3 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-3
279- Include fix for segfaults (lighttpd bug #876, changeset 1352).
280
281* Mon Sep 25 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-1
282- Update to 1.4.12 final.
283
284* Fri Sep 22 2006 Matthias Saou <http://freshrpms.net/> 1.4.12-0.1.r1332
285- Update to latest 1.4.12 pre-release, fixes SSL issues and other bugs.
286- Update powered_by_fedora.png to the new logo.
287
288* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.4.11-2
289- FC6 rebuild.
290
291* Thu Mar  9 2006 Matthias Saou <http://freshrpms.net/> 1.4.11-1
292- Update to 1.4.11.
293
294* Mon Mar  6 2006 Matthias Saou <http://freshrpms.net/> 1.4.10-2
295- FC5 rebuild.
296
297* Wed Feb  8 2006 Matthias Saou <http://freshrpms.net/> 1.4.10-1
298- Update to 1.4.10.
299- Remove now included fix.
300
301* Wed Jan 25 2006 Matthias Saou <http://freshrpms.net/> 1.4.9-2
302- Add mod_fastcgi-fix patch to fix crash on backend overload.
303
304* Mon Jan 16 2006 Matthias Saou <http://freshrpms.net/> 1.4.9-1
305- Update to 1.4.9.
306
307* Wed Nov 23 2005 Matthias Saou <http://freshrpms.net/> 1.4.8-1
308- Update to 1.4.8.
309
310* Fri Nov  4 2005 Matthias Saou <http://freshrpms.net/> 1.4.7-1
311- Update to 1.4.7.
312
313* Wed Oct 12 2005 Matthias Saou <http://freshrpms.net/> 1.4.6-1
314- Update to 1.4.6.
315
316* Mon Oct  3 2005 Matthias Saou <http://freshrpms.net/> 1.4.5-1
317- Update to 1.4.5.
318- Disable gamin/fam support for now, it does not work.
319
320* Tue Sep 27 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-3
321- Update to current SVN to check if it fixes the remaining load problems.
322
323* Wed Sep 21 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-2
324- Patch to SVN 722 revision : Fixes a crash in mod_mysql_vhost and a problem
325  with keepalive and certain browsers.
326
327* Mon Sep 19 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-1
328- Update to 1.4.4 final.
329- Enable ldap auth, gdbm and gamin/fam support by default.
330
331* Thu Sep 15 2005 Matthias Saou <http://freshrpms.net/> 1.4.4-0
332- Update to 1.4.4 pre-release (fixes another fastcgi memleak).
333- Enable lua (cml module) by default.
334- Add --with-webdav-props conditional option.
335
336* Tue Sep 13 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-2
337- Include lighttpd-1.4.3-stat_cache.patch to fix memleak.
338
339* Fri Sep  2 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-1.1
340- Rearrange the included index.html to include the new logo, button and
341  favicon from lighttpd.net.
342
343* Fri Sep  2 2005 Matthias Saou <http://freshrpms.net/> 1.4.3-1
344- Update to 1.4.3.
345- No longer override libdir at make install stage, use DESTDIR instead, as
346  the resulting binary would now have referenced to %%{buildroot} :-(
347
348* Tue Aug 30 2005 Matthias Saou <http://freshrpms.net/> 1.4.2-1
349- Update to 1.4.2.
350
351* Mon Aug 22 2005 Matthias Saou <http://freshrpms.net/> 1.4.1-1
352- Update to 1.4.1.
353
354* Sun Aug 21 2005 Matthias Saou <http://freshrpms.net/> 1.4.0-1
355- Update to 1.4.0.
356- Add conditional of gamin, gdbm, memcache and lua options.
357
358* Mon Aug  1 2005 Matthias Saou <http://freshrpms.net/> 1.3.16-2
359- Update to 1.3.16, rebuild.
360
361* Mon Jul 18 2005 Matthias Saou <http://freshrpms.net/> 1.3.15-1
362- Update to 1.3.15.
363
364* Mon Jun 20 2005 Matthias Saou <http://freshrpms.net/> 1.3.14-1
365- Update to 1.3.14.
366
367* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.3.13-5
368- rebuild on all arches
369
370* Mon Apr  4 2005 Matthias Saou <http://freshrpms.net/> 1.3.13-4
371- Change signal sent from the logrotate script from USR1 to HUP, as that's the
372  correct one.
373
374* Fri Apr  1 2005 Michael Schwendt <mschwendt[AT]users.sf.net> 1.3.13-2
375- Include /etc/lighttpd directory.
376
377* Sun Mar  6 2005 Matthias Saou <http://freshrpms.net/> 1.3.13-1
378- Update to 1.3.13.
379
380* Wed Mar  2 2005 Matthias Saou <http://freshrpms.net/> 1.3.12-1
381- Update to 1.3.12.
382- Remove obsolete empty_cgi_handler patch.
383
384* Tue Mar  1 2005 Matthias Saou <http://freshrpms.net/> 1.3.11-2
385- Add missing defattr to sub-packages (#150018).
386
387* Mon Feb 21 2005 Matthias Saou <http://freshrpms.net/> 1.3.11-0
388- Update to 1.3.11.
389- Remove cleanconf and init.d patches (merged upstream).
390- Add empty_cgi_handler patch.
391
392* Fri Feb 18 2005 Matthias Saou <http://freshrpms.net/> 1.3.10-0
393- Split off -fastcgi sub-package.
394- Include php.d entry to set sane FastCGI defaults.
395
396* Wed Feb 16 2005 Matthias Saou <http://freshrpms.net/> 1.3.10-0
397- Spec file cleanup for freshrpms.net/Extras.
398- Compile OpenSSL support unconditionally.
399- Put modules in a subdirectory of libdir.
400- Don't include all of libdir's content to avoid debuginfo content.
401- Add optional LDAP support.
402- Add patch to change the default configuration.
403- Add dedicated lighttpd user/group creation.
404- Add logrotate entry.
405- Include a nice little default page for the default setup.
406- Split off mod_mysql_vhost sub-package, get dep only there.
407- Use webroot in /srv by default.
408- Exclude .la files, I doubt anyone will need them.
409
410* Thu Sep 30 2004 <jan@kneschke.de> 1.3.1
411- upgraded to 1.3.1
412
413* Tue Jun 29 2004 <jan@kneschke.de> 1.2.3
414- rpmlint'ed the package
415- added URL
416- added (noreplace) to start-script
417- change group to Networking/Daemon (like apache)
418
419* Sun Feb 23 2003 <jan@kneschke.de>
420- initial version
421
Note: See TracBrowser for help on using the repository browser.