source: projects/specs/trunk/l/ldns/ldns-vl.spec @ 5787

Revision 5787, 9.7 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild with python-2.7.2

Line 
1%{?!with_python:      %global with_python      1}
2%{?!enable_gost:      %global enable_gost      0}
3
4%if %{with_python}
5%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
7%endif
8
9%if %{enable_gost}
10%define subdir_conf_opt --disable-rpath --disable-static
11%else
12%define subdir_conf_opt --disable-rpath --disable-static --disable-gost
13%endif
14
15
16Summary: Lowlevel DNS(SEC) library with API
17Summary(ja): 低レベルな DNS(SEC) ライブラリと API
18Name: ldns
19Version: 1.6.10
20Release: 2%{?_dist_release}
21License: BSD
22Url: http://www.nlnetlabs.nl/%{name}/
23Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
24Group: System Environment/Libraries
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
27BuildRequires: perl, libpcap-devel
28%if %{enable_gost}
29BuildRequires: openssl-devel >= 1.0.0
30%else
31BuildRequires: openssl-devel
32%endif
33
34Requires: libpcap, openssl
35
36Distribution: Vine Linux
37Vendor: Project Vine
38Packager: iwaim
39
40%if %{with_python}
41BuildRequires:  python-devel, swig
42%endif
43
44%description
45ldns is a library with the aim to simplify DNS programing in C. All
46lowlevel DNS/DNSSEC operations are supported. We also define a higher
47level API which allows a programmer to (for instance) create or sign
48packets.
49
50%package devel
51Summary: Development package that includes the ldns header files
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56The devel package contains the ldns library and the include files
57
58%if %{with_python}
59%package python
60Summary: Python extensions for ldns
61Group: Applications/System
62Requires: %{name} = %{version}-%{release}
63
64%description python
65Python extensions for ldns
66%endif
67
68
69%prep
70%setup -q
71
72%build
73%configure --disable-rpath --disable-static \
74%if %{with_python}
75 --with-pyldns \
76%endif
77%if !%{enable_gost}
78 --disable-gost \
79%endif
80 --with-sha2
81
82(cd drill ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
83(cd examples ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
84
85make %{?_smp_mflags}
86( cd drill ; make %{?_smp_mflags} )
87( cd examples ; make %{?_smp_mflags} )
88make %{?_smp_mflags} doc
89
90%install
91rm -rf %{buildroot}
92
93make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
94make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
95
96%if %{with_python}
97# remove execute perms from python files
98chmod a-x %{buildroot}%{python_sitelib}/*py
99%endif
100
101# don't package building script in doc
102rm doc/doxyparse.pl
103#remove doc stubs
104rm -rf doc/.svn
105#remove double set of man pages
106rm -rf doc/man
107
108# remove .la files
109rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitelib}/*.la
110(cd drill ; make DESTDIR=%{buildroot} install)
111(cd examples; make DESTDIR=%{buildroot} install)
112
113%clean
114rm -rf %{buildroot}
115
116%files
117%defattr(-,root,root)
118%{_libdir}/libldns*so.*
119%{_bindir}/drill
120%{_bindir}/ldnsd
121#%{_bindir}/ldns-*
122%{_bindir}/ldns-chaos
123%{_bindir}/ldns-compare-zones
124%{_bindir}/ldns-[d-z]*
125%doc README LICENSE
126%{_mandir}/*/*
127
128%files devel
129%defattr(-,root,root,-)
130%{_libdir}/libldns*so
131%{_bindir}/ldns-config
132%dir %{_includedir}/ldns
133%{_includedir}/ldns/*.h
134%doc doc Changelog README
135
136%if %{with_python}
137%files python
138%defattr(-,root,root)
139%{python_sitelib}/*
140%endif
141
142%post -p /sbin/ldconfig
143
144%postun -p /sbin/ldconfig
145
146%changelog
147* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-2
148- rebuild with python-2.7.2
149
150* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
151- new upstream release
152
153* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
154- new upstream release
155
156* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
157- new upstream release
158
159* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
160- new upstream release
161- add enable_gost flag: default disable
162- defined subdir_conf_opt rpm macro
163
164* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
165- new upstream release
166
167* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
168- new upstream release
169- drop unnecessary installfix patch (Patch1): upstream merged
170- drop unnecessary rpathfix patch (Patch2): upstream merged
171
172* Thu Jun  3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
173- rebuild with libpcap 1.1.1 on VineSeed
174
175* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
176- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
177
178* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
179- Fix missing _ldns.so causing ldns-python to not work
180- Patch for installing ldns-python files
181- Patch for rpath in ldns-python
182- Don't install .a file for ldns-python
183
184* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
185- Upgraded to 1.6.4.
186- Added ldns-python sub package
187
188* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
189- Upgraded to 1.6.3, which has minor bugfixes
190
191* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
192- Upgraded to 1.6.2. This fixes various bugs.
193  (upstream released mostly to default with sha2 for the imminent
194   signed root, but we already enabled that in our builds)
195
196* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
197- rebuilt with new openssl
198
199* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
200- Added openssl dependancy back in, since we get more functionality
201 when using openssl. Especially in 'drill'.
202
203* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
204- Updated to 1.6.1
205
206* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
207- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
208
209* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
210- Fixed the ssl patch so it can now compile --without-ssl
211
212* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
213- Added patch to compile with --without-ssl
214- Removed openssl dependancies
215- Recompiled with --without-ssl
216
217* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
218- Updated to 1.6.0
219- (did not yet compile with --without-ssl due to compile failures)
220
221* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
222- Updated to 1.6.0
223- Compile without openssl
224
225* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
226- Memory management bug when generating a sha256 key, see:
227  https://bugzilla.redhat.com/show_bug.cgi?id=493953
228
229* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
230- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
231
232* Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
233- Updated to new version, 1.5.0 had a bug preventing
234  zone signing.
235
236* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
237- Updated to new version
238
239* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
240- fixed configure flags
241
242* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
243- rebuild with new openssl
244
245* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
246- Updated to 1.4.0
247
248* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
249- enable SHA2 functionality
250
251* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
252- re-tag (don't do builds while renaming local repo dirs)
253
254* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
255- Updated to latest release
256
257* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
258- Autorebuild for GCC 4.3
259
260* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
261- Rebuild for new libcrypto
262
263* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
264- Upgraded to 1.2.2. Removed no longer needed race workaround
265
266* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
267- Try to fix racing ln -s statements in parallel builds
268
269* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
270- Added patch for ldns-read-zone that does not put @. in RRDATA
271
272* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
273- Use install -p to work around multilib conflicts for .h files
274
275* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
276- Updated to 1.2.1
277- Removed patches that got moved into upstream
278
279* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
280- Patch for ldns-key2ds to write to stdout
281- Again remove extra set of man pages from doc
282- own /usr/include/ldns (bug 233858)
283
284* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
285- Added sha256 DS record patch to ldns-key2ds
286- Minor tweaks for proper doc/man page installation.
287- Workaround for parallel builds
288
289* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
290- Own the /usr/include/ldns directory (bug #233858)
291- Removed obsoleted patch
292- Remove files form previous libtool run accidentally packages by upstream
293
294* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
295- Commented out 1.1.0 make targets, put make 1.0.1 targets.
296
297* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
298- Fixed changelog typo in date
299- Rebuild requested for PT_GNU_HASH support from gcc
300- Did not upgrade to 1.1.0 due to compile issues on x86_64
301
302* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
303- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
304
305* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
306- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
307
308* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
309- Patched 'make clean' target to get rid of object files shipped with 1.0.0
310
311* Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
312- added a make clean for 2.3.3 since .o files were left behind upstream,
313  causing failure on ppc platform
314
315* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
316- minor cleanups
317
318* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
319- reworked for svn version
320
321* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
322- Initial version
Note: See TracBrowser for help on using the repository browser.