source: projects/specs/trunk/l/ldns/ldns-vl.spec @ 12121

Revision 12121, 10.5 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%{?!with_python:      %global with_python      1}
2%{?!enable_gost:      %global enable_gost      1}
3%{?!enable_dane:      %global enable_dane      1}
4
5%if %{enable_gost}
6%define subdir_conf_opt --disable-rpath --disable-static
7%else
8%define subdir_conf_opt --disable-rpath --disable-static --disable-gost
9%endif
10
11
12Summary: Lowlevel DNS(SEC) library with API
13Summary(ja): 低レベルな DNS(SEC) ライブラリと API
14Name: ldns
15Version: 1.7.1
16Release: 1%{?_dist_release}
17License: BSD
18Url: http://www.nlnetlabs.nl/%{name}/
19Source: https://www.nlnetlabs.nl/downloads/ldns/%{name}-%{version}.tar.gz
20Group: System Environment/Libraries
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
23BuildRequires: perl, libpcap-devel
24%if %{enable_gost}
25BuildRequires: openssl-devel >= 1.0.0
26%else
27BuildRequires: openssl-devel
28%endif
29%if %{with_python}
30BuildRequires: python-rpm-macros
31%endif
32
33Requires: libpcap, openssl
34
35Distribution: Vine Linux
36Vendor: Project Vine
37Packager: iwaim
38
39%if %{with_python}
40BuildRequires:  python-devel, swig
41%endif
42
43%description
44ldns is a library with the aim to simplify DNS programing in C. All
45lowlevel DNS/DNSSEC operations are supported. We also define a higher
46level API which allows a programmer to (for instance) create or sign
47packets.
48
49%package devel
50Summary: Development package that includes the ldns header files
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53
54%description devel
55The devel package contains the ldns library and the include files
56
57%if %{with_python}
58%package python
59Summary: Python extensions for ldns
60Group: Applications/System
61Requires: %{name} = %{version}-%{release}
62
63%description python
64Python extensions for ldns
65%endif
66
67
68%prep
69%setup -q
70
71%build
72%configure --disable-rpath --disable-static \
73%if %{with_python}
74 --with-pyldns \
75%endif
76%if !%{enable_gost}
77 --disable-gost \
78%endif
79%if !%{enable_gost}
80 --disable-dane-verify \
81%endif
82 --with-sha2
83
84make %{?_smp_mflags}
85make %{?_smp_mflags} drill
86make %{?_smp_mflags} examples
87make %{?_smp_mflags} doc
88
89%install
90rm -rf %{buildroot}
91
92mkdir -p %{buildroot}%{_libdir}/pkgconfig
93
94make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
95make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-drill
96make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-examples
97make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
98
99%if %{with_python}
100# remove execute perms from python files
101chmod a-x %{buildroot}%{python_sitearch}/*py
102%endif
103
104# don't package building script in doc
105rm doc/doxyparse.pl
106#remove doc stubs
107rm -rf doc/.svn
108#remove double set of man pages
109rm -rf doc/man
110
111# remove .la files
112rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la
113
114%clean
115rm -rf %{buildroot}
116
117%files
118%defattr(-,root,root)
119%{_libdir}/libldns*so.*
120%{_bindir}/drill
121%{_bindir}/ldnsd
122#%{_bindir}/ldns-*
123%{_bindir}/ldns-chaos
124%{_bindir}/ldns-compare-zones
125%{_bindir}/ldns-[d-z]*
126%doc README LICENSE
127%{_mandir}/*/*
128
129%files devel
130%defattr(-,root,root,-)
131%{_libdir}/libldns*so
132%{_bindir}/ldns-config
133%{_libdir}/pkgconfig/*.pc
134%dir %{_includedir}/ldns
135%{_includedir}/ldns/*.h
136%doc doc Changelog README
137
138%if %{with_python}
139%files python
140%defattr(-,root,root)
141%{python_sitearch}/*
142%endif
143
144%post -p /sbin/ldconfig
145
146%postun -p /sbin/ldconfig
147
148%changelog
149* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
150- updated to 1.7.1.
151
152* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-2
153- rebuilt with openssl-1.1.1.
154
155* Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.0-1
156- update to 1.7.0
157- add enable_dane option
158
159* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.17-2
160- rebuilt with openssl-1.0.2g.
161
162* Mon Mar  9 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.17-1
163- update to 1.6.17
164- drop 'fix compiler warnings and one uninitialized value' patch (Patch1000)
165 - upstream merged
166
167* Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.16-2
168- add 'fix compiler warnings and one uninitialized value' patch (Patch1000)
169 - from Fedora ldns-1.6.16-6.fc20
170
171* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.6.16-1
172- new upstream release
173
174* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.13-1
175- new upstream release
176- move python files to sitearch from sitelib
177
178* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-2
179- rebuild with python-2.7.2
180
181* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
182- new upstream release
183
184* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
185- new upstream release
186
187* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
188- new upstream release
189
190* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
191- new upstream release
192- add enable_gost flag: default disable
193- defined subdir_conf_opt rpm macro
194
195* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
196- new upstream release
197
198* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
199- new upstream release
200- drop unnecessary installfix patch (Patch1): upstream merged
201- drop unnecessary rpathfix patch (Patch2): upstream merged
202
203* Thu Jun  3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
204- rebuild with libpcap 1.1.1 on VineSeed
205
206* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
207- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
208
209* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
210- Fix missing _ldns.so causing ldns-python to not work
211- Patch for installing ldns-python files
212- Patch for rpath in ldns-python
213- Don't install .a file for ldns-python
214
215* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
216- Upgraded to 1.6.4.
217- Added ldns-python sub package
218
219* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
220- Upgraded to 1.6.3, which has minor bugfixes
221
222* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
223- Upgraded to 1.6.2. This fixes various bugs.
224  (upstream released mostly to default with sha2 for the imminent
225   signed root, but we already enabled that in our builds)
226
227* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
228- rebuilt with new openssl
229
230* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
231- Added openssl dependancy back in, since we get more functionality
232 when using openssl. Especially in 'drill'.
233
234* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
235- Updated to 1.6.1
236
237* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
238- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
239
240* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
241- Fixed the ssl patch so it can now compile --without-ssl
242
243* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
244- Added patch to compile with --without-ssl
245- Removed openssl dependancies
246- Recompiled with --without-ssl
247
248* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
249- Updated to 1.6.0
250- (did not yet compile with --without-ssl due to compile failures)
251
252* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
253- Updated to 1.6.0
254- Compile without openssl
255
256* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
257- Memory management bug when generating a sha256 key, see:
258  https://bugzilla.redhat.com/show_bug.cgi?id=493953
259
260* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
261- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
262
263* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
264- Updated to new version, 1.5.0 had a bug preventing
265  zone signing.
266
267* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
268- Updated to new version
269
270* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
271- fixed configure flags
272
273* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
274- rebuild with new openssl
275
276* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
277- Updated to 1.4.0
278
279* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
280- enable SHA2 functionality
281
282* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
283- re-tag (don't do builds while renaming local repo dirs)
284
285* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
286- Updated to latest release
287
288* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
289- Autorebuild for GCC 4.3
290
291* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
292- Rebuild for new libcrypto
293
294* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
295- Upgraded to 1.2.2. Removed no longer needed race workaround
296
297* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
298- Try to fix racing ln -s statements in parallel builds
299
300* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
301- Added patch for ldns-read-zone that does not put @. in RRDATA
302
303* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
304- Use install -p to work around multilib conflicts for .h files
305
306* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
307- Updated to 1.2.1
308- Removed patches that got moved into upstream
309
310* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
311- Patch for ldns-key2ds to write to stdout
312- Again remove extra set of man pages from doc
313- own /usr/include/ldns (bug 233858)
314
315* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
316- Added sha256 DS record patch to ldns-key2ds
317- Minor tweaks for proper doc/man page installation.
318- Workaround for parallel builds
319
320* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
321- Own the /usr/include/ldns directory (bug #233858)
322- Removed obsoleted patch
323- Remove files form previous libtool run accidentally packages by upstream
324
325* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
326- Commented out 1.1.0 make targets, put make 1.0.1 targets.
327
328* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
329- Fixed changelog typo in date
330- Rebuild requested for PT_GNU_HASH support from gcc
331- Did not upgrade to 1.1.0 due to compile issues on x86_64
332
333* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
334- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
335
336* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
337- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
338
339* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
340- Patched 'make clean' target to get rid of object files shipped with 1.0.0
341
342* Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
343- added a make clean for 2.3.3 since .o files were left behind upstream,
344  causing failure on ppc platform
345
346* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
347- minor cleanups
348
349* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
350- reworked for svn version
351
352* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
353- Initial version
Note: See TracBrowser for help on using the repository browser.