source: projects/specs/trunk/l/ldns/ldns-vl.spec @ 4906

Revision 4906, 9.6 KB checked in by iwaim, 13 years ago (diff)

ldns 1.6.10-1

Line 
1%{?!with_python:      %global with_python      1}
2%{?!enable_gost:      %global enable_gost      0}
3
4%if %{with_python}
5%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
7%endif
8
9%if %{enable_gost}
10%define subdir_conf_opt --disable-rpath --disable-static
11%else
12%define subdir_conf_opt --disable-rpath --disable-static --disable-gost
13%endif
14
15
16Summary: Lowlevel DNS(SEC) library with API
17Summary(ja): 低レベルな DNS(SEC) ライブラリと API
18Name: ldns
19Version: 1.6.10
20Release: 1%{?_dist_release}
21License: BSD
22Url: http://www.nlnetlabs.nl/%{name}/
23Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
24Group: System Environment/Libraries
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
27BuildRequires: perl, libpcap-devel
28%if %{enable_gost}
29BuildRequires: openssl-devel >= 1.0.0
30%else
31BuildRequires: openssl-devel
32%endif
33
34Requires: libpcap, openssl
35
36Distribution: Vine Linux
37Vendor: Project Vine
38Packager: iwaim
39
40%if %{with_python}
41BuildRequires:  python-devel, swig
42%endif
43
44%description
45ldns is a library with the aim to simplify DNS programing in C. All
46lowlevel DNS/DNSSEC operations are supported. We also define a higher
47level API which allows a programmer to (for instance) create or sign
48packets.
49
50%package devel
51Summary: Development package that includes the ldns header files
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56The devel package contains the ldns library and the include files
57
58%if %{with_python}
59%package python
60Summary: Python extensions for ldns
61Group: Applications/System
62Requires: %{name} = %{version}-%{release}
63
64%description python
65Python extensions for ldns
66%endif
67
68
69%prep
70%setup -q
71
72%build
73%configure --disable-rpath --disable-static \
74%if %{with_python}
75 --with-pyldns \
76%endif
77%if !%{enable_gost}
78 --disable-gost \
79%endif
80 --with-sha2
81
82(cd drill ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
83(cd examples ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
84
85make %{?_smp_mflags}
86( cd drill ; make %{?_smp_mflags} )
87( cd examples ; make %{?_smp_mflags} )
88make %{?_smp_mflags} doc
89
90%install
91rm -rf %{buildroot}
92
93make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
94make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
95
96%if %{with_python}
97# remove execute perms from python files
98chmod a-x %{buildroot}%{python_sitelib}/*py
99%endif
100
101# don't package building script in doc
102rm doc/doxyparse.pl
103#remove doc stubs
104rm -rf doc/.svn
105#remove double set of man pages
106rm -rf doc/man
107
108# remove .la files
109rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitelib}/*.la
110(cd drill ; make DESTDIR=%{buildroot} install)
111(cd examples; make DESTDIR=%{buildroot} install)
112
113%clean
114rm -rf %{buildroot}
115
116%files
117%defattr(-,root,root)
118%{_libdir}/libldns*so.*
119%{_bindir}/drill
120%{_bindir}/ldnsd
121#%{_bindir}/ldns-*
122%{_bindir}/ldns-chaos
123%{_bindir}/ldns-compare-zones
124%{_bindir}/ldns-[d-z]*
125%doc README LICENSE
126%{_mandir}/*/*
127
128%files devel
129%defattr(-,root,root,-)
130%{_libdir}/libldns*so
131%{_bindir}/ldns-config
132%dir %{_includedir}/ldns
133%{_includedir}/ldns/*.h
134%doc doc Changelog README
135
136%if %{with_python}
137%files python
138%defattr(-,root,root)
139%{python_sitelib}/*
140%endif
141
142%post -p /sbin/ldconfig
143
144%postun -p /sbin/ldconfig
145
146%changelog
147* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
148- new upstream release
149
150* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
151- new upstream release
152
153* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
154- new upstream release
155
156* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
157- new upstream release
158- add enable_gost flag: default disable
159- defined subdir_conf_opt rpm macro
160
161* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
162- new upstream release
163
164* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
165- new upstream release
166- drop unnecessary installfix patch (Patch1): upstream merged
167- drop unnecessary rpathfix patch (Patch2): upstream merged
168
169* Thu Jun  3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
170- rebuild with libpcap 1.1.1 on VineSeed
171
172* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
173- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
174
175* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
176- Fix missing _ldns.so causing ldns-python to not work
177- Patch for installing ldns-python files
178- Patch for rpath in ldns-python
179- Don't install .a file for ldns-python
180
181* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
182- Upgraded to 1.6.4.
183- Added ldns-python sub package
184
185* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
186- Upgraded to 1.6.3, which has minor bugfixes
187
188* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
189- Upgraded to 1.6.2. This fixes various bugs.
190  (upstream released mostly to default with sha2 for the imminent
191   signed root, but we already enabled that in our builds)
192
193* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
194- rebuilt with new openssl
195
196* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
197- Added openssl dependancy back in, since we get more functionality
198 when using openssl. Especially in 'drill'.
199
200* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
201- Updated to 1.6.1
202
203* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
204- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
205
206* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
207- Fixed the ssl patch so it can now compile --without-ssl
208
209* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
210- Added patch to compile with --without-ssl
211- Removed openssl dependancies
212- Recompiled with --without-ssl
213
214* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
215- Updated to 1.6.0
216- (did not yet compile with --without-ssl due to compile failures)
217
218* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
219- Updated to 1.6.0
220- Compile without openssl
221
222* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
223- Memory management bug when generating a sha256 key, see:
224  https://bugzilla.redhat.com/show_bug.cgi?id=493953
225
226* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
227- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
228
229* Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
230- Updated to new version, 1.5.0 had a bug preventing
231  zone signing.
232
233* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
234- Updated to new version
235
236* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
237- fixed configure flags
238
239* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
240- rebuild with new openssl
241
242* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
243- Updated to 1.4.0
244
245* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
246- enable SHA2 functionality
247
248* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
249- re-tag (don't do builds while renaming local repo dirs)
250
251* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
252- Updated to latest release
253
254* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
255- Autorebuild for GCC 4.3
256
257* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
258- Rebuild for new libcrypto
259
260* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
261- Upgraded to 1.2.2. Removed no longer needed race workaround
262
263* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
264- Try to fix racing ln -s statements in parallel builds
265
266* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
267- Added patch for ldns-read-zone that does not put @. in RRDATA
268
269* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
270- Use install -p to work around multilib conflicts for .h files
271
272* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
273- Updated to 1.2.1
274- Removed patches that got moved into upstream
275
276* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
277- Patch for ldns-key2ds to write to stdout
278- Again remove extra set of man pages from doc
279- own /usr/include/ldns (bug 233858)
280
281* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
282- Added sha256 DS record patch to ldns-key2ds
283- Minor tweaks for proper doc/man page installation.
284- Workaround for parallel builds
285
286* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
287- Own the /usr/include/ldns directory (bug #233858)
288- Removed obsoleted patch
289- Remove files form previous libtool run accidentally packages by upstream
290
291* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
292- Commented out 1.1.0 make targets, put make 1.0.1 targets.
293
294* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
295- Fixed changelog typo in date
296- Rebuild requested for PT_GNU_HASH support from gcc
297- Did not upgrade to 1.1.0 due to compile issues on x86_64
298
299* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
300- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
301
302* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
303- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
304
305* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
306- Patched 'make clean' target to get rid of object files shipped with 1.0.0
307
308* Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
309- added a make clean for 2.3.3 since .o files were left behind upstream,
310  causing failure on ppc platform
311
312* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
313- minor cleanups
314
315* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
316- reworked for svn version
317
318* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
319- Initial version
Note: See TracBrowser for help on using the repository browser.