source: projects/specs/trunk/k/kdevelop/kdevelop-vl.spec @ 6968

Revision 6968, 15.1 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Name: kdevelop
2Summary: Integrated Development Environment for C++/C
3Summary(ja): C++/C 向け統合開発環境
4Version: 4.4.0
5Release: 1%{?_dist_release}
6
7License: GPLv2
8URL: http://www.kdevelop.org/
9Group: Applications/Development
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.bz2
12
13# fixing https://bugs.kde.org/show_bug.cgi?id=236315
14Patch100: kdevelop-4.0.0-qmake_qt4.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: desktop-file-utils
18BuildRequires: gettext
19BuildRequires: kdebase-workspace-devel
20BuildRequires: kdevplatform-devel >= 1.4.0
21BuildRequires: kdelibs-devel
22BuildRequires: kdesdk-devel
23BuildRequires: soprano-devel
24BuildRequires: valgrind
25
26Requires: %{name}-libs = %{version}-%{release}
27Requires: kdevplatform >= 1.4.0
28
29#Conflicts: kdevelop
30
31%description
32The KDevelop Integrated Development Environment provides many features
33that developers need as well as providing a unified interface to programs
34like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
35
36All development tools needed for C++ programming like Compiler,
37Linker, automake and autoconf; KAppWizard, which generates complete,
38ready-to-go sample applications; Classgenerator, for creating new
39classes and integrating them into the current project; File management
40for sources, headers, documentation etc. to be included in the
41project; The creation of User-Handbooks written with SGML and the
42automatic generation of HTML-output with the KDE look and feel;
43Automatic HTML-based API-documentation for your project's classes with
44cross-references to the used libraries; Internationalization support
45for your application, allowing translators to easily add their target
46language to a project;
47
48KDevelop also includes WYSIWYG (What you see is what you get)-creation
49of user interfaces with a built-in dialog editor; Debugging your
50application by integrating KDbg; Editing of project-specific pixmaps
51with KIconEdit; The inclusion of any other program you need for
52development by adding it to the "Tools"-menu according to your
53individual needs.
54
55%package libs
56Summary: %{name} runtime libraries
57Summary(ja): %{name} のランタイムライブラリ
58Group:   System Environment/Libraries
59#Requires: %{name} = %{version}-%{release}
60Requires: kdelibs4
61
62%description libs
63%{summary}.
64
65
66%package devel
67Summary: Development files for %{name}
68Summary(ja): %{name} の開発用ファイル
69Group: Development/Libraries
70Requires: %{name}-libs = %{version}-%{release}
71
72%description devel
73%{summary}.
74
75
76%prep
77%setup -q -n kdevelop-%{version}
78#patch100 -p1 -b .qmake_qt4
79
80%build
81mkdir -p %{_target_platform}
82pushd %{_target_platform}
83%cmake \
84    -DCMAKE_BUILD_TYPE=release \
85    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
86    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
87    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
88    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
89    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
90    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
91    ..
92popd
93
94make %{?_smp_mflags} -C %{_target_platform}
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
101
102%find_lang %{name} --all-name --with-kde
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107
108%post
109touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
110
111%postun
112if [ $1 -eq 0 ] ; then
113touch --no-create %{_datadir}/icons/hicolor &> /dev/null
114gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
115update-desktop-database -q &> /dev/null
116update-mime-database %{_datadir}/mime &> /dev/null
117fi
118
119%posttrans
120gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
121update-desktop-database -q &> /dev/null
122update-mime-database %{_datadir}/mime &> /dev/null
123
124%post libs -p /sbin/ldconfig
125
126%postun libs -p /sbin/ldconfig
127
128%files -f %{name}.lang
129%defattr(-,root,root)
130%{_bindir}/*
131%config %{_datadir}/config/kdeveloprc
132%{_datadir}/applications/kde4/*.desktop
133%{_datadir}/config/kdevelop-qthelp.knsrc
134%{_datadir}/kde4/apps/kdev*/
135%{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/contents/ui/kdevelopsessions.qml
136%{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/metadata.desktop
137%{_datadir}/kde4/apps/plasma/services/org.kde.plasma.dataengine.kdevelopsessions.operations
138%{_datadir}/kde4/services/*.desktop
139%{_datadir}/icons/hicolor/*/*/*
140%{_datadir}/mime/packages/kdevelop.xml
141#{_datadir}/servicetypes/*
142#doc %{_datadir}/doc/HTML/en/*
143
144%files libs
145%defattr(-,root,root,-)
146%{_libdir}/lib*.so
147%{_libdir}/kde4/*.so
148
149%files devel
150%defattr(-,root,root,-)
151%{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
152%{_includedir}/kde4/kdevelop/
153
154
155%changelog
156* Sat Oct 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.0-1
157- new upstream release
158
159* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.1-1
160- new upstream release
161
162* Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.3-1
163- new upstream release
164
165* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-2
166- add BuildRequires: kdesdk-devel, soprano-devel
167
168* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
169- new upstream release
170
171* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
172- new upstream release
173
174* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
175- new upstream release
176- split shared libraries and header files
177
178* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
179- new upstream release
180- applied new versioning policy, spec in UTF-8
181- changed Group to Applications/Development
182
183* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
184- rebuild for VineSeed
185
186* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
187- new upstream release
188
189* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
190- rebuild for VineSeed
191
192* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
193- new upstream release
194
195* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
196- rebuild for VineSeed
197
198* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
199- new upstream release
200- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
201
202* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
203- rebuild for VineSeed
204
205* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
206- new upstream release
207
208* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
209- rebuild for VineSeed
210
211* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
212- new upstream release
213
214* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
215- rebuild for VineSeed
216
217* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
218- new upstream release
219- add BuildPrereq: apache2-devel subversion-devel
220
221* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
222- new upstream release
223
224* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
225- new upstream release
226- delete Patch0
227
228* Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
229- new upstream release
230- add Patch0
231- update %%files
232
233* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
234- rebuild for VineSeed
235
236* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
237- new upstream release
238
239* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
240- rebuild for VineSeed
241
242* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
243- new upstream release
244- add --disable-rpath to configure option
245- remove BuildPrereq: qt-static
246
247* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
248- rebuild for VineSeed
249
250* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
251- new upstream release
252- update %%files
253- add +w to %%{_prefix}/kdevbdb/*
254
255* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
256- rebuild for VineSeed
257
258* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
259- new upstream release
260- update %%files
261
262* Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
263- source upgrade
264- add BuildPrereq: qt-static
265
266* Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
267- rebuild with qt32
268
269* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
270- source upgrade
271- remove lines about vine26
272
273* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
274- source upgrade
275- add Requires: ctags
276
277* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
278- source upgrade
279- remove all patches
280- remove c references
281- add Requires: htdig
282
283* Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
284- change spec to build both VineSeed and Vine2.5/2.6
285- change configure options
286- add %%clean section
287- add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
288
289* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
290- source upgrade
291- change spec to build both VineSeed and Vine2.5/2.6
292- change configure option (add -enable--final, remove -enable--debug)
293- update %%files section
294
295* Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
296- source upgrade
297- remove patch1 (rejected)
298
299* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
300- BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
301
302* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
303- source upgrade
304- revised Source1
305- remove Patch1 and Patch4
306
307* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
308- merged with rawhide 2.1.1-3
309- clean up spec
310- add BuildPrereq: objprelink (i386 only)
311- remove Obsoletes: kdevelop-c_c++_ref
312- add BuildPrereq: autoconf252 automake15
313- There is Vine's previous changes, hacked for Vine
314 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
315  - build for VineSeed
316  - delete Epoch
317  - update Patch1 and delete Patch2
318
319* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
320- automated rebuild
321
322* Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
323- don't forcibly strip binaries
324
325* Sun Jun  2 2002 Than Ngo <than@redhat.com> 2.1.1-1
326- 2.1.1
327
328* Sun May 26 2002 Tim Powers <timp@redhat.com>
329- automated rebuild
330
331* Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
332- Use automake15
333
334* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
335- Change sonames
336
337* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
338- final
339
340* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
341- update
342
343* Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
344- update to 2.1rc3
345
346* Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
347- update to 2.1rc2
348
349* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
350- rebuild against new kdelibs
351
352* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
353- fixed Strange characters appear in the output window (bug #59217)
354- fixed return-line feed sign in Kdevelop setup tool (bug #55032)
355
356* Wed Mar  8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
357- update to 2.1beta2
358
359* Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
360- rebuild against new kdelibs
361
362* Wed Jan  9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
363- update to 2.1 beta1
364- fix build against gcc 3
365- fix some typo bugs
366- get rid of libkfile
367- update c_cpp_reference to 2.0.1
368
369* Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
370- add patch to show non lattin1 font in build-in editor correct (bug #54457)
371
372* Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
373- fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
374- backport some major bugfixes from 2.0.1
375
376* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
377- Don't crash on startup
378
379* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
380- Fix file list
381
382* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
383- Update
384
385* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
386- Yet another respin - printing was broken.
387
388* Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
389- Update the C/C++ reference guide docs. The older version had a
390  couple of examples that won't work with gcc 2.96-*
391
392* Thu Feb 22 2001 Than Ngo <than@redhat.com>
393- fix version number
394
395* Wed Feb 21 2001 Than Ngo <than@redhat.com>
396- 1.4-respin
397
398* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
399- 1.4
400
401* Wed Feb 14 2001 Than Ngo <than@redhat.com>
402- update (only bugfixes)
403- fix up kdelibs documentation path
404- fix a dependency problem with kde-i18n package (Bug #27675)
405- add qt-designer into requires
406
407* Sun Feb 11 2001 Than Ngo <than@redhat.com>
408- fixed to build on s390
409
410* Tue Feb 06 2001 Than Ngo <than@redhat.com>
411- update, only bugfixes
412
413* Wed Jan 24 2001 Than Ngo <than@redhat.com>
414- hacked for building of KDE references
415
416* Tue Jan 23 2001 Than Ngo <than@redhat.com>
417- work-around to build on alpha
418
419* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
420- Update
421
422* Wed Jan 10 2001 Than Ngo <than@redhat.com>
423- update new snapshot, only require KDE2/Qt2
424
425* Fri Dec 22 2000 Than Ngo <than@redhat.com>
426- fixed dependency problem with kde-i18n
427
428* Thu Dec 21 2000 Than Ngo <than@redhat.com>
429- updated to 1.4beta1 with KDE2 support
430- fixed to build on s390
431- fixed some broken codes
432 
433* Fri Dec 8 2000 Than Ngo <than@redhat.com>
434- fixed for building on ia64
435 
436* Wed Nov 15 2000 Than Ngo <than@redhat.com>
437- build snapshot 20001112, it works now with KDE2 and kde1-compat
438- fix libtool to build on sparc and alpha
439- don't use make -j
440 
441* Sun Aug 13 2000 Than Ngo <than@redhat.com>
442- fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
443 
444* Tue Aug 01 2000 Than Ngo <than@redhat.de>
445- add missing ldconfig in %post and %postun section (Bug #14924)
446- add missing C references stuff to kdevelop
447 
448* Sun Jul 30 2000 Than Ngo <than@redhat.de>
449- rebuilt against compat-egcs-c++, put KDE1 under /usr
450- cleanup specfile
451 
452* Tue Jul 25 2000 Than Ngo <than@redhat.de>
453- fix dependency problem
454 
455* Wed Jul 19 2000 Than Ngo <than@redhat.de>
456- rebuilt against compat-libstdc++
457 
458* Mon Jul 17 2000 Than Ngo <than@redhat.de>
459- install under /usr/share instead /usr/lib/kde1-compat/share,
460  fix dependency problem
461 
462* Sat Jul 15 2000 Than Ngo <than@redhat.de>
463- rebuilt with egcs-c++-1.1.2
464
465* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
466- automatic rebuild
467 
468* Mon Jul 03 2000 Than Ngo <than@redhat.de>
469- fix docdir
470- add requires kdebase
471 
472* Sun Jul 02 2000 Than Ngo <than@redhat.de>
473- rebuilt with  kde1-compat
474 
475* Sun Jun 18 2000 Than Ngo <than@redhat.de>
476- rebuilt in the new build environment, fix docdir
477- FHS packaging
478 
479* Thu Jun 08 2000 Than Ngo <than@redhat.de>
480- update to 1.2
481- move from powertools to main CD
482- use %%configure
483 
484* Mon Apr 3 2000 Ngo Than <than@redhat.de>
485- fix up reference (Bug #10368)
486 
487* Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
488- Fix up documentation path (Bug #7291)
489- Update to current stable branch - this should fix up the debugger problem
490- clean up spec file
491 
492* Fri Jan  6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
493- Update to current stable branch
494- Adapt to 6.2 Qt libraries
495- Use BuildPrereq
496 
497* Wed Jan 05 2000 Ngo Than <than@redhat.de>
498- added patch for alpha
499 
500* Tue Dec 21 1999 Ngo Than <than@redhat.de>
501- updated kdevelop-1.0 release
502 
503* Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
504- kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
505 
506* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
507- initial packaging for 6.1.
Note: See TracBrowser for help on using the repository browser.