source: projects/specs/trunk/k/kdevelop/kdevelop-vl.spec @ 6774

Revision 6774, 14.8 KB checked in by Takemikaduchi, 12 years ago (diff)

libalkimia, libdbi: new package
others: new upstream release

Line 
1Name: kdevelop
2Summary: Integrated Development Environment for C++/C
3Summary(ja): C++/C 向け統合開発環境
4Version: 4.3.1
5Release: 1%{?_dist_release}
6
7License: GPLv2
8URL: http://www.kdevelop.org/
9Group: Applications/Development
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.bz2
12
13# fixing https://bugs.kde.org/show_bug.cgi?id=236315
14Patch100: kdevelop-4.0.0-qmake_qt4.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: desktop-file-utils
18BuildRequires: gettext
19BuildRequires: kdebase-workspace-devel
20BuildRequires: kdevplatform-devel >= 1.3.1
21BuildRequires: kdelibs-devel
22BuildRequires: kdesdk-devel
23BuildRequires: soprano-devel
24BuildRequires: valgrind
25
26Requires: %{name}-libs = %{version}-%{release}
27Requires: kdevplatform >= 1.3.1
28
29#Conflicts: kdevelop
30
31%description
32The KDevelop Integrated Development Environment provides many features
33that developers need as well as providing a unified interface to programs
34like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
35
36All development tools needed for C++ programming like Compiler,
37Linker, automake and autoconf; KAppWizard, which generates complete,
38ready-to-go sample applications; Classgenerator, for creating new
39classes and integrating them into the current project; File management
40for sources, headers, documentation etc. to be included in the
41project; The creation of User-Handbooks written with SGML and the
42automatic generation of HTML-output with the KDE look and feel;
43Automatic HTML-based API-documentation for your project's classes with
44cross-references to the used libraries; Internationalization support
45for your application, allowing translators to easily add their target
46language to a project;
47
48KDevelop also includes WYSIWYG (What you see is what you get)-creation
49of user interfaces with a built-in dialog editor; Debugging your
50application by integrating KDbg; Editing of project-specific pixmaps
51with KIconEdit; The inclusion of any other program you need for
52development by adding it to the "Tools"-menu according to your
53individual needs.
54
55%package libs
56Summary: %{name} runtime libraries
57Summary(ja): %{name} のランタイムライブラリ
58Group:   System Environment/Libraries
59#Requires: %{name} = %{version}-%{release}
60Requires: kdelibs4
61
62%description libs
63%{summary}.
64
65
66%package devel
67Summary: Development files for %{name}
68Summary(ja): %{name} の開発用ファイル
69Group: Development/Libraries
70Requires: %{name}-libs = %{version}-%{release}
71
72%description devel
73%{summary}.
74
75
76%prep
77%setup -q -n kdevelop-%{version}
78#patch100 -p1 -b .qmake_qt4
79
80%build
81mkdir -p %{_target_platform}
82pushd %{_target_platform}
83%cmake \
84    -DCMAKE_BUILD_TYPE=release \
85    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
86    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
87    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
88    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
89    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
90    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
91    ..
92popd
93
94make %{?_smp_mflags} -C %{_target_platform}
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
101
102%find_lang %{name} --all-name --with-kde
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107
108%post
109touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
110
111%postun
112if [ $1 -eq 0 ] ; then
113touch --no-create %{_datadir}/icons/hicolor &> /dev/null
114gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
115update-desktop-database -q &> /dev/null
116update-mime-database %{_datadir}/mime &> /dev/null
117fi
118
119%posttrans
120gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
121update-desktop-database -q &> /dev/null
122update-mime-database %{_datadir}/mime &> /dev/null
123
124%post libs -p /sbin/ldconfig
125
126%postun libs -p /sbin/ldconfig
127
128%files -f %{name}.lang
129%defattr(-,root,root)
130%{_bindir}/*
131%config %{_datadir}/config/kdeveloprc
132%{_datadir}/applications/kde4/*.desktop
133%{_datadir}/kde4/apps/kdev*/
134%{_datadir}/kde4/services/*.desktop
135%{_datadir}/icons/hicolor/*/*/*
136%{_datadir}/mime/packages/kdevelop.xml
137#{_datadir}/servicetypes/*
138#doc %{_datadir}/doc/HTML/en/*
139
140%files libs
141%defattr(-,root,root,-)
142%{_libdir}/lib*.so
143%{_libdir}/kde4/*.so
144
145%files devel
146%defattr(-,root,root,-)
147%{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
148%{_includedir}/kde4/kdevelop/
149
150
151%changelog
152* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.1-1
153- new upstream release
154
155* Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.3-1
156- new upstream release
157
158* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-2
159- add BuildRequires: kdesdk-devel, soprano-devel
160
161* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
162- new upstream release
163
164* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
165- new upstream release
166
167* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
168- new upstream release
169- split shared libraries and header files
170
171* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
172- new upstream release
173- applied new versioning policy, spec in UTF-8
174- changed Group to Applications/Development
175
176* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
177- rebuild for VineSeed
178
179* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
180- new upstream release
181
182* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
183- rebuild for VineSeed
184
185* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
186- new upstream release
187
188* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
189- rebuild for VineSeed
190
191* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
192- new upstream release
193- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
194
195* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
196- rebuild for VineSeed
197
198* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
199- new upstream release
200
201* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
202- rebuild for VineSeed
203
204* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
205- new upstream release
206
207* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
208- rebuild for VineSeed
209
210* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
211- new upstream release
212- add BuildPrereq: apache2-devel subversion-devel
213
214* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
215- new upstream release
216
217* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
218- new upstream release
219- delete Patch0
220
221* Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
222- new upstream release
223- add Patch0
224- update %%files
225
226* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
227- rebuild for VineSeed
228
229* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
230- new upstream release
231
232* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
233- rebuild for VineSeed
234
235* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
236- new upstream release
237- add --disable-rpath to configure option
238- remove BuildPrereq: qt-static
239
240* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
241- rebuild for VineSeed
242
243* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
244- new upstream release
245- update %%files
246- add +w to %%{_prefix}/kdevbdb/*
247
248* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
249- rebuild for VineSeed
250
251* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
252- new upstream release
253- update %%files
254
255* Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
256- source upgrade
257- add BuildPrereq: qt-static
258
259* Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
260- rebuild with qt32
261
262* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
263- source upgrade
264- remove lines about vine26
265
266* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
267- source upgrade
268- add Requires: ctags
269
270* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
271- source upgrade
272- remove all patches
273- remove c references
274- add Requires: htdig
275
276* Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
277- change spec to build both VineSeed and Vine2.5/2.6
278- change configure options
279- add %%clean section
280- add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
281
282* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
283- source upgrade
284- change spec to build both VineSeed and Vine2.5/2.6
285- change configure option (add -enable--final, remove -enable--debug)
286- update %%files section
287
288* Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
289- source upgrade
290- remove patch1 (rejected)
291
292* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
293- BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
294
295* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
296- source upgrade
297- revised Source1
298- remove Patch1 and Patch4
299
300* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
301- merged with rawhide 2.1.1-3
302- clean up spec
303- add BuildPrereq: objprelink (i386 only)
304- remove Obsoletes: kdevelop-c_c++_ref
305- add BuildPrereq: autoconf252 automake15
306- There is Vine's previous changes, hacked for Vine
307 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
308  - build for VineSeed
309  - delete Epoch
310  - update Patch1 and delete Patch2
311
312* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
313- automated rebuild
314
315* Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
316- don't forcibly strip binaries
317
318* Sun Jun  2 2002 Than Ngo <than@redhat.com> 2.1.1-1
319- 2.1.1
320
321* Sun May 26 2002 Tim Powers <timp@redhat.com>
322- automated rebuild
323
324* Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
325- Use automake15
326
327* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
328- Change sonames
329
330* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
331- final
332
333* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
334- update
335
336* Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
337- update to 2.1rc3
338
339* Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
340- update to 2.1rc2
341
342* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
343- rebuild against new kdelibs
344
345* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
346- fixed Strange characters appear in the output window (bug #59217)
347- fixed return-line feed sign in Kdevelop setup tool (bug #55032)
348
349* Wed Mar  8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
350- update to 2.1beta2
351
352* Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
353- rebuild against new kdelibs
354
355* Wed Jan  9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
356- update to 2.1 beta1
357- fix build against gcc 3
358- fix some typo bugs
359- get rid of libkfile
360- update c_cpp_reference to 2.0.1
361
362* Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
363- add patch to show non lattin1 font in build-in editor correct (bug #54457)
364
365* Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
366- fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
367- backport some major bugfixes from 2.0.1
368
369* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
370- Don't crash on startup
371
372* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
373- Fix file list
374
375* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
376- Update
377
378* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
379- Yet another respin - printing was broken.
380
381* Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
382- Update the C/C++ reference guide docs. The older version had a
383  couple of examples that won't work with gcc 2.96-*
384
385* Thu Feb 22 2001 Than Ngo <than@redhat.com>
386- fix version number
387
388* Wed Feb 21 2001 Than Ngo <than@redhat.com>
389- 1.4-respin
390
391* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
392- 1.4
393
394* Wed Feb 14 2001 Than Ngo <than@redhat.com>
395- update (only bugfixes)
396- fix up kdelibs documentation path
397- fix a dependency problem with kde-i18n package (Bug #27675)
398- add qt-designer into requires
399
400* Sun Feb 11 2001 Than Ngo <than@redhat.com>
401- fixed to build on s390
402
403* Tue Feb 06 2001 Than Ngo <than@redhat.com>
404- update, only bugfixes
405
406* Wed Jan 24 2001 Than Ngo <than@redhat.com>
407- hacked for building of KDE references
408
409* Tue Jan 23 2001 Than Ngo <than@redhat.com>
410- work-around to build on alpha
411
412* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
413- Update
414
415* Wed Jan 10 2001 Than Ngo <than@redhat.com>
416- update new snapshot, only require KDE2/Qt2
417
418* Fri Dec 22 2000 Than Ngo <than@redhat.com>
419- fixed dependency problem with kde-i18n
420
421* Thu Dec 21 2000 Than Ngo <than@redhat.com>
422- updated to 1.4beta1 with KDE2 support
423- fixed to build on s390
424- fixed some broken codes
425 
426* Fri Dec 8 2000 Than Ngo <than@redhat.com>
427- fixed for building on ia64
428 
429* Wed Nov 15 2000 Than Ngo <than@redhat.com>
430- build snapshot 20001112, it works now with KDE2 and kde1-compat
431- fix libtool to build on sparc and alpha
432- don't use make -j
433 
434* Sun Aug 13 2000 Than Ngo <than@redhat.com>
435- fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
436 
437* Tue Aug 01 2000 Than Ngo <than@redhat.de>
438- add missing ldconfig in %post and %postun section (Bug #14924)
439- add missing C references stuff to kdevelop
440 
441* Sun Jul 30 2000 Than Ngo <than@redhat.de>
442- rebuilt against compat-egcs-c++, put KDE1 under /usr
443- cleanup specfile
444 
445* Tue Jul 25 2000 Than Ngo <than@redhat.de>
446- fix dependency problem
447 
448* Wed Jul 19 2000 Than Ngo <than@redhat.de>
449- rebuilt against compat-libstdc++
450 
451* Mon Jul 17 2000 Than Ngo <than@redhat.de>
452- install under /usr/share instead /usr/lib/kde1-compat/share,
453  fix dependency problem
454 
455* Sat Jul 15 2000 Than Ngo <than@redhat.de>
456- rebuilt with egcs-c++-1.1.2
457
458* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
459- automatic rebuild
460 
461* Mon Jul 03 2000 Than Ngo <than@redhat.de>
462- fix docdir
463- add requires kdebase
464 
465* Sun Jul 02 2000 Than Ngo <than@redhat.de>
466- rebuilt with  kde1-compat
467 
468* Sun Jun 18 2000 Than Ngo <than@redhat.de>
469- rebuilt in the new build environment, fix docdir
470- FHS packaging
471 
472* Thu Jun 08 2000 Than Ngo <than@redhat.de>
473- update to 1.2
474- move from powertools to main CD
475- use %%configure
476 
477* Mon Apr 3 2000 Ngo Than <than@redhat.de>
478- fix up reference (Bug #10368)
479 
480* Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
481- Fix up documentation path (Bug #7291)
482- Update to current stable branch - this should fix up the debugger problem
483- clean up spec file
484 
485* Fri Jan  6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
486- Update to current stable branch
487- Adapt to 6.2 Qt libraries
488- Use BuildPrereq
489 
490* Wed Jan 05 2000 Ngo Than <than@redhat.de>
491- added patch for alpha
492 
493* Tue Dec 21 1999 Ngo Than <than@redhat.de>
494- updated kdevelop-1.0 release
495 
496* Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
497- kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
498 
499* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
500- initial packaging for 6.1.
Note: See TracBrowser for help on using the repository browser.