source: projects/specs/trunk/k/kdevelop/kdevelop-vl.spec @ 10570

Revision 10570, 15.6 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name: kdevelop
2Summary: Integrated Development Environment for C++/C
3Summary(ja): C++/C 向け統合開発環境
4Version: 4.7.0
5Release: 2%{?_dist_release}
6
7License: GPLv2
8URL: http://www.kdevelop.org/
9Group: Applications/Development
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.xz
12
13# fixing https://bugs.kde.org/show_bug.cgi?id=236315
14Patch100: kdevelop-4.0.0-qmake_qt4.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: desktop-file-utils
18BuildRequires: gettext
19BuildRequires: kdebase-workspace-devel
20BuildRequires: kdevplatform-devel >= 1.4.0
21BuildRequires: kdelibs-devel
22BuildRequires: kdesdk-devel
23BuildRequires: soprano-devel
24BuildRequires: qjson-devel
25BuildRequires: valgrind
26
27Requires: %{name}-libs = %{version}-%{release}
28Requires: kdevplatform >= 1.4.0
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34The KDevelop Integrated Development Environment provides many features
35that developers need as well as providing a unified interface to programs
36like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
37
38All development tools needed for C++ programming like Compiler,
39Linker, automake and autoconf; KAppWizard, which generates complete,
40ready-to-go sample applications; Classgenerator, for creating new
41classes and integrating them into the current project; File management
42for sources, headers, documentation etc. to be included in the
43project; The creation of User-Handbooks written with SGML and the
44automatic generation of HTML-output with the KDE look and feel;
45Automatic HTML-based API-documentation for your project's classes with
46cross-references to the used libraries; Internationalization support
47for your application, allowing translators to easily add their target
48language to a project;
49
50KDevelop also includes WYSIWYG (What you see is what you get)-creation
51of user interfaces with a built-in dialog editor; Debugging your
52application by integrating KDbg; Editing of project-specific pixmaps
53with KIconEdit; The inclusion of any other program you need for
54development by adding it to the "Tools"-menu according to your
55individual needs.
56
57%package libs
58Summary: %{name} runtime libraries
59Summary(ja): %{name} のランタイムライブラリ
60Group:   System Environment/Libraries
61#Requires: %{name} = %{version}-%{release}
62Requires: kdelibs
63
64%description libs
65%{summary}.
66
67
68%package devel
69Summary: Development files for %{name}
70Summary(ja): %{name} の開発用ファイル
71Group: Development/Libraries
72Requires: %{name}-libs = %{version}-%{release}
73
74%description devel
75%{summary}.
76
77
78%prep
79%setup -q -n kdevelop-%{version}
80#patch100 -p1 -b .qmake_qt4
81
82%build
83mkdir -p %{_target_platform}
84pushd %{_target_platform}
85%cmake \
86    -DCMAKE_BUILD_TYPE=release \
87    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
88    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
89    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
90    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
91    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
92    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
93    ..
94popd
95
96make %{?_smp_mflags} -C %{_target_platform}
97
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
103
104%find_lang %{name} --all-name --with-kde
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109
110%post
111touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
112
113%postun
114if [ $1 -eq 0 ] ; then
115touch --no-create %{_datadir}/icons/hicolor &> /dev/null
116gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
117update-desktop-database -q &> /dev/null
118update-mime-database %{_datadir}/mime &> /dev/null
119fi
120
121%posttrans
122gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
123update-desktop-database -q &> /dev/null
124update-mime-database %{_datadir}/mime &> /dev/null
125
126%post libs -p /sbin/ldconfig
127
128%postun libs -p /sbin/ldconfig
129
130%files -f %{name}.lang
131%defattr(-,root,root)
132%{_bindir}/*
133%config %{_datadir}/config/kdeveloprc
134%{_datadir}/applications/kde4/*.desktop
135%{_datadir}/config/kdevelop-qthelp.knsrc
136%{_datadir}/kde4/apps/kdev*/
137%{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/contents/ui/kdevelopsessions.qml
138%{_datadir}/kde4/apps/plasma/plasmoids/kdevelopsessions/metadata.desktop
139%{_datadir}/kde4/apps/plasma/services/org.kde.plasma.dataengine.kdevelopsessions.operations
140%{_datadir}/kde4/services/*.desktop
141%{_datadir}/icons/hicolor/*/*/*
142%{_datadir}/mime/packages/kdevelop.xml
143#{_datadir}/servicetypes/*
144#doc %{_datadir}/doc/HTML/en/*
145
146%files libs
147%defattr(-,root,root,-)
148%{_libdir}/lib*.so
149%{_libdir}/kde4/*.so
150
151%files devel
152%defattr(-,root,root,-)
153%{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
154%{_includedir}/kde4/kdevelop/
155
156
157%changelog
158* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.0-2
159- rebuild with gcc-5.4.0
160
161* Sun Jan 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.0-1
162- new upstream release
163
164* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.0-1
165- new upstream release
166- add BuildRequires: qjson-devel
167
168* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.1-1
169- new upstream release
170
171* Sat Oct 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.0-1
172- new upstream release
173
174* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.1-1
175- new upstream release
176
177* Sat Jun 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.3-1
178- new upstream release
179
180* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-2
181- add BuildRequires: kdesdk-devel, soprano-devel
182
183* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
184- new upstream release
185
186* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
187- new upstream release
188
189* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
190- new upstream release
191- split shared libraries and header files
192
193* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
194- new upstream release
195- applied new versioning policy, spec in UTF-8
196- changed Group to Applications/Development
197
198* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
199- rebuild for VineSeed
200
201* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
202- new upstream release
203
204* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
205- rebuild for VineSeed
206
207* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
208- new upstream release
209
210* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
211- rebuild for VineSeed
212
213* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
214- new upstream release
215- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
216
217* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
218- rebuild for VineSeed
219
220* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
221- new upstream release
222
223* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
224- rebuild for VineSeed
225
226* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
227- new upstream release
228
229* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
230- rebuild for VineSeed
231
232* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
233- new upstream release
234- add BuildPrereq: apache2-devel subversion-devel
235
236* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
237- new upstream release
238
239* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
240- new upstream release
241- delete Patch0
242
243* Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
244- new upstream release
245- add Patch0
246- update %%files
247
248* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
249- rebuild for VineSeed
250
251* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
252- new upstream release
253
254* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
255- rebuild for VineSeed
256
257* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
258- new upstream release
259- add --disable-rpath to configure option
260- remove BuildPrereq: qt-static
261
262* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
263- rebuild for VineSeed
264
265* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
266- new upstream release
267- update %%files
268- add +w to %%{_prefix}/kdevbdb/*
269
270* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
271- rebuild for VineSeed
272
273* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
274- new upstream release
275- update %%files
276
277* Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
278- source upgrade
279- add BuildPrereq: qt-static
280
281* Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
282- rebuild with qt32
283
284* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
285- source upgrade
286- remove lines about vine26
287
288* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
289- source upgrade
290- add Requires: ctags
291
292* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
293- source upgrade
294- remove all patches
295- remove c references
296- add Requires: htdig
297
298* Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
299- change spec to build both VineSeed and Vine2.5/2.6
300- change configure options
301- add %%clean section
302- add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
303
304* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
305- source upgrade
306- change spec to build both VineSeed and Vine2.5/2.6
307- change configure option (add -enable--final, remove -enable--debug)
308- update %%files section
309
310* Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
311- source upgrade
312- remove patch1 (rejected)
313
314* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
315- BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
316
317* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
318- source upgrade
319- revised Source1
320- remove Patch1 and Patch4
321
322* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
323- merged with rawhide 2.1.1-3
324- clean up spec
325- add BuildPrereq: objprelink (i386 only)
326- remove Obsoletes: kdevelop-c_c++_ref
327- add BuildPrereq: autoconf252 automake15
328- There is Vine's previous changes, hacked for Vine
329 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
330  - build for VineSeed
331  - delete Epoch
332  - update Patch1 and delete Patch2
333
334* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
335- automated rebuild
336
337* Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
338- don't forcibly strip binaries
339
340* Sun Jun  2 2002 Than Ngo <than@redhat.com> 2.1.1-1
341- 2.1.1
342
343* Sun May 26 2002 Tim Powers <timp@redhat.com>
344- automated rebuild
345
346* Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
347- Use automake15
348
349* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
350- Change sonames
351
352* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
353- final
354
355* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
356- update
357
358* Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
359- update to 2.1rc3
360
361* Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
362- update to 2.1rc2
363
364* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
365- rebuild against new kdelibs
366
367* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
368- fixed Strange characters appear in the output window (bug #59217)
369- fixed return-line feed sign in Kdevelop setup tool (bug #55032)
370
371* Fri Mar  8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
372- update to 2.1beta2
373
374* Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
375- rebuild against new kdelibs
376
377* Wed Jan  9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
378- update to 2.1 beta1
379- fix build against gcc 3
380- fix some typo bugs
381- get rid of libkfile
382- update c_cpp_reference to 2.0.1
383
384* Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
385- add patch to show non lattin1 font in build-in editor correct (bug #54457)
386
387* Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
388- fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
389- backport some major bugfixes from 2.0.1
390
391* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
392- Don't crash on startup
393
394* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
395- Fix file list
396
397* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
398- Update
399
400* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
401- Yet another respin - printing was broken.
402
403* Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
404- Update the C/C++ reference guide docs. The older version had a
405  couple of examples that won't work with gcc 2.96-*
406
407* Thu Feb 22 2001 Than Ngo <than@redhat.com>
408- fix version number
409
410* Wed Feb 21 2001 Than Ngo <than@redhat.com>
411- 1.4-respin
412
413* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
414- 1.4
415
416* Wed Feb 14 2001 Than Ngo <than@redhat.com>
417- update (only bugfixes)
418- fix up kdelibs documentation path
419- fix a dependency problem with kde-i18n package (Bug #27675)
420- add qt-designer into requires
421
422* Sun Feb 11 2001 Than Ngo <than@redhat.com>
423- fixed to build on s390
424
425* Tue Feb 06 2001 Than Ngo <than@redhat.com>
426- update, only bugfixes
427
428* Wed Jan 24 2001 Than Ngo <than@redhat.com>
429- hacked for building of KDE references
430
431* Tue Jan 23 2001 Than Ngo <than@redhat.com>
432- work-around to build on alpha
433
434* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
435- Update
436
437* Wed Jan 10 2001 Than Ngo <than@redhat.com>
438- update new snapshot, only require KDE2/Qt2
439
440* Fri Dec 22 2000 Than Ngo <than@redhat.com>
441- fixed dependency problem with kde-i18n
442
443* Thu Dec 21 2000 Than Ngo <than@redhat.com>
444- updated to 1.4beta1 with KDE2 support
445- fixed to build on s390
446- fixed some broken codes
447 
448* Fri Dec 8 2000 Than Ngo <than@redhat.com>
449- fixed for building on ia64
450 
451* Wed Nov 15 2000 Than Ngo <than@redhat.com>
452- build snapshot 20001112, it works now with KDE2 and kde1-compat
453- fix libtool to build on sparc and alpha
454- don't use make -j
455 
456* Sun Aug 13 2000 Than Ngo <than@redhat.com>
457- fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
458 
459* Tue Aug 01 2000 Than Ngo <than@redhat.de>
460- add missing ldconfig in %post and %postun section (Bug #14924)
461- add missing C references stuff to kdevelop
462 
463* Sun Jul 30 2000 Than Ngo <than@redhat.de>
464- rebuilt against compat-egcs-c++, put KDE1 under /usr
465- cleanup specfile
466 
467* Tue Jul 25 2000 Than Ngo <than@redhat.de>
468- fix dependency problem
469 
470* Wed Jul 19 2000 Than Ngo <than@redhat.de>
471- rebuilt against compat-libstdc++
472 
473* Mon Jul 17 2000 Than Ngo <than@redhat.de>
474- install under /usr/share instead /usr/lib/kde1-compat/share,
475  fix dependency problem
476 
477* Sat Jul 15 2000 Than Ngo <than@redhat.de>
478- rebuilt with egcs-c++-1.1.2
479
480* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
481- automatic rebuild
482 
483* Mon Jul 03 2000 Than Ngo <than@redhat.de>
484- fix docdir
485- add requires kdebase
486 
487* Sun Jul 02 2000 Than Ngo <than@redhat.de>
488- rebuilt with  kde1-compat
489 
490* Sun Jun 18 2000 Than Ngo <than@redhat.de>
491- rebuilt in the new build environment, fix docdir
492- FHS packaging
493 
494* Thu Jun 08 2000 Than Ngo <than@redhat.de>
495- update to 1.2
496- move from powertools to main CD
497- use %%configure
498 
499* Mon Apr 3 2000 Ngo Than <than@redhat.de>
500- fix up reference (Bug #10368)
501 
502* Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
503- Fix up documentation path (Bug #7291)
504- Update to current stable branch - this should fix up the debugger problem
505- clean up spec file
506 
507* Thu Jan  6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
508- Update to current stable branch
509- Adapt to 6.2 Qt libraries
510- Use BuildPrereq
511 
512* Wed Jan 05 2000 Ngo Than <than@redhat.de>
513- added patch for alpha
514 
515* Tue Dec 21 1999 Ngo Than <than@redhat.de>
516- updated kdevelop-1.0 release
517 
518* Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
519- kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
520 
521* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
522- initial packaging for 6.1.
Note: See TracBrowser for help on using the repository browser.