source: projects/specs/trunk/k/kdevelop/kdevelop-vl.spec @ 2775

Revision 2775, 14.6 KB checked in by inagaki, 13 years ago (diff)

updated: choqok, k3b, kaffeine, kdevelop, kdevplatform,

konversation, kde-partitionmanager, qjson, self-build-k3b-extra

NEW: skrooge

Line 
1Name: kdevelop
2Summary: Integrated Development Environment for C++/C
3Summary(ja): C++/C 向け統合開発環境
4Version: 4.2.0
5Release: 1%{?_dist_release}
6
7License: GPLv2
8URL: http://www.kdevelop.org/
9Group: Applications/Development
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.bz2
12Source1: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.md5sum
13
14# fixing https://bugs.kde.org/show_bug.cgi?id=236315
15Patch100: kdevelop-4.0.0-qmake_qt4.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: desktop-file-utils
19BuildRequires: gettext
20BuildRequires: kdebase-workspace-devel
21BuildRequires: kdevplatform-devel >= 1.2.0
22BuildRequires: kdelibs4-devel
23BuildRequires: valgrind
24
25Requires: %{name}-libs = %{version}-%{release}
26Requires: kdevplatform >= 1.2.0
27
28#Conflicts: kdevelop
29
30%description
31The KDevelop Integrated Development Environment provides many features
32that developers need as well as providing a unified interface to programs
33like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
34
35All development tools needed for C++ programming like Compiler,
36Linker, automake and autoconf; KAppWizard, which generates complete,
37ready-to-go sample applications; Classgenerator, for creating new
38classes and integrating them into the current project; File management
39for sources, headers, documentation etc. to be included in the
40project; The creation of User-Handbooks written with SGML and the
41automatic generation of HTML-output with the KDE look and feel;
42Automatic HTML-based API-documentation for your project's classes with
43cross-references to the used libraries; Internationalization support
44for your application, allowing translators to easily add their target
45language to a project;
46
47KDevelop also includes WYSIWYG (What you see is what you get)-creation
48of user interfaces with a built-in dialog editor; Debugging your
49application by integrating KDbg; Editing of project-specific pixmaps
50with KIconEdit; The inclusion of any other program you need for
51development by adding it to the "Tools"-menu according to your
52individual needs.
53
54%package libs
55Summary: %{name} runtime libraries
56Summary(ja): %{name} のランタイムライブラリ
57Group:   System Environment/Libraries
58#Requires: %{name} = %{version}-%{release}
59Requires: kdelibs4
60
61%description libs
62%{summary}.
63
64
65%package devel
66Summary: Development files for %{name}
67Summary(ja): %{name} の開発用ファイル
68Group: Development/Libraries
69Requires: %{name}-libs = %{version}-%{release}
70
71%description devel
72%{summary}.
73
74
75%prep
76%setup -q -n kdevelop-%{version}
77#patch100 -p1 -b .qmake_qt4
78
79%build
80mkdir -p %{_target_platform}
81pushd %{_target_platform}
82unset QTDIR || : ; . /etc/profile.d/qt4.sh
83%cmake \
84    -DCMAKE_BUILD_TYPE=release \
85    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
86    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
87    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
88    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
89    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
90    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
91    ..
92popd
93
94make %{?_smp_mflags} -C %{_target_platform}
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
101
102%find_lang %{name} --all-name --with-kde
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107
108%post
109touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
110
111%postun
112if [ $1 -eq 0 ] ; then
113touch --no-create %{_datadir}/icons/hicolor &> /dev/null
114gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
115update-desktop-database -q &> /dev/null
116update-mime-database %{_datadir}/mime &> /dev/null
117fi
118
119%posttrans
120gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
121update-desktop-database -q &> /dev/null
122update-mime-database %{_datadir}/mime &> /dev/null
123
124%post libs -p /sbin/ldconfig
125
126%postun libs -p /sbin/ldconfig
127
128%files -f %{name}.lang
129%defattr(-,root,root)
130%{_bindir}/*
131%config %{_datadir}/config/kdeveloprc
132%{_datadir}/applications/kde4/*.desktop
133%{_datadir}/kde4/apps/kdev*/
134%{_datadir}/kde4/services/*.desktop
135%{_datadir}/icons/hicolor/*/*/*
136%{_datadir}/mime/packages/kdevelop.xml
137#{_datadir}/servicetypes/*
138#doc %{_datadir}/doc/HTML/en/*
139
140%files libs
141%defattr(-,root,root,-)
142%{_libdir}/lib*.so
143%{_libdir}/kde4/*.so
144
145%files devel
146%defattr(-,root,root,-)
147%{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
148%{_includedir}/kde4/kdevelop/
149
150
151%changelog
152* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
153- new upstream release
154
155* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
156- new upstream release
157
158* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
159- new upstream release
160- split shared libraries and header files
161
162* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
163- new upstream release
164- applied new versioning policy, spec in UTF-8
165- changed Group to Applications/Development
166
167* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
168- rebuild for VineSeed
169
170* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
171- new upstream release
172
173* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
174- rebuild for VineSeed
175
176* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
177- new upstream release
178
179* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
180- rebuild for VineSeed
181
182* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
183- new upstream release
184- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
185
186* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
187- rebuild for VineSeed
188
189* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
190- new upstream release
191
192* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
193- rebuild for VineSeed
194
195* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
196- new upstream release
197
198* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
199- rebuild for VineSeed
200
201* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
202- new upstream release
203- add BuildPrereq: apache2-devel subversion-devel
204
205* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
206- new upstream release
207
208* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
209- new upstream release
210- delete Patch0
211
212* Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
213- new upstream release
214- add Patch0
215- update %%files
216
217* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
218- rebuild for VineSeed
219
220* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
221- new upstream release
222
223* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
224- rebuild for VineSeed
225
226* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
227- new upstream release
228- add --disable-rpath to configure option
229- remove BuildPrereq: qt-static
230
231* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
232- rebuild for VineSeed
233
234* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
235- new upstream release
236- update %%files
237- add +w to %%{_prefix}/kdevbdb/*
238
239* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
240- rebuild for VineSeed
241
242* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
243- new upstream release
244- update %%files
245
246* Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
247- source upgrade
248- add BuildPrereq: qt-static
249
250* Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
251- rebuild with qt32
252
253* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
254- source upgrade
255- remove lines about vine26
256
257* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
258- source upgrade
259- add Requires: ctags
260
261* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
262- source upgrade
263- remove all patches
264- remove c references
265- add Requires: htdig
266
267* Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
268- change spec to build both VineSeed and Vine2.5/2.6
269- change configure options
270- add %%clean section
271- add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
272
273* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
274- source upgrade
275- change spec to build both VineSeed and Vine2.5/2.6
276- change configure option (add -enable--final, remove -enable--debug)
277- update %%files section
278
279* Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
280- source upgrade
281- remove patch1 (rejected)
282
283* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
284- BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
285
286* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
287- source upgrade
288- revised Source1
289- remove Patch1 and Patch4
290
291* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
292- merged with rawhide 2.1.1-3
293- clean up spec
294- add BuildPrereq: objprelink (i386 only)
295- remove Obsoletes: kdevelop-c_c++_ref
296- add BuildPrereq: autoconf252 automake15
297- There is Vine's previous changes, hacked for Vine
298 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
299  - build for VineSeed
300  - delete Epoch
301  - update Patch1 and delete Patch2
302
303* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
304- automated rebuild
305
306* Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
307- don't forcibly strip binaries
308
309* Sun Jun  2 2002 Than Ngo <than@redhat.com> 2.1.1-1
310- 2.1.1
311
312* Sun May 26 2002 Tim Powers <timp@redhat.com>
313- automated rebuild
314
315* Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
316- Use automake15
317
318* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
319- Change sonames
320
321* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
322- final
323
324* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
325- update
326
327* Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
328- update to 2.1rc3
329
330* Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
331- update to 2.1rc2
332
333* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
334- rebuild against new kdelibs
335
336* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
337- fixed Strange characters appear in the output window (bug #59217)
338- fixed return-line feed sign in Kdevelop setup tool (bug #55032)
339
340* Wed Mar  8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
341- update to 2.1beta2
342
343* Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
344- rebuild against new kdelibs
345
346* Wed Jan  9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
347- update to 2.1 beta1
348- fix build against gcc 3
349- fix some typo bugs
350- get rid of libkfile
351- update c_cpp_reference to 2.0.1
352
353* Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
354- add patch to show non lattin1 font in build-in editor correct (bug #54457)
355
356* Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
357- fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
358- backport some major bugfixes from 2.0.1
359
360* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
361- Don't crash on startup
362
363* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
364- Fix file list
365
366* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
367- Update
368
369* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
370- Yet another respin - printing was broken.
371
372* Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
373- Update the C/C++ reference guide docs. The older version had a
374  couple of examples that won't work with gcc 2.96-*
375
376* Thu Feb 22 2001 Than Ngo <than@redhat.com>
377- fix version number
378
379* Wed Feb 21 2001 Than Ngo <than@redhat.com>
380- 1.4-respin
381
382* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
383- 1.4
384
385* Wed Feb 14 2001 Than Ngo <than@redhat.com>
386- update (only bugfixes)
387- fix up kdelibs documentation path
388- fix a dependency problem with kde-i18n package (Bug #27675)
389- add qt-designer into requires
390
391* Sun Feb 11 2001 Than Ngo <than@redhat.com>
392- fixed to build on s390
393
394* Tue Feb 06 2001 Than Ngo <than@redhat.com>
395- update, only bugfixes
396
397* Wed Jan 24 2001 Than Ngo <than@redhat.com>
398- hacked for building of KDE references
399
400* Tue Jan 23 2001 Than Ngo <than@redhat.com>
401- work-around to build on alpha
402
403* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
404- Update
405
406* Wed Jan 10 2001 Than Ngo <than@redhat.com>
407- update new snapshot, only require KDE2/Qt2
408
409* Fri Dec 22 2000 Than Ngo <than@redhat.com>
410- fixed dependency problem with kde-i18n
411
412* Thu Dec 21 2000 Than Ngo <than@redhat.com>
413- updated to 1.4beta1 with KDE2 support
414- fixed to build on s390
415- fixed some broken codes
416 
417* Fri Dec 8 2000 Than Ngo <than@redhat.com>
418- fixed for building on ia64
419 
420* Wed Nov 15 2000 Than Ngo <than@redhat.com>
421- build snapshot 20001112, it works now with KDE2 and kde1-compat
422- fix libtool to build on sparc and alpha
423- don't use make -j
424 
425* Sun Aug 13 2000 Than Ngo <than@redhat.com>
426- fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
427 
428* Tue Aug 01 2000 Than Ngo <than@redhat.de>
429- add missing ldconfig in %post and %postun section (Bug #14924)
430- add missing C references stuff to kdevelop
431 
432* Sun Jul 30 2000 Than Ngo <than@redhat.de>
433- rebuilt against compat-egcs-c++, put KDE1 under /usr
434- cleanup specfile
435 
436* Tue Jul 25 2000 Than Ngo <than@redhat.de>
437- fix dependency problem
438 
439* Wed Jul 19 2000 Than Ngo <than@redhat.de>
440- rebuilt against compat-libstdc++
441 
442* Mon Jul 17 2000 Than Ngo <than@redhat.de>
443- install under /usr/share instead /usr/lib/kde1-compat/share,
444  fix dependency problem
445 
446* Sat Jul 15 2000 Than Ngo <than@redhat.de>
447- rebuilt with egcs-c++-1.1.2
448
449* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
450- automatic rebuild
451 
452* Mon Jul 03 2000 Than Ngo <than@redhat.de>
453- fix docdir
454- add requires kdebase
455 
456* Sun Jul 02 2000 Than Ngo <than@redhat.de>
457- rebuilt with  kde1-compat
458 
459* Sun Jun 18 2000 Than Ngo <than@redhat.de>
460- rebuilt in the new build environment, fix docdir
461- FHS packaging
462 
463* Thu Jun 08 2000 Than Ngo <than@redhat.de>
464- update to 1.2
465- move from powertools to main CD
466- use %%configure
467 
468* Mon Apr 3 2000 Ngo Than <than@redhat.de>
469- fix up reference (Bug #10368)
470 
471* Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
472- Fix up documentation path (Bug #7291)
473- Update to current stable branch - this should fix up the debugger problem
474- clean up spec file
475 
476* Fri Jan  6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
477- Update to current stable branch
478- Adapt to 6.2 Qt libraries
479- Use BuildPrereq
480 
481* Wed Jan 05 2000 Ngo Than <than@redhat.de>
482- added patch for alpha
483 
484* Tue Dec 21 1999 Ngo Than <than@redhat.de>
485- updated kdevelop-1.0 release
486 
487* Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
488- kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
489 
490* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
491- initial packaging for 6.1.
Note: See TracBrowser for help on using the repository browser.