source: projects/specs/trunk/k/kdevelop/kdevelop-vl.spec @ 3876

Revision 3876, 14.7 KB checked in by Takemikaduchi, 13 years ago (diff)

drumstick,kdevplatform,kdevelop: add BR, others: new upstream release

Line 
1Name: kdevelop
2Summary: Integrated Development Environment for C++/C
3Summary(ja): C++/C 向け統合開発環境
4Version: 4.2.0
5Release: 2%{?_dist_release}
6
7License: GPLv2
8URL: http://www.kdevelop.org/
9Group: Applications/Development
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.bz2
12Source1: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.md5sum
13
14# fixing https://bugs.kde.org/show_bug.cgi?id=236315
15Patch100: kdevelop-4.0.0-qmake_qt4.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: desktop-file-utils
19BuildRequires: gettext
20BuildRequires: kdebase-workspace-devel
21BuildRequires: kdevplatform-devel >= 1.2.0
22BuildRequires: kdelibs4-devel
23BuildRequires: kdesdk-devel
24BuildRequires: soprano-devel
25BuildRequires: valgrind
26
27Requires: %{name}-libs = %{version}-%{release}
28Requires: kdevplatform >= 1.2.0
29
30#Conflicts: kdevelop
31
32%description
33The KDevelop Integrated Development Environment provides many features
34that developers need as well as providing a unified interface to programs
35like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
36
37All development tools needed for C++ programming like Compiler,
38Linker, automake and autoconf; KAppWizard, which generates complete,
39ready-to-go sample applications; Classgenerator, for creating new
40classes and integrating them into the current project; File management
41for sources, headers, documentation etc. to be included in the
42project; The creation of User-Handbooks written with SGML and the
43automatic generation of HTML-output with the KDE look and feel;
44Automatic HTML-based API-documentation for your project's classes with
45cross-references to the used libraries; Internationalization support
46for your application, allowing translators to easily add their target
47language to a project;
48
49KDevelop also includes WYSIWYG (What you see is what you get)-creation
50of user interfaces with a built-in dialog editor; Debugging your
51application by integrating KDbg; Editing of project-specific pixmaps
52with KIconEdit; The inclusion of any other program you need for
53development by adding it to the "Tools"-menu according to your
54individual needs.
55
56%package libs
57Summary: %{name} runtime libraries
58Summary(ja): %{name} のランタイムライブラリ
59Group:   System Environment/Libraries
60#Requires: %{name} = %{version}-%{release}
61Requires: kdelibs4
62
63%description libs
64%{summary}.
65
66
67%package devel
68Summary: Development files for %{name}
69Summary(ja): %{name} の開発用ファイル
70Group: Development/Libraries
71Requires: %{name}-libs = %{version}-%{release}
72
73%description devel
74%{summary}.
75
76
77%prep
78%setup -q -n kdevelop-%{version}
79#patch100 -p1 -b .qmake_qt4
80
81%build
82mkdir -p %{_target_platform}
83pushd %{_target_platform}
84unset QTDIR || : ; . /etc/profile.d/qt4.sh
85%cmake \
86    -DCMAKE_BUILD_TYPE=release \
87    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
88    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
89    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
90    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
91    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
92    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
93    ..
94popd
95
96make %{?_smp_mflags} -C %{_target_platform}
97
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
103
104%find_lang %{name} --all-name --with-kde
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109
110%post
111touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
112
113%postun
114if [ $1 -eq 0 ] ; then
115touch --no-create %{_datadir}/icons/hicolor &> /dev/null
116gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
117update-desktop-database -q &> /dev/null
118update-mime-database %{_datadir}/mime &> /dev/null
119fi
120
121%posttrans
122gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
123update-desktop-database -q &> /dev/null
124update-mime-database %{_datadir}/mime &> /dev/null
125
126%post libs -p /sbin/ldconfig
127
128%postun libs -p /sbin/ldconfig
129
130%files -f %{name}.lang
131%defattr(-,root,root)
132%{_bindir}/*
133%config %{_datadir}/config/kdeveloprc
134%{_datadir}/applications/kde4/*.desktop
135%{_datadir}/kde4/apps/kdev*/
136%{_datadir}/kde4/services/*.desktop
137%{_datadir}/icons/hicolor/*/*/*
138%{_datadir}/mime/packages/kdevelop.xml
139#{_datadir}/servicetypes/*
140#doc %{_datadir}/doc/HTML/en/*
141
142%files libs
143%defattr(-,root,root,-)
144%{_libdir}/lib*.so
145%{_libdir}/kde4/*.so
146
147%files devel
148%defattr(-,root,root,-)
149%{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
150%{_includedir}/kde4/kdevelop/
151
152
153%changelog
154* Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-2
155- add BuildRequires: kdesdk-devel, soprano-devel
156
157* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
158- new upstream release
159
160* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
161- new upstream release
162
163* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
164- new upstream release
165- split shared libraries and header files
166
167* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
168- new upstream release
169- applied new versioning policy, spec in UTF-8
170- changed Group to Applications/Development
171
172* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
173- rebuild for VineSeed
174
175* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
176- new upstream release
177
178* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
179- rebuild for VineSeed
180
181* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
182- new upstream release
183
184* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
185- rebuild for VineSeed
186
187* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
188- new upstream release
189- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
190
191* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
192- rebuild for VineSeed
193
194* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
195- new upstream release
196
197* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
198- rebuild for VineSeed
199
200* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
201- new upstream release
202
203* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
204- rebuild for VineSeed
205
206* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
207- new upstream release
208- add BuildPrereq: apache2-devel subversion-devel
209
210* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
211- new upstream release
212
213* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
214- new upstream release
215- delete Patch0
216
217* Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
218- new upstream release
219- add Patch0
220- update %%files
221
222* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
223- rebuild for VineSeed
224
225* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
226- new upstream release
227
228* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
229- rebuild for VineSeed
230
231* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
232- new upstream release
233- add --disable-rpath to configure option
234- remove BuildPrereq: qt-static
235
236* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
237- rebuild for VineSeed
238
239* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
240- new upstream release
241- update %%files
242- add +w to %%{_prefix}/kdevbdb/*
243
244* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
245- rebuild for VineSeed
246
247* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
248- new upstream release
249- update %%files
250
251* Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
252- source upgrade
253- add BuildPrereq: qt-static
254
255* Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
256- rebuild with qt32
257
258* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
259- source upgrade
260- remove lines about vine26
261
262* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
263- source upgrade
264- add Requires: ctags
265
266* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
267- source upgrade
268- remove all patches
269- remove c references
270- add Requires: htdig
271
272* Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
273- change spec to build both VineSeed and Vine2.5/2.6
274- change configure options
275- add %%clean section
276- add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
277
278* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
279- source upgrade
280- change spec to build both VineSeed and Vine2.5/2.6
281- change configure option (add -enable--final, remove -enable--debug)
282- update %%files section
283
284* Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
285- source upgrade
286- remove patch1 (rejected)
287
288* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
289- BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
290
291* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
292- source upgrade
293- revised Source1
294- remove Patch1 and Patch4
295
296* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
297- merged with rawhide 2.1.1-3
298- clean up spec
299- add BuildPrereq: objprelink (i386 only)
300- remove Obsoletes: kdevelop-c_c++_ref
301- add BuildPrereq: autoconf252 automake15
302- There is Vine's previous changes, hacked for Vine
303 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
304  - build for VineSeed
305  - delete Epoch
306  - update Patch1 and delete Patch2
307
308* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
309- automated rebuild
310
311* Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
312- don't forcibly strip binaries
313
314* Sun Jun  2 2002 Than Ngo <than@redhat.com> 2.1.1-1
315- 2.1.1
316
317* Sun May 26 2002 Tim Powers <timp@redhat.com>
318- automated rebuild
319
320* Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
321- Use automake15
322
323* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
324- Change sonames
325
326* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
327- final
328
329* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
330- update
331
332* Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
333- update to 2.1rc3
334
335* Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
336- update to 2.1rc2
337
338* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
339- rebuild against new kdelibs
340
341* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
342- fixed Strange characters appear in the output window (bug #59217)
343- fixed return-line feed sign in Kdevelop setup tool (bug #55032)
344
345* Wed Mar  8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
346- update to 2.1beta2
347
348* Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
349- rebuild against new kdelibs
350
351* Wed Jan  9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
352- update to 2.1 beta1
353- fix build against gcc 3
354- fix some typo bugs
355- get rid of libkfile
356- update c_cpp_reference to 2.0.1
357
358* Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
359- add patch to show non lattin1 font in build-in editor correct (bug #54457)
360
361* Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
362- fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
363- backport some major bugfixes from 2.0.1
364
365* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
366- Don't crash on startup
367
368* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
369- Fix file list
370
371* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
372- Update
373
374* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
375- Yet another respin - printing was broken.
376
377* Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
378- Update the C/C++ reference guide docs. The older version had a
379  couple of examples that won't work with gcc 2.96-*
380
381* Thu Feb 22 2001 Than Ngo <than@redhat.com>
382- fix version number
383
384* Wed Feb 21 2001 Than Ngo <than@redhat.com>
385- 1.4-respin
386
387* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
388- 1.4
389
390* Wed Feb 14 2001 Than Ngo <than@redhat.com>
391- update (only bugfixes)
392- fix up kdelibs documentation path
393- fix a dependency problem with kde-i18n package (Bug #27675)
394- add qt-designer into requires
395
396* Sun Feb 11 2001 Than Ngo <than@redhat.com>
397- fixed to build on s390
398
399* Tue Feb 06 2001 Than Ngo <than@redhat.com>
400- update, only bugfixes
401
402* Wed Jan 24 2001 Than Ngo <than@redhat.com>
403- hacked for building of KDE references
404
405* Tue Jan 23 2001 Than Ngo <than@redhat.com>
406- work-around to build on alpha
407
408* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
409- Update
410
411* Wed Jan 10 2001 Than Ngo <than@redhat.com>
412- update new snapshot, only require KDE2/Qt2
413
414* Fri Dec 22 2000 Than Ngo <than@redhat.com>
415- fixed dependency problem with kde-i18n
416
417* Thu Dec 21 2000 Than Ngo <than@redhat.com>
418- updated to 1.4beta1 with KDE2 support
419- fixed to build on s390
420- fixed some broken codes
421 
422* Fri Dec 8 2000 Than Ngo <than@redhat.com>
423- fixed for building on ia64
424 
425* Wed Nov 15 2000 Than Ngo <than@redhat.com>
426- build snapshot 20001112, it works now with KDE2 and kde1-compat
427- fix libtool to build on sparc and alpha
428- don't use make -j
429 
430* Sun Aug 13 2000 Than Ngo <than@redhat.com>
431- fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
432 
433* Tue Aug 01 2000 Than Ngo <than@redhat.de>
434- add missing ldconfig in %post and %postun section (Bug #14924)
435- add missing C references stuff to kdevelop
436 
437* Sun Jul 30 2000 Than Ngo <than@redhat.de>
438- rebuilt against compat-egcs-c++, put KDE1 under /usr
439- cleanup specfile
440 
441* Tue Jul 25 2000 Than Ngo <than@redhat.de>
442- fix dependency problem
443 
444* Wed Jul 19 2000 Than Ngo <than@redhat.de>
445- rebuilt against compat-libstdc++
446 
447* Mon Jul 17 2000 Than Ngo <than@redhat.de>
448- install under /usr/share instead /usr/lib/kde1-compat/share,
449  fix dependency problem
450 
451* Sat Jul 15 2000 Than Ngo <than@redhat.de>
452- rebuilt with egcs-c++-1.1.2
453
454* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
455- automatic rebuild
456 
457* Mon Jul 03 2000 Than Ngo <than@redhat.de>
458- fix docdir
459- add requires kdebase
460 
461* Sun Jul 02 2000 Than Ngo <than@redhat.de>
462- rebuilt with  kde1-compat
463 
464* Sun Jun 18 2000 Than Ngo <than@redhat.de>
465- rebuilt in the new build environment, fix docdir
466- FHS packaging
467 
468* Thu Jun 08 2000 Than Ngo <than@redhat.de>
469- update to 1.2
470- move from powertools to main CD
471- use %%configure
472 
473* Mon Apr 3 2000 Ngo Than <than@redhat.de>
474- fix up reference (Bug #10368)
475 
476* Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
477- Fix up documentation path (Bug #7291)
478- Update to current stable branch - this should fix up the debugger problem
479- clean up spec file
480 
481* Fri Jan  6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
482- Update to current stable branch
483- Adapt to 6.2 Qt libraries
484- Use BuildPrereq
485 
486* Wed Jan 05 2000 Ngo Than <than@redhat.de>
487- added patch for alpha
488 
489* Tue Dec 21 1999 Ngo Than <than@redhat.de>
490- updated kdevelop-1.0 release
491 
492* Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
493- kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
494 
495* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
496- initial packaging for 6.1.
Note: See TracBrowser for help on using the repository browser.