source: projects/specs/trunk/k/kdevelop/kdevelop-vl.spec @ 1049

Revision 1049, 14.3 KB checked in by inagaki, 14 years ago (diff)

updated: KDevelop

Line 
1Name: kdevelop
2Summary: Integrated Development Environment for C++/C
3Summary(ja): C++/C 向け統合開発環境
4Version: 4.0.0
5Release: 1%{?_dist_release}
6
7License: GPLv2
8URL: http://www.kdevelop.org/
9Group: Applications/Development
10Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/%{name}-%{version}.tar.bz2
11Source1: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/%{name}-%{version}.tar.bz2.md5sum
12
13#Source1: kdevelop
14#Source2: kdevelop-htdig.conf
15
16# fixing https://bugs.kde.org/show_bug.cgi?id=236315
17Patch100: kdevelop-4.0.0-qmake_qt4.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: desktop-file-utils
21BuildRequires: gettext
22BuildRequires: kdebase-workspace-devel
23BuildRequires: kdevplatform-devel >= 1.0.0
24BuildRequires: kdelibs4-devel
25BuildRequires: valgrind
26
27Requires: %{name}-libs = %{version}-%{release}
28Requires: kdevplatform >= 1.0.0
29
30%description
31The KDevelop Integrated Development Environment provides many features
32that developers need as well as providing a unified interface to programs
33like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
34
35All development tools needed for C++ programming like Compiler,
36Linker, automake and autoconf; KAppWizard, which generates complete,
37ready-to-go sample applications; Classgenerator, for creating new
38classes and integrating them into the current project; File management
39for sources, headers, documentation etc. to be included in the
40project; The creation of User-Handbooks written with SGML and the
41automatic generation of HTML-output with the KDE look and feel;
42Automatic HTML-based API-documentation for your project's classes with
43cross-references to the used libraries; Internationalization support
44for your application, allowing translators to easily add their target
45language to a project;
46
47KDevelop also includes WYSIWYG (What you see is what you get)-creation
48of user interfaces with a built-in dialog editor; Debugging your
49application by integrating KDbg; Editing of project-specific pixmaps
50with KIconEdit; The inclusion of any other program you need for
51development by adding it to the "Tools"-menu according to your
52individual needs.
53
54%package libs
55Summary: %{name} runtime libraries
56Group:   System Environment/Libraries
57#Requires: %{name} = %{version}-%{release}
58Requires: kdelibs4
59
60%description libs
61%{summary}.
62
63
64%package devel
65Summary: Development files for %{name}
66Group: Development/Libraries
67Requires: %{name}-libs = %{version}-%{release}
68
69%description devel
70%{summary}.
71
72
73%prep
74%setup -q
75%patch100 -p1 -b .qmake_qt4
76
77%build
78mkdir -p %{_target_platform}
79pushd %{_target_platform}
80unset QTDIR || : ; . /etc/profile.d/qt4.sh
81%cmake \
82    -DCMAKE_BUILD_TYPE=release \
83    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
84    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
85    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
86    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
87    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
88    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
89    ..
90popd
91
92make %{?_smp_mflags} -C %{_target_platform}
93
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
99
100%find_lang %{name} --all-name --with-kde
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105
106%post
107touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
108
109%postun
110if [ $1 -eq 0 ] ; then
111touch --no-create %{_datadir}/icons/hicolor &> /dev/null
112gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
113update-desktop-database -q &> /dev/null
114update-mime-database %{_datadir}/mime &> /dev/null
115fi
116
117%posttrans
118gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
119update-desktop-database -q &> /dev/null
120update-mime-database %{_datadir}/mime &> /dev/null
121
122%post libs -p /sbin/ldconfig
123
124%postun libs -p /sbin/ldconfig
125
126%files -f %{name}.lang
127%defattr(-,root,root)
128%{_bindir}/*
129%config %{_datadir}/config/kdeveloprc
130%{_datadir}/applications/kde4/*.desktop
131%{_datadir}/kde4/apps/kdev*/
132%{_datadir}/kde4/services/*.desktop
133%{_datadir}/icons/hicolor/*/*/*
134%{_datadir}/mime/packages/kdevelop.xml
135#{_datadir}/servicetypes/*
136#doc %{_datadir}/doc/HTML/en/*
137
138%files libs
139%defattr(-,root,root,-)
140%{_libdir}/lib*.so
141%{_libdir}/kde4/*.so
142
143%files devel
144%defattr(-,root,root,-)
145%{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
146%{_includedir}/kde4/kdevelop/
147
148
149%changelog
150* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
151- new upstream release
152- split shared libraries and header files
153
154* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
155- new upstream release
156- applied new versioning policy, spec in UTF-8
157- changed Group to Applications/Development
158
159* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
160- rebuild for VineSeed
161
162* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
163- new upstream release
164
165* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
166- rebuild for VineSeed
167
168* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
169- new upstream release
170
171* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
172- rebuild for VineSeed
173
174* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
175- new upstream release
176- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
177
178* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
179- rebuild for VineSeed
180
181* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
182- new upstream release
183
184* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
185- rebuild for VineSeed
186
187* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
188- new upstream release
189
190* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
191- rebuild for VineSeed
192
193* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
194- new upstream release
195- add BuildPrereq: apache2-devel subversion-devel
196
197* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
198- new upstream release
199
200* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
201- new upstream release
202- delete Patch0
203
204* Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
205- new upstream release
206- add Patch0
207- update %%files
208
209* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
210- rebuild for VineSeed
211
212* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
213- new upstream release
214
215* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
216- rebuild for VineSeed
217
218* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
219- new upstream release
220- add --disable-rpath to configure option
221- remove BuildPrereq: qt-static
222
223* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
224- rebuild for VineSeed
225
226* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
227- new upstream release
228- update %%files
229- add +w to %%{_prefix}/kdevbdb/*
230
231* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
232- rebuild for VineSeed
233
234* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
235- new upstream release
236- update %%files
237
238* Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
239- source upgrade
240- add BuildPrereq: qt-static
241
242* Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
243- rebuild with qt32
244
245* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
246- source upgrade
247- remove lines about vine26
248
249* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
250- source upgrade
251- add Requires: ctags
252
253* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
254- source upgrade
255- remove all patches
256- remove c references
257- add Requires: htdig
258
259* Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
260- change spec to build both VineSeed and Vine2.5/2.6
261- change configure options
262- add %%clean section
263- add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
264
265* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
266- source upgrade
267- change spec to build both VineSeed and Vine2.5/2.6
268- change configure option (add -enable--final, remove -enable--debug)
269- update %%files section
270
271* Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
272- source upgrade
273- remove patch1 (rejected)
274
275* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
276- BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
277
278* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
279- source upgrade
280- revised Source1
281- remove Patch1 and Patch4
282
283* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
284- merged with rawhide 2.1.1-3
285- clean up spec
286- add BuildPrereq: objprelink (i386 only)
287- remove Obsoletes: kdevelop-c_c++_ref
288- add BuildPrereq: autoconf252 automake15
289- There is Vine's previous changes, hacked for Vine
290 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
291  - build for VineSeed
292  - delete Epoch
293  - update Patch1 and delete Patch2
294
295* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
296- automated rebuild
297
298* Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
299- don't forcibly strip binaries
300
301* Sun Jun  2 2002 Than Ngo <than@redhat.com> 2.1.1-1
302- 2.1.1
303
304* Sun May 26 2002 Tim Powers <timp@redhat.com>
305- automated rebuild
306
307* Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
308- Use automake15
309
310* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
311- Change sonames
312
313* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
314- final
315
316* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
317- update
318
319* Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
320- update to 2.1rc3
321
322* Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
323- update to 2.1rc2
324
325* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
326- rebuild against new kdelibs
327
328* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
329- fixed Strange characters appear in the output window (bug #59217)
330- fixed return-line feed sign in Kdevelop setup tool (bug #55032)
331
332* Wed Mar  8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
333- update to 2.1beta2
334
335* Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
336- rebuild against new kdelibs
337
338* Wed Jan  9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
339- update to 2.1 beta1
340- fix build against gcc 3
341- fix some typo bugs
342- get rid of libkfile
343- update c_cpp_reference to 2.0.1
344
345* Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
346- add patch to show non lattin1 font in build-in editor correct (bug #54457)
347
348* Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
349- fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
350- backport some major bugfixes from 2.0.1
351
352* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
353- Don't crash on startup
354
355* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
356- Fix file list
357
358* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
359- Update
360
361* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
362- Yet another respin - printing was broken.
363
364* Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
365- Update the C/C++ reference guide docs. The older version had a
366  couple of examples that won't work with gcc 2.96-*
367
368* Thu Feb 22 2001 Than Ngo <than@redhat.com>
369- fix version number
370
371* Wed Feb 21 2001 Than Ngo <than@redhat.com>
372- 1.4-respin
373
374* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
375- 1.4
376
377* Wed Feb 14 2001 Than Ngo <than@redhat.com>
378- update (only bugfixes)
379- fix up kdelibs documentation path
380- fix a dependency problem with kde-i18n package (Bug #27675)
381- add qt-designer into requires
382
383* Sun Feb 11 2001 Than Ngo <than@redhat.com>
384- fixed to build on s390
385
386* Tue Feb 06 2001 Than Ngo <than@redhat.com>
387- update, only bugfixes
388
389* Wed Jan 24 2001 Than Ngo <than@redhat.com>
390- hacked for building of KDE references
391
392* Tue Jan 23 2001 Than Ngo <than@redhat.com>
393- work-around to build on alpha
394
395* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
396- Update
397
398* Wed Jan 10 2001 Than Ngo <than@redhat.com>
399- update new snapshot, only require KDE2/Qt2
400
401* Fri Dec 22 2000 Than Ngo <than@redhat.com>
402- fixed dependency problem with kde-i18n
403
404* Thu Dec 21 2000 Than Ngo <than@redhat.com>
405- updated to 1.4beta1 with KDE2 support
406- fixed to build on s390
407- fixed some broken codes
408 
409* Fri Dec 8 2000 Than Ngo <than@redhat.com>
410- fixed for building on ia64
411 
412* Wed Nov 15 2000 Than Ngo <than@redhat.com>
413- build snapshot 20001112, it works now with KDE2 and kde1-compat
414- fix libtool to build on sparc and alpha
415- don't use make -j
416 
417* Sun Aug 13 2000 Than Ngo <than@redhat.com>
418- fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
419 
420* Tue Aug 01 2000 Than Ngo <than@redhat.de>
421- add missing ldconfig in %post and %postun section (Bug #14924)
422- add missing C references stuff to kdevelop
423 
424* Sun Jul 30 2000 Than Ngo <than@redhat.de>
425- rebuilt against compat-egcs-c++, put KDE1 under /usr
426- cleanup specfile
427 
428* Tue Jul 25 2000 Than Ngo <than@redhat.de>
429- fix dependency problem
430 
431* Wed Jul 19 2000 Than Ngo <than@redhat.de>
432- rebuilt against compat-libstdc++
433 
434* Mon Jul 17 2000 Than Ngo <than@redhat.de>
435- install under /usr/share instead /usr/lib/kde1-compat/share,
436  fix dependency problem
437 
438* Sat Jul 15 2000 Than Ngo <than@redhat.de>
439- rebuilt with egcs-c++-1.1.2
440
441* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
442- automatic rebuild
443 
444* Mon Jul 03 2000 Than Ngo <than@redhat.de>
445- fix docdir
446- add requires kdebase
447 
448* Sun Jul 02 2000 Than Ngo <than@redhat.de>
449- rebuilt with  kde1-compat
450 
451* Sun Jun 18 2000 Than Ngo <than@redhat.de>
452- rebuilt in the new build environment, fix docdir
453- FHS packaging
454 
455* Thu Jun 08 2000 Than Ngo <than@redhat.de>
456- update to 1.2
457- move from powertools to main CD
458- use %%configure
459 
460* Mon Apr 3 2000 Ngo Than <than@redhat.de>
461- fix up reference (Bug #10368)
462 
463* Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
464- Fix up documentation path (Bug #7291)
465- Update to current stable branch - this should fix up the debugger problem
466- clean up spec file
467 
468* Fri Jan  6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
469- Update to current stable branch
470- Adapt to 6.2 Qt libraries
471- Use BuildPrereq
472 
473* Wed Jan 05 2000 Ngo Than <than@redhat.de>
474- added patch for alpha
475 
476* Tue Dec 21 1999 Ngo Than <than@redhat.de>
477- updated kdevelop-1.0 release
478 
479* Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
480- kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
481 
482* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
483- initial packaging for 6.1.
Note: See TracBrowser for help on using the repository browser.