source: projects/specs/trunk/k/kdevelop/kdevelop-vl.spec @ 521

Revision 521, 13.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define beta 0
2%define seed %(grep -c Seed /etc/vine-release)
3%define kde_ver 3.5.5
4
5Name: kdevelop
6Version: 3.5.4
7%if %{beta}
8Release: 1.%{beta}%{?_dist_relase}
9%else
10Release: 1%{?_dist_release}
11%endif
12Summary: Integrated Development Environment for C++/C
13Summary(ja): C++/C 向け統合開発環境
14%if %{beta}
15Source: ftp://ftp.kde.org/pub/kde/unstable/%{kde_ver}-%{beta}/src/%{name}-%{version}-%{beta}.tar.bz2
16%else
17Source: ftp://ftp.kde.org/pub/kde/stable/%{kde_ver}/src/%{name}-%{version}.tar.bz2
18%endif
19Source1: kdevelop
20Source2: kdevelop-htdig.conf
21URL: http://www.kdevelop.org/
22Group: Applications/Development
23License: GPL
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: qt-devel >= 3.3.2
27BuildRequires: kdelibs-devel >= %{kde_ver}
28BuildRequires: libpng-devel >= 1.2.5
29BuildRequires: libtool libmng-devel libjpeg-devel zlib-devel
30BuildRequires: flex db4-devel gettext apache2-devel subversion-devel
31Requires: make, perl >= 5.004
32Requires: flex >= 2.5.4
33Requires: qt >= 3.3.2, qt-designer >= 3.3.2, kdelibs-devel >= %{kde_ver}
34Requires: libmng libjpeg libpng zlib
35Requires: kdbg kdoc kdegraphics kdeutils kdesdk htdig ctags
36%if %{seed}
37BuildPrereq: apr-devel apr-util-devel
38Requires: apr apr-util
39%else
40BuildPrereq: apache2-apr-devel
41Requires: apache2-apr
42%endif
43
44%description
45The KDevelop Integrated Development Environment provides many features
46that developers need as well as providing a unified interface to programs
47like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
48
49All development tools needed for C++ programming like Compiler,
50Linker, automake and autoconf; KAppWizard, which generates complete,
51ready-to-go sample applications; Classgenerator, for creating new
52classes and integrating them into the current project; File management
53for sources, headers, documentation etc. to be included in the
54project; The creation of User-Handbooks written with SGML and the
55automatic generation of HTML-output with the KDE look and feel;
56Automatic HTML-based API-documentation for your project's classes with
57cross-references to the used libraries; Internationalization support
58for your application, allowing translators to easily add their target
59language to a project;
60
61KDevelop also includes WYSIWYG (What you see is what you get)-creation
62of user interfaces with a built-in dialog editor; Debugging your
63application by integrating KDbg; Editing of project-specific pixmaps
64with KIconEdit; The inclusion of any other program you need for
65development by adding it to the "Tools"-menu according to your
66individual needs.
67
68%prep
69%setup -q
70
71%build
72export KDEDIR=%{_prefix}
73QTDIR="" && source /etc/profile.d/qt.sh
74FLAGS="$RPM_OPT_FLAGS -DNDEBUG -DNO_DEBUG -D_GNU_SOURCE"
75
76CXXFLAGS="$FLAGS" CFLAGS="$FLAGS" \
77./configure --prefix=$KDEDIR \
78  --with-qtdoc-dir=$QTDIR/doc/html/ \
79  --with-xinerama \
80  --with-pythondir=%{_prefix} \
81  --enable-new-ldflags \
82  --disable-dependency-tracking \
83%if %{seed}
84    --with-apr-config=%{_bindir}/apr-1-config \
85    --with-apu-config=%{_bindir}/apu-1-config \
86%endif
87    --enable-final \
88    --disable-rpath
89
90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95make DESTDIR=$RPM_BUILD_ROOT install
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%files
101%defattr(-,root,root)
102%doc %{_datadir}/doc/HTML/en/*
103%{_bindir}/*
104%{_includedir}*
105%{_libdir}/*
106%{_datadir}/applications/*
107%{_datadir}/apps/*
108%config %{_datadir}/config/*
109%{_datadir}/desktop-directories/*
110%{_datadir}/icons/*
111%{_datadir}/mimelnk/*
112%{_datadir}/services/*
113%{_datadir}/servicetypes/*
114
115%changelog
116* Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
117- new upstream release
118- applied new versioning policy, spec in UTF-8
119- changed Group to Applications/Development
120
121* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
122- rebuild for VineSeed
123
124* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
125- new upstream release
126
127* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
128- rebuild for VineSeed
129
130* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
131- new upstream release
132
133* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
134- rebuild for VineSeed
135
136* Fri Jun  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
137- new upstream release
138- use ap?-config for Vine3.x and use ap?-1-config for VineSeed
139
140* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
141- rebuild for VineSeed
142
143* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
144- new upstream release
145
146* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
147- rebuild for VineSeed
148
149* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
150- new upstream release
151
152* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
153- rebuild for VineSeed
154
155* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
156- new upstream release
157- add BuildPrereq: apache2-devel subversion-devel
158
159* Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
160- new upstream release
161
162* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
163- new upstream release
164- delete Patch0
165
166* Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
167- new upstream release
168- add Patch0
169- update %%files
170
171* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
172- rebuild for VineSeed
173
174* Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
175- new upstream release
176
177* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
178- rebuild for VineSeed
179
180* Tue Jul  5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
181- new upstream release
182- add --disable-rpath to configure option
183- remove BuildPrereq: qt-static
184
185* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
186- rebuild for VineSeed
187
188* Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
189- new upstream release
190- update %%files
191- add +w to %%{_prefix}/kdevbdb/*
192
193* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
194- rebuild for VineSeed
195
196* Sun Jan  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
197- new upstream release
198- update %%files
199
200* Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
201- source upgrade
202- add BuildPrereq: qt-static
203
204* Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
205- rebuild with qt32
206
207* Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
208- source upgrade
209- remove lines about vine26
210
211* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
212- source upgrade
213- add Requires: ctags
214
215* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
216- source upgrade
217- remove all patches
218- remove c references
219- add Requires: htdig
220
221* Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
222- change spec to build both VineSeed and Vine2.5/2.6
223- change configure options
224- add %%clean section
225- add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
226
227* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
228- source upgrade
229- change spec to build both VineSeed and Vine2.5/2.6
230- change configure option (add -enable--final, remove -enable--debug)
231- update %%files section
232
233* Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
234- source upgrade
235- remove patch1 (rejected)
236
237* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
238- BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
239
240* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
241- source upgrade
242- revised Source1
243- remove Patch1 and Patch4
244
245* Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
246- merged with rawhide 2.1.1-3
247- clean up spec
248- add BuildPrereq: objprelink (i386 only)
249- remove Obsoletes: kdevelop-c_c++_ref
250- add BuildPrereq: autoconf252 automake15
251- There is Vine's previous changes, hacked for Vine
252 -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
253  - build for VineSeed
254  - delete Epoch
255  - update Patch1 and delete Patch2
256
257* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
258- automated rebuild
259
260* Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
261- don't forcibly strip binaries
262
263* Sun Jun  2 2002 Than Ngo <than@redhat.com> 2.1.1-1
264- 2.1.1
265
266* Sun May 26 2002 Tim Powers <timp@redhat.com>
267- automated rebuild
268
269* Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
270- Use automake15
271
272* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
273- Change sonames
274
275* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
276- final
277
278* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
279- update
280
281* Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
282- update to 2.1rc3
283
284* Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
285- update to 2.1rc2
286
287* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
288- rebuild against new kdelibs
289
290* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
291- fixed Strange characters appear in the output window (bug #59217)
292- fixed return-line feed sign in Kdevelop setup tool (bug #55032)
293
294* Wed Mar  8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
295- update to 2.1beta2
296
297* Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
298- rebuild against new kdelibs
299
300* Wed Jan  9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
301- update to 2.1 beta1
302- fix build against gcc 3
303- fix some typo bugs
304- get rid of libkfile
305- update c_cpp_reference to 2.0.1
306
307* Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
308- add patch to show non lattin1 font in build-in editor correct (bug #54457)
309
310* Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
311- fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
312- backport some major bugfixes from 2.0.1
313
314* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
315- Don't crash on startup
316
317* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
318- Fix file list
319
320* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
321- Update
322
323* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
324- Yet another respin - printing was broken.
325
326* Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
327- Update the C/C++ reference guide docs. The older version had a
328  couple of examples that won't work with gcc 2.96-*
329
330* Thu Feb 22 2001 Than Ngo <than@redhat.com>
331- fix version number
332
333* Wed Feb 21 2001 Than Ngo <than@redhat.com>
334- 1.4-respin
335
336* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
337- 1.4
338
339* Wed Feb 14 2001 Than Ngo <than@redhat.com>
340- update (only bugfixes)
341- fix up kdelibs documentation path
342- fix a dependency problem with kde-i18n package (Bug #27675)
343- add qt-designer into requires
344
345* Sun Feb 11 2001 Than Ngo <than@redhat.com>
346- fixed to build on s390
347
348* Tue Feb 06 2001 Than Ngo <than@redhat.com>
349- update, only bugfixes
350
351* Wed Jan 24 2001 Than Ngo <than@redhat.com>
352- hacked for building of KDE references
353
354* Tue Jan 23 2001 Than Ngo <than@redhat.com>
355- work-around to build on alpha
356
357* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
358- Update
359
360* Wed Jan 10 2001 Than Ngo <than@redhat.com>
361- update new snapshot, only require KDE2/Qt2
362
363* Fri Dec 22 2000 Than Ngo <than@redhat.com>
364- fixed dependency problem with kde-i18n
365
366* Thu Dec 21 2000 Than Ngo <than@redhat.com>
367- updated to 1.4beta1 with KDE2 support
368- fixed to build on s390
369- fixed some broken codes
370 
371* Fri Dec 8 2000 Than Ngo <than@redhat.com>
372- fixed for building on ia64
373 
374* Wed Nov 15 2000 Than Ngo <than@redhat.com>
375- build snapshot 20001112, it works now with KDE2 and kde1-compat
376- fix libtool to build on sparc and alpha
377- don't use make -j
378 
379* Sun Aug 13 2000 Than Ngo <than@redhat.com>
380- fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
381 
382* Tue Aug 01 2000 Than Ngo <than@redhat.de>
383- add missing ldconfig in %post and %postun section (Bug #14924)
384- add missing C references stuff to kdevelop
385 
386* Sun Jul 30 2000 Than Ngo <than@redhat.de>
387- rebuilt against compat-egcs-c++, put KDE1 under /usr
388- cleanup specfile
389 
390* Tue Jul 25 2000 Than Ngo <than@redhat.de>
391- fix dependency problem
392 
393* Wed Jul 19 2000 Than Ngo <than@redhat.de>
394- rebuilt against compat-libstdc++
395 
396* Mon Jul 17 2000 Than Ngo <than@redhat.de>
397- install under /usr/share instead /usr/lib/kde1-compat/share,
398  fix dependency problem
399 
400* Sat Jul 15 2000 Than Ngo <than@redhat.de>
401- rebuilt with egcs-c++-1.1.2
402
403* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
404- automatic rebuild
405 
406* Mon Jul 03 2000 Than Ngo <than@redhat.de>
407- fix docdir
408- add requires kdebase
409 
410* Sun Jul 02 2000 Than Ngo <than@redhat.de>
411- rebuilt with  kde1-compat
412 
413* Sun Jun 18 2000 Than Ngo <than@redhat.de>
414- rebuilt in the new build environment, fix docdir
415- FHS packaging
416 
417* Thu Jun 08 2000 Than Ngo <than@redhat.de>
418- update to 1.2
419- move from powertools to main CD
420- use %%configure
421 
422* Mon Apr 3 2000 Ngo Than <than@redhat.de>
423- fix up reference (Bug #10368)
424 
425* Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
426- Fix up documentation path (Bug #7291)
427- Update to current stable branch - this should fix up the debugger problem
428- clean up spec file
429 
430* Fri Jan  6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
431- Update to current stable branch
432- Adapt to 6.2 Qt libraries
433- Use BuildPrereq
434 
435* Wed Jan 05 2000 Ngo Than <than@redhat.de>
436- added patch for alpha
437 
438* Tue Dec 21 1999 Ngo Than <than@redhat.de>
439- updated kdevelop-1.0 release
440 
441* Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
442- kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
443 
444* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
445- initial packaging for 6.1.
Note: See TracBrowser for help on using the repository browser.