source: projects/specs/trunk/k/kdegames3/kdegames3-vl.spec @ 636

Revision 636, 15.5 KB checked in by inagaki, 14 years ago (diff)

updated: KDE 3 stuffs

Line 
1%define make_cvs 1
2
3# These games are already in KDE 4.
4%define donotcompilelist katomic kbattleship kblackbox kbounce kgoldrunner kjumpingcube klines kmahjongg kmines knetwalk kolf konquest kpat kreversi ksame kshisen kspaceduel ktron ktuberling kwin4 lskat
5
6Name: kdegames3
7Summary: K Desktop Environment 3 - Games not ported to KDE 4
8Summary(ja): K デスクトップ環境 3 - KDE 4 に移植されていないゲーム集
9Version: 3.5.10
10Release: 1%{?_dist_release}
11
12License: GPLv2
13Group: Applications/Games
14URL: http://www.kde.org/
15
16Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegames-%{version}.tar.bz2
17Patch0: kdegames-3.5.10-trademarks.patch
18# fix build with make_cvs enabled and autoconf >= 2.64
19Patch1: arts-acinclude.patch
20# fix FTBFS with the new stricter ld in F13 (#565113)
21Patch2: kdegames-3.5.10-ftbfs.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: kdelibs3-devel >= %{version}
25BuildRequires: zlib-devel libpng-devel libjpeg-devel
26%if %{make_cvs}
27BuildRequires: automake libtool
28%endif
29Requires: kdelibs3 >= %{version}
30Requires: hicolor-icon-theme
31
32%description
33Games and gaming libraries for KDE which have not been ported to KDE 4 yet.
34Included with this package are: atlantik, kasteroids, kbackgammon, kboxpush,
35kenolaba, kfouleggs, klickety, kpoker, ksirtet, ksmiletris, ksnake.
36
37
38%package devel
39Summary: Development files for kdegames3
40Summary(ja): kdegames3 の開発用ファイル
41Group: Development/Libraries
42License: LGPLv2
43Requires: %{name} = %{version}-%{release}
44Requires: kdelibs3-devel >= %{version}
45
46%description devel
47Development files for the KDE gaming libraries.
48Install kdegames-devel if you wish to develop or compile games for the
49KDE desktop.
50
51%prep
52%setup -q -n kdegames-%{version}
53%patch0 -p1
54%patch1 -p1 -b .autoconf
55%patch2 -p1 -b .ftbfs
56
57export DO_NOT_COMPILE="%{donotcompilelist}"
58%if %{make_cvs}
59# hack/fix for newer automake
60  sed -iautomake -e 's|automake\*1.10\*|automake\*1.1[0-5]\*|' admin/cvs.sh
61  make -f admin/Makefile.common cvs
62%endif
63
64%build
65unset QTDIR || : ; . /etc/profile.d/qt.sh
66export DO_NOT_COMPILE="%{donotcompilelist}"
67
68%configure \
69    --with-qt-libraries=$QTDIR/lib \
70    --enable-new-ldflags \
71    --disable-dependency-tracking \
72    --disable-rpath \
73    --enable-final \
74    --disable-debug \
75    --disable-warnings \
76    --includedir=%{_includedir}/kde \
77    --disable-setgid
78
79make %{?_smp_mflags}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
84export DO_NOT_COMPILE="%{donotcompilelist}"
85make DESTDIR=$RPM_BUILD_ROOT install
86
87# locales
88%find_lang %{name} || touch %{name}.lang
89HTML_DIR=$(kde-config --expandvars --install html)
90if [ -d $RPM_BUILD_ROOT$HTML_DIR ]; then
91for lang_dir in $RPM_BUILD_ROOT$HTML_DIR/* ; do
92  if [ -d $lang_dir ]; then
93    # remove documentation for games we don't ship
94    pushd $lang_dir
95      for i in *; do
96        case "%{donotcompilelist}" in
97          *$i*)
98            # $i is listed in %{donotcompilelist}, zap
99            [ -d $i ] && rm -rf $i
100          ;;
101        esac
102      done
103      rm -rf kdegames-apidocs
104    popd
105    lang=$(basename $lang_dir)
106    echo "%lang($lang) $HTML_DIR/$lang/*" >> %{name}.lang
107    # replace absolute symlinks with relative ones
108    pushd $lang_dir
109      for i in *; do
110        [ -d $i -a -L $i/common ] && ln -nsf ../common $i/common
111      done
112    popd
113  fi
114done
115fi
116
117# rpmdocs
118for dir in atlantik k* ; do
119  case "%{donotcompilelist}" in
120    *$dir*)
121      # $dir is listed in %{donotcompilelist}, skip
122    ;;
123    *)
124      for file in AUTHORS ChangeLog README TODO ; do
125        test -s  "$dir/$file" && install -p -m644 -D "$dir/$file" "rpmdocs/$dir/$file"
126      done
127    ;;
128  esac
129done
130
131# remove libkdegames devel stuff, not used by anything and conflicts with KDE 4
132rm -rf $RPM_BUILD_ROOT%{_includedir}/kde/k* $RPM_BUILD_ROOT%{_libdir}/libkdegames.so
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%post
138/sbin/ldconfig
139for f in crystalsvg hicolor ; do
140  touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
141  gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
142done
143update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
144
145%postun
146/sbin/ldconfig
147for f in crystalsvg hicolor ; do
148  touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
149  gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
150done
151update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
152
153%files
154%defattr(-,root,root)
155%doc %{_datadir}/doc/HTML/en/*
156%{_bindir}/*
157%{_libdir}/lib*.so.*
158%{_libdir}/lib*.la
159%{_libdir}/kde3/*
160%{_datadir}/applications/kde/*.desktop
161%{_datadir}/apps/*
162%{_datadir}/config.kcfg/*
163%{_datadir}/icons/crystalsvg/*/*/*
164%{_datadir}/icons/hicolor/*/*/*
165%{_datadir}/services/*
166
167%files devel
168%defattr(-,root,root)
169%{_includedir}/kde/*
170%{_libdir}/lib*.so
171
172
173%changelog
174* Sun Mar 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-1
175- updated to 3.5.10 based on FC
176- built with new toolchain
177
178* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-2
179- renamed kdegames3
180
181* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
182- applied new versioning policy, spec in UTF-8
183
184* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
185- rebuild for VineSeed
186
187* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
188- new upstream release
189
190* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
191- rebuild for VineSeed
192
193* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
194- new upstream release
195
196* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
197- new upstream release
198
199* Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
200- added --with-qt-libraries and --enable-libsuffix option
201
202* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
203- rebuild for VineSeed
204
205* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
206- new upstream release
207
208* Mon Sep 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-0vl3
209- changed Group to Applications/Games
210- added Japanese summary
211
212* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
213- rebuild for VineSeed
214
215* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
216- new upstream release
217
218* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
219- rebuild for VineSeed
220
221* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
222- new upstream release
223
224* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
225- rebuild for VineSeed
226
227* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
228- new upstream release
229
230* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
231- rebuild for VineSeed
232
233* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
234- new upstream release
235
236* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
237- rebuild for VineSeed
238
239* Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
240- new upstream release
241
242* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
243- new upstream release
244
245* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
246- new upstream release
247
248* Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
249- new upstream release
250
251* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
252- rebuild for VineSeed
253
254* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
255- new upstream release
256
257* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
258- build for VineSeed
259- add --disable-rpath to configure option
260
261* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
262- new upstream release
263- use %%{?_smp_mflags} for make option
264
265* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
266- rebuild for VineSeed
267
268* Mon Mar 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
269- new upstream release
270
271* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
272- new upstream release (3.4.0-rc1)
273- update %%files
274
275* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
276- rebuild for VineSeed
277
278* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
279- source upgrade
280- build for Vine Linux 3.1
281
282* Thu Oct 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
283- source upgrade
284
285* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
286- rebuild with qt32
287
288* Sun Jun  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
289- source upgrade
290- remove lines about vine26
291- add URL: http://www.kde.org/
292
293* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
294- source upgrade
295
296* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
297- move *.so to main package
298
299* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
300- source upgrade
301
302* Thu Feb  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
303- source upgrade
304
305* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
306- rebuild for VineSeedPlus
307
308* Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
309- source upgrade
310- build for VinePlus/2.6
311- (VinePlus/2.6) BuildPrereq: autoconf258
312
313* Fri Dec 26 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
314- build for VineSeed with new toolchain and qt-3.2.3
315
316* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
317- rebuild with qt-3.2.1-0.26vl3
318
319* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
320- rebuild with qt-3.2.1-0vl3
321
322* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
323- source upgrade
324- build with gcc-3.2.3
325
326* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
327- source upgrade
328- change spec to build with gcc295
329- change make option for SMP and add script
330
331* Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
332- change spec to build with g++-2.95.3
333
334* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
335- source upgrade
336- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
337
338* Sat Mar 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
339- source upgrade
340- change spec to build both VineSeed and Vine2.5/2.6
341
342* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
343- source upgrade to 3.1-stable
344
345* Mon Jan 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0.rc7vl1
346- source upgrade to 3.1rc7
347- stop using objprelink2, it does not work with gcc3
348- change spec to make monolithic package only
349- move %{_libdir}/*.la and %{_libdir}/*.so to devel package
350- add %{_libdir}/kde3/*
351- cleanup spec
352
353* Sun Dec 29 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.5a-0vl1
354- source upgrade
355
356* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
357- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
358- add Prereq: ldconfig
359- add Requires: XFree86-libs XFree86-gl freetype2 libjpeg libmng libpng zlib
360- add Requires: qt >= 3.0.5 arts >= 1:1.0.4 kdelibs >= %{version}
361
362* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
363- source upgrade
364- BuildPrereq: autoconf253 objprelink2
365
366* Mon Sep 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
367- source upgrade
368
369* Fri Jul  5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
370- source upgrade
371
372* Fri Jun  7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-0vl1
373- source update to 3.0.1
374
375* Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
376- source update to 3.0
377- add configure option `--with-xinerama --enable-final'
378- add kbounce
379
380* Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
381- merged with rawhide 3.0.0-0.cvs20020306.1
382- source update to cvs-20020329
383- add BuildPrereq: autoconf252 automake15
384- There is Vine's previous changes, hacked for Vine
385 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
386  - update to 2.2.2
387 -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
388  - Delete Epoch
389  - Change BuildRequires and Requires
390  - objprelink (i386 only)
391  - Build for VineSeed
392
393* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
394- Fix packaging glitch in monolithic version
395
396* Tue Mar  5 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020305.1
397- Make splits a buildtime option (off by default) on request
398
399* Mon Jan  7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020107.1
400- Update to work with latest kdelibs changes
401
402* Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
403- Update
404- Add missing %{_bindir}/kbattleship
405
406* Sat Dec 15 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011215.1
407- Update
408- Split into several packages (one package per game)
409
410* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
411- Update
412- Work around ia64 breakages
413- Add build requirements (#48977)
414
415* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
416- Fix problem when changing the card type (Bug #28824)
417
418* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
419- 2.1-respin
420
421* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
422- 2.1
423
424* Sun Feb 11 2001 Than Ngo <than@redhat.com>
425- don't use make -j CPU, it's broken
426
427* Thu Feb  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
428- Run ldconfig in %%post and %%postun to make libkdegames happy
429- Replace absolute symlinks with relative symlinks (#24787)
430
431* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
432- Update
433- includedir=/usr/include/kde,
434  now that libkdegames installs kcarddeck.h
435
436* Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
437- Get rid of the gcc bug workaround, it's no longer needed
438
439* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
440- Update
441- Don't exclude ia64
442
443* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
444- Update to HEAD
445
446* Sat Oct 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
447- Update to KDE_2_0_BRANCH, now that the ".0 release" bugs are fixed.
448
449* Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
450- 2.0 final
451
452* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
453- 2.0
454
455* Mon Oct  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
456- new CVS
457- work around g++ bugs (in kjumpingcube)
458
459* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
460- 1.93
461
462* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
463- new version
464
465* Wed Jul 19 2000 Than Ngo <than@redhat.de>
466- fix docdir
467- rebuild 16 July snapshot
468
469* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
470- SMPify
471- don't hardcode QTDIR
472
473* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
474- use gcc 2.96
475- new snapshot
476
477* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
478- new snapshot
479- ExcludeArch ia64 for now
480
481* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
482- new snapshot
483- move it to /usr, where it belongs
484
485* Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
486- 2.0 snapshot
487
488* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
489- mark doc files as such
490
491* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
492- 1.1.2 release.
493
494* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
495- snapshot, includes kde 1.1.1 + fixes
496
497* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
498- last snapshot before release
499- ripped out asteroids and sirtet
500
501* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
502- latest stable snapshot
503
504* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
505- Injected new description and group.
506
507* Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
508- upgraded to KDE 1.1 final.
509
510* Fri Feb 05 1999 Preston Brown <pbrown@redhat.com>
511- rebuilt for new libstdc++ etc.
512
513* Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
514- re-merged updates from Duncan Haldane, change /opt/kde --> /usr
515
Note: See TracBrowser for help on using the repository browser.