source: projects/specs/trunk/k/kdegames3/kdegames3-vl.spec @ 521

Revision 521, 15.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# These games are already in KDE 4.
2%define donotcompilelist katomic kbattleship kblackbox kbounce kgoldrunner kjumpingcube klines kmahjongg kmines knetwalk kolf konquest kpat kreversi ksame kshisen kspaceduel ktron ktuberling kwin4 lskat
3
4Name: kdegames3
5Version: 3.5.8
6Release: 2%{?_dist_release}
7Summary: K Desktop Environment 3 - Games not ported to KDE 4
8Summary(ja): K デスクトップ環境 3 - KDE 4 に移植されていないゲーム集
9Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegames-%{version}.tar.bz2
10URL: http://www.kde.org/
11Group: Applications/Games
12License: GPLv2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: qt-devel >= 3.3.2
16BuildRequires: arts-devel >= 1:1.5.0
17BuildRequires: kdelibs3-devel >= %{version}
18BuildRequires: zlib-devel libjpeg-devel libpng-devel
19Requires: kdelibs3 >= %{version}
20Requires: hicolor-icon-theme
21
22%description
23Games and gaming libraries for the K Desktop Environment which have not been
24ported to KDE 4 yet.
25Included with this package are: atlantik, kasteroids, kbackgammon, kboxpush,
26kenolaba, kfouleggs, klickety, kpoker, ksirtet, ksmiletris, ksnake.
27
28%package devel
29Summary: Development files for kdegames3
30Summary(ja): kdegames3 の開発用ファイル
31Group: Development/Libraries
32License: LGPLv2
33Requires: %{name} = %{version}-%{release}
34Requires: kdelibs3-devel >= %{version}
35
36%description devel
37Development files for the KDE gaming libraries.
38Install kdegames-devel if you wish to develop or compile games for the
39KDE desktop.
40
41%prep
42%setup -q -n kdegames-%{version}
43
44%build
45export KDEDIR=%{_prefix}
46export DO_NOT_COMPILE="%{donotcompilelist}"
47unset QTDIR || : ; . /etc/profile.d/qt.sh
48CFLAGS="$RPM_OPT_FLAGS -DNO_DEBUG -DNDEBUG" \
49CXXFLAGS="$RPM_OPT_FLAGS -DNO_DEBUG -DNDEBUG -fno-check-new" \
50./configure --prefix=%{_prefix} \
51    --with-qt-libraries=$QTDIR/lib \
52    --includedir=%{_includedir}/kde \
53    --with-xinerama \
54    --enable-new-ldflags \
55    --disable-dependency-tracking \
56    --enable-final \
57    --disable-rpath
58
59make %{?_smp_mflags}
60
61%install
62rm -rf $RPM_BUILD_ROOT
63
64export DO_NOT_COMPILE="%{donotcompilelist}"
65make DESTDIR=$RPM_BUILD_ROOT install
66
67# locales
68%find_lang %{name} || touch %{name}.lang
69HTML_DIR=$(kde-config --expandvars --install html)
70if [ -d %{buildroot}$HTML_DIR ]; then
71for lang_dir in %{buildroot}$HTML_DIR/* ; do
72  if [ -d $lang_dir ]; then
73    # remove documentation for games we don't ship
74    pushd $lang_dir
75      for i in *; do
76        case "%{donotcompilelist}" in
77          *$i*)
78            # $i is listed in %{donotcompilelist}, zap
79            [ -d $i ] && rm -rf $i
80          ;;
81        esac
82      done
83      rm -rf kdegames-apidocs
84    popd
85    lang=$(basename $lang_dir)
86    echo "%lang($lang) $HTML_DIR/$lang/*" >> %{name}.lang
87    # replace absolute symlinks with relative ones
88    pushd $lang_dir
89      for i in *; do
90        [ -d $i -a -L $i/common ] && ln -nsf ../common $i/common
91      done
92    popd
93  fi
94done
95fi
96
97# rpmdocs
98for dir in atlantik k* ; do
99  case "%{donotcompilelist}" in
100    *$dir*)
101      # $dir is listed in %{donotcompilelist}, skip
102    ;;
103    *)
104      for file in AUTHORS ChangeLog README TODO ; do
105        test -s  "$dir/$file" && install -p -m644 -D "$dir/$file" "rpmdocs/$dir/$file"
106      done
107    ;;
108  esac
109done
110
111# remove libkdegames devel stuff, not used by anything and conflicts with KDE 4
112rm -rf $RPM_BUILD_ROOT%{_includedir}/kde/k* $RPM_BUILD_ROOT%{_libdir}/libkdegames.so
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post
118/sbin/ldconfig
119for f in crystalsvg hicolor ; do
120  touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
121  gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
122done
123update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
124
125%postun
126/sbin/ldconfig
127for f in crystalsvg hicolor ; do
128  touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
129  gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
130done
131update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
132
133%files
134%defattr(-,root,root)
135%doc %{_datadir}/doc/HTML/en/*
136%{_bindir}/*
137%{_libdir}/lib*.so.*
138%{_libdir}/lib*.la
139%{_libdir}/kde3/*
140%{_datadir}/applications/kde/*.desktop
141%{_datadir}/apps/*
142%{_datadir}/config.kcfg/*
143%{_datadir}/icons/crystalsvg/*/*/*
144%{_datadir}/icons/hicolor/*/*/*
145%{_datadir}/services/*
146
147%files devel
148%defattr(-,root,root)
149%{_includedir}/kde/*
150%{_libdir}/lib*.so
151
152
153%changelog
154* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-2
155- renamed kdegames3
156
157* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
158- applied new versioning policy, spec in UTF-8
159
160* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
161- rebuild for VineSeed
162
163* Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
164- new upstream release
165
166* Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
167- rebuild for VineSeed
168
169* Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
170- new upstream release
171
172* Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
173- new upstream release
174
175* Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
176- added --with-qt-libraries and --enable-libsuffix option
177
178* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
179- rebuild for VineSeed
180
181* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
182- new upstream release
183
184* Mon Sep 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-0vl3
185- changed Group to Applications/Games
186- added Japanese summary
187
188* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
189- rebuild for VineSeed
190
191* Tue Aug  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
192- new upstream release
193
194* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
195- rebuild for VineSeed
196
197* Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
198- new upstream release
199
200* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
201- rebuild for VineSeed
202
203* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
204- new upstream release
205
206* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
207- rebuild for VineSeed
208
209* Mon Feb  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
210- new upstream release
211
212* Thu Dec  8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
213- rebuild for VineSeed
214
215* Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
216- new upstream release
217
218* Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
219- new upstream release
220
221* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
222- new upstream release
223
224* Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
225- new upstream release
226
227* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
228- rebuild for VineSeed
229
230* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
231- new upstream release
232
233* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
234- build for VineSeed
235- add --disable-rpath to configure option
236
237* Mon Jun  6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
238- new upstream release
239- use %%{?_smp_mflags} for make option
240
241* Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
242- rebuild for VineSeed
243
244* Mon Mar 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
245- new upstream release
246
247* Fri Mar  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
248- new upstream release (3.4.0-rc1)
249- update %%files
250
251* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
252- rebuild for VineSeed
253
254* Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
255- source upgrade
256- build for Vine Linux 3.1
257
258* Thu Oct 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
259- source upgrade
260
261* Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
262- rebuild with qt32
263
264* Sun Jun  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
265- source upgrade
266- remove lines about vine26
267- add URL: http://www.kde.org/
268
269* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
270- source upgrade
271
272* Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
273- move *.so to main package
274
275* Tue Mar  9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
276- source upgrade
277
278* Thu Feb  5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
279- source upgrade
280
281* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
282- rebuild for VineSeedPlus
283
284* Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
285- source upgrade
286- build for VinePlus/2.6
287- (VinePlus/2.6) BuildPrereq: autoconf258
288
289* Fri Dec 26 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
290- build for VineSeed with new toolchain and qt-3.2.3
291
292* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
293- rebuild with qt-3.2.1-0.26vl3
294
295* Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
296- rebuild with qt-3.2.1-0vl3
297
298* Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
299- source upgrade
300- build with gcc-3.2.3
301
302* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
303- source upgrade
304- change spec to build with gcc295
305- change make option for SMP and add script
306
307* Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
308- change spec to build with g++-2.95.3
309
310* Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
311- source upgrade
312- built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
313
314* Sat Mar 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
315- source upgrade
316- change spec to build both VineSeed and Vine2.5/2.6
317
318* Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
319- source upgrade to 3.1-stable
320
321* Mon Jan 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0.rc7vl1
322- source upgrade to 3.1rc7
323- stop using objprelink2, it does not work with gcc3
324- change spec to make monolithic package only
325- move %{_libdir}/*.la and %{_libdir}/*.so to devel package
326- add %{_libdir}/kde3/*
327- cleanup spec
328
329* Sun Dec 29 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.5a-0vl1
330- source upgrade
331
332* Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
333- objprelink2 support only ix86 (add %ifarch %{ix86} ... )
334- add Prereq: ldconfig
335- add Requires: XFree86-libs XFree86-gl freetype2 libjpeg libmng libpng zlib
336- add Requires: qt >= 3.0.5 arts >= 1:1.0.4 kdelibs >= %{version}
337
338* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
339- source upgrade
340- BuildPrereq: autoconf253 objprelink2
341
342* Mon Sep 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
343- source upgrade
344
345* Fri Jul  5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
346- source upgrade
347
348* Fri Jun  7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-0vl1
349- source update to 3.0.1
350
351* Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
352- source update to 3.0
353- add configure option `--with-xinerama --enable-final'
354- add kbounce
355
356* Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
357- merged with rawhide 3.0.0-0.cvs20020306.1
358- source update to cvs-20020329
359- add BuildPrereq: autoconf252 automake15
360- There is Vine's previous changes, hacked for Vine
361 -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
362  - update to 2.2.2
363 -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
364  - Delete Epoch
365  - Change BuildRequires and Requires
366  - objprelink (i386 only)
367  - Build for VineSeed
368
369* Wed Mar  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
370- Fix packaging glitch in monolithic version
371
372* Tue Mar  5 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020305.1
373- Make splits a buildtime option (off by default) on request
374
375* Mon Jan  7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020107.1
376- Update to work with latest kdelibs changes
377
378* Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
379- Update
380- Add missing %{_bindir}/kbattleship
381
382* Sat Dec 15 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011215.1
383- Update
384- Split into several packages (one package per game)
385
386* Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
387- Update
388- Work around ia64 breakages
389- Add build requirements (#48977)
390
391* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
392- Fix problem when changing the card type (Bug #28824)
393
394* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
395- 2.1-respin
396
397* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
398- 2.1
399
400* Sun Feb 11 2001 Than Ngo <than@redhat.com>
401- don't use make -j CPU, it's broken
402
403* Thu Feb  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
404- Run ldconfig in %%post and %%postun to make libkdegames happy
405- Replace absolute symlinks with relative symlinks (#24787)
406
407* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
408- Update
409- includedir=/usr/include/kde,
410  now that libkdegames installs kcarddeck.h
411
412* Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
413- Get rid of the gcc bug workaround, it's no longer needed
414
415* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
416- Update
417- Don't exclude ia64
418
419* Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
420- Update to HEAD
421
422* Sat Oct 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
423- Update to KDE_2_0_BRANCH, now that the ".0 release" bugs are fixed.
424
425* Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
426- 2.0 final
427
428* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
429- 2.0
430
431* Mon Oct  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
432- new CVS
433- work around g++ bugs (in kjumpingcube)
434
435* Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
436- 1.93
437
438* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
439- new version
440
441* Wed Jul 19 2000 Than Ngo <than@redhat.de>
442- fix docdir
443- rebuild 16 July snapshot
444
445* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
446- SMPify
447- don't hardcode QTDIR
448
449* Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
450- use gcc 2.96
451- new snapshot
452
453* Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
454- new snapshot
455- ExcludeArch ia64 for now
456
457* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
458- new snapshot
459- move it to /usr, where it belongs
460
461* Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
462- 2.0 snapshot
463
464* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
465- mark doc files as such
466
467* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
468- 1.1.2 release.
469
470* Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
471- snapshot, includes kde 1.1.1 + fixes
472
473* Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
474- last snapshot before release
475- ripped out asteroids and sirtet
476
477* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
478- latest stable snapshot
479
480* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
481- Injected new description and group.
482
483* Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
484- upgraded to KDE 1.1 final.
485
486* Fri Feb 05 1999 Preston Brown <pbrown@redhat.com>
487- rebuilt for new libstdc++ etc.
488
489* Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
490- re-merged updates from Duncan Haldane, change /opt/kde --> /usr
491
Note: See TracBrowser for help on using the repository browser.