source: projects/specs/trunk/j/jasper/jasper-vl.spec @ 12523

Revision 12523, 6.4 KB checked in by tomop, 3 years ago (diff)

updated 2 packages

jasper-2.0.24-1

pinentry-1.1.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           jasper
4Summary:        implementation of the JPEG-2000 standard, Part 1
5Version:        2.0.24
6Release:        1%{?_dist_release}
7Group:          graphics
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11License:        Modified BSD (see LICENSE)
12URL:            https://www.ece.uvic.ca/~frodo/jasper/
13Source:         https://github.com/mdadams/jasper/archive/version-%{version}.tar.gz#/%{name}-version-%{version}.tar.gz
14
15# skip hard-coded prefix/lib rpath
16Patch1:         jasper-2.0.14-rpath.patch
17Patch1000:      CVE-2021-3272.patch
18
19
20BuildRoot:   %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  autoconf automake libtool
22BuildRequires:  freeglut-devel
23BuildRequires:  libGLU-devel
24BuildRequires:  libjpeg-devel
25BuildRequires:  pkgconfig
26BuildRequires:  cmake
27BuildRequires:  git
28
29Requires:       %{name}-libs = %{version}-%{release}
30
31%description
32JasPer is a collection of software (i.e., a library and application
33programs) for the coding and manipulation of images.  This software
34can handle image data in a variety of formats.  One such format
35supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
36
37
38%package devel
39Summary:     Include Files and Documentation for jasper
40Group:       programming
41Requires:    %{name}-libs = %{version}-%{release}
42Requires:    libjpeg-devel
43
44%description devel
45This package contains libjasper, a library implementing the JPEG-2000
46image compression standard Part 1.
47
48
49%package libs
50Summary: Runtime libraries for %{name}
51Group:   system
52
53%description libs
54This package contains runtime libraries for JasPer.
55
56
57# compat32
58%package -n compat32-%{name}-devel
59Summary:     Include Files and Documentation for jasper
60Group:       programming
61Requires:    %{name}-libs = %{version}-%{release}
62Requires:    compat32-libjpeg-devel
63
64%description -n compat32-%{name}-devel
65This package contains libjasper, a library implementing the JPEG-2000
66image compression standard Part 1.
67
68
69%package -n compat32-%{name}-libs
70Summary: Runtime libraries for %{name}
71Group:   system
72
73%description -n compat32-%{name}-libs
74This package contains runtime libraries for JasPer.
75
76
77%debug_package
78
79
80%prep
81%autosetup -S git -n %{name}-version-%{version}
82
83
84%build
85mkdir -p builder
86pushd builder
87%cmake -DJAS_ENABLE_DOC:BOOL=OFF ..
88popd
89%make_build -C builder
90
91
92%install
93[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
94make install/fast DESTDIR=%{buildroot} -C builder
95
96# Unpackaged files
97rm -f doc/README
98rm -f %{buildroot}%{_libdir}/lib*.la
99rm -rf %{buildroot}%{_docdir}/JasPer
100
101
102%check
103make test -C builder
104
105
106%clean
107[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
108
109
110%post libs -p /sbin/ldconfig
111%postun libs -p /sbin/ldconfig
112
113%post -n compat32-%{name}-libs -p /sbin/ldconfig
114%postun -n compat32-%{name}-libs -p /sbin/ldconfig
115
116
117%files
118%defattr(-,root,root)
119%{!?_licensedir:%global license %%doc}
120%{_bindir}/*
121%{_mandir}/man1/*
122
123%files libs
124%license COPYRIGHT LICENSE
125%doc INSTALL README doc/README doc/jasper.pdf doc/jpeg2000.pdf
126%defattr(-,root,root)
127%{_libdir}/libjasper*.so.*
128
129%files devel
130%defattr(-,root,root)
131%{_includedir}/jasper
132%{_libdir}/libjasper*.so
133%{_libdir}/pkgconfig/jasper.pc
134
135# compat32
136%if %{build_compat32}
137%files -n compat32-%{name}-libs
138%defattr(-,root,root)
139%{_libdir}/libjasper*.so.*
140
141%files -n compat32-%{name}-devel
142%defattr(-,root,root)
143%{_libdir}/libjasper*.so
144%{_libdir}/pkgconfig/jasper.pc
145%endif
146
147
148%changelog
149* Thu Feb 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.24-1
150- new upstream release.
151- added Patch1000 to fix CVE-2021-3272.
152
153* Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.23-1
154- new upstream release.
155
156* Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.19-1
157- new upstream release.
158
159* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.16-1
160- new upstream release.
161- dropped Patch1: fixed in upstream.
162- imported Patch1 from rawhide.
163
164* Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.12-1
165- new upstream release.
166- dropped all patches.
167- imported patch1 from rawhide.
168
169* Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
170- added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
171
172* Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
173- imported all patches from RawHide.
174
175* Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
176- rebuild with libpng-1.6.12
177
178* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
179- rebuilt with current VineSeed
180
181* Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
182- added compat32 subpackage for x86_64 arch support.
183
184* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
185- splited out runtime library to sub package
186- enable opengl again, add BuildRequires: freeglut-devel
187
188* Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
189- remove .la
190- add --disable-static to configure option
191
192* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
193- added Patch0 from VinePlus/4.0
194  * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
195  - add patch100 for fix CVE-2007-2721
196  - add Vendor/Distributin Tag
197
198* Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
199- remove BuildPrereq: freeglut-devel and Requires freeglut
200- add --disable-opengl to configure option
201
202* Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
203- add BuildPreReq: unzip (used in the %%pre section)
204
205* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
206- new upstream release
207
208* Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
209- new upstream release
210- changed Group to System Environment/Libraries
211- added --mandir=%{_mandir}
212- added %post and %postun section
213
214* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
215- added --libdir=%{_libdir} configure option
216
217* Tue Sep  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
218- build with freeglut
219- change BuildPrereq and Requires
220
221* Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
222- new upstream version (jasper-1.701.0)
223
224* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
225- rebuild for VineSeedPlus
226
227* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
228- source upgrade
229- change spec to build for VineLinux
230
231* Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
232- spec file created
Note: See TracBrowser for help on using the repository browser.