source: projects/specs/trunk/j/jasper/jasper-vl.spec @ 12513

Revision 12513, 6.2 KB checked in by tomop, 3 years ago (diff)

updated 9 packages

curl-7.74.0-1

freerdp-2.2.0-1

golang-1.15.6-1

jasper-2.0.23-1

libssh-0.9.5-1

nghttp2-1.42.0-1

nodejs-14.15.1-1

pulseaudio-14.0-1

samba-4.13.3-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           jasper
4Summary:        implementation of the JPEG-2000 standard, Part 1
5Version:        2.0.23
6Release:        1%{?_dist_release}
7Group:          graphics
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11License:        Modified BSD (see LICENSE)
12URL:            https://www.ece.uvic.ca/~frodo/jasper/
13Source:         https://github.com/mdadams/jasper/archive/version-%{version}.tar.gz#/%{name}-version-%{version}.tar.gz
14
15# skip hard-coded prefix/lib rpath
16Patch1:         jasper-2.0.14-rpath.patch
17
18BuildRoot:   %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  autoconf automake libtool
20BuildRequires:  freeglut-devel
21BuildRequires:  libGLU-devel
22BuildRequires:  libjpeg-devel
23BuildRequires:  pkgconfig
24BuildRequires:  cmake
25
26Requires:       %{name}-libs = %{version}-%{release}
27
28%description
29JasPer is a collection of software (i.e., a library and application
30programs) for the coding and manipulation of images.  This software
31can handle image data in a variety of formats.  One such format
32supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
33
34
35%package devel
36Summary:     Include Files and Documentation for jasper
37Group:       programming
38Requires:    %{name}-libs = %{version}-%{release}
39Requires:    libjpeg-devel
40
41%description devel
42This package contains libjasper, a library implementing the JPEG-2000
43image compression standard Part 1.
44
45
46%package libs
47Summary: Runtime libraries for %{name}
48Group:   system
49
50%description libs
51This package contains runtime libraries for JasPer.
52
53
54# compat32
55%package -n compat32-%{name}-devel
56Summary:     Include Files and Documentation for jasper
57Group:       programming
58Requires:    %{name}-libs = %{version}-%{release}
59Requires:    compat32-libjpeg-devel
60
61%description -n compat32-%{name}-devel
62This package contains libjasper, a library implementing the JPEG-2000
63image compression standard Part 1.
64
65
66%package -n compat32-%{name}-libs
67Summary: Runtime libraries for %{name}
68Group:   system
69
70%description -n compat32-%{name}-libs
71This package contains runtime libraries for JasPer.
72
73
74%debug_package
75
76
77%prep
78%setup -q -n %{name}-version-%{version}
79
80%patch1 -p1 -b .rpath
81
82
83%build
84mkdir -p builder
85pushd builder
86%cmake -DJAS_ENABLE_DOC:BOOL=OFF ..
87popd
88%make_build -C builder
89
90
91%install
92[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
93make install/fast DESTDIR=%{buildroot} -C builder
94
95# Unpackaged files
96rm -f doc/README
97rm -f %{buildroot}%{_libdir}/lib*.la
98rm -rf %{buildroot}%{_docdir}/JasPer
99
100
101%check
102make test -C builder
103
104
105%clean
106[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
107
108
109%post libs -p /sbin/ldconfig
110%postun libs -p /sbin/ldconfig
111
112%post -n compat32-%{name}-libs -p /sbin/ldconfig
113%postun -n compat32-%{name}-libs -p /sbin/ldconfig
114
115
116%files
117%defattr(-,root,root)
118%{!?_licensedir:%global license %%doc}
119%{_bindir}/*
120%{_mandir}/man1/*
121
122%files libs
123%license COPYRIGHT LICENSE
124%doc INSTALL README doc/README doc/jasper.pdf doc/jpeg2000.pdf
125%defattr(-,root,root)
126%{_libdir}/libjasper*.so.*
127
128%files devel
129%defattr(-,root,root)
130%{_includedir}/jasper
131%{_libdir}/libjasper*.so
132%{_libdir}/pkgconfig/jasper.pc
133
134# compat32
135%if %{build_compat32}
136%files -n compat32-%{name}-libs
137%defattr(-,root,root)
138%{_libdir}/libjasper*.so.*
139
140%files -n compat32-%{name}-devel
141%defattr(-,root,root)
142%{_libdir}/libjasper*.so
143%{_libdir}/pkgconfig/jasper.pc
144%endif
145
146
147%changelog
148* Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.23-1
149- new upstream release.
150
151* Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.19-1
152- new upstream release.
153
154* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.16-1
155- new upstream release.
156- dropped Patch1: fixed in upstream.
157- imported Patch1 from rawhide.
158
159* Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.12-1
160- new upstream release.
161- dropped all patches.
162- imported patch1 from rawhide.
163
164* Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
165- added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
166
167* Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
168- imported all patches from RawHide.
169
170* Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
171- rebuild with libpng-1.6.12
172
173* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
174- rebuilt with current VineSeed
175
176* Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
177- added compat32 subpackage for x86_64 arch support.
178
179* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
180- splited out runtime library to sub package
181- enable opengl again, add BuildRequires: freeglut-devel
182
183* Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
184- remove .la
185- add --disable-static to configure option
186
187* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
188- added Patch0 from VinePlus/4.0
189  * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
190  - add patch100 for fix CVE-2007-2721
191  - add Vendor/Distributin Tag
192
193* Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
194- remove BuildPrereq: freeglut-devel and Requires freeglut
195- add --disable-opengl to configure option
196
197* Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
198- add BuildPreReq: unzip (used in the %%pre section)
199
200* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
201- new upstream release
202
203* Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
204- new upstream release
205- changed Group to System Environment/Libraries
206- added --mandir=%{_mandir}
207- added %post and %postun section
208
209* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
210- added --libdir=%{_libdir} configure option
211
212* Tue Sep  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
213- build with freeglut
214- change BuildPrereq and Requires
215
216* Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
217- new upstream version (jasper-1.701.0)
218
219* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
220- rebuild for VineSeedPlus
221
222* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
223- source upgrade
224- change spec to build for VineLinux
225
226* Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
227- spec file created
Note: See TracBrowser for help on using the repository browser.