source: projects/specs/trunk/j/jasper/jasper-vl.spec @ 12554

Revision 12554, 6.4 KB checked in by tomop, 3 years ago (diff)

updated 3 packages

bind-9.11.28-1

jasper-2.0.25-1

python3-3.8.8-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           jasper
4Summary:        implementation of the JPEG-2000 standard, Part 1
5Version:        2.0.25
6Release:        1%{?_dist_release}
7Group:          graphics
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11License:        Modified BSD (see LICENSE)
12URL:            https://www.ece.uvic.ca/~frodo/jasper/
13Source:         https://github.com/mdadams/jasper/archive/version-%{version}.tar.gz#/%{name}-version-%{version}.tar.gz
14
15# skip hard-coded prefix/lib rpath
16Patch1:         jasper-2.0.14-rpath.patch
17
18BuildRoot:   %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  autoconf automake libtool
20BuildRequires:  freeglut-devel
21BuildRequires:  libGLU-devel
22BuildRequires:  libjpeg-devel
23BuildRequires:  pkgconfig
24BuildRequires:  cmake
25BuildRequires:  git
26
27Requires:       %{name}-libs = %{version}-%{release}
28
29%description
30JasPer is a collection of software (i.e., a library and application
31programs) for the coding and manipulation of images.  This software
32can handle image data in a variety of formats.  One such format
33supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
34
35
36%package devel
37Summary:     Include Files and Documentation for jasper
38Group:       programming
39Requires:    %{name}-libs = %{version}-%{release}
40Requires:    libjpeg-devel
41
42%description devel
43This package contains libjasper, a library implementing the JPEG-2000
44image compression standard Part 1.
45
46
47%package libs
48Summary: Runtime libraries for %{name}
49Group:   system
50
51%description libs
52This package contains runtime libraries for JasPer.
53
54
55# compat32
56%package -n compat32-%{name}-devel
57Summary:     Include Files and Documentation for jasper
58Group:       programming
59Requires:    %{name}-libs = %{version}-%{release}
60Requires:    compat32-libjpeg-devel
61
62%description -n compat32-%{name}-devel
63This package contains libjasper, a library implementing the JPEG-2000
64image compression standard Part 1.
65
66
67%package -n compat32-%{name}-libs
68Summary: Runtime libraries for %{name}
69Group:   system
70
71%description -n compat32-%{name}-libs
72This package contains runtime libraries for JasPer.
73
74
75%debug_package
76
77
78%prep
79%autosetup -S git -n %{name}-version-%{version}
80
81
82%build
83mkdir -p builder
84pushd builder
85%cmake -DJAS_ENABLE_DOC:BOOL=OFF ..
86popd
87%make_build -C builder
88
89
90%install
91[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
92make install/fast DESTDIR=%{buildroot} -C builder
93
94# Unpackaged files
95rm -f doc/README
96rm -f %{buildroot}%{_libdir}/lib*.la
97rm -rf %{buildroot}%{_docdir}/JasPer
98
99
100%check
101make test -C builder
102
103
104%clean
105[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
106
107
108%ldconfig_scriptlets libs
109%ldconfig_scriptlets -n compat32-%{name}-libs
110
111
112%files
113%defattr(-,root,root)
114%{!?_licensedir:%global license %%doc}
115%{_bindir}/*
116%{_mandir}/man1/*
117
118%files libs
119%license COPYRIGHT LICENSE
120%doc INSTALL README doc/README doc/jasper.pdf doc/jpeg2000.pdf
121%defattr(-,root,root)
122%{_libdir}/libjasper*.so.*
123
124%files devel
125%defattr(-,root,root)
126%{_includedir}/jasper
127%{_libdir}/libjasper*.so
128%{_libdir}/pkgconfig/jasper.pc
129
130# compat32
131%if %{build_compat32}
132%files -n compat32-%{name}-libs
133%defattr(-,root,root)
134%{_libdir}/libjasper*.so.*
135
136%files -n compat32-%{name}-devel
137%defattr(-,root,root)
138%{_libdir}/libjasper*.so
139%{_libdir}/pkgconfig/jasper.pc
140%endif
141
142
143%changelog
144* Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.25-1
145- new upstream release.
146- dropped Patch1000: fixed in upstream.
147
148* Thu Feb 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.24-1
149- new upstream release.
150- added Patch1000 to fix CVE-2021-3272.
151
152* Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.23-1
153- new upstream release.
154
155* Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.19-1
156- new upstream release.
157
158* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.16-1
159- new upstream release.
160- dropped Patch1: fixed in upstream.
161- imported Patch1 from rawhide.
162
163* Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.12-1
164- new upstream release.
165- dropped all patches.
166- imported patch1 from rawhide.
167
168* Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
169- added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
170
171* Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
172- imported all patches from RawHide.
173
174* Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
175- rebuild with libpng-1.6.12
176
177* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
178- rebuilt with current VineSeed
179
180* Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
181- added compat32 subpackage for x86_64 arch support.
182
183* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
184- splited out runtime library to sub package
185- enable opengl again, add BuildRequires: freeglut-devel
186
187* Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
188- remove .la
189- add --disable-static to configure option
190
191* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
192- added Patch0 from VinePlus/4.0
193  * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
194  - add patch100 for fix CVE-2007-2721
195  - add Vendor/Distributin Tag
196
197* Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
198- remove BuildPrereq: freeglut-devel and Requires freeglut
199- add --disable-opengl to configure option
200
201* Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
202- add BuildPreReq: unzip (used in the %%pre section)
203
204* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
205- new upstream release
206
207* Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
208- new upstream release
209- changed Group to System Environment/Libraries
210- added --mandir=%{_mandir}
211- added %post and %postun section
212
213* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
214- added --libdir=%{_libdir} configure option
215
216* Tue Sep  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
217- build with freeglut
218- change BuildPrereq and Requires
219
220* Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
221- new upstream version (jasper-1.701.0)
222
223* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
224- rebuild for VineSeedPlus
225
226* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
227- source upgrade
228- change spec to build for VineLinux
229
230* Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
231- spec file created
Note: See TracBrowser for help on using the repository browser.