source: projects/specs/trunk/j/jasper/jasper-vl.spec @ 12189

Revision 12189, 6.1 KB checked in by tomop, 5 years ago (diff)

updated image libs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Name:        jasper
5Summary:     implementation of the JPEG-2000 standard, Part 1
6Version:     2.0.16
7Release:     1%{?_dist_release}
8
9Group:       Applications/Graphics
10License:     Modified BSD (see LICENSE)
11URL:         http://www.ece.uvic.ca/~mdadams/jasper/
12
13Source:      https://github.com/mdadams/jasper/archive/version-%{version}.tar.gz#/%{name}-version-%{version}.tar.gz
14
15# skip hard-coded prefix/lib rpath
16Patch1: jasper-2.0.14-rpath.patch
17
18BuildRoot:   %{_tmppath}/%{name}-%{version}-root
19BuildRequires: autoconf automake libtool
20BuildRequires: freeglut-devel
21BuildRequires: libGLU-devel
22BuildRequires: libjpeg-devel
23BuildRequires: pkgconfig
24BuildRequires: cmake
25
26Requires:    %{name}-libs = %{version}-%{release}
27
28Vendor:       Project Vine
29Distribution: Vine Linux
30
31%description
32JasPer is a collection of software (i.e., a library and application
33programs) for the coding and manipulation of images.  This software
34can handle image data in a variety of formats.  One such format
35supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
36
37%package devel
38Summary:     Include Files and Documentation for jasper
39Group:       Development/Libraries
40Requires:    %{name}-libs = %{version}-%{release}
41Requires:    libjpeg-devel
42
43%description devel
44This package contains libjasper, a library implementing the JPEG-2000
45image compression standard Part 1.
46
47%package libs
48Summary: Runtime libraries for %{name}
49Group:   System Environment/Libraries
50
51%description libs
52This package contains runtime libraries for JasPer.
53
54# compat32
55%package -n compat32-%{name}-devel
56Summary:     Include Files and Documentation for jasper
57Group:       Development/Libraries
58Requires:    %{name}-libs = %{version}-%{release}
59Requires:    compat32-libjpeg-devel
60
61%description -n compat32-%{name}-devel
62This package contains libjasper, a library implementing the JPEG-2000
63image compression standard Part 1.
64
65%package -n compat32-%{name}-libs
66Summary: Runtime libraries for %{name}
67Group:   System Environment/Libraries
68
69%description -n compat32-%{name}-libs
70This package contains runtime libraries for JasPer.
71
72
73%prep
74%setup -q -n %{name}-version-%{version}
75
76%patch1 -p1 -b .rpath
77
78
79%build
80mkdir -p builder
81pushd builder
82%cmake -DJAS_ENABLE_DOC:BOOL=OFF ..
83popd
84%make_build -C builder
85
86
87%install
88[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
89make install/fast DESTDIR=%{buildroot} -C builder
90
91# Unpackaged files
92rm -f doc/README
93rm -f %{buildroot}%{_libdir}/lib*.la
94rm -rf %{buildroot}%{_docdir}/JasPer
95
96%check
97make test -C builder
98
99
100%clean
101[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
102
103%post libs -p /sbin/ldconfig
104
105%postun libs -p /sbin/ldconfig
106
107%post -n compat32-%{name}-libs -p /sbin/ldconfig
108
109%postun -n compat32-%{name}-libs -p /sbin/ldconfig
110
111%files
112%defattr(-,root,root)
113%{!?_licensedir:%global license %%doc}
114%{_bindir}/*
115%{_mandir}/man1/*
116
117%files libs
118%license COPYRIGHT LICENSE
119%doc INSTALL README doc/README doc/jasper.pdf doc/jpeg2000.pdf
120%defattr(-,root,root)
121%{_libdir}/libjasper*.so.*
122
123%files devel
124%defattr(-,root,root)
125%{_includedir}/jasper
126%{_libdir}/libjasper*.so
127%{_libdir}/pkgconfig/jasper.pc
128
129# compat32
130%if %{build_compat32}
131%files -n compat32-%{name}-libs
132%defattr(-,root,root)
133%{_libdir}/libjasper*.so.*
134
135%files -n compat32-%{name}-devel
136%defattr(-,root,root)
137%{_libdir}/libjasper*.so
138%{_libdir}/pkgconfig/jasper.pc
139%endif
140
141%changelog
142* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.16-1
143- new upstream release.
144- dropped Patch1: fixed in upstream.
145- imported Patch1 from rawhide.
146
147* Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.12-1
148- new upstream release.
149- dropped all patches.
150- imported patch1 from rawhide.
151
152* Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
153- added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
154
155* Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
156- imported all patches from RawHide.
157
158* Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
159- rebuild with libpng-1.6.12
160
161* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
162- rebuilt with current VineSeed
163
164* Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
165- added compat32 subpackage for x86_64 arch support.
166
167* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
168- splited out runtime library to sub package
169- enable opengl again, add BuildRequires: freeglut-devel
170
171* Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
172- remove .la
173- add --disable-static to configure option
174
175* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
176- added Patch0 from VinePlus/4.0
177  * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
178  - add patch100 for fix CVE-2007-2721
179  - add Vendor/Distributin Tag
180
181* Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
182- remove BuildPrereq: freeglut-devel and Requires freeglut
183- add --disable-opengl to configure option
184
185* Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
186- add BuildPreReq: unzip (used in the %%pre section)
187
188* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
189- new upstream release
190
191* Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
192- new upstream release
193- changed Group to System Environment/Libraries
194- added --mandir=%{_mandir}
195- added %post and %postun section
196
197* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
198- added --libdir=%{_libdir} configure option
199
200* Tue Sep  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
201- build with freeglut
202- change BuildPrereq and Requires
203
204* Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
205- new upstream version (jasper-1.701.0)
206
207* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
208- rebuild for VineSeedPlus
209
210* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
211- source upgrade
212- change spec to build for VineLinux
213
214* Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
215- spec file created
Note: See TracBrowser for help on using the repository browser.