source: projects/specs/trunk/j/jasper/jasper-vl.spec @ 10956

Revision 10956, 6.0 KB checked in by tomop, 7 years ago (diff)

gd, jasper, jasper1, libtiff, openjpeg2, sqlite3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Name:        jasper
5Summary:     implementation of the JPEG-2000 standard, Part 1
6Version:     2.0.12
7Release:     1%{?_dist_release}
8
9Group:       Applications/Graphics
10License:     Modified BSD (see LICENSE)
11URL:         http://www.ece.uvic.ca/~mdadams/jasper/
12
13Source:      %{name}-version-%{version}.tar.gz
14
15Patch1: jasper-1.900.1-CVE-2008-3520.patch
16
17BuildRoot:   %{_tmppath}/%{name}-%{version}-root
18BuildRequires: autoconf automake libtool
19BuildRequires: freeglut-devel
20BuildRequires: libGLU-devel
21BuildRequires: libjpeg-devel
22BuildRequires: pkgconfig
23BuildRequires: cmake
24
25Requires:    %{name}-libs = %{version}-%{release}
26
27Vendor:       Project Vine
28Distribution: Vine Linux
29
30%description
31JasPer is a collection of software (i.e., a library and application
32programs) for the coding and manipulation of images.  This software
33can handle image data in a variety of formats.  One such format
34supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
35
36%package devel
37Summary:     Include Files and Documentation for jasper
38Group:       Development/Libraries
39Requires:    %{name}-libs = %{version}-%{release}
40Requires:    libjpeg-devel
41
42%description devel
43This package contains libjasper, a library implementing the JPEG-2000
44image compression standard Part 1.
45
46%package libs
47Summary: Runtime libraries for %{name}
48Group:   System Environment/Libraries
49
50%description libs
51This package contains runtime libraries for JasPer.
52
53# compat32
54%package -n compat32-%{name}-devel
55Summary:     Include Files and Documentation for jasper
56Group:       Development/Libraries
57Requires:    %{name}-libs = %{version}-%{release}
58Requires:    compat32-libjpeg-devel
59
60%description -n compat32-%{name}-devel
61This package contains libjasper, a library implementing the JPEG-2000
62image compression standard Part 1.
63
64%package -n compat32-%{name}-libs
65Summary: Runtime libraries for %{name}
66Group:   System Environment/Libraries
67
68%description -n compat32-%{name}-libs
69This package contains runtime libraries for JasPer.
70
71
72%prep
73%setup -q -n %{name}-version-%{version}
74
75%patch1 -p1 -b .CVE-2008-3520
76
77%build
78mkdir -p builder
79
80%cmake -G "Unix Makefiles" \
81       -H%{_builddir}/%{name}-version-%{version} \
82       -B%{_builddir}/%{name}-version-%{version}/builder
83
84pushd builder
85make %{?_smp_mflags} clean all
86popd
87
88%install
89[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
90pushd builder
91make install DESTDIR=%{buildroot}
92
93# remove .la
94rm -f %{buildroot}/%{_libdir}/*.la
95
96popd
97
98rm -rf %{buildroot}%{_docdir}/JasPer
99
100%check
101pushd builder
102LD_PRELOAD=`pwd`/src/libjasper/libjasper.so \
103make test
104popd
105
106%clean
107[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
108
109%post libs -p /sbin/ldconfig
110
111%postun libs -p /sbin/ldconfig
112
113%post -n compat32-%{name}-libs -p /sbin/ldconfig
114
115%postun -n compat32-%{name}-libs -p /sbin/ldconfig
116
117%files
118%defattr(-,root,root)
119%{!?_licensedir:%global license %%doc}
120%license COPYRIGHT LICENSE
121%doc INSTALL README doc/README doc/jasper.pdf doc/jpeg2000.pdf
122%{_bindir}/*
123%{_mandir}/man1/*
124
125%files libs
126%defattr(-,root,root)
127%{_libdir}/libjasper*.so.*
128
129%files devel
130%defattr(-,root,root)
131%{_includedir}/jasper
132%{_libdir}/libjasper*.so
133%{_libdir}/pkgconfig/jasper.pc
134
135# compat32
136%if %{build_compat32}
137%files -n compat32-%{name}-libs
138%defattr(-,root,root)
139%{_libdir}/libjasper*.so.*
140
141%files -n compat32-%{name}-devel
142%defattr(-,root,root)
143%{_libdir}/libjasper*.so
144%{_libdir}/pkgconfig/jasper.pc
145%endif
146
147%changelog
148* Mon Mar 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.12-1
149- new upstream release.
150- dropped all patches.
151- imported patch1 from rawhide.
152
153* Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-11
154- added Patch1000-1002 to fix CVE-2016-{1577,2089,2116}.
155
156* Wed Dec 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.900.1-10
157- imported all patches from RawHide.
158
159* Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.900.1-9
160- rebuild with libpng-1.6.12
161
162* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
163- rebuilt with current VineSeed
164
165* Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
166- added compat32 subpackage for x86_64 arch support.
167
168* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
169- splited out runtime library to sub package
170- enable opengl again, add BuildRequires: freeglut-devel
171
172* Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
173- remove .la
174- add --disable-static to configure option
175
176* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
177- added Patch0 from VinePlus/4.0
178  * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
179  - add patch100 for fix CVE-2007-2721
180  - add Vendor/Distributin Tag
181
182* Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
183- remove BuildPrereq: freeglut-devel and Requires freeglut
184- add --disable-opengl to configure option
185
186* Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
187- add BuildPreReq: unzip (used in the %%pre section)
188
189* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
190- new upstream release
191
192* Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
193- new upstream release
194- changed Group to System Environment/Libraries
195- added --mandir=%{_mandir}
196- added %post and %postun section
197
198* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
199- added --libdir=%{_libdir} configure option
200
201* Tue Sep  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
202- build with freeglut
203- change BuildPrereq and Requires
204
205* Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
206- new upstream version (jasper-1.701.0)
207
208* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
209- rebuild for VineSeedPlus
210
211* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
212- source upgrade
213- change spec to build for VineLinux
214
215* Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
216- spec file created
Note: See TracBrowser for help on using the repository browser.