source: projects/specs/trunk/j/jack-audio-connection-kit/jack-audio-connection-kit-vl.spec @ 10507

Revision 10507, 12.4 KB checked in by tomop, 8 years ago (diff)

jack-audio-connection-kit-1.9.10-2

Line 
1Summary: The Jack Audio Connection Kit
2Name: jack-audio-connection-kit
3Version: 1.9.10
4Release: 2%{?_dist_release}
5# The entire source (~500 files) is a mixture of these three licenses
6License: GPLv2 and GPLv2+ and LGPLv2+
7Group: System Environment/Daemons
8URL: http://www.jackaudio.org
9
10Vendor: Project Vine
11Distribution: Vine Linux
12
13#Source0: http://www.jackaudio.org/downloads/%{name}-%{version}.tar.gz
14Source0: https://dl.dropbox.com/u/28869550/jack-%{version}.tar.bz2
15Source1: %{name}-README.Fedora
16Source2: %{name}-script.pa
17Source3: %{name}-limits.conf
18
19# No-date-footer hack to remove dates from doxygen documentation
20Patch0:        jack-audio-connection-kit-no_date_footer.patch
21# Build fix
22Patch1:        jack-doxygen-output-dir-fix.patch
23# We don't want the internal API documentation
24Patch2:        jack-apidoc-only.patch
25# Adjust default priority. RHBZ#795094
26Patch3:        jack-realtime-compat.patch
27# Enable renaming and reordering the jack ports RHBZ#887408
28Patch4:        jack-portnames.patch
29# Fix ppc64 mpd startup issue RHBZ#799552
30Patch5:        jack-ppc64-long.patch
31#Patch0:        jack-audio-connection-kit-0.124.1-freebob_driver.patch
32# Fix building with gcc5
33Patch6:        jack-gcc5.patch
34
35BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36BuildRequires: alsa-lib-devel
37BuildRequires: celt-devel
38BuildRequires: dbus-devel
39BuildRequires: doxygen
40BuildRequires: expat-devel
41BuildRequires: libfreebob-devel >= 1.0.0
42BuildRequires: libsamplerate-devel
43BuildRequires: libsndfile-devel >= 1.0.0
44BuildRequires: ncurses-devel
45BuildRequires: pkgconfig
46BuildRequires: python
47BuildRequires: readline-devel
48#BuildRequires: autoconf >= 2.59, automake >= 1.9.3, libtool
49#BuildRequires: libdb-devel
50#BuildRequires: libuuid-devel
51
52%global groupname jackuser
53%global pagroup   pulse-rt
54
55Requires(pre): shadow-utils
56Requires(post): /sbin/ldconfig
57
58%description
59JACK is a low-latency audio server, written primarily for the Linux
60operating system. It can connect a number of different applications to
61an audio device, as well as allowing them to share audio between
62themselves. Its clients can run in their own processes (ie. as a
63normal application), or can they can run within a JACK server (ie. a
64"plugin").
65
66JACK is different from other audio server efforts in that it has been
67designed from the ground up to be suitable for professional audio
68work. This means that it focuses on two key areas: synchronous
69execution of all clients, and low latency operation.
70
71%package dbus
72Summary:        Jack D-Bus launcher
73Group:          Applications/Multimedia
74Requires:       %{name} = %{version}-%{release}
75
76%description dbus
77Launcher to start Jack through D-Bus.
78
79
80%package devel
81Summary:        Development files for %{name}
82Summary(ja):    %{name} の開発用ファイル
83Group:          Development/Libraries
84Requires:       %{name} = %{version}-%{release}
85Requires:       pkgconfig
86
87%description devel
88Development files for the Jack Audio Connection Kit.
89
90%package example-clients
91Summary:        Example clients that use Jack
92Summary(ja):    %{name} を利用したサンプルプログラム
93Group:          Applications/Multimedia
94Requires:       %{name} = %{version}-%{release}
95
96%description example-clients
97Small example clients that use the Jack Audio Connection Kit.
98
99%prep
100%setup -q -n jack-%{version}
101%patch0 -p1 -b .nodate
102%patch1 -p1 -b .outdir
103%patch2 -p1 -b .nointernalapi
104%patch3 -p1 -b .priority
105%patch4 -p1 -b .portnames
106%patch5 -p1 -b .mpd
107%patch6 -p1 -b .gcc5
108
109# Fix encoding issues
110for file in ChangeLog README TODO; do
111    sed 's|\r||' $file > $file.tmp
112    iconv -f ISO-8859-1 -t UTF8 $file.tmp > $file.tmp2
113    touch -r $file $file.tmp2
114    mv -f $file.tmp2 $file
115done
116
117%build
118export CPPFLAGS="$RPM_OPT_FLAGS -O0"
119export PREFIX=%{_prefix}
120# Parallel build disabled as it fails sometimes
121./waf configure \
122      %{?_smp_mflags} \
123      --mandir=%{_mandir}/man1 \
124      --libdir=%{_libdir} \
125      --alsa \
126      --classic \
127      --clients 256 \
128      --dbus \
129      --doxygen \
130      --freebob \
131      --ports-per-application=2048
132
133./waf build %{?_smp_mflags} -v
134
135%install
136rm -rf $RPM_BUILD_ROOT
137./waf --destdir=$RPM_BUILD_ROOT install
138
139# move doxygen documentation to the right place
140mv $RPM_BUILD_ROOT%{_datadir}/jack-audio-connection-kit/reference .
141rm -rf $RPM_BUILD_ROOT%{_datadir}/jack-audio-connection-kit
142
143# install our limits to the /etc/security/limits.d
144mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/security/limits.d
145sed -e 's,@groupname@,%groupname,g; s,@pagroup@,%pagroup,g;' \
146    %{SOURCE3} > $RPM_BUILD_ROOT%{_sysconfdir}/security/limits.d/95-jack.conf
147
148# prepare README.Fedora for documentation including
149install -p -m644 %{SOURCE1} README.Fedora
150
151# install pulseaudio script for jack (as documentation part)
152install -p -m644 %{SOURCE2} jack.pa
153
154# For compatibility with jack1
155mv $RPM_BUILD_ROOT%{_bindir}/jack_rec $RPM_BUILD_ROOT%{_bindir}/jackrec
156
157# Fix permissions of the modules
158chmod 755 $RPM_BUILD_ROOT%{_libdir}/jack/*.so $RPM_BUILD_ROOT%{_libdir}/libjack*.so.*.*.*
159
160%clean
161rm -rf $RPM_BUILD_ROOT
162
163%pre
164getent group %groupname > /dev/null || groupadd -r %groupname
165exit 0
166
167%post -p /sbin/ldconfig
168
169%postun -p /sbin/ldconfig
170
171%files
172%defattr(-,root,root)
173%doc ChangeLog README README_NETJACK2 TODO
174%doc README.Fedora
175%doc jack.pa
176%config(noreplace) %{_sysconfdir}/security/limits.d/*.conf
177%{_bindir}/jackd
178%{_bindir}/jackrec
179%{_libdir}/jack/
180%{_libdir}/libjack.so.*
181%{_libdir}/libjacknet.so.*
182%{_libdir}/libjackserver.so.*
183%{_mandir}/man1/jackrec.1*
184%{_mandir}/man1/jackd*.1*
185
186%files dbus
187%defattr(-,root,root)
188%{_bindir}/jackdbus
189%{_datadir}/dbus-1/services/org.jackaudio.service
190%{_bindir}/jack_control
191
192%files devel
193%defattr(-,root,root)
194%doc reference/html/
195%{_includedir}/jack/
196%{_libdir}/libjack.so
197%{_libdir}/libjacknet.so
198%{_libdir}/libjackserver.so
199%{_libdir}/pkgconfig/jack.pc
200
201%files example-clients
202%defattr(-,root,root)
203%{_bindir}/alsa_in
204%{_bindir}/alsa_out
205%{_bindir}/jack_alias
206%{_bindir}/jack_bufsize
207%{_bindir}/jack_connect
208%{_bindir}/jack_disconnect
209%{_bindir}/jack_cpu_load
210%{_bindir}/jack_evmon
211%{_bindir}/jack_freewheel
212# These are not ready yet
213#{_bindir}/jack_impulse_grabber
214%exclude %{_mandir}/man1/jack_impulse_grabber.1*
215%{_bindir}/jack_latent_client
216%{_bindir}/jack_load
217%{_bindir}/jack_unload
218%{_bindir}/jack_lsp
219%{_bindir}/jack_metro
220%{_bindir}/jack_midi_dump
221%{_bindir}/jack_midi_latency_test
222%{_bindir}/jack_midiseq
223%{_bindir}/jack_midisine
224%{_bindir}/jack_monitor_client
225%{_bindir}/jack_net_master
226%{_bindir}/jack_net_slave
227%{_bindir}/jack_netsource
228%{_bindir}/jack_samplerate
229%{_bindir}/jack_server_control
230%{_bindir}/jack_session_notify
231%{_bindir}/jack_showtime
232%{_bindir}/jack_simple_client
233%{_bindir}/jack_simple_session_client
234%{_bindir}/jack_thru
235%{_bindir}/jack_transport
236%{_bindir}/jack_wait
237%{_bindir}/jack_zombie
238%{_mandir}/man1/alsa_*.1*
239%{_mandir}/man1/jack_bufsize.1*
240%{_mandir}/man1/jack_connect.1*
241%{_mandir}/man1/jack_disconnect.1*
242%{_mandir}/man1/jack_freewheel*.1*
243%{_mandir}/man1/jack_load*.1*
244%{_mandir}/man1/jack_unload*.1*
245%{_mandir}/man1/jack_lsp.1*
246%{_mandir}/man1/jack_metro.1*
247%{_mandir}/man1/jack_monitor_client.1*
248%{_mandir}/man1/jack_netsource.1*
249%{_mandir}/man1/jack_samplerate.1*
250%{_mandir}/man1/jack_showtime.1*
251%{_mandir}/man1/jack_simple_client.1*
252%{_mandir}/man1/jack_transport.1*
253%{_mandir}/man1/jack_wait.1*
254
255# tests
256%{_bindir}/jack_cpu
257%{_bindir}/jack_iodelay
258%{_bindir}/jack_multiple_metro
259%{_bindir}/jack_test
260%{_mandir}/man1/jack_iodelay.1*
261
262
263%changelog
264* Sat Jul  2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.10-2
265- rebuilt with new toolchain.
266- added Patch6 for gcc5.
267
268* Thu Apr  2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.9.10-1
269- updated to 1.9.10
270- built with readline 6.3
271- added dbus subpackage
272
273* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.124.1
274- update to 0.124.1
275- add BuildRequires: libdb-devel, libuuid-devel
276- add Patch0 (jack-audio-connection-kit-0.124.1-freebob_driver.patch)
277
278* Wed Feb 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.121.3
279- update to 0.121.3
280- add BuildRequires: celt-devel
281
282* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.118.0-2
283- rebuild with rpm-4.8.1 for pkg-config file
284- add BuildRequires: libsamplerate-devel
285
286* Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.118.0-1
287- new upstream release
288
289* Sun Jul 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.116.1-1
290- new upstream release
291- rebuild with ncurses-devel
292
293* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.109.2-1
294- initial build for Vine Linux
295
296* Wed Feb 13 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.2-1.1
297- update to the last official release
298
299* Mon Jan 21 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.0-1
300- update to the last official release (#429162)
301- shut up the postinstall script (#359291)
302
303* Sat Oct 20 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-5
304- fix timestamps to avoid multiarch conflicts (#341621)
305
306* Tue Sep 04 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-4
307- fix Source Forge's URL scheme
308
309* Thu Aug 16 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-3
310- fix according to new guidelines:
311  - License tag
312  - group creation
313
314* Wed May 23 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-1
315- update to the last official release
316- append defaults to the limits.conf (#221785, #235624)
317
318* Wed Mar 07 2007 Andy Shevchenko <andy@smile.org.ua> 0.102.20-4
319- drop libtermcap-devel build requirement (#231203)
320- create special jackuser group (#221785)
321
322* Sat Oct 28 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-3
323- fix BuildRequires: libfreebob -> libfreebob-devel
324
325* Tue Oct 24 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.1
326- rebuild with libfreebob (should closed #211751)
327
328* Wed Oct 11 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.0
329- update to 0.102.20
330- drop patch0 (already in mainstream)
331- no pack jack_transport (build error)
332- pack new JACK MIDI files
333
334* Tue Aug 29 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-13
335- http://fedoraproject.org/wiki/Extras/Schedule/FC6MassRebuild
336
337* Tue Aug 01 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-12
338- use install instead of cp (#200835)
339
340* Tue Jul 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-11
341- update URL
342- add BR: libtool
343
344* Tue Jun 20 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-10
345- add BRs: autoconf, automake
346  (http://fedoraproject.org/wiki/QA/FixBuildRequires)
347
348* Sat May 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-9
349- remove --enable-stripped-jackd and --enable-optimize (use default flags)
350
351* Fri May 19 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-8
352- uniform directories items at %files section
353
354* Wed May 17 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-7
355- change License tag to GPL/LGPL
356- remove --enable-shared (it should be default)
357- add a -p flag to the line that copies README.Fedora
358
359* Wed May 10 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-6
360- apply clock fix for AMD X2 CPUs (please, refer to
361  http://sourceforge.net/mailarchive/forum.php?thread_id=8085535&forum_id=3040)
362
363* Wed May 03 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-5
364- adjust spec after reviewing
365
366* Thu Apr 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-4
367- reformatting README.Fedora to 72 symbols width
368
369* Wed Apr 26 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-3
370- add README.Fedora
371- remove useless BRs
372
373* Mon Apr 24 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-2
374- disable oss and portaudio engines
375- use /dev/shm as jack tmpdir
376- remove capabilities stuff
377
378* Tue Apr 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-1
379- update to 0.101.1
380
381* Mon Mar 27 2006 Andy Shevchenko <andriy@asplinux.com.ua>
382- update to 0.100.7 (#183912)
383- adjust BR (add versions)
384- replace files between examples and main packages
385- own jack tmpdir
386
387* Fri Mar 17 2006 Andy Shevchenko <andriy@asplinux.com.ua>
388- no libs subpackage
389- From Fernando Lopez-Lezcano <nando@ccrma.stanford.edu>:
390  - added configuration variable to build with/without capabilities
391  - added --enable-optimize flag to configure script
392  - disabled sse/mmx instructions in i386 build
393  - create temporary directory as /var/lib/jack/tmp
394  - create and erase tmp directory at install or uninstall
395  - try to umount the temporary directory before uninstalling the package
396
397* Fri Mar 03 2006 Andy Shevchenko <andriy@asplinux.com.ua>
398- fix spec for extras injection
399
400* Fri Nov 18 2005 Andy Shevchenko <andriy@asplinux.ru>
401- exclude *.la files
402- use dist tag
403
404* Fri Oct 14 2005 Andy Shevchenko <andriy@asplinux.ru>
405- 0.100.0
406- no optimization
407
408* Tue Sep 28 2004 Andy Shevchenko <andriy@asplinux.ru>
409- 0.99.1
410
411* Fri Aug 20 2004 Andy Shevchenko <andriy@asplinux.ru>
412- rebuild from Mandrake
Note: See TracBrowser for help on using the repository browser.