source: projects/specs/trunk/j/jack-audio-connection-kit/jack-audio-connection-kit-vl.spec @ 12178

Revision 12178, 12.2 KB checked in by tomop, 5 years ago (diff)

jack-audio-connection-kit-1.9.12-3

Line 
1Summary: The Jack Audio Connection Kit
2Name: jack-audio-connection-kit
3Version: 1.9.12
4Release: 3%{?_dist_release}
5# The entire source (~500 files) is a mixture of these three licenses
6License: GPLv2 and GPLv2+ and LGPLv2+
7Group: System Environment/Daemons
8URL: http://www.jackaudio.org
9
10Vendor: Project Vine
11Distribution: Vine Linux
12
13#Source0: http://www.jackaudio.org/downloads/%{name}-%{version}.tar.gz
14Source0: https://github.com/jackaudio/jack2/releases/download/v%{version}/jack2-%{version}.tar.gz
15Source1: %{name}-README.Fedora
16Source2: %{name}-script.pa
17Source3: %{name}-limits.conf
18
19# No-date-footer hack to remove dates from doxygen documentation
20Patch0:        jack2-1.9.12-nodate.patch
21# Build fix
22Patch1:        jack2-1.9.12-outdir.patch
23# We don't want the internal API documentation
24Patch2:        jack2-1.9.12-nointernalapi.patch
25# Adjust default priority. RHBZ#795094
26Patch3:        jack-realtime-compat.patch
27# Remove binary junk from README
28Patch4:        jack2-1.9.12-nojunk.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: alsa-lib-devel
32BuildRequires: celt-devel
33BuildRequires: dbus-devel
34BuildRequires: doxygen
35BuildRequires: expat-devel
36BuildRequires: libfreebob-devel >= 1.0.0
37BuildRequires: libsamplerate-devel
38BuildRequires: libsndfile-devel >= 1.0.0
39BuildRequires: ncurses-devel
40BuildRequires: pkgconfig
41BuildRequires: python
42BuildRequires: readline-devel
43#BuildRequires: autoconf >= 2.59, automake >= 1.9.3, libtool
44#BuildRequires: libdb-devel
45#BuildRequires: libuuid-devel
46
47%global groupname jackuser
48%global pagroup   pulse-rt
49
50Requires(pre): shadow-utils
51Requires(post): /sbin/ldconfig
52
53%description
54JACK is a low-latency audio server, written primarily for the Linux
55operating system. It can connect a number of different applications to
56an audio device, as well as allowing them to share audio between
57themselves. Its clients can run in their own processes (ie. as a
58normal application), or can they can run within a JACK server (ie. a
59"plugin").
60
61JACK is different from other audio server efforts in that it has been
62designed from the ground up to be suitable for professional audio
63work. This means that it focuses on two key areas: synchronous
64execution of all clients, and low latency operation.
65
66%package dbus
67Summary:        Jack D-Bus launcher
68Group:          Applications/Multimedia
69Requires:       %{name} = %{version}-%{release}
70
71%description dbus
72Launcher to start Jack through D-Bus.
73
74
75%package devel
76Summary:        Development files for %{name}
77Summary(ja):    %{name} の開発用ファイル
78Group:          Development/Libraries
79Requires:       %{name} = %{version}-%{release}
80Requires:       pkgconfig
81
82%description devel
83Development files for the Jack Audio Connection Kit.
84
85%package example-clients
86Summary:        Example clients that use Jack
87Summary(ja):    %{name} を利用したサンプルプログラム
88Group:          Applications/Multimedia
89Requires:       %{name} = %{version}-%{release}
90
91%description example-clients
92Small example clients that use the Jack Audio Connection Kit.
93
94%prep
95%setup -q -n jack2-%{version}
96%patch0 -p1 -b .nodate
97%patch1 -p1 -b .outdir
98%patch2 -p1 -b .nointernalapi
99%patch3 -p1 -b .priority
100%patch4 -p1 -b .nojunk
101
102%build
103export CPPFLAGS="$RPM_OPT_FLAGS"
104export PREFIX=%{_prefix}
105# Parallel build disabled as it fails sometimes
106./waf configure \
107      %{?_smp_mflags} \
108      --mandir=%{_mandir}/man1 \
109      --libdir=%{_libdir} \
110      --alsa \
111      --classic \
112      --clients 256 \
113      --dbus \
114      --doxygen \
115      --freebob \
116      --ports-per-application=2048
117
118./waf build %{?_smp_mflags} -v
119
120%install
121rm -rf $RPM_BUILD_ROOT
122./waf --destdir=$RPM_BUILD_ROOT install
123
124# move doxygen documentation to the right place
125mv $RPM_BUILD_ROOT%{_datadir}/jack-audio-connection-kit/reference .
126rm -rf $RPM_BUILD_ROOT%{_datadir}/jack-audio-connection-kit
127
128# install our limits to the /etc/security/limits.d
129mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/security/limits.d
130sed -e 's,@groupname@,%groupname,g; s,@pagroup@,%pagroup,g;' \
131    %{SOURCE3} > $RPM_BUILD_ROOT%{_sysconfdir}/security/limits.d/95-jack.conf
132
133# prepare README.Fedora for documentation including
134install -p -m644 %{SOURCE1} README.Fedora
135
136# install pulseaudio script for jack (as documentation part)
137install -p -m644 %{SOURCE2} jack.pa
138
139# For compatibility with jack1
140mv $RPM_BUILD_ROOT%{_bindir}/jack_rec $RPM_BUILD_ROOT%{_bindir}/jackrec
141
142# Fix permissions of the modules
143chmod 755 $RPM_BUILD_ROOT%{_libdir}/jack/*.so $RPM_BUILD_ROOT%{_libdir}/libjack*.so.*.*.*
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%pre
149getent group %groupname > /dev/null || groupadd -r %groupname
150exit 0
151
152%post -p /sbin/ldconfig
153
154%postun -p /sbin/ldconfig
155
156%files
157%defattr(-,root,root)
158%doc ChangeLog README README_NETJACK2 TODO
159%doc README.Fedora
160%doc jack.pa
161%config(noreplace) %{_sysconfdir}/security/limits.d/*.conf
162%{_bindir}/jackd
163%{_bindir}/jackrec
164%{_libdir}/jack/
165%{_libdir}/libjack.so.*
166%{_libdir}/libjacknet.so.*
167%{_libdir}/libjackserver.so.*
168%{_mandir}/man1/jackrec.1*
169%{_mandir}/man1/jackd*.1*
170
171%files dbus
172%defattr(-,root,root)
173%{_bindir}/jackdbus
174%{_datadir}/dbus-1/services/org.jackaudio.service
175%{_bindir}/jack_control
176
177%files devel
178%defattr(-,root,root)
179%doc reference/html/
180%{_includedir}/jack/
181%{_libdir}/libjack.so
182%{_libdir}/libjacknet.so
183%{_libdir}/libjackserver.so
184%{_libdir}/pkgconfig/jack.pc
185
186%files example-clients
187%defattr(-,root,root)
188%{_bindir}/alsa_in
189%{_bindir}/alsa_out
190%{_bindir}/jack_alias
191%{_bindir}/jack_bufsize
192%{_bindir}/jack_connect
193%{_bindir}/jack_disconnect
194%{_bindir}/jack_cpu_load
195%{_bindir}/jack_evmon
196%{_bindir}/jack_freewheel
197# These are not ready yet
198#{_bindir}/jack_impulse_grabber
199%exclude %{_mandir}/man1/jack_impulse_grabber.1*
200%{_bindir}/jack_latent_client
201%{_bindir}/jack_load
202%{_bindir}/jack_unload
203%{_bindir}/jack_lsp
204%{_bindir}/jack_metro
205%{_bindir}/jack_midi_dump
206%{_bindir}/jack_midi_latency_test
207%{_bindir}/jack_midiseq
208%{_bindir}/jack_midisine
209%{_bindir}/jack_monitor_client
210%{_bindir}/jack_net_master
211%{_bindir}/jack_net_slave
212%{_bindir}/jack_netsource
213%{_bindir}/jack_samplerate
214%{_bindir}/jack_server_control
215%{_bindir}/jack_session_notify
216%{_bindir}/jack_showtime
217%{_bindir}/jack_simple_client
218%{_bindir}/jack_simple_session_client
219%{_bindir}/jack_thru
220%{_bindir}/jack_transport
221%{_bindir}/jack_wait
222%{_bindir}/jack_zombie
223%{_mandir}/man1/alsa_*.1*
224%{_mandir}/man1/jack_bufsize.1*
225%{_mandir}/man1/jack_connect.1*
226%{_mandir}/man1/jack_disconnect.1*
227%{_mandir}/man1/jack_freewheel*.1*
228%{_mandir}/man1/jack_load*.1*
229%{_mandir}/man1/jack_unload*.1*
230%{_mandir}/man1/jack_lsp.1*
231%{_mandir}/man1/jack_metro.1*
232%{_mandir}/man1/jack_monitor_client.1*
233%{_mandir}/man1/jack_netsource.1*
234%{_mandir}/man1/jack_samplerate.1*
235%{_mandir}/man1/jack_showtime.1*
236%{_mandir}/man1/jack_simple_client.1*
237%{_mandir}/man1/jack_transport.1*
238%{_mandir}/man1/jack_wait.1*
239
240# tests
241%{_bindir}/jack_cpu
242%{_bindir}/jack_iodelay
243%{_bindir}/jack_multiple_metro
244%{_bindir}/jack_simdtests
245%{_bindir}/jack_test
246%{_mandir}/man1/jack_iodelay.1*
247
248
249%changelog
250* Wed Sep 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-3
251- rebuilt only.
252
253* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
254- updated to 1.9.12.
255- built with readline-8.0.
256- updated Patch0-2.
257- dropped Patch4-6.
258- imported Patch4 from rawhide.
259
260* Sat Jul  2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.10-2
261- rebuilt with new toolchain.
262- added Patch6 for gcc5.
263
264* Thu Apr  2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.9.10-1
265- updated to 1.9.10
266- built with readline 6.3
267- added dbus subpackage
268
269* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.124.1
270- update to 0.124.1
271- add BuildRequires: libdb-devel, libuuid-devel
272- add Patch0 (jack-audio-connection-kit-0.124.1-freebob_driver.patch)
273
274* Wed Feb 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.121.3
275- update to 0.121.3
276- add BuildRequires: celt-devel
277
278* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.118.0-2
279- rebuild with rpm-4.8.1 for pkg-config file
280- add BuildRequires: libsamplerate-devel
281
282* Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.118.0-1
283- new upstream release
284
285* Sun Jul 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.116.1-1
286- new upstream release
287- rebuild with ncurses-devel
288
289* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.109.2-1
290- initial build for Vine Linux
291
292* Wed Feb 13 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.2-1.1
293- update to the last official release
294
295* Mon Jan 21 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.0-1
296- update to the last official release (#429162)
297- shut up the postinstall script (#359291)
298
299* Sat Oct 20 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-5
300- fix timestamps to avoid multiarch conflicts (#341621)
301
302* Tue Sep 04 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-4
303- fix Source Forge's URL scheme
304
305* Thu Aug 16 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-3
306- fix according to new guidelines:
307  - License tag
308  - group creation
309
310* Wed May 23 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-1
311- update to the last official release
312- append defaults to the limits.conf (#221785, #235624)
313
314* Wed Mar 07 2007 Andy Shevchenko <andy@smile.org.ua> 0.102.20-4
315- drop libtermcap-devel build requirement (#231203)
316- create special jackuser group (#221785)
317
318* Sat Oct 28 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-3
319- fix BuildRequires: libfreebob -> libfreebob-devel
320
321* Tue Oct 24 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.1
322- rebuild with libfreebob (should closed #211751)
323
324* Wed Oct 11 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.0
325- update to 0.102.20
326- drop patch0 (already in mainstream)
327- no pack jack_transport (build error)
328- pack new JACK MIDI files
329
330* Tue Aug 29 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-13
331- http://fedoraproject.org/wiki/Extras/Schedule/FC6MassRebuild
332
333* Tue Aug 01 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-12
334- use install instead of cp (#200835)
335
336* Tue Jul 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-11
337- update URL
338- add BR: libtool
339
340* Tue Jun 20 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-10
341- add BRs: autoconf, automake
342  (http://fedoraproject.org/wiki/QA/FixBuildRequires)
343
344* Sat May 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-9
345- remove --enable-stripped-jackd and --enable-optimize (use default flags)
346
347* Fri May 19 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-8
348- uniform directories items at %files section
349
350* Wed May 17 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-7
351- change License tag to GPL/LGPL
352- remove --enable-shared (it should be default)
353- add a -p flag to the line that copies README.Fedora
354
355* Wed May 10 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-6
356- apply clock fix for AMD X2 CPUs (please, refer to
357  http://sourceforge.net/mailarchive/forum.php?thread_id=8085535&forum_id=3040)
358
359* Wed May 03 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-5
360- adjust spec after reviewing
361
362* Thu Apr 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-4
363- reformatting README.Fedora to 72 symbols width
364
365* Wed Apr 26 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-3
366- add README.Fedora
367- remove useless BRs
368
369* Mon Apr 24 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-2
370- disable oss and portaudio engines
371- use /dev/shm as jack tmpdir
372- remove capabilities stuff
373
374* Tue Apr 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-1
375- update to 0.101.1
376
377* Mon Mar 27 2006 Andy Shevchenko <andriy@asplinux.com.ua>
378- update to 0.100.7 (#183912)
379- adjust BR (add versions)
380- replace files between examples and main packages
381- own jack tmpdir
382
383* Fri Mar 17 2006 Andy Shevchenko <andriy@asplinux.com.ua>
384- no libs subpackage
385- From Fernando Lopez-Lezcano <nando@ccrma.stanford.edu>:
386  - added configuration variable to build with/without capabilities
387  - added --enable-optimize flag to configure script
388  - disabled sse/mmx instructions in i386 build
389  - create temporary directory as /var/lib/jack/tmp
390  - create and erase tmp directory at install or uninstall
391  - try to umount the temporary directory before uninstalling the package
392
393* Fri Mar 03 2006 Andy Shevchenko <andriy@asplinux.com.ua>
394- fix spec for extras injection
395
396* Fri Nov 18 2005 Andy Shevchenko <andriy@asplinux.ru>
397- exclude *.la files
398- use dist tag
399
400* Fri Oct 14 2005 Andy Shevchenko <andriy@asplinux.ru>
401- 0.100.0
402- no optimization
403
404* Tue Sep 28 2004 Andy Shevchenko <andriy@asplinux.ru>
405- 0.99.1
406
407* Fri Aug 20 2004 Andy Shevchenko <andriy@asplinux.ru>
408- rebuild from Mandrake
Note: See TracBrowser for help on using the repository browser.