source: projects/specs/trunk/j/jack-audio-connection-kit/jack-audio-connection-kit-vl.spec @ 12168

Revision 12168, 12.1 KB checked in by tomop, 5 years ago (diff)

jack-audio-connection-kit-1.9.12-1

Line 
1Summary: The Jack Audio Connection Kit
2Name: jack-audio-connection-kit
3Version: 1.9.12
4Release: 1%{?_dist_release}
5# The entire source (~500 files) is a mixture of these three licenses
6License: GPLv2 and GPLv2+ and LGPLv2+
7Group: System Environment/Daemons
8URL: http://www.jackaudio.org
9
10Vendor: Project Vine
11Distribution: Vine Linux
12
13#Source0: http://www.jackaudio.org/downloads/%{name}-%{version}.tar.gz
14Source0: https://github.com/jackaudio/jack2/releases/download/v%{version}/jack2-%{version}.tar.gz
15Source1: %{name}-README.Fedora
16Source2: %{name}-script.pa
17Source3: %{name}-limits.conf
18
19# No-date-footer hack to remove dates from doxygen documentation
20Patch0:        jack2-1.9.12-nodate.patch
21# Build fix
22Patch1:        jack2-1.9.12-outdir.patch
23# We don't want the internal API documentation
24Patch2:        jack2-1.9.12-nointernalapi.patch
25# Adjust default priority. RHBZ#795094
26Patch3:        jack-realtime-compat.patch
27# Remove binary junk from README
28Patch4:        jack2-1.9.12-nojunk.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: alsa-lib-devel
32BuildRequires: celt-devel
33BuildRequires: dbus-devel
34BuildRequires: doxygen
35BuildRequires: expat-devel
36BuildRequires: libfreebob-devel >= 1.0.0
37BuildRequires: libsamplerate-devel
38BuildRequires: libsndfile-devel >= 1.0.0
39BuildRequires: ncurses-devel
40BuildRequires: pkgconfig
41BuildRequires: python
42BuildRequires: readline-devel
43#BuildRequires: autoconf >= 2.59, automake >= 1.9.3, libtool
44#BuildRequires: libdb-devel
45#BuildRequires: libuuid-devel
46
47%global groupname jackuser
48%global pagroup   pulse-rt
49
50Requires(pre): shadow-utils
51Requires(post): /sbin/ldconfig
52
53%description
54JACK is a low-latency audio server, written primarily for the Linux
55operating system. It can connect a number of different applications to
56an audio device, as well as allowing them to share audio between
57themselves. Its clients can run in their own processes (ie. as a
58normal application), or can they can run within a JACK server (ie. a
59"plugin").
60
61JACK is different from other audio server efforts in that it has been
62designed from the ground up to be suitable for professional audio
63work. This means that it focuses on two key areas: synchronous
64execution of all clients, and low latency operation.
65
66%package dbus
67Summary:        Jack D-Bus launcher
68Group:          Applications/Multimedia
69Requires:       %{name} = %{version}-%{release}
70
71%description dbus
72Launcher to start Jack through D-Bus.
73
74
75%package devel
76Summary:        Development files for %{name}
77Summary(ja):    %{name} の開発用ファイル
78Group:          Development/Libraries
79Requires:       %{name} = %{version}-%{release}
80Requires:       pkgconfig
81
82%description devel
83Development files for the Jack Audio Connection Kit.
84
85%package example-clients
86Summary:        Example clients that use Jack
87Summary(ja):    %{name} を利用したサンプルプログラム
88Group:          Applications/Multimedia
89Requires:       %{name} = %{version}-%{release}
90
91%description example-clients
92Small example clients that use the Jack Audio Connection Kit.
93
94%prep
95%setup -q -n jack2-%{version}
96%patch0 -p1 -b .nodate
97%patch1 -p1 -b .outdir
98%patch2 -p1 -b .nointernalapi
99%patch3 -p1 -b .priority
100%patch4 -p1 -b .nojunk
101
102%build
103export CPPFLAGS="$RPM_OPT_FLAGS"
104export PREFIX=%{_prefix}
105# Parallel build disabled as it fails sometimes
106./waf configure \
107      %{?_smp_mflags} \
108      --mandir=%{_mandir}/man1 \
109      --libdir=%{_libdir} \
110      --alsa \
111      --classic \
112      --clients 256 \
113      --dbus \
114      --doxygen \
115      --freebob \
116      --ports-per-application=2048
117
118./waf build %{?_smp_mflags} -v
119
120%install
121rm -rf $RPM_BUILD_ROOT
122./waf --destdir=$RPM_BUILD_ROOT install
123
124# move doxygen documentation to the right place
125mv $RPM_BUILD_ROOT%{_datadir}/jack-audio-connection-kit/reference .
126rm -rf $RPM_BUILD_ROOT%{_datadir}/jack-audio-connection-kit
127
128# install our limits to the /etc/security/limits.d
129mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/security/limits.d
130sed -e 's,@groupname@,%groupname,g; s,@pagroup@,%pagroup,g;' \
131    %{SOURCE3} > $RPM_BUILD_ROOT%{_sysconfdir}/security/limits.d/95-jack.conf
132
133# prepare README.Fedora for documentation including
134install -p -m644 %{SOURCE1} README.Fedora
135
136# install pulseaudio script for jack (as documentation part)
137install -p -m644 %{SOURCE2} jack.pa
138
139# For compatibility with jack1
140mv $RPM_BUILD_ROOT%{_bindir}/jack_rec $RPM_BUILD_ROOT%{_bindir}/jackrec
141
142# Fix permissions of the modules
143chmod 755 $RPM_BUILD_ROOT%{_libdir}/jack/*.so $RPM_BUILD_ROOT%{_libdir}/libjack*.so.*.*.*
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%pre
149getent group %groupname > /dev/null || groupadd -r %groupname
150exit 0
151
152%post -p /sbin/ldconfig
153
154%postun -p /sbin/ldconfig
155
156%files
157%defattr(-,root,root)
158%doc ChangeLog README README_NETJACK2 TODO
159%doc README.Fedora
160%doc jack.pa
161%config(noreplace) %{_sysconfdir}/security/limits.d/*.conf
162%{_bindir}/jackd
163%{_bindir}/jackrec
164%{_libdir}/jack/
165%{_libdir}/libjack.so.*
166%{_libdir}/libjacknet.so.*
167%{_libdir}/libjackserver.so.*
168%{_mandir}/man1/jackrec.1*
169%{_mandir}/man1/jackd*.1*
170
171%files dbus
172%defattr(-,root,root)
173%{_bindir}/jackdbus
174%{_datadir}/dbus-1/services/org.jackaudio.service
175%{_bindir}/jack_control
176
177%files devel
178%defattr(-,root,root)
179%doc reference/html/
180%{_includedir}/jack/
181%{_libdir}/libjack.so
182%{_libdir}/libjacknet.so
183%{_libdir}/libjackserver.so
184%{_libdir}/pkgconfig/jack.pc
185
186%files example-clients
187%defattr(-,root,root)
188%{_bindir}/alsa_in
189%{_bindir}/alsa_out
190%{_bindir}/jack_alias
191%{_bindir}/jack_bufsize
192%{_bindir}/jack_connect
193%{_bindir}/jack_disconnect
194%{_bindir}/jack_cpu_load
195%{_bindir}/jack_evmon
196%{_bindir}/jack_freewheel
197# These are not ready yet
198#{_bindir}/jack_impulse_grabber
199%exclude %{_mandir}/man1/jack_impulse_grabber.1*
200%{_bindir}/jack_latent_client
201%{_bindir}/jack_load
202%{_bindir}/jack_unload
203%{_bindir}/jack_lsp
204%{_bindir}/jack_metro
205%{_bindir}/jack_midi_dump
206%{_bindir}/jack_midi_latency_test
207%{_bindir}/jack_midiseq
208%{_bindir}/jack_midisine
209%{_bindir}/jack_monitor_client
210%{_bindir}/jack_net_master
211%{_bindir}/jack_net_slave
212%{_bindir}/jack_netsource
213%{_bindir}/jack_samplerate
214%{_bindir}/jack_server_control
215%{_bindir}/jack_session_notify
216%{_bindir}/jack_showtime
217%{_bindir}/jack_simple_client
218%{_bindir}/jack_simple_session_client
219%{_bindir}/jack_thru
220%{_bindir}/jack_transport
221%{_bindir}/jack_wait
222%{_bindir}/jack_zombie
223%{_mandir}/man1/alsa_*.1*
224%{_mandir}/man1/jack_bufsize.1*
225%{_mandir}/man1/jack_connect.1*
226%{_mandir}/man1/jack_disconnect.1*
227%{_mandir}/man1/jack_freewheel*.1*
228%{_mandir}/man1/jack_load*.1*
229%{_mandir}/man1/jack_unload*.1*
230%{_mandir}/man1/jack_lsp.1*
231%{_mandir}/man1/jack_metro.1*
232%{_mandir}/man1/jack_monitor_client.1*
233%{_mandir}/man1/jack_netsource.1*
234%{_mandir}/man1/jack_samplerate.1*
235%{_mandir}/man1/jack_showtime.1*
236%{_mandir}/man1/jack_simple_client.1*
237%{_mandir}/man1/jack_transport.1*
238%{_mandir}/man1/jack_wait.1*
239
240# tests
241%{_bindir}/jack_cpu
242%{_bindir}/jack_iodelay
243%{_bindir}/jack_multiple_metro
244%{_bindir}/jack_simdtests
245%{_bindir}/jack_test
246%{_mandir}/man1/jack_iodelay.1*
247
248
249%changelog
250* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
251- updated to 1.9.12.
252- built with readline-8.0.
253- updated Patch0-2.
254- dropped Patch4-6.
255- imported Patch4 from rawhide.
256
257* Sat Jul  2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.10-2
258- rebuilt with new toolchain.
259- added Patch6 for gcc5.
260
261* Thu Apr  2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.9.10-1
262- updated to 1.9.10
263- built with readline 6.3
264- added dbus subpackage
265
266* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.124.1
267- update to 0.124.1
268- add BuildRequires: libdb-devel, libuuid-devel
269- add Patch0 (jack-audio-connection-kit-0.124.1-freebob_driver.patch)
270
271* Wed Feb 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.121.3
272- update to 0.121.3
273- add BuildRequires: celt-devel
274
275* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.118.0-2
276- rebuild with rpm-4.8.1 for pkg-config file
277- add BuildRequires: libsamplerate-devel
278
279* Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.118.0-1
280- new upstream release
281
282* Sun Jul 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.116.1-1
283- new upstream release
284- rebuild with ncurses-devel
285
286* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.109.2-1
287- initial build for Vine Linux
288
289* Wed Feb 13 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.2-1.1
290- update to the last official release
291
292* Mon Jan 21 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.0-1
293- update to the last official release (#429162)
294- shut up the postinstall script (#359291)
295
296* Sat Oct 20 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-5
297- fix timestamps to avoid multiarch conflicts (#341621)
298
299* Tue Sep 04 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-4
300- fix Source Forge's URL scheme
301
302* Thu Aug 16 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-3
303- fix according to new guidelines:
304  - License tag
305  - group creation
306
307* Wed May 23 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-1
308- update to the last official release
309- append defaults to the limits.conf (#221785, #235624)
310
311* Wed Mar 07 2007 Andy Shevchenko <andy@smile.org.ua> 0.102.20-4
312- drop libtermcap-devel build requirement (#231203)
313- create special jackuser group (#221785)
314
315* Sat Oct 28 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-3
316- fix BuildRequires: libfreebob -> libfreebob-devel
317
318* Tue Oct 24 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.1
319- rebuild with libfreebob (should closed #211751)
320
321* Wed Oct 11 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.0
322- update to 0.102.20
323- drop patch0 (already in mainstream)
324- no pack jack_transport (build error)
325- pack new JACK MIDI files
326
327* Tue Aug 29 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-13
328- http://fedoraproject.org/wiki/Extras/Schedule/FC6MassRebuild
329
330* Tue Aug 01 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-12
331- use install instead of cp (#200835)
332
333* Tue Jul 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-11
334- update URL
335- add BR: libtool
336
337* Tue Jun 20 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-10
338- add BRs: autoconf, automake
339  (http://fedoraproject.org/wiki/QA/FixBuildRequires)
340
341* Sat May 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-9
342- remove --enable-stripped-jackd and --enable-optimize (use default flags)
343
344* Fri May 19 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-8
345- uniform directories items at %files section
346
347* Wed May 17 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-7
348- change License tag to GPL/LGPL
349- remove --enable-shared (it should be default)
350- add a -p flag to the line that copies README.Fedora
351
352* Wed May 10 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-6
353- apply clock fix for AMD X2 CPUs (please, refer to
354  http://sourceforge.net/mailarchive/forum.php?thread_id=8085535&forum_id=3040)
355
356* Wed May 03 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-5
357- adjust spec after reviewing
358
359* Thu Apr 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-4
360- reformatting README.Fedora to 72 symbols width
361
362* Wed Apr 26 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-3
363- add README.Fedora
364- remove useless BRs
365
366* Mon Apr 24 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-2
367- disable oss and portaudio engines
368- use /dev/shm as jack tmpdir
369- remove capabilities stuff
370
371* Tue Apr 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-1
372- update to 0.101.1
373
374* Mon Mar 27 2006 Andy Shevchenko <andriy@asplinux.com.ua>
375- update to 0.100.7 (#183912)
376- adjust BR (add versions)
377- replace files between examples and main packages
378- own jack tmpdir
379
380* Fri Mar 17 2006 Andy Shevchenko <andriy@asplinux.com.ua>
381- no libs subpackage
382- From Fernando Lopez-Lezcano <nando@ccrma.stanford.edu>:
383  - added configuration variable to build with/without capabilities
384  - added --enable-optimize flag to configure script
385  - disabled sse/mmx instructions in i386 build
386  - create temporary directory as /var/lib/jack/tmp
387  - create and erase tmp directory at install or uninstall
388  - try to umount the temporary directory before uninstalling the package
389
390* Fri Mar 03 2006 Andy Shevchenko <andriy@asplinux.com.ua>
391- fix spec for extras injection
392
393* Fri Nov 18 2005 Andy Shevchenko <andriy@asplinux.ru>
394- exclude *.la files
395- use dist tag
396
397* Fri Oct 14 2005 Andy Shevchenko <andriy@asplinux.ru>
398- 0.100.0
399- no optimization
400
401* Tue Sep 28 2004 Andy Shevchenko <andriy@asplinux.ru>
402- 0.99.1
403
404* Fri Aug 20 2004 Andy Shevchenko <andriy@asplinux.ru>
405- rebuild from Mandrake
Note: See TracBrowser for help on using the repository browser.