source: projects/specs/trunk/i/iputils/iputils-vl.spec @ 11908

Revision 11908, 11.3 KB checked in by tomop, 5 years ago (diff)

iputils-20180629-1

Line 
1Summary: Network monitoring tools including ping.
2Summary(ja): ping 等のネットワークモニタツール集
3Name: iputils
4Version: 20180629
5Release: 1%{?_dist_release}
6# some parts are under the original BSD (ping.c)
7# some are under GPLv2+ (tracepath.c)
8License: BSD and GPLv2+
9Group: System Environment/Daemons
10URL: https://github.com/iputils/iputils
11Source0: https://github.com/iputils/iputils/archive/s%{version}.tar.gz#/%{name}-s%{version}.tar.gz
12Source1: ifenslave.tar.gz
13Source3: rdisc.initd
14Source5: rdisc.sysconfig
15Source6: ninfod.initd
16Source7: ninfod.sysconfig
17
18Source10: bsd.txt
19Source11: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
20
21Patch0: iputils-rh.patch
22Patch1: iputils-ifenslave.patch
23
24# Vine Source(s)/Patch(es)
25Source1000: iputils-s20180629-ja.po
26Patch1000: iputils-s20180629-gettext.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29BuildRequires: docbook-utils perl-SGMLSpm
30BuildRequires: glibc-kernheaders >= 2.4-8.19
31BuildRequires: libidn2-devel
32BuildRequires: openssl-devel
33BuildRequires: libcap-devel
34BuildRequires: libxslt
35BuildRequires: docbook-style-xsl
36Requires(post): chkconfig
37Requires(preun): chkconfig
38Requires(preun): initscripts
39Requires(postun): initscripts
40
41Vendor: Project Vine
42Distribution: Vine Linux
43
44%description
45The iputils package contains basic utilities for monitoring a network,
46including ping. The ping command sends a series of ICMP protocol
47ECHO_REQUEST packets to a specified network host to discover whether
48the target machine is alive and receiving network traffic.
49
50%prep
51%setup -q -a 1 -n %{name}-s%{version}
52
53cp %{SOURCE10} %{SOURCE11} .
54
55%patch0 -p1
56%patch1 -p1
57
58#
59%patch1000 -p1 -b .gettext
60
61# add ja.po
62cp %{SOURCE1000} po/ja.po
63
64%build
65%ifarch s390 s390x
66export CFLAGS="$RPM_OPT_FLAGS -fPIE"
67%else
68export CFLAGS="$RPM_OPT_FLAGS -fpie"
69%endif
70export LDFLAGS="-pie -Wl,-z,relro,-z,now"
71
72make %{?_smp_mflags} arping clockdiff ping rdisc tracepath ninfod
73gcc -Wall $RPM_OPT_FLAGS $CFLAGS $LDFLAGS ifenslave.c -o ifenslave
74make -C doc man
75make -C po
76
77%install
78rm -rf ${RPM_BUILD_ROOT}
79
80mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
81mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
82mkdir -p ${RPM_BUILD_ROOT}/{bin,sbin}
83mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
84
85install -c clockdiff            ${RPM_BUILD_ROOT}%{_sbindir}/
86install -cp arping              ${RPM_BUILD_ROOT}/sbin/
87ln -s /sbin/arping              ${RPM_BUILD_ROOT}%{_sbindir}/arping
88install -cp ping                ${RPM_BUILD_ROOT}/bin/
89install -cp ifenslave           ${RPM_BUILD_ROOT}/sbin/
90install -cp rdisc               ${RPM_BUILD_ROOT}/sbin/
91install -cp tracepath           ${RPM_BUILD_ROOT}/bin/
92install -cp ninfod/ninfod       ${RPM_BUILD_ROOT}/sbin/
93
94ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}
95ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}/ping6
96ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
97ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}/tracepath6
98
99mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
100install -cp doc/clockdiff.8     ${RPM_BUILD_ROOT}%{_mandir}/man8/
101install -cp doc/arping.8        ${RPM_BUILD_ROOT}%{_mandir}/man8/
102install -cp doc/ping.8          ${RPM_BUILD_ROOT}%{_mandir}/man8/
103install -cp doc/rdisc.8         ${RPM_BUILD_ROOT}%{_mandir}/man8/
104install -cp doc/tracepath.8     ${RPM_BUILD_ROOT}%{_mandir}/man8/
105install -cp doc/ninfod.8        ${RPM_BUILD_ROOT}%{_mandir}/man8/
106install -cp ifenslave.8         ${RPM_BUILD_ROOT}%{_mandir}/man8/
107ln -s ping.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/ping6.8.gz
108ln -s tracepath.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/tracepath6.8.gz
109
110find ${RPM_BUILD_ROOT}%{_mandir} -type f | xargs chmod 644
111
112install -dp ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
113install -m 755 -p %{SOURCE3} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/rdisc
114install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rdisc
115install -m 755 -p %{SOURCE6} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/ninfod
116install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ninfod
117
118make -C po install DESTDIR=$RPM_BUILD_ROOT
119
120%find_lang %{name}
121
122%post
123/sbin/chkconfig --add rdisc
124/sbin/chkconfig --add ninfod
125
126%preun
127if [ $1 = 0 ]; then
128   service rdisc stop >/dev/null 2>&1
129   service ninfod stop >/dev/null 2>&1
130   /sbin/chkconfig --del rdisc
131   /sbin/chkconfig --del ninfod
132fi
133
134%postun
135if [ "$1" -ge "1" ]; then
136    service rdisc condrestart >/dev/null 2>&1 || :
137    service ninfod condrestart >/dev/null 2>&1 || :
138fi
139
140
141%clean
142rm -rf ${RPM_BUILD_ROOT}
143
144%files -f %{name}.lang
145%defattr(-,root,root)
146%doc LICENSE* README.*
147%{_sbindir}/clockdiff
148/sbin/arping
149%{_sbindir}/arping
150%attr(4755,root,root)   /bin/ping
151/sbin/ifenslave
152/sbin/rdisc
153/bin/tracepath
154/sbin/ninfod
155%{_sbindir}/ping
156%{_sbindir}/ping6
157%{_sbindir}/tracepath
158%{_sbindir}/tracepath6
159%{_mandir}/man8/*
160%{_sysconfdir}/rc.d/init.d/rdisc
161%{_sysconfdir}/rc.d/init.d/ninfod
162%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/rdisc
163%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/ninfod
164
165%changelog
166* Sat Nov 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20180629-1
167- updated to 20180629.
168- dropped Patch2-5 (fixed in upstream).
169- updated gettext patch and translation.
170- added BR:libxslt.
171- added BR:docbook-style-xsl.
172
173* Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-2
174- fixed initscripts.
175
176* Fri Feb 23 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-1
177- updated to 20161105.
178- updated gettext patch and translation.
179- updated license.
180
181* Sun Jul 13 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 20140519-1
182- update to 20140519
183- update URL to new upstream
184- update gettext patch and translation
185
186* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 20101006-1
187- new upstream release
188- merget with fedora/20101006-8
189- update gettext patch and ja.po
190
191* Fri Apr 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-2
192- rebuild to add sign..
193
194* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-1
195- new upstream release
196- spec in utf-8
197
198* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-41vl1
199- remove traceroute6 that is now provided by traceroute package.
200- merge changes from FC
201
202* Sat Jul 31 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20020927-13vl2
203- ppc patch (Patch110) removed (it's no necessary now)
204
205* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-13vl1
206- update to 20020927 merged with 20020927-13
207- update i18n patch, ja.po
208  * Thu Oct 02 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-12
209  - Fixed unaligned access problem on ia64 (#101417)
210  * Wed Sep 10 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-11
211  - Dont use own headers, use glibc and kernheaders.
212  * Thu Sep 04 2003 Bill Nottingham <notting@redhat.com> 20020927-10
213  - fix build with new glibc-kernheaders
214  * Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9
215  - Start icmp_seq from 0 instead of 1 (Conform with debian and Solaris #100609).
216  * Thu Jul 31 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-8
217  - One more update to ifenslave.c
218  * Mon Jun 16 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-7
219  - Updated ifenslave.c and README.bonding to latest version.
220  * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-5
221  - Bumped release and rebuilt
222  * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-4
223  - Fixed DNS lookup problems (#68212).
224  - Added warning if binding problem failed on subinterface (#81640).
225  * Tue May 13 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-3
226  - Removed bonding tarball and replaced it with ifenslave.c and README
227  - FHS compliance for all tools, now to be found in /bin with compat symlinks to
228    old places.
229  * Fri Nov 29 2002 Phil Knirsch <pknirsch@redhat.com> 20020927-1
230  - Updated to latest upstream version.
231  * Tue Jun 18 2002 Phil Knirsch <pknirsch@redhat.com> 20020124-7
232  - Added new BuildPreReqs for docbook-utils and perl-SGMLSpm (#66661)
233  - Fixed ipv6 error printing problem (#66659).
234  * Tue May 21 2002 Phil Knirsch <pknirsch@redhat.com>
235  - Added a patch to activate the rdisc server (#64270).
236  - Display the countermeasures warning only in verbose (#55236)
237  * Thu Apr 18 2002 Bill Nottingham <notting@redhat.com>
238  - quit trying to build HTML versions of the man pages
239  * Thu Mar 14 2002 Phil Knirsch <pknirsch@redhat.com>
240  - Added fix by Tom "spot" Callaway to fix buffer overflow problems in stats.
241  * Wed Feb 27 2002 Phil Knirsch <pknirsch@redhat.com>
242  - Update to iputils-ss020124.
243
244* Sat Feb 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl2
245- changed Patch110 to have clear_bit() within the ipv6 source for ppc
246
247* Sun Jan 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl1
248- based on 20001110-7 from Rawhide
249- merged Vine changes from 20001010-1vl4
250  --- Mon Jul 16 2001 <sagami@vinelinux.org>
251    - 20001010-1vl4
252    - use %%{find_lang} to fix so as not to own locale dir
253
254  --- Thu Jun 07 2001 <sagami@vinelinux.org>
255    - 20001010-1vl3: rebuilt for %%{_mandir}
256
257  --- Fri Oct 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
258    - 20001010-1vl2
259    - remove ping6 for ppc
260    - added Japanese summary and description
261
262  --- Thu Oct 26 2000 Jun Nishii <jun@vinelinux.org>
263    - added ja.po and nls patch
264
265* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
266- automated rebuild
267
268* Mon Aug 27 2001 Philipp Knirsch <pknirsch@redhat.de> 20001110-6
269- Fixed buffer overflow problem in traceroute6.c (#51135)
270
271* Sun Jul 01 2001 Philipp Knirsch <pknirsch@redhat.de>
272- Made ping6 and traceroute6 setuid (safe as they drop it VERY early) (#46769)
273
274* Thu Jun 28 2001 Philipp Knirsch <pknirsch@redhat.de>
275- Fixed ping statistics overflow bug (#43801)
276
277* Tue Jun 26 2001 Philipp Knirsch <pknirsch@redhat.de>
278- Fixed a bunch of compiler warnings (#37131)
279- Fixed wrong exit code for no packets and deadline (#40323)
280- Moved arping to /sbin from /usr/sbin due to ifup call (#45785). Symlink from
281  /usr/sbin/ provided for backwards compatibility.
282
283* Mon Apr 30 2001 Preston Brown <pbrown@redhat.com>
284- install in.rdisc.8c as rdisc.8
285
286* Tue Jan 16 2001 Jeff Johnson <jbj@redhat.com>
287- update to ss001110
288- doco fixes (#23844).
289
290* Sun Oct  8 2000 Jeff Johnson <jbj@redhat.com>
291- update to ss001007.
292
293* Tue Aug  8 2000 Tim Waugh <twaugh@redhat.com>
294- fix spelling mistake (#15714).
295
296* Tue Aug  8 2000 Tim Waugh <twaugh@redhat.com>
297- turn on -U on machines without TSC (#15223).
298
299* Tue Aug  1 2000 Jeff Johnson <jbj@redhat.com>
300- better doco patch (#15050).
301
302* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
303- fix include-glibc/ to work with new glibc 2.2 resolver headers
304
305* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
306- automatic rebuild
307
308* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
309- FHS packaging.
310- update to ss000418.
311- perform reverse DNS lookup only once for same input.
312
313* Sun Mar  5 2000 Jeff Johnson <jbj@redhat.com>
314- include README.ifenslave doco.
315- "ping -i N" was broke for N >= 3 (#9929).
316- update to ss000121:
317-- clockdiff: preserve raw socket errno.
318-- ping: change error exit code to 1 (used to be 92,93, ...)
319-- ping,ping6: if -w specified, transmit until -c limit is reached.
320-- ping,ping6: exit code non-zero if some packets not received within deadline.
321
322* Tue Feb 22 2000 Jeff Johnson <jbj@redhat.com>
323- man page corrections (#9690).
324
325* Wed Feb  9 2000 Jeff Johnson <jbj@jbj.org>
326- add ifenslave.
327
328* Thu Feb  3 2000 Elliot Lee <sopwith@redhat.com>
329- List /usr/sbin/rdisc in %files list.
330
331* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
332- add remaining binaries.
333- casts to remove compilation warnings.
334- terminate if -w deadline is reached exactly (#8724).
335
336* Fri Dec 24 1999 Jeff Johnson <jbj@redhat.com>
337- create (only ping for now, traceroute et al soon).
Note: See TracBrowser for help on using the repository browser.