source: projects/specs/trunk/i/iputils/iputils-vl.spec @ 11527

Revision 11527, 11.4 KB checked in by tomop, 6 years ago (diff)

iputils-20161105-2

Line 
1Summary: Network monitoring tools including ping.
2Summary(ja): ping 等のネットワークモニタツール集
3Name: iputils
4Version: 20161105
5Release: 2%{?_dist_release}
6# some parts are under the original BSD (ping.c)
7# some are under GPLv2+ (tracepath.c)
8License: BSD and GPLv2+
9Group: System Environment/Daemons
10URL: https://github.com/iputils/iputils
11Source0: https://github.com/iputils/iputils/archive/s%{version}.tar.gz#/%{name}-s%{version}.tar.gz
12Source1: ifenslave.tar.gz
13Source3: rdisc.initd
14Source5: rdisc.sysconfig
15Source6: ninfod.initd
16Source7: ninfod.sysconfig
17
18Source10: bsd.txt
19Source11: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
20
21Patch0: iputils-rh.patch
22Patch1: iputils-ifenslave.patch
23Patch2: 0001-arping-tracepath-removed-unused-idna-header.patch
24Patch3: 0002-traceroute6-use-getaddrinfo-IDNA-conversion.patch
25Patch4: 0003-ping6-simplified-IDNA-usage.patch
26Patch5: 0004-ping-use-libidn2-instead-of-libidn.patch
27
28# Vine Source(s)/Patch(es)
29Source1000: iputils-s20161105-ja.po
30Patch1000: iputils-s20161105-gettext.patch
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
33BuildRequires: docbook-utils perl-SGMLSpm
34BuildRequires: glibc-kernheaders >= 2.4-8.19
35BuildRequires: libidn2-devel
36BuildRequires: openssl-devel
37BuildRequires: libcap-devel
38Requires(post): chkconfig
39Requires(preun): chkconfig
40Requires(preun): initscripts
41Requires(postun): initscripts
42
43Vendor: Project Vine
44Distribution: Vine Linux
45
46%description
47The iputils package contains basic utilities for monitoring a network,
48including ping. The ping command sends a series of ICMP protocol
49ECHO_REQUEST packets to a specified network host to discover whether
50the target machine is alive and receiving network traffic.
51
52%prep
53%setup -q -a 1 -n %{name}-s%{version}
54
55cp %{SOURCE10} %{SOURCE11} .
56
57%patch0 -p1
58%patch1 -p1
59%patch2 -p1
60%patch3 -p1
61%patch4 -p1
62%patch5 -p1
63
64#
65%patch1000 -p1 -b .gettext
66
67# add ja.po
68cp %{SOURCE1000} po/ja.po
69
70%build
71%ifarch s390 s390x
72export CFLAGS="$RPM_OPT_FLAGS -fPIE"
73%else
74export CFLAGS="$RPM_OPT_FLAGS -fpie"
75%endif
76export LDFLAGS="-pie -Wl,-z,relro,-z,now"
77
78make %{?_smp_mflags} arping clockdiff ping rdisc tracepath ninfod
79gcc -Wall $RPM_OPT_FLAGS $CFLAGS $LDFLAGS ifenslave.c -o ifenslave
80make -C doc man
81make -C po
82
83%install
84rm -rf ${RPM_BUILD_ROOT}
85
86mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
87mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
88mkdir -p ${RPM_BUILD_ROOT}/{bin,sbin}
89mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
90
91install -c clockdiff            ${RPM_BUILD_ROOT}%{_sbindir}/
92install -cp arping              ${RPM_BUILD_ROOT}/sbin/
93ln -s /sbin/arping              ${RPM_BUILD_ROOT}%{_sbindir}/arping
94install -cp ping                ${RPM_BUILD_ROOT}/bin/
95install -cp ifenslave           ${RPM_BUILD_ROOT}/sbin/
96install -cp rdisc               ${RPM_BUILD_ROOT}/sbin/
97install -cp tracepath           ${RPM_BUILD_ROOT}/bin/
98install -cp ninfod/ninfod       ${RPM_BUILD_ROOT}/sbin/
99
100ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}
101ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}/ping6
102ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
103ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}/tracepath6
104
105mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
106install -cp doc/clockdiff.8     ${RPM_BUILD_ROOT}%{_mandir}/man8/
107install -cp doc/arping.8        ${RPM_BUILD_ROOT}%{_mandir}/man8/
108install -cp doc/ping.8          ${RPM_BUILD_ROOT}%{_mandir}/man8/
109install -cp doc/rdisc.8         ${RPM_BUILD_ROOT}%{_mandir}/man8/
110install -cp doc/tracepath.8     ${RPM_BUILD_ROOT}%{_mandir}/man8/
111install -cp doc/ninfod.8        ${RPM_BUILD_ROOT}%{_mandir}/man8/
112install -cp ifenslave.8         ${RPM_BUILD_ROOT}%{_mandir}/man8/
113ln -s ping.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/ping6.8.gz
114ln -s tracepath.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/tracepath6.8.gz
115
116find ${RPM_BUILD_ROOT}%{_mandir} -type f | xargs chmod 644
117
118install -dp ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
119install -m 755 -p %{SOURCE3} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/rdisc
120install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rdisc
121install -m 755 -p %{SOURCE6} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/ninfod
122install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ninfod
123
124make -C po install DESTDIR=$RPM_BUILD_ROOT
125
126%find_lang %{name}
127
128iconv -f ISO88591 -t UTF8 RELNOTES -o RELNOTES.tmp
129touch -r RELNOTES RELNOTES.tmp
130mv -f RELNOTES.tmp RELNOTES
131
132%post
133/sbin/chkconfig --add rdisc
134/sbin/chkconfig --add ninfod
135
136%preun
137if [ $1 = 0 ]; then
138   service rdisc stop >/dev/null 2>&1
139   service ninfod stop >/dev/null 2>&1
140   /sbin/chkconfig --del rdisc
141   /sbin/chkconfig --del ninfod
142fi
143
144%postun
145if [ "$1" -ge "1" ]; then
146    service rdisc condrestart >/dev/null 2>&1 || :
147    service ninfod condrestart >/dev/null 2>&1 || :
148fi
149
150
151%clean
152rm -rf ${RPM_BUILD_ROOT}
153
154%files -f %{name}.lang
155%defattr(-,root,root)
156%doc bsd.txt gpl-2.0.txt RELNOTES README.*
157%{_sbindir}/clockdiff
158/sbin/arping
159%{_sbindir}/arping
160%attr(4755,root,root)   /bin/ping
161/sbin/ifenslave
162/sbin/rdisc
163/bin/tracepath
164/sbin/ninfod
165%{_sbindir}/ping
166%{_sbindir}/ping6
167%{_sbindir}/tracepath
168%{_sbindir}/tracepath6
169%{_mandir}/man8/*
170%{_sysconfdir}/rc.d/init.d/rdisc
171%{_sysconfdir}/rc.d/init.d/ninfod
172%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/rdisc
173%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/ninfod
174
175%changelog
176* Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-2
177- fixed initscripts.
178
179* Fri Feb 23 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-1
180- updated to 20161105.
181- updated gettext patch and translation.
182- updated license.
183
184* Sun Jul 13 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 20140519-1
185- update to 20140519
186- update URL to new upstream
187- update gettext patch and translation
188
189* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 20101006-1
190- new upstream release
191- merget with fedora/20101006-8
192- update gettext patch and ja.po
193
194* Fri Apr 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-2
195- rebuild to add sign..
196
197* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-1
198- new upstream release
199- spec in utf-8
200
201* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-41vl1
202- remove traceroute6 that is now provided by traceroute package.
203- merge changes from FC
204
205* Sat Jul 31 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20020927-13vl2
206- ppc patch (Patch110) removed (it's no necessary now)
207
208* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-13vl1
209- update to 20020927 merged with 20020927-13
210- update i18n patch, ja.po
211  * Thu Oct 02 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-12
212  - Fixed unaligned access problem on ia64 (#101417)
213  * Wed Sep 10 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-11
214  - Dont use own headers, use glibc and kernheaders.
215  * Thu Sep 04 2003 Bill Nottingham <notting@redhat.com> 20020927-10
216  - fix build with new glibc-kernheaders
217  * Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9
218  - Start icmp_seq from 0 instead of 1 (Conform with debian and Solaris #100609).
219  * Thu Jul 31 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-8
220  - One more update to ifenslave.c
221  * Mon Jun 16 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-7
222  - Updated ifenslave.c and README.bonding to latest version.
223  * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-5
224  - Bumped release and rebuilt
225  * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-4
226  - Fixed DNS lookup problems (#68212).
227  - Added warning if binding problem failed on subinterface (#81640).
228  * Tue May 13 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-3
229  - Removed bonding tarball and replaced it with ifenslave.c and README
230  - FHS compliance for all tools, now to be found in /bin with compat symlinks to
231    old places.
232  * Fri Nov 29 2002 Phil Knirsch <pknirsch@redhat.com> 20020927-1
233  - Updated to latest upstream version.
234  * Tue Jun 18 2002 Phil Knirsch <pknirsch@redhat.com> 20020124-7
235  - Added new BuildPreReqs for docbook-utils and perl-SGMLSpm (#66661)
236  - Fixed ipv6 error printing problem (#66659).
237  * Tue May 21 2002 Phil Knirsch <pknirsch@redhat.com>
238  - Added a patch to activate the rdisc server (#64270).
239  - Display the countermeasures warning only in verbose (#55236)
240  * Thu Apr 18 2002 Bill Nottingham <notting@redhat.com>
241  - quit trying to build HTML versions of the man pages
242  * Thu Mar 14 2002 Phil Knirsch <pknirsch@redhat.com>
243  - Added fix by Tom "spot" Callaway to fix buffer overflow problems in stats.
244  * Wed Feb 27 2002 Phil Knirsch <pknirsch@redhat.com>
245  - Update to iputils-ss020124.
246
247* Sat Feb 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl2
248- changed Patch110 to have clear_bit() within the ipv6 source for ppc
249
250* Sun Jan 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl1
251- based on 20001110-7 from Rawhide
252- merged Vine changes from 20001010-1vl4
253  --- Mon Jul 16 2001 <sagami@vinelinux.org>
254    - 20001010-1vl4
255    - use %%{find_lang} to fix so as not to own locale dir
256
257  --- Thu Jun 07 2001 <sagami@vinelinux.org>
258    - 20001010-1vl3: rebuilt for %%{_mandir}
259
260  --- Fri Oct 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
261    - 20001010-1vl2
262    - remove ping6 for ppc
263    - added Japanese summary and description
264
265  --- Thu Oct 26 2000 Jun Nishii <jun@vinelinux.org>
266    - added ja.po and nls patch
267
268* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
269- automated rebuild
270
271* Mon Aug 27 2001 Philipp Knirsch <pknirsch@redhat.de> 20001110-6
272- Fixed buffer overflow problem in traceroute6.c (#51135)
273
274* Sun Jul 01 2001 Philipp Knirsch <pknirsch@redhat.de>
275- Made ping6 and traceroute6 setuid (safe as they drop it VERY early) (#46769)
276
277* Thu Jun 28 2001 Philipp Knirsch <pknirsch@redhat.de>
278- Fixed ping statistics overflow bug (#43801)
279
280* Tue Jun 26 2001 Philipp Knirsch <pknirsch@redhat.de>
281- Fixed a bunch of compiler warnings (#37131)
282- Fixed wrong exit code for no packets and deadline (#40323)
283- Moved arping to /sbin from /usr/sbin due to ifup call (#45785). Symlink from
284  /usr/sbin/ provided for backwards compatibility.
285
286* Mon Apr 30 2001 Preston Brown <pbrown@redhat.com>
287- install in.rdisc.8c as rdisc.8
288
289* Tue Jan 16 2001 Jeff Johnson <jbj@redhat.com>
290- update to ss001110
291- doco fixes (#23844).
292
293* Sun Oct  8 2000 Jeff Johnson <jbj@redhat.com>
294- update to ss001007.
295
296* Tue Aug  8 2000 Tim Waugh <twaugh@redhat.com>
297- fix spelling mistake (#15714).
298
299* Tue Aug  8 2000 Tim Waugh <twaugh@redhat.com>
300- turn on -U on machines without TSC (#15223).
301
302* Tue Aug  1 2000 Jeff Johnson <jbj@redhat.com>
303- better doco patch (#15050).
304
305* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
306- fix include-glibc/ to work with new glibc 2.2 resolver headers
307
308* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
309- automatic rebuild
310
311* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
312- FHS packaging.
313- update to ss000418.
314- perform reverse DNS lookup only once for same input.
315
316* Sun Mar  5 2000 Jeff Johnson <jbj@redhat.com>
317- include README.ifenslave doco.
318- "ping -i N" was broke for N >= 3 (#9929).
319- update to ss000121:
320-- clockdiff: preserve raw socket errno.
321-- ping: change error exit code to 1 (used to be 92,93, ...)
322-- ping,ping6: if -w specified, transmit until -c limit is reached.
323-- ping,ping6: exit code non-zero if some packets not received within deadline.
324
325* Tue Feb 22 2000 Jeff Johnson <jbj@redhat.com>
326- man page corrections (#9690).
327
328* Wed Feb  9 2000 Jeff Johnson <jbj@jbj.org>
329- add ifenslave.
330
331* Thu Feb  3 2000 Elliot Lee <sopwith@redhat.com>
332- List /usr/sbin/rdisc in %files list.
333
334* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
335- add remaining binaries.
336- casts to remove compilation warnings.
337- terminate if -w deadline is reached exactly (#8724).
338
339* Fri Dec 24 1999 Jeff Johnson <jbj@redhat.com>
340- create (only ping for now, traceroute et al soon).
Note: See TracBrowser for help on using the repository browser.