source: projects/specs/trunk/i/iputils/iputils-vl.spec @ 12299

Revision 12299, 11.5 KB checked in by tomop, 5 years ago (diff)

updated 15 packages

ant-1.9.14-1

ccid-1.4.31-1

extra-cmake-modules-5.63.0-1

file-5.37-2

iputils-20190709-1

libarchive-3.4.0-1

libidn2-2.2.0-1

libmodsecurity-3.0.3-4

libxslt-1.1.33-2

ncurses-6.1-3

pcsc-lite-1.8.25-1

polkit-qt-0.112.0-3

qca2-2.2.1-1

rdesktop-1.9.0-1

util-linux-2.34-1

Line 
1Summary: Network monitoring tools including ping.
2Summary(ja): ping 等のネットワークモニタツール集
3Name: iputils
4Version: 20190709
5Release: 1%{?_dist_release}
6# some parts are under the original BSD (ping.c)
7# some are under GPLv2+ (tracepath.c)
8License: BSD and GPLv2+
9Group: System Environment/Daemons
10URL: https://github.com/iputils/iputils
11Source0: https://github.com/iputils/iputils/archive/s%{version}.tar.gz#/%{name}-s%{version}.tar.gz
12Source1: ifenslave.tar.gz
13Source3: rdisc.initd
14Source5: rdisc.sysconfig
15Source6: ninfod.initd
16Source7: ninfod.sysconfig
17
18Source10: bsd.txt
19Source11: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
20
21Patch1: iputils-ifenslave.patch
22
23# Vine Source(s)/Patch(es)
24
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
27BuildRequires: docbook-utils perl-SGMLSpm
28BuildRequires: glibc-kernheaders >= 2.4-8.19
29BuildRequires: libidn2-devel
30BuildRequires: openssl-devel
31BuildRequires: libcap-devel
32BuildRequires: libxslt
33BuildRequires: docbook5-style-xsl
34BuildRequires: meson
35Requires(post): chkconfig
36Requires(preun): chkconfig
37Requires(preun): initscripts
38Requires(postun): initscripts
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%description
44The iputils package contains basic utilities for monitoring a network,
45including ping. The ping command sends a series of ICMP protocol
46ECHO_REQUEST packets to a specified network host to discover whether
47the target machine is alive and receiving network traffic.
48
49%prep
50%setup -q -a 1 -n %{name}-s%{version}
51
52cp %{SOURCE10} %{SOURCE11} .
53
54%patch1 -p1
55
56%build
57%ifarch s390 s390x
58export CFLAGS="$RPM_OPT_FLAGS -fPIE"
59%else
60export CFLAGS="$RPM_OPT_FLAGS -fpie"
61%endif
62export LDFLAGS="-pie -Wl,-z,relro,-z,now"
63
64%meson
65%meson_build
66%ninja_build -C %{_target_platform} iputils-gmo
67
68gcc -Wall $RPM_OPT_FLAGS $CFLAGS $LDFLAGS ifenslave.c -o ifenslave
69
70
71%install
72rm -rf ${RPM_BUILD_ROOT}
73
74mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
75mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
76mkdir -p ${RPM_BUILD_ROOT}/{bin,sbin}
77mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
78
79pushd %{_target_platform}
80install -c clockdiff            ${RPM_BUILD_ROOT}%{_sbindir}/
81install -cp arping              ${RPM_BUILD_ROOT}/sbin/
82ln -s /sbin/arping              ${RPM_BUILD_ROOT}%{_sbindir}/arping
83install -cp ping                ${RPM_BUILD_ROOT}/bin/
84install -cp ../ifenslave                ${RPM_BUILD_ROOT}/sbin/
85install -cp rdisc               ${RPM_BUILD_ROOT}/sbin/
86install -cp tracepath           ${RPM_BUILD_ROOT}/bin/
87install -cp ninfod/ninfod       ${RPM_BUILD_ROOT}/sbin/
88
89ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}
90ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}/ping6
91ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
92ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}/tracepath6
93
94mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
95install -cp doc/clockdiff.8     ${RPM_BUILD_ROOT}%{_mandir}/man8/
96install -cp doc/arping.8        ${RPM_BUILD_ROOT}%{_mandir}/man8/
97install -cp doc/ping.8          ${RPM_BUILD_ROOT}%{_mandir}/man8/
98install -cp doc/rdisc.8         ${RPM_BUILD_ROOT}%{_mandir}/man8/
99install -cp doc/tracepath.8     ${RPM_BUILD_ROOT}%{_mandir}/man8/
100install -cp doc/ninfod.8        ${RPM_BUILD_ROOT}%{_mandir}/man8/
101install -cp ../ifenslave.8              ${RPM_BUILD_ROOT}%{_mandir}/man8/
102ln -s ping.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/ping6.8.gz
103ln -s tracepath.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/tracepath6.8.gz
104
105install -dp ${RPM_BUILD_ROOT}%{_datadir}/locale/ja/LC_MESSAGES
106install -m 644 po/ja.gmo $RPM_BUILD_ROOT%{_datadir}/locale/ja/LC_MESSAGES/iputils.mo
107popd
108
109find ${RPM_BUILD_ROOT}%{_mandir} -type f | xargs chmod 644
110
111install -dp ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
112install -m 755 -p %{SOURCE3} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/rdisc
113install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rdisc
114install -m 755 -p %{SOURCE6} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/ninfod
115install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ninfod
116
117%find_lang %{name}
118
119%post
120/sbin/chkconfig --add rdisc
121/sbin/chkconfig --add ninfod
122
123%preun
124if [ $1 = 0 ]; then
125   service rdisc stop >/dev/null 2>&1
126   service ninfod stop >/dev/null 2>&1
127   /sbin/chkconfig --del rdisc
128   /sbin/chkconfig --del ninfod
129fi
130
131%postun
132if [ "$1" -ge "1" ]; then
133    service rdisc condrestart >/dev/null 2>&1 || :
134    service ninfod condrestart >/dev/null 2>&1 || :
135fi
136
137
138%clean
139rm -rf ${RPM_BUILD_ROOT}
140
141%files -f %{name}.lang
142%defattr(-,root,root)
143%license LICENSE*
144%doc README.*
145%{_sbindir}/clockdiff
146/sbin/arping
147%{_sbindir}/arping
148%attr(4755,root,root)   /bin/ping
149/sbin/ifenslave
150/sbin/rdisc
151/bin/tracepath
152/sbin/ninfod
153%{_sbindir}/ping
154%{_sbindir}/ping6
155%{_sbindir}/tracepath
156%{_sbindir}/tracepath6
157%{_mandir}/man8/*
158%{_sysconfdir}/rc.d/init.d/rdisc
159%{_sysconfdir}/rc.d/init.d/ninfod
160%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/rdisc
161%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/ninfod
162
163%changelog
164* Tue Oct 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20190709-1
165- updated to 20190709.
166- dropped Source1000 and Patch1000: merged into upstream.
167- switched buildsystem to meson.
168- dropped Patch0: Makefile is deprecated.
169
170* Sat Nov 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20180629-1
171- updated to 20180629.
172- dropped Patch2-5 (fixed in upstream).
173- updated gettext patch and translation.
174- added BR:libxslt.
175- added BR:docbook-style-xsl.
176
177* Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-2
178- fixed initscripts.
179
180* Fri Feb 23 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-1
181- updated to 20161105.
182- updated gettext patch and translation.
183- updated license.
184
185* Sun Jul 13 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 20140519-1
186- update to 20140519
187- update URL to new upstream
188- update gettext patch and translation
189
190* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 20101006-1
191- new upstream release
192- merget with fedora/20101006-8
193- update gettext patch and ja.po
194
195* Fri Apr 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-2
196- rebuild to add sign..
197
198* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-1
199- new upstream release
200- spec in utf-8
201
202* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-41vl1
203- remove traceroute6 that is now provided by traceroute package.
204- merge changes from FC
205
206* Sat Jul 31 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20020927-13vl2
207- ppc patch (Patch110) removed (it's no necessary now)
208
209* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-13vl1
210- update to 20020927 merged with 20020927-13
211- update i18n patch, ja.po
212  * Thu Oct 02 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-12
213  - Fixed unaligned access problem on ia64 (#101417)
214  * Wed Sep 10 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-11
215  - Dont use own headers, use glibc and kernheaders.
216  * Thu Sep 04 2003 Bill Nottingham <notting@redhat.com> 20020927-10
217  - fix build with new glibc-kernheaders
218  * Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9
219  - Start icmp_seq from 0 instead of 1 (Conform with debian and Solaris #100609).
220  * Thu Jul 31 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-8
221  - One more update to ifenslave.c
222  * Mon Jun 16 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-7
223  - Updated ifenslave.c and README.bonding to latest version.
224  * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-5
225  - Bumped release and rebuilt
226  * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-4
227  - Fixed DNS lookup problems (#68212).
228  - Added warning if binding problem failed on subinterface (#81640).
229  * Tue May 13 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-3
230  - Removed bonding tarball and replaced it with ifenslave.c and README
231  - FHS compliance for all tools, now to be found in /bin with compat symlinks to
232    old places.
233  * Fri Nov 29 2002 Phil Knirsch <pknirsch@redhat.com> 20020927-1
234  - Updated to latest upstream version.
235  * Tue Jun 18 2002 Phil Knirsch <pknirsch@redhat.com> 20020124-7
236  - Added new BuildPreReqs for docbook-utils and perl-SGMLSpm (#66661)
237  - Fixed ipv6 error printing problem (#66659).
238  * Tue May 21 2002 Phil Knirsch <pknirsch@redhat.com>
239  - Added a patch to activate the rdisc server (#64270).
240  - Display the countermeasures warning only in verbose (#55236)
241  * Thu Apr 18 2002 Bill Nottingham <notting@redhat.com>
242  - quit trying to build HTML versions of the man pages
243  * Thu Mar 14 2002 Phil Knirsch <pknirsch@redhat.com>
244  - Added fix by Tom "spot" Callaway to fix buffer overflow problems in stats.
245  * Wed Feb 27 2002 Phil Knirsch <pknirsch@redhat.com>
246  - Update to iputils-ss020124.
247
248* Sat Feb 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl2
249- changed Patch110 to have clear_bit() within the ipv6 source for ppc
250
251* Sun Jan 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl1
252- based on 20001110-7 from Rawhide
253- merged Vine changes from 20001010-1vl4
254  --- Mon Jul 16 2001 <sagami@vinelinux.org>
255    - 20001010-1vl4
256    - use %%{find_lang} to fix so as not to own locale dir
257
258  --- Thu Jun 07 2001 <sagami@vinelinux.org>
259    - 20001010-1vl3: rebuilt for %%{_mandir}
260
261  --- Fri Oct 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
262    - 20001010-1vl2
263    - remove ping6 for ppc
264    - added Japanese summary and description
265
266  --- Thu Oct 26 2000 Jun Nishii <jun@vinelinux.org>
267    - added ja.po and nls patch
268
269* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
270- automated rebuild
271
272* Mon Aug 27 2001 Philipp Knirsch <pknirsch@redhat.de> 20001110-6
273- Fixed buffer overflow problem in traceroute6.c (#51135)
274
275* Sun Jul 01 2001 Philipp Knirsch <pknirsch@redhat.de>
276- Made ping6 and traceroute6 setuid (safe as they drop it VERY early) (#46769)
277
278* Thu Jun 28 2001 Philipp Knirsch <pknirsch@redhat.de>
279- Fixed ping statistics overflow bug (#43801)
280
281* Tue Jun 26 2001 Philipp Knirsch <pknirsch@redhat.de>
282- Fixed a bunch of compiler warnings (#37131)
283- Fixed wrong exit code for no packets and deadline (#40323)
284- Moved arping to /sbin from /usr/sbin due to ifup call (#45785). Symlink from
285  /usr/sbin/ provided for backwards compatibility.
286
287* Mon Apr 30 2001 Preston Brown <pbrown@redhat.com>
288- install in.rdisc.8c as rdisc.8
289
290* Tue Jan 16 2001 Jeff Johnson <jbj@redhat.com>
291- update to ss001110
292- doco fixes (#23844).
293
294* Sun Oct  8 2000 Jeff Johnson <jbj@redhat.com>
295- update to ss001007.
296
297* Tue Aug  8 2000 Tim Waugh <twaugh@redhat.com>
298- fix spelling mistake (#15714).
299
300* Tue Aug  8 2000 Tim Waugh <twaugh@redhat.com>
301- turn on -U on machines without TSC (#15223).
302
303* Tue Aug  1 2000 Jeff Johnson <jbj@redhat.com>
304- better doco patch (#15050).
305
306* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
307- fix include-glibc/ to work with new glibc 2.2 resolver headers
308
309* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
310- automatic rebuild
311
312* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
313- FHS packaging.
314- update to ss000418.
315- perform reverse DNS lookup only once for same input.
316
317* Sun Mar  5 2000 Jeff Johnson <jbj@redhat.com>
318- include README.ifenslave doco.
319- "ping -i N" was broke for N >= 3 (#9929).
320- update to ss000121:
321-- clockdiff: preserve raw socket errno.
322-- ping: change error exit code to 1 (used to be 92,93, ...)
323-- ping,ping6: if -w specified, transmit until -c limit is reached.
324-- ping,ping6: exit code non-zero if some packets not received within deadline.
325
326* Tue Feb 22 2000 Jeff Johnson <jbj@redhat.com>
327- man page corrections (#9690).
328
329* Wed Feb  9 2000 Jeff Johnson <jbj@jbj.org>
330- add ifenslave.
331
332* Thu Feb  3 2000 Elliot Lee <sopwith@redhat.com>
333- List /usr/sbin/rdisc in %files list.
334
335* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
336- add remaining binaries.
337- casts to remove compilation warnings.
338- terminate if -w deadline is reached exactly (#8724).
339
340* Fri Dec 24 1999 Jeff Johnson <jbj@redhat.com>
341- create (only ping for now, traceroute et al soon).
Note: See TracBrowser for help on using the repository browser.